Subject: [Sip] sdp in 1xx/2xx for different offer-answer scenarios

From: Chadha Retesh-A19894 <[email-masked]>
Date: Sat, 14 May 2005 11:16:10 +0530

I have certain doubts regarding sending of sdp in 1xx/2xx in some scenarios.

Scenario 1.  PRACK and 1xx (with answer)
                                     <----         INVITE(with offer1)
    1xx (with answer1)    --->  
                                     <----        PRACK
    200 ok (for PRACK) --->  
    Qs -- Now in the subsequent 1xx and 2xx responses, is it ok if no sdp is
sent? And if sdp has to be sent then can it be a new answer??
    
Scenario 2. PRACK and 1xx (with offer)
                                     <----         INVITE(with no sdp)
    1xx (with offer1)    --->  
                                     <----        PRACK(with answer1)
    200 ok (for PRACK) --->  
    Qs -- Now in the subsequent 1xx and 2xx responses, is it ok if no sdp is
sent? And if sdp has to be sent, then can it be a new offer?? 
 
RFC 3261 mandates same sdp to be sent in subsequent 1xx and 2xx, but that's
only if ealier sdp was sent in non-reliable responses. So, what should be
the case when PRACK is there?
 
Scenario 3. UPDATE and 1xx (non-reliable)
                                                 <----         INVITE(with
no sdp)
    1xx (with offer1)(not reliable)     --->  
    UPDATE     --->  
 
    Qs -- Now the above UPDATE has to have a new offer or same offer1? 
 
Thanks in advance
Rgds
Retesh
 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Chadha Retesh-A19894 <[email-masked]>
Date: Tue, 17 May 2005 08:48:51 +0530

Resending, in case it was missed on the weekend. Any comments on this??

-----Original Message-----
From: Chadha Retesh-A19894 
Sent: Saturday, May 14, 2005 11:16 AM
To: [email-masked]'; [email-masked]
Subject: sdp in 1xx/2xx for different offer-answer scenarios

    

 

                                                 <----         INVITE(with
no sdp)

 
Thanks in advance
Rgds
Retesh