Subject: [Sip] 100rel and early-session option tags (RFC 3959)

From: Chauhan Bhavik-A20762 <[email-masked]>
Date: Tue, 24 May 2005 10:52:35 +0530

Hi,
 
With Reference to RFC 3959 section 6,
 
I think "early-session" option tag must be accompanied "100rel" if it is in
"Require" header
to indicate "Reliability of Provisional Response" support as I didn't find
any relationship cited 
in RFCs. 
 
    Does "early-session" implicitly indicate that?
 
If not then,
 
1.
       A                                                      B
       ---INVITE(Require: early-session) ---->
 
(INVITE is without 100rel option)
As 100rel is not there what will be response from B?
 
2.   
       A
B
   ----INVITE(Supported: early-session) with OFFER ---->
     <---- 180 Reliable with early-offer & ANSWER----
 
(INVITE is without 100rel option )
What will be response from A as no 100rel supported?

Regards,
Bhavik Chauhan
 
Motorola India Eletronics Pvt Ltd.
 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Chauhan Bhavik-A20762 <[email-masked]>
Date: Mon, 30 May 2005 17:00:39 +0530

Resending it. Any comments on this?
 
Thanks,
Bhavik

-----Original Message-----
From: Chauhan Bhavik-A20762 
Sent: Tuesday, May 24, 2005 10:53 AM
To: [email-masked]
Subject: 100rel and early-session option tags (RFC 3959)

Hi,

 
 
If not then,
 
1.
       A                                                      B

2.   
       A
B

Regards,
Bhavik Chauhan