Subject: [Sip] Event Package for Registrations (RFC-3680)

From: "Thomas Ackermann" <[email-masked]>
Date: Wed, 4 May 2005 15:12:24 +0200

Hi together,

I looked for a way to notify a SIP client
about its unregistration before the expire time elapsed.
Now I found "Event Package for Registrations" (RFC-3680).

OK, fine, this is what I needed.
But what the hell is XML doing there?
SIP is a simple text based protocol (inherited from HTTP).
The SDP for session negotiation as well.
Everything was perfectly straight in the early days.
And now with every little extension there comes another way
of content encoding.

Why do you have to have an XML engine everywhere you stand?
Especially for things that really do NOT need XML
due to very non-complexity?

Why not simply defining it this way:

#NOTIFY ...
#Event: reg
#Content-Type: application/reginfo
#Content-Length: xxx
#
#state=registered|unregistered|etc.

just like outband DTMF transmission:

#INFO ...
#Content-Type: application/dtmf-relay
#Content-Length: xxx
#
#Signal=1
#Duration=160

or like session negotiation:

#INVITE ...
#Content-Type: application/sdp
#Content-Length: xxx
#
#v=0
#...

Best regards,
Thomas

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Dale Worley" <[email-masked]>
Date: Wed, 4 May 2005 10:16:38 -0400

> From: Thomas Ackermann

First, remember that if all you need to do is *generate*
registration/unregistration NOTIFYs, then you can *write* the needed XML
quite easily, it's just a text string with a number of substitutions.

As to why XML is used, there are several reasons:

- XML is well-understood and there are many parsers in existence.  Thus,
there is less work involved in creating a new XML-based format than would
seem.

- XML allows "structured" data.  In this case, a notice consists of a list
of registration notices, which each contain a number of contacts.  A simple
text-based format for such data quickly becomes much less simple when it
tries to capture such information.

- XML is extensible.  It is understood how to add elements to XML structures
in ways that are upward-compatible with processors of the old format.

Dale