Subject: [Sip] UPDATE with ANSWER?

From: Chauhan Bhavik-A20762 <[email-masked]>
Date: Thu, 19 May 2005 15:09:39 +0530

Hi all,
 
I was exploring the possibility for the UPDATE to send the Answer,
As I haven't found any explicit restriction in RFC 3311.
 
I went through the older Thread
http://lists.cs.columbia.edu/pipermail/sip-implementors/2004-January/006017.
html
<http://lists.cs.columbia.edu/pipermail/sip-implementors/2004-January/006017
.html> 
and came across following Qs which I found not clarified though.
 
1. Can UPDATE be used to send an answer SDP ?
    Consider the following scenario:
    -  INVITE was sent without SDP
    - 18x is received with Offer SDP
    - There is no PRACK exchange because 18x does not contain a
Require:100rel header
    Now can UPDATE be used to send answer SDP??
 
2. As per RFC 3311, UPDATE method should be used only if dialog is
established.
    If INVITE/18x exchange happened without PRACK, can both ends treat
this as early dialog and feel free to use UPDATE ?
 
3. Is 18x send/recv over TCP considered reliable ?
    In the following scenario:
    - INVITE with offer sdp sent
    - 18x over TCP with answer sdp recvd (No PRACK exchange happened)
    Now can the caller/calleee use UPDATE ?

Can any body clarify the same?
 
Thanks in advance,
Bhavik Chauhan
 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 19 May 2005 09:39:49 -0400

We really need to create an FAQ about this.

A long time ago, probably in the thread you cite, we debated this 
extensively. It is true that the RFCs are not entirely clear on this, 
and reasonable people can differ in interpretation of them. But we 
finally came to some agreement on it.

I am quite sure we agreed that UPDATE could *not* be used to send an 
answer. We ended up with a quite restrictive list of cases for how 
INVITE, UPDATE, PRACK, and their responses and ACK can be used to convey 
offer/answer.

I was one who originally argued for fewer restrictions. But there were 
issues with that, and the restrictive approach won out. In practice I 
don't think the restrictions impose any great burden.

	Paul

Chauhan Bhavik-A20762 wrote:
> Sip-implementors mailing list
> [email-masked]
> http://lists.cs.columbia.edu/mailman/listinfo/sip-implementors
>