Subject: RE: [Sip] UPDATE with ANSWER?

From: Avasarala Ranjit-A20990 <[email-masked]>
Date: Thu, 19 May 2005 15:21:08 +0530

Hi
    No UPDATE cannot be used to send answer, since UPDATE can be used only
after a dialog is established. 

Regards 
Ranjit 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Chauhan Bhavik-A20762
Sent: Thursday, May 19, 2005 3:10 PM
To: [email-masked]; [email-masked]
Subject: [Sip] UPDATE with ANSWER?

Hi all,
 
I was exploring the possibility for the UPDATE to send the Answer,
As I haven't found any explicit restriction in RFC 3311.
 
I went through the older Thread
http://lists.cs.columbia.edu/pipermail/sip-implementors/2004-January/006017.
html
<http://lists.cs.columbia.edu/pipermail/sip-implementors/2004-January/006017
.html> 
and came across following Qs which I found not clarified though.
 
1. Can UPDATE be used to send an answer SDP ?
    Consider the following scenario:
    -  INVITE was sent without SDP
    - 18x is received with Offer SDP
    - There is no PRACK exchange because 18x does not contain a
Require:100rel header
    Now can UPDATE be used to send answer SDP??
 
2. As per RFC 3311, UPDATE method should be used only if dialog is
established.
    If INVITE/18x exchange happened without PRACK, can both ends treat
this as early dialog and feel free to use UPDATE ?
 
3. Is 18x send/recv over TCP considered reliable ?
    In the following scenario:
    - INVITE with offer sdp sent
    - 18x over TCP with answer sdp recvd (No PRACK exchange happened)
    Now can the caller/calleee use UPDATE ?

Can any body clarify the same?
 
Thanks in advance,
Bhavik Chauhan
 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Thu, 19 May 2005 13:25:35 +0200

Hi,
 
If you don't use PRACK you can't send a valid offer in a 18x. An offer (and an answer) has to be sent reliably.
 
Regards,
 
Christer Holmberg
LM Ericsson

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Chauhan Bhavik-A20762
Sent: 19. toukokuuta 2005 12:40
To: [email-masked]; [email-masked]
Subject: [Sip] UPDATE with ANSWER?

Hi all,

 
I went through the older Thread http://lists.cs.columbia.edu/pipermail/sip-implementors/2004-January/006017.html
and came across following Qs which I found not clarified though.

 

Thanks in advance,
Bhavik Chauhan

---

From: Chauhan Bhavik-A20762 <[email-masked]>
Date: Fri, 20 May 2005 11:09:00 +0530

Yes Agree, The FAQ creation afford would be appreciated and this will reduce
exploration through threads which can be like debate than conclusion and 
in fact this is quite natural.

Also I would be thankful if we maintain "agreed upon" things which are not
cited in RFCs
to ascertain the unanimity of all UACs/UASs implementation.

Thanks,
Bhavik

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]]
Sent: Thursday, May 19, 2005 7:10 PM
To: Chauhan Bhavik-A20762
Cc: [email-masked]; [email-masked]
Subject: Re: [Sip-implementors] UPDATE with ANSWER?

We really need to create an FAQ about this.

A long time ago, probably in the thread you cite, we debated this
extensively. It is true that the RFCs are not entirely clear on this,
and reasonable people can differ in interpretation of them. But we
finally came to some agreement on it.

I am quite sure we agreed that UPDATE could *not* be used to send an
answer. We ended up with a quite restrictive list of cases for how
INVITE, UPDATE, PRACK, and their responses and ACK can be used to convey
offer/answer.

I was one who originally argued for fewer restrictions. But there were
issues with that, and the restrictive approach won out. In practice I
don't think the restrictions impose any great burden.

        Paul

Chauhan Bhavik-A20762 wrote:
> Hi all,
> 
> I was exploring the possibility for the UPDATE to send the Answer, As
> I haven't found any explicit restriction in RFC 3311.
> 
> Sip-implementors mailing list [email-masked]
> http://lists.cs.columbia.edu/mailman/listinfo/sip-implementors
>

---

From: "James M. Polk" <[email-masked]>
Date: Fri, 27 May 2005 17:22:30 -0500

At 03:21 PM 5/19/2005 +0530, Avasarala Ranjit-A20990 wrote:
>Hi
>     No UPDATE cannot be used to send answer, since UPDATE can be used 
> only after a dialog is established.

The only valid Request message that can include an SDP answer is in the ACK 
message [RFC3261], and only if the original INVITE did not contain an Offer 
(meaning the offer was in the 200 OK message).

and to the second point made above:

generally, a reINVITE is used after a dialog is established for the same 
Call-ID. An UPDATE is used before a final response has been received to 
alter the parameters contained in the INVITE.

><http://lists.cs.columbia.edu/pipermail/sip-implementors/2004-January/006017.html>http://lists.cs.columbia.edu/pipermail/sip-implementors/2004-January/006017.html

cheers,
James

                                 *******************
                 Truth is not to be argued... it is to be presented.

                      Alas, few *truths* exist without the math.

                             ...all else is a matter of perspective