Subject: [Sip] SDP query

From: [email-masked]
Date: Wed, 7 Sep 2005 12:57:41 -0400

Hi,

Just want to know if following offer-answer exchange is correct, it has 
different dynamic payload types for DTMF and telephone events,
is it necessary for both these to be same ? 
If they are not same, then how both parties will use these values to send 
telephone-events and DTMF digits.

Offer:
m: audio 8000 RTP/AVP 18 0 96
rtpmap: 18 G729/8000
rtpmap: 0 PCMU/8000
fmtp:96 0-15
rtpmap:96 telephone-event/8000

Answer
m: audio 8000 RTP/AVP 18 0 96 97
rtpmap: 18 G729/8000
rtpmap: 0 PCMU/8000
fmtp:96 0-15
rtpmap:97 telephone-event/8000

Thanks,
Udit
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Bob Penfield" <[email-masked]>
Date: Wed, 7 Sep 2005 16:09:27 -0400

It is OK that the answer uses a different payload. However, the Answer in
you example is not correct because it includes payload 96, but no "rtpmap".
Assuming the answerer wants payload 97 for telephone-event, it should look
like this:

Answer
m: audio 8000 RTP/AVP 18 0 97
rtpmap: 18 G729/8000
rtpmap: 0 PCMU/8000
fmtp:97 0-15
rtpmap:97 telephone-event/8000

cheers,
(-:bob

Robert F. Penfield
Chief Software Architect
Acme Packet, Inc.
71 Third Avenue
Burlington, MA 01803
[email-masked]

----- Original Message ----- 
From: <[email-masked]>
To: "SIP Implementors" <[email-masked]>
Cc: "SIP IETF" <[email-masked]>
Sent: Wednesday, September 07, 2005 12:57 PM
Subject: [Sip-implementors] SDP query

> Sip-implementors mailing list
> [email-masked]
> http://lists.cs.columbia.edu/mailman/listinfo/sip-implementors
>