Subject: [Sip] SIP mobility implementation: which draft to look at?

From: Alvaro Canivell <[email-masked]>
Date: Wed, 14 Sep 2005 11:24:30 +0200 (CEST)

I am interested on the implementation of SIP mobility
into the JAIN-SIP platform.

I have found several drafts concerning SIP mobility,
but as I am a beginner in the "draft-ietf thing", I am
not sure where to look at.

First, I found these "active" drafts:

- draft-mingqiang-sipping-session-mobility-media-00
- draft-shacham-sipping-session-mobility-01

Afterwards, I found also the following ones, which are
marked as expired:

- draft-itsumo-sipping-mobility-multimedia-01
- draft-itsumo-sipping-mobility-req-00
- draft-itsumo-sipping-mobility-service-00
- draft-itsumo-sipping-mobility-tcp-00
- draft-itsumo-sip-mobility-multimedia-00
- draft-itsumo-sip-mobility-req-02
- draft-itsumo-sip-mobility-service-00
- draft-itsumo-sip-mobility-tcp-00

Which ones describe the recommendations for the SIP
mobility implementation? Which ones should I read ?

Any kind of advice is welcome!

// Álvaro

______________________________________________ 
Renovamos el Correo Yahoo! 
Nuevos servicios, más seguridad 
http://correo.yahoo.es

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brijesh Kumar" <[email-masked]>
Date: Wed, 14 Sep 2005 10:30:29 -0400

>mobility implementation? Which ones should I read ?

Alvaro:

Shacham's draft is about basic sip mobility and is a good place to
begin with.  This draft elaborates the basic idea of session mobility using
SIP using already existing capabilities in SIP. It should work fine
specially
for (VoIP) applications where session transfer could accept some packet
losses during a session transfer.

Mingqiang's draft   is about seamless session mobility transfer  for
multimedia applications - more specifically of video streams. The main
aim in this draft is to propose changes to SIP that, we believe, are
necessary
for fast and seamless transfer of multimedia streams from one device to
another  device (e.g., from a mobile device to your DVR or to a large video
display). This draft can be seen as complementary (but not dependent) to
above draft since it proposes very specific changes to standard sip  session
transfer procedure and to  media handling  during and after session
transfer.

My understanding is that authors of both drafts have done a private
implementation to study performance, and should be able to help in
your implementation.

Cheers,

--bk

----- Original Message ----- 
From: "Alvaro Canivell" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, September 14, 2005 5:24 AM
Subject: [Sipping] SIP mobility implementation: which draft to look at?

// Álvaro

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP