Subject: RE: [Sip] Multicasting in SIP

From: "Wongbe, Taa" <[email-masked]>
Date: Wed, 21 Sep 2005 12:17:22 -0500

Theja,
 
Although some of the functionalities are not inherent in the protocol,
you could still use multicast with SIP. The Registrar could send an
INVITE to a UA to join a multicast group that is already predefined:
 
UA-----------------REGISTER--------------------->SIP Server
UA<---------------200 OK----------------------------SIP Server
UA-----------------SUBSCRIBE------------------>SIP Server (UA SUBSCRIBE
to a multicast group for its content)
UA<---------------200 OK ------------------------->SIP Server
UA<---------------INVITE----------------------------SIP Server
(Registrar OK and INVITE the UA to the group.)
UA-----------------200 OK------------------------->SIP Server
UA<---------------ACK-------------------------------SIP Server 
 
I agree there need to be more support for multicast, but I think the
protocol itself is at the stage where you perform those functions you
are requesting.
 
-Taa

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Thejeswara Reddy.P
	Sent: Wednesday, September 21, 2005 10:03 AM
	To: [email-masked]
	Subject: Re: [Sip] Multicasting in SIP

	hai Rosenberg.
	       multicast signalling support in sip may open many
applications in iptel such as news on demand.
	 
	i think some investigation needed in this area.
	 
	thanks
	 
	theja
	
	Jonathan Rosenberg <[email-masked]> wrote:

		RFC2543 had "more" support for multicast; we had in mind
that you could 
		send an INVITE to a multicast group for help desk kinds
of functions. 
		But it proved to be very complicated and the mechanisms
in 2543 didn't 
		work. The transaction state machine didn't work
particularly well for 
		multicast and the demand was not there. So the
capability was 
		significantly reduced in 3261.
		
		-Jonathan R.
		
		Samuel Osorio Calvo wrote:
		
		> Although 3261 left the door opened for multicasting
SIP requests, besides the usage of locating registrar servers via a
multicast REGISTER, there isn't description for other cases.
		> So, AFAIK, multicast is just mentioned in the standard
and no other draft expands the use of multicast within SIP. Probably the
classic multicast issues (insecurity and lack of support) has stopped
describing reliable usages. 
		> > Samuel.
		> 
		> 
		> Unclassified.
		> 
		>>>>"Thejeswara Reddy.P" 09/21/05 11:22AM >>>
		> 
		> 
		> 
		> Hai,
		> 
		> I had a question,
		> 
		> Is there any draft for SIP in case of multicast
signalling.
		> thanks
		> theja
__________________________________________________________ 
		> Yahoo! India Matrimony: Find your partner now. Go to
http://yahoo.shaadi.com 
		> 
		> _______________________________________________
		> Sip mailing list
https://www1.ietf.org/mailman/listinfo/sip 
		> This list is for NEW development of the core SIP
Protocol
		> Use [email-masked] for questions on
current sip
		> Use [email-masked] for new developments on the
application of sip
		> 
		> 
		> _______________________________________________
		> Sip mailing list
https://www1.ietf.org/mailman/listinfo/sip
		> This list is for NEW development of the core SIP
Protocol
		> Use [email-masked] for questions on
current sip
		> Use [email-masked] for new developments on the
application of sip
		
		-- 
		Jonathan D. Rosenberg, Ph.D. 600 Lanidex Plaza
		Director, Service Provider VoIP Architecture Parsippany,
NJ 07054-2711
		Cisco Systems
		[email-masked] FAX: (973) 952-5050
		http://www.jdrosen.net PHONE: (973) 952-5000
		http://www.cisco.com

________________________________

	Yahoo! India Matrimony <http://yahoo.shaadi.com> : Find your
partner now.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Thejeswara Reddy.P" <[email-masked]>
Date: Thu, 22 Sep 2005 04:15:11 +0100 (BST)

hai Wongbe,

  I am thinking to take UA as multicast source and rest of UAs as multicast
listeners.

using REGISTER method UA able to register with multicast SIP proxy.

SIP proxies can be used as Rendazaveous points like most popular multicast
routing protocols.

I think there is need of new methods support in SIP for this multicast
signaling.

thanks

theja

		
__________________________________________________________ 
Yahoo! India Matrimony: Find your partner now. Go to http://yahoo.shaadi.com