Subject: RE: [Sip] Constraints on MESSAGE responses

From: Cuda Alberto <[email-masked]>
Date: Wed, 07 Sep 2005 16:44:33 +0200

Hi Hisham, thank you for your answer. In that case which status
code would be best? 200 or 202? Waiting for the acknowledge
from the other network would give an hint of whether the message
has been received or it has been stored, but if an answer must
be given immediately, it is not always easy to guess.

I was wondering which are the disadvantages of waiting a limited
amount of time (compatible with SIP retransmission timers): it 
would give a more significative information of what's going on
at virtually no expenses. Is there a point I'm missing?

Do you have an opinion also on contents of final error responses?

	Thanks, Regards.
		Alberto.

> -----Original Message-----
> From: Hisham Khartabil [mailto:[email-masked]]
> Sent: mercoledì 7 settembre 2005 16.02
> To: Cuda Alberto
> Cc: [email-masked]
> Subject: Re: [Sip] Constraints on MESSAGE responses
> 
> I would say after step 2.x: when the UAC Core has received the MESSAGE
> request. It sends a 2xx response before the gatewaying process takes
> place (step 3).
> 
> Regards,
> Hisham
> 
> On Sep 7, 2005, at 12:36 PM, Cuda Alberto wrote:
> 
> > Hi everybody,
> > I need some clarification about semantic in MESSAGE response.
> > I've tried to find some discussion in the archives, but I did not
> > succeed.
> >
> > According to RFC 3428, paragraph 7, an UAS must send a final response
> > immediately after receiving a MESSAGE request. What does "immediately"
> > actually mean?
> >
> > I am thinking of a SIP <-> non-SIP gateway: when processing a MESSAGE
> > coming from a SIP interface, the rough list of operations it must
> > perform is:
> >
> > 1. Parse SIP headers;
> > 2. Parse SIP body (in case it is not text/plain);
> > 3. Build non-SIP translation of the message
> > 4. Send non-SIP message
> > 5. Wait for an acknowledgment from the non-SIP side (assuming the other
> >   protocol guarantees that ackowledge to be received in less that
> > 200ms)
> >
> > All these steps may encounter some error, for instance in the format
> > of the message, or due to lack of resources (e.g. memory). It may
> > also fail because a negative acknowledgment is received from the
> > non-SIP network. However, none of these steps introduces a
> > significative
> > latency which may cause retransmissions: which is the last step
> > that can be performed before the response must be sent?
> >
> > Another question is: in case of a 4xx or 5xx response code is
> > generated,
> > are there any restrictions on their content type?
> >
> >      Thanks, cheers.
> > 	   Alberto.
> >
> >
> >
> >
> >
> > Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia
> > S.p.A.
> >
> > ====================================================================
> > CONFIDENTIALITY NOTICE
> > This message and its attachments are addressed solely to the persons
> > above and may contain confidential information. If you have received
> > the message in error, be informed that any use of the content hereof
> > is prohibited. Please return it immediately to the sender and delete
> > the message. Should you have any questions, please send an e_mail to
> > [email-masked]. Thank you
> > ====================================================================
> >
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> >

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please send an e_mail to
[email-masked]. Thank you
====================================================================

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Dale R. Worley" <[email-masked]>
Date: Wed, 07 Sep 2005 12:08:35 -0400

> immediately after receiving a MESSAGE request. What does "immediately"

It seems that in practice the requirement is "not significantly longer
than end-to-end SIP transmission times".  Whether your gateway can wait
until the far end of the other network replies depends on the situation.

On Wed, 2005-09-07 at 16:44 +0200, Cuda Alberto wrote:
> code would be best? 200 or 202?

I like the idea of using the 200 response only if the gateway has
received a positive response (200!) from the far end of the other
network, and using 202 otherwise.

Dale

---

From: Hisham Khartabil <[email-masked]>
Date: Thu, 8 Sep 2005 15:32:00 +0200

There is work going on in the SIMPLE working group for Instant Message  
Delivery Notification.

http://www.ietf.org/internet-drafts/draft-khartabil-simple-im-report 
-00.txt
http://www.ietf.org/internet-drafts/draft-burger-simple-imdn-01.txt

I think something like that is what you need.

Regards,
Hisham