Subject: RE: [Sip] WGLC for draft-ietf-sip-fork-loop-fix-01.txt

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Thu, 20 Apr 2006 09:05:03 +0200

Hi Robert,

What you say is pretty much what I said in my proposed text (see below),
that a proxy "MUST ensure, using a standards lopp 
detection mechanism, that a request is not looping through this proxy.".

After that I said that one mechanism is defined in RFC3261, but other
mechanisms can also be used. The reason for that was that the text would
be "valid" also after other mechanisms have been defined.

Do we want to say that a proxy SHOULD use the 3261 mechanism, EVEN if
other mechanims exist?

Regards,

Christer

-----Original Message-----
From: Robert Sparks [mailto:[email-masked]] 
Sent: 20. huhtikuuta 2006 9:57
To: Christer Holmberg (JO/LMF)
Cc: Jonathan Rosenberg; [email-masked]; Robert Sparks; Keith Drage; Dean
Willis
Subject: Re: [Sip] WGLC for draft-ietf-sip-fork-loop-fix-01.txt

How do you get that from this conversation?

What we want to say is you MUST perform loop detection if you are
forking to locations that might loop. You SHOULD use the 3261 algorithm
to do this detection.

That's stronger and more specific than simply saying you SHOULD use
3261 loop detection in
a vacuum.

RjS

On 20-Apr-06, at 2:43 PM, Christer Holmberg ((JO/LMF)) wrote:

>
> Hi,
>
> So, all we want to say with this draft is: "You SHOULD implement this 
> optional RFC3261 feature"?
>
> Regards,
>
> Christer
>
>
> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: 12. huhtikuuta 2006 18:11
> To: Christer Holmberg (JO/LMF)
> Cc: Robert Sparks; [email-masked]; Robert Sparks; Keith Drage; Dean 
> Willis
> Subject: Re: [Sip] WGLC for draft-ietf-sip-fork-loop-fix-01.txt
>
>
>
> Christer Holmberg (JO/LMF) wrote:
>
>
>> So, maybe you could say: "MUST ensure, using a standards lopp 
>> detection mechanism, that a request is not looping through this 
>> proxy.
>
>> RFC 3261 defines a mechanism in chapter x.x.x.. Other standardized 
>> mechansims for loop detecting MAY be used instead, or in addition, to

>> the one defined in RFC 3261.".
>>
>> Or something like that...
>
> I don't like that wording. I think its important to give clear 
> guidance on what an implementor should do. The clear guidance is to 
> implement the loop detection mechanism in RFC3261.
>
> -Jonathan R.
>
>
> -- 
> Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
> Cisco Fellow                                   Parsippany, NJ  
> 07054-2711
> Cisco Systems
> [email-masked]                              FAX:   (973) 952-5050
> http://www.jdrosen.net                         PHONE: (973) 952-5000
> http://www.cisco.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Robert Sparks <[email-masked]>
Date: Thu, 20 Apr 2006 16:40:10 +0900

Do you mean "EVEN if other standardized mechanisms exist?"

If so, no - that's not what we're trying to say.

RjS

On 20-Apr-06, at 4:05 PM, Christer Holmberg ((JO/LMF)) wrote:

> proxy.".