Subject: [Sip]Does message/cpim is a valid Content-Type in SIP

From: "Xiang Ting" <[email-masked]>
Date: Thu, 13 Apr 2006 22:34:30 +0800

I saw somebody assign message/cpim as Content-Type head field content
in SIP. However, the cpim format requires a blank line between the
Content-Type line and the cpim message header. I want to know which
following SIP message segment is valid, or both, or neither?

[snip1]
MESSAGE sip:[email-masked] SIP/2.0
...
...
Content-Type: message/CPIM
Content-Length: 115

NS: XX<uid:[email-masked]>
XX.Reply: no
Conent-Type: text/plain

This is a plain text in cpim.
[/snip1]

------------------------

[snip2]
MESSAGE sip:[email-masked] SIP/2.0
...
...
Content-Length: 115
Content-Type: message/CPIM

NS: XX<uid:[email-masked]>
XX.Reply: no
Conent-Type: text/plain

This is a plain text in cpim.
[/snip2]

Thanks in advance!

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Dale R. Worley" <[email-masked]>
Date: Thu, 13 Apr 2006 13:32:36 -0400

> following SIP message segment is valid, or both, or neither?

They are equivalent, because they differ only in the ordering of two
different headers (Content-Type and Content-Length).

Dale