Subject: [Sip] offer answer

From: "Mahesh Govind" <[email-masked]>
Date: Mon, 10 Apr 2006 23:07:54 +0900

HI,

I have a doubt .

If  an offer is having  a media line
m=audio 4000 RTP/AVP 1 2 3

can an answer  contain ,

If  an offer is having  a media line
m=audio 4000 RTP/AVP 1 2 3 5

With thanks and regards
Mahesh
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Bala Neelakantan" <[email-masked]>
Date: Tue, 11 Apr 2006 10:19:43 -0500

See Section 6.1, page 10.

  The stream MAY indicate additional media formats, not listed in the
   corresponding stream in the offer, that the answerer is willing to
   send or receive (of course, it will not be able to send them at this
   time, since it was not listed in the offer).  For streams marked as

So, the answer can have additional media formats in the media line..

Thanks,

Neel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mahesh
Govind
Sent: Monday, April 10, 2006 9:08 AM
To: [email-masked]
Subject: [Sip] offer answer

HI,

I have a doubt .

can an answer  contain ,

With thanks and regards

Mahesh

---

From: "Xiang Ting" <[email-masked]>
Date: Wed, 12 Apr 2006 21:17:28 +0800

>    time, since it was not listed in the offer).  For streams marked as
Then at what time it will be able to send media descreiption with additional
media formats?

Thank you.
> Sip mailing list
> https://www1.ietf.org/mailman/listinfo/sip

---

From: "Bala Neelakantan" <[email-masked]>
Date: Wed, 12 Apr 2006 17:05:31 -0500

Xiang,

If the answerer needs to enforce extra media formats, then it should start a
new Offer after the current offer/answer negotiation is completed.  

Thanks,
Neel

-----Original Message-----
From: Xiang Ting [mailto:[email-masked]] 
Sent: Wednesday, April 12, 2006 8:17 AM
To: [email-masked]
Cc: Mahesh Govind; [email-masked]
Subject: Re: [Sip] offer answer

Thank you.

---

From: "Xiang Ting" <[email-masked]>
Date: Thu, 13 Apr 2006 19:48:33 +0800

Hi Bala,

> new Offer after the current offer/answer negotiation is completed.
That is to say the answerer can not add extra media format information
in this particular transaction, isn't it?

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 13 Apr 2006 18:04:32 -0400

> in this particular transaction, isn't it?

The answerer may add them, but they may not be used. However they can 
serve as hints for the next offer/answer cycle.

In general with offer/answer it seems to work out best if each side 
keeps stating what it wants, censoring itself based on what it thinks 
the other end wants. This isn't always possible - there are rules that 
must be followed that don't always allow this.  But its still good 
policy when applied to the extent allowed.

	Paul

>>>From: [email-masked] [mailto:[email-masked]] On Behalf Of
>>
>>Mahesh
>>
>>>Govind

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 17 Apr 2006 12:03:08 -0400

I just noticed I made a significant omission in what I posted earlier. 
See correction inline.

	Paul

Paul Kyzivat wrote:
> the other end wants.

I meant to say:

In general with offer/answer it seems to work out best if each side
keeps stating what it wants, RATHER THAN censoring itself based on what 
it thinks the other end wants.

> This isn't always possible - there are rules that