Subject: [Sip] http://www.ietf.org/internet-drafts/draft-ietf-sip-outbound-03.txt

From: "Jeroen van Bemmel" <[email-masked]>
Date: Tue, 4 Apr 2006 08:02:07 +0200

Rohan,

Two things, 1 comment and a nit:

1. clarification on recent flows: There are several references to the registrar using the most recent flow. There are two potential issues with this:
1a q-value ordering - if the UAC first registers a flow with q=0.8 and later with q=0.1, I think the former should be used (i.e. q-value taking precedence over flow establishment time). Same goes for scenario's with two different UACs registering for the same user, one using outbound and another one not (with higher q-value)
1b multiple flows established with a single REGISTER - what is the most recent one in this case?

2 - section 11 says "the proxy stores the value of the Path header field", this should be "the registrar"

Regards,

Jeroen

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rohan Mahy <[email-masked]>
Date: Tue, 4 Apr 2006 09:26:35 -0700

On Apr 3, 2006, at 23:02, Jeroen van Bemmel wrote:

> 1. clarification on recent flows: There are several references to the 
> registrar using the most recent flow.

Hi Jeroen,

The intent is that if you have more than one registration with the same 
AOR, instance, *AND* reg-id you use the most recently registered of 
these.  An AOR and Contact with no instance will never match one with 
an instance so I think this is pretty safe.  If you can think of a 
better way to express this in the draft please let me know.

> There are two potential issues with this:
> 1a q-value ordering - if the UAC first registers a flow with q=0.8 and 
> later with q=0.1, I think the former should be used (i.e. q-value 
> taking precedence over flow establishment time). Same goes for 
> scenario's with two different UACs registering for the same user, one 
> using outbound and another one not (with higher q-value)

A single register request can only establish one flow maximum.

> field", this should be "the registrar"

good catch.  thanks,
-rohan

---

From: "Jeroen van Bemmel" <[email-masked]>
Date: Tue, 4 Apr 2006 21:02:48 +0200

Hi Rohan

see inline

Regards,
Jeroen
----- Original Message ----- 
From: "Rohan Mahy" <[email-masked]>
To: "Jeroen van Bemmel" <[email-masked]>
Cc: "Rohan Mahy" <[email-masked]>; <[email-masked]>
Sent: Tuesday, April 04, 2006 6:26 PM
Subject: Re: 
http://www.ietf.org/internet-drafts/draft-ietf-sip-outbound-03.txt

Hi Jeroen,

[Jvb] This part I understood. Perhaps my question below wasn't clear. (1a) 
is about the moment a request comes in destined for an AoR which has 2 
registered contacts. At least one of them (the most recent one) has an 
associated flow, but the other has a higher q-value. Question is: which one 
gets selected?

> later with q=0.1, I think the former should be used (i.e. q-value taking 
> precedence over flow establishment time). Same goes for scenario's with 
> two different UACs registering for the same user, one using outbound and 
> another one not (with higher q-value)

[Jvb] Right, I mixed up my thoughts. So should the draft state then that the 
REGISTER request SHOULD NOT contain more than 1 Contact?

good catch.  thanks,
-rohan

---

From: Rohan Mahy <[email-masked]>
Date: Sat, 8 Apr 2006 16:07:09 -0700

On Apr 4, 2006, at 12:02, Jeroen van Bemmel wrote:

> Hi Rohan
>
> see inline
>
> Regards,
> Jeroen
> ----- Original Message ----- From: "Rohan Mahy" <[email-masked]>
> [Jvb] This part I understood. Perhaps my question below wasn't clear. 
> (1a) is about the moment a request comes in destined for an AoR which 
> has 2 registered contacts. At least one of them (the most recent one) 
> has an associated flow, but the other has a higher q-value. Question 
> is: which one gets selected?

How the proxy selects specific instances (whether determined by unique 
instance-id or contact URI) to make up the fork set is (still) proxy 
local policy.  I know of several proxies that parallel fork all the 
instances with the same q-value then wait and parallel fork the 
instances with the next q-value.  Outbound doesn't change any of this.  
Once you decide to try instance xyz then what flow you pick is 
described in outbound.

>> 1a q-value ordering - if the UAC first registers a flow with q=0.8 
>> and later with q=0.1, I think the former should be used (i.e. q-value 
> [Jvb] Right, I mixed up my thoughts. So should the draft state then 
> that the REGISTER request SHOULD NOT contain more than 1 Contact?

yes.

thanks,
-rohan