Subject: RE: 3rd party registration (was RE: [Sip] SIP MIB ietf-sip-mib comments)

From: "Michael Procter" <[email-masked]>
Date: Wed, 5 Apr 2006 16:47:06 +0100

Alan Hawrylyshen wrote:
> On 4/5/06, Michael Procter <[email-masked]> wrote: 
> 
>> Jonathan Rosenburg mentioned on this list (Dec 15, 2005) that
>> draft-ietf-sip-outbound breaks 3rd party registrations, but 
>> I can't find the paragraph in the draft that states this after
>> a brief reading.  Para 4.2.1 appears to relate to the *other*
>> meaning of 3rd party registration.
> 
> Well, by binding an AoR to a 'flow', the outbound draft
> effectively limits your ability to register a contact URI 
> that get fair RFC3263 treatment, and therefore, makes 3rd
> party registration significantly more challenging. (The
> association between your flow and the AoR that gets made
> using the outbound mechanism may not be what you want for 3pr).

I think I understand your concern, but I don't think it applies in
this case.  Maybe I should explain the scenario in more detail.

Suppose Bob's phone needs to register a line with Alice's AOR
(for example, Bob is Alice's secretary - the normal example).
Bob's phone can send a REGISTER with the following headers:
To: sip:[email-masked]
From: sip:[email-masked]
Contact: sip:[email-masked]

This is a 3rd party registration (To != From), but (and I think
this is where the confusion occurs), the Contact header relates
to the device that is sending the REGISTER (Bob's phone).  I
believe that this will still work with 'outbound' but I'd welcome
comments if this is not the case.

I agree with you that if you tried to register a Contact that
didn't point to the same device (e.g. Bob trying to register a
contact from Carol's phone), then outbound would break it.  But
this is the *other* understanding of 3rd party registration
that Cullen originally commented on (I think).

Given these two scenarios, I believe that Jonathan's original
comment may have been ambiguous.  To provide some context, I've
appended an extract from the orignal message:

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Jonathan Rosenberg
> Sent: 15 December 2005 14:54
> To: Paul Kyzivat
> Cc: Cullen Jennings; [email-masked]
> Subject: Re: モヘ?: RE: [Sip] one question on the authentication
> forthird-party registration
> 
> 
> I think these use cases are better handled through configuration of a 
> forwarding feature that runs on the proxy. I had always 
> envisioned xcap 
> being used for this kind of thing too; we need only define schema for 
> the forwarding numbers.
> 
> Note that, with draft-ietf-sip-outbound, third-party 
> registrations are 
> not possible anymore. I think thats a good thing; it allows us to 
> separate routing from retargeting, per the discussion we had at ietf.
> 
> -Jonathan R.
> 
> Paul Kyzivat wrote:
> 
> > I'm not aware of any. But I've been discussing use cases for it for 
> > years. One is for a boss/secretary arrangement, where the 
> secretary can 
> > register for the boss' AOR, but doesn't need the boss' own 
> credentials 
> > to do it.
> > 
> > Somebody has to be first. Go for it!
> > 
> >     Paul
> > 
> > Cullen Jennings wrote:
> > 
> >> Has anyone build a proxy that allows the configuration of a policy 
> >> that says
> >> Bob is allowed to register for Alice's AOR?
> >>

Regards,

Michael Procter

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Alan Hawrylyshen" <[email-masked]>
Date: Wed, 5 Apr 2006 10:05:09 -0600

> > >> Bob is allowed to register for Alice's AOR?

Cullen;

Yes. I have seen a couple vendors, one in the US and another in Europe that
rely on this feature to be able to either implement the 'administrative
registration' (secretary registering the boss' AoR) AND in order to permit
some 3rd party device to register for arbitrary AoRs with 'magic / special'
credentials. These credentials allow the third device to register as any one
of a collection of AoRs that the proxy knows about. It is almost like a
group credential.

Cheers,
Alan

--
--
a d o t h a w r y l y s h e n a t g m a i l d o t c o m