Subject: RE: [Sip] RE: Outbound: Multiple flows and forking

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Wed, 5 Apr 2006 14:20:31 +0200

Hi,
 
I agree with Erkki - mobile devices may well use outbound.
 
However, to comment Erikki's new text proposal: I don't think the main
issue how many outbuond proxies the UA is mandated to support, but that
fact that the UA MUST send a REGISTER to each of them. I think the UA
should be allowed to send a REGISTER with only one of the outbound
proxies. If we think that may cause problems we can always RECOMMEND
sending REGISTER to multiple outbound proxies.
 
Also, we talk about "outbound proxy URIs". Are we sure that the UA will
always have the outbound proxy in a form of a URI?
 
Regards,
 
Christer

________________________________

From: [email-masked] [mailto:[email-masked]] 
Sent: 5. huhtikuuta 2006 14:44
To: [email-masked]; Christer Holmberg (JO/LMF); [email-masked]
Subject: RE: [Sip] RE: Outbound: Multiple flows and forking

Hi,
 
While the referred estimates give an idea about the impact of keepalives
when using certain cellular technologies, the mobile devices might as
well
use WLAN. In that case the impact for battery lifetime is much less
dramatic,
but not negligible. So mobile devices might well use outbound, but still
like
to minimize the flows to be kept alive.
 
I would also request to downgrade the requirement as follows:
 
"However, a UA SHOULD support sets with at least two outbound proxy URIs
(primary and backup) and MAY support sets with up to four URIs."
 
Otherwise the spec would be too stringent for some environments. I can 
also imagine certain cases where only one single proxy is available due
to cost 
or other architectural reasons. While not ideal, I would not like ban a
mobile 
service provider or a small company to apply outbound with one single
proxy 
only and cope with UAs supporting a single proxy only. The spec could 
however be explicit on mentioning the limitations or risks caused by
doing so.
 
Regards,
 
Erkki

________________________________

	From: ext Jeroen van Bemmel [mailto:[email-masked]] 
	Sent: 05.April.2006 14:04
	To: Christer Holmberg (JO/LMF); [email-masked]
	Subject: Re: [Sip] RE: Outbound: Multiple flows and forking

	Christer,
	 
	I wouldn't recommend using outbound for mobile devices in the
first place
	 
	In
http://www.ietf.org/internet-drafts/draft-brok-simple-regulate-publish-0
2.txt section 2.2 there are some estimates for the effect of periodic
transmissions on the battery lifetime. This is for periodic PUBLISH, for
periodic keepalive (UDP: every 24-29 seconds, TCP: every 95-120 seconds)
it would even be worse. Your battery would be depleted in about a day
	 
	Regards,
	 
	Jeroen

		----- Original Message ----- 
		From: Christer Holmberg (JO/LMF)
<mailto:[email-masked]>  
		To: [email-masked] 
		Sent: Wednesday, April 05, 2006 11:58 AM
		Subject: [Sip] RE: Outbound: Multiple flows and forking

		Hi, 

		One more thing about mandating the sending of REGISTERs
to multiple proxies. To maintain a single registration flow will most
likely have impacts on batteries in mobile devices, and mandating to
maintain multiple flows would have even bigger impacts. So, that's
another reason I don't think it shall be mandated.

		Regards, 

		Christer 

		_____________________________________________ 
		From:   Christer Holmberg (JO/LMF)  
		Sent:   5. huhtikuuta 2006 11:26 
		To:     [email-masked] 
		Subject:        Outbound: Multiple flows and forking 

		Hi, 

		A couple of issues on chapter 4.2. 

		The text says: 

		"However, a UA MUST support sets with at least two
outbound proxy URIs (primary and backup) and SHOULD support sets with up
to four URIs.  For each

		outbound proxy URI in the set, the UA MUST send a
REGISTER in the normal way using this URI as the default outbound
proxy."

		I don't think we should mandate this, because it is very
much dependent on the architecture, transport techniques etc. 

		Also, if the UA has registered multiple flows, should
the registrar fork dialog initiation requests (addressed for the UA) on
all of them? I realize it is an implementation issue, but I think it
would be good to have some words about it in the draft, for example
saying that a registrar may choose not to fork if the same instance-id
is used for multiple bindings. Or something like that...

		Regards, 

		Christer 

________________________________

		_______________________________________________
		Sip mailing list
https://www1.ietf.org/mailman/listinfo/sip
		This list is for NEW development of the core SIP
Protocol
		Use [email-masked] for questions on
current sip
		Use [email-masked] for new developments on the
application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: <[email-masked]>
Date: Wed, 5 Apr 2006 15:41:37 +0300

Hi Christer,
 
Regarding to your proposal: Why would it be a MUST to the UA to support
two outbound proxy
URIs if it is legal to send a REGISTER to only one of them ? Why would
the second URI be needed ?
 
In my text proposal the idea was that the UA would send REGISTER and
create flow to as many
outbound proxy URIs as the UA supports: 1, 2, 3 or 4.
 
If the UA only supports creating only one flow it could do it by
supporting a proxy set with one
single URI only.
 
Regards,
 
Erkki

	From: ext Christer Holmberg (JO/LMF)
[mailto:[email-masked]] 
	Sent: 05.April.2006 15:21
	To: Koivusalo Erkki (Nokia-TP/Helsinki); [email-masked];
[email-masked]
	Subject: RE: [Sip] RE: Outbound: Multiple flows and forking

	Hi,

	However, to comment Erikki's new text proposal: I don't think
the main issue how many outbuond proxies the UA is mandated to support,
but that fact that the UA MUST send a REGISTER to each of them. I think
the UA should be allowed to send a REGISTER with only one of the
outbound proxies. If we think that may cause problems we can always
RECOMMEND sending REGISTER to multiple outbound proxies.
	 
	Also, we talk about "outbound proxy URIs". Are we sure that the
UA will always have the outbound proxy in a form of a URI?
	 
	Regards,
	 
	Christer

	

	From: [email-masked]
[mailto:[email-masked]] 
	Sent: 5. huhtikuuta 2006 14:44
	To: [email-masked]; Christer Holmberg (JO/LMF); [email-masked]
	Subject: RE: [Sip] RE: Outbound: Multiple flows and forking

	Hi,
	 
	While the referred estimates give an idea about the impact of
keepalives
	when using certain cellular technologies, the mobile devices
might as well
	use WLAN. In that case the impact for battery lifetime is much
less dramatic,
	but not negligible. So mobile devices might well use outbound,
but still like
	to minimize the flows to be kept alive.

	"However, a UA SHOULD support sets with at least two outbound
proxy URIs (primary and backup) and MAY support sets with up to four
URIs."
	 
	Otherwise the spec would be too stringent for some environments.
I can 
	also imagine certain cases where only one single proxy is
available due to cost 
	or other architectural reasons. While not ideal, I would not
like ban a mobile 
	service provider or a small company to apply outbound with one
single proxy 
	only and cope with UAs supporting a single proxy only. The spec
could 
	however be explicit on mentioning the limitations or risks
caused by doing so.
	 
	Regards,
	 
	Erkki

		From: ext Jeroen van Bemmel [mailto:[email-masked]] 
		Sent: 05.April.2006 14:04
		To: Christer Holmberg (JO/LMF); [email-masked]
		Subject: Re: [Sip] RE: Outbound: Multiple flows and
forking

		Christer,
		 
		I wouldn't recommend using outbound for mobile devices
in the first place
		 
		In
		 
		Regards,
		 
		Jeroen

			----- Original Message ----- 
			From: Christer Holmberg (JO/LMF)
<mailto:[email-masked]>  
			To: [email-masked] 
			Sent: Wednesday, April 05, 2006 11:58 AM
			Subject: [Sip] RE: Outbound: Multiple flows and
forking

			Hi, 

			One more thing about mandating the sending of
REGISTERs to multiple proxies. To maintain a single registration flow
will most likely have impacts on batteries in mobile devices, and
mandating to maintain multiple flows would have even bigger impacts. So,
that's another reason I don't think it shall be mandated.

			Regards, 

			Christer 

			_____________________________________________ 
			From:   Christer Holmberg (JO/LMF)  
			Sent:   5. huhtikuuta 2006 11:26 
			To:     [email-masked] 
			Subject:        Outbound: Multiple flows and
forking 

			Hi, 

			The text says: 

			"However, a UA MUST support sets with at least
two outbound proxy URIs (primary and backup) and SHOULD support sets
with up to four URIs.  For each

			outbound proxy URI in the set, the UA MUST send
a REGISTER in the normal way using this URI as the default outbound
proxy."

			I don't think we should mandate this, because it
is very much dependent on the architecture, transport techniques etc. 

			Also, if the UA has registered multiple flows,
should the registrar fork dialog initiation requests (addressed for the
UA) on all of them? I realize it is an implementation issue, but I think
it would be good to have some words about it in the draft, for example
saying that a registrar may choose not to fork if the same instance-id
is used for multiple bindings. Or something like that...

			Regards, 

			Christer 

			

			Use [email-masked] for
questions on current sip