Subject: [Sip] Question about propagation of dual stack along message path

From: "James M. Polk" <[email-masked]>
Date: Thu, 27 Apr 2006 15:49:51 -0500

Hey

Given this generic topology:

Alice --> Proxy1 --> Proxy2 --> Proxy3 --> Bob

If Alice has a dual stack (IPv4 and IPv6), can she include both types of 
addresses everywhere in each of her messages towards Bob?

If so, can Proxy1 do the same (add both address types everywhere it can)?

for example, in the Via header "received=<Alice's IPv4 address>"

Can this Via header have "received=<IPv4 add & IPv6 add>"?

If this is true, can this propagate all the way to Bob?

What happens if there is a Proxy that does not have dual stacks?

Does it drop the IPv6 addressing, or ignore then and pass them on?

The intent is for the offerer to offer both choices, and the answerer 
answer with IPv6 if they have that stack (or both stacks), and v4 if they 
only have this one stack.

Is this written anywhere in an RFC or ID (even an old one)?

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 27 Apr 2006 15:57:27 -0500

James: See
http://www.ietf.org/internet-drafts/draft-ietf-sipping-v6-transition-02.txt
for some answers to your questions.

- vijay

James M. Polk wrote:
> answer with IPv6 if they have that stack (or both stacks), and v4 if 
> they only have this one stack.
> 

-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Bell Laboratories, Lucent Technologies, Inc.
2701 Lucent Lane, Rm. 9F-546, Lisle, Illinois 60532 (USA)
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip