Subject: RE: [Sip] RE: Outbound: Multiple flows and forking

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Wed, 5 Apr 2006 14:46:59 +0200

Hi Erkki,
 
I don't think the UA MUST support two outbound proxy URIs, so I agree
with your text change proposal.
 
What I meant was that the main issue is the fact that the UA MUST send
REGISTER to all of the proxies. The number of URIs does not impact
battery life, but the number of registration flows do :)
 
So, no matter how many outbound proxy URIs the UA supports, it should
not be mandated to send REGISTER to all of them.
 
Regards,
 
Christer

________________________________

From: [email-masked] [mailto:[email-masked]] 
Sent: 5. huhtikuuta 2006 15:42
To: Christer Holmberg (JO/LMF); [email-masked]; [email-masked]
Subject: RE: [Sip] RE: Outbound: Multiple flows and forking

Hi Christer,
 
Regarding to your proposal: Why would it be a MUST to the UA to support
two outbound proxy
URIs if it is legal to send a REGISTER to only one of them ? Why would
the second URI be needed ?
 
In my text proposal the idea was that the UA would send REGISTER and
create flow to as many
outbound proxy URIs as the UA supports: 1, 2, 3 or 4.
 
If the UA only supports creating only one flow it could do it by
supporting a proxy set with one
single URI only.
 
Regards,
 
Erkki

________________________________

	From: ext Christer Holmberg (JO/LMF)
[mailto:[email-masked]] 
	Sent: 05.April.2006 15:21
	To: Koivusalo Erkki (Nokia-TP/Helsinki); [email-masked];
[email-masked]
	Subject: RE: [Sip] RE: Outbound: Multiple flows and forking

	Hi,
	 
	I agree with Erkki - mobile devices may well use outbound.
	 
	However, to comment Erikki's new text proposal: I don't think
the main issue how many outbuond proxies the UA is mandated to support,
but that fact that the UA MUST send a REGISTER to each of them. I think
the UA should be allowed to send a REGISTER with only one of the
outbound proxies. If we think that may cause problems we can always
RECOMMEND sending REGISTER to multiple outbound proxies.
	 
	Also, we talk about "outbound proxy URIs". Are we sure that the
UA will always have the outbound proxy in a form of a URI?
	 
	Regards,
	 
	Christer

	
________________________________

	From: [email-masked]
[mailto:[email-masked]] 
	Sent: 5. huhtikuuta 2006 14:44
	To: [email-masked]; Christer Holmberg (JO/LMF); [email-masked]
	Subject: RE: [Sip] RE: Outbound: Multiple flows and forking

	Hi,
	 
	While the referred estimates give an idea about the impact of
keepalives
	when using certain cellular technologies, the mobile devices
might as well
	use WLAN. In that case the impact for battery lifetime is much
less dramatic,
	but not negligible. So mobile devices might well use outbound,
but still like
	to minimize the flows to be kept alive.
	 
	I would also request to downgrade the requirement as follows:
	 
	"However, a UA SHOULD support sets with at least two outbound
proxy URIs (primary and backup) and MAY support sets with up to four
URIs."
	 
	Otherwise the spec would be too stringent for some environments.
I can 
	also imagine certain cases where only one single proxy is
available due to cost 
	or other architectural reasons. While not ideal, I would not
like ban a mobile 
	service provider or a small company to apply outbound with one
single proxy 
	only and cope with UAs supporting a single proxy only. The spec
could 
	however be explicit on mentioning the limitations or risks
caused by doing so.
	 
	Regards,
	 
	Erkki

________________________________

		From: ext Jeroen van Bemmel [mailto:[email-masked]] 
		Sent: 05.April.2006 14:04
		To: Christer Holmberg (JO/LMF); [email-masked]
		Subject: Re: [Sip] RE: Outbound: Multiple flows and
forking

		Christer,
		 
		I wouldn't recommend using outbound for mobile devices
in the first place
		 
		In
http://www.ietf.org/internet-drafts/draft-brok-simple-regulate-publish-0
2.txt section 2.2 there are some estimates for the effect of periodic
transmissions on the battery lifetime. This is for periodic PUBLISH, for
periodic keepalive (UDP: every 24-29 seconds, TCP: every 95-120 seconds)
it would even be worse. Your battery would be depleted in about a day
		 
		Regards,
		 
		Jeroen

			----- Original Message ----- 
			From: Christer Holmberg (JO/LMF)
<mailto:[email-masked]>  
			To: [email-masked] 
			Sent: Wednesday, April 05, 2006 11:58 AM
			Subject: [Sip] RE: Outbound: Multiple flows and
forking

			Hi, 

			One more thing about mandating the sending of
REGISTERs to multiple proxies. To maintain a single registration flow
will most likely have impacts on batteries in mobile devices, and
mandating to maintain multiple flows would have even bigger impacts. So,
that's another reason I don't think it shall be mandated.

			Regards, 

			Christer 

			_____________________________________________ 
			From:   Christer Holmberg (JO/LMF)  
			Sent:   5. huhtikuuta 2006 11:26 
			To:     [email-masked] 
			Subject:        Outbound: Multiple flows and
forking 

			Hi, 

			A couple of issues on chapter 4.2. 

			The text says: 

			"However, a UA MUST support sets with at least
two outbound proxy URIs (primary and backup) and SHOULD support sets
with up to four URIs.  For each

			outbound proxy URI in the set, the UA MUST send
a REGISTER in the normal way using this URI as the default outbound
proxy."

			I don't think we should mandate this, because it
is very much dependent on the architecture, transport techniques etc. 

			Also, if the UA has registered multiple flows,
should the registrar fork dialog initiation requests (addressed for the
UA) on all of them? I realize it is an implementation issue, but I think
it would be good to have some words about it in the draft, for example
saying that a registrar may choose not to fork if the same instance-id
is used for multiple bindings. Or something like that...

			Regards, 

			Christer 

________________________________

			_______________________________________________
			Sip mailing list
https://www1.ietf.org/mailman/listinfo/sip
			This list is for NEW development of the core SIP
Protocol
			Use [email-masked] for
questions on current sip
			Use [email-masked] for new developments on the
application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Fri, 7 Apr 2006 09:51:57 +0200

Hi,

Then we could write something like: "For reliability or load balancing
reasons, the UA MAY send REGISTER to more than one outbound proxy..."

Or something like that...

Regards,

Christer 

-----Original Message-----
From: Juha Heinanen [mailto:[email-masked]] 
Sent: 7. huhtikuuta 2006 10:50
To: Christer Holmberg (JO/LMF)
Cc: [email-masked]; [email-masked]
Subject: RE: [Sip] Outbound: Multiple flows and forking

Christer Holmberg (JO/LMF) writes:

 > However, I am not sure "load balancing" is the best possible wording,
> because my understanding is that the purpose of contacting multiple  >
outbound proxies is more related to realiablilty than load balancing.

if it is possible to achieve both at the same time, it is stupid to do
only one.

-- juha

---

From: "Samir Srivastava" <[email-masked]>
Date: Fri, 7 Apr 2006 17:58:23 -0500

Here keep alive traffic is most of the time. How the load balancing will
be achieved unless we have different keep alive timers for primary and
secondary or secondary flows comes into picture when primary is failed.
Is that author intended ?

SRV RFC used the term primary and secondary for services with different
priority values. But here we don't have any of such designation as we
are keeping flow alives with available proxies for reliability.

Section 3.3 of outbound talks about the load balancing among primaries,
but how it is achieved as mostly we have keep alive traffic ? How SRV
helps here as noted in the draft.

Thx
Samir

-----Original Message-----
From: Juha Heinanen [mailto:[email-masked]] 
Sent: Friday, April 07, 2006 12:50 AM
To: Christer Holmberg (JO/LMF)
Cc: [email-masked]
Subject: RE: [Sip] Outbound: Multiple flows and forking

-- juha

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol Use
[email-masked] for questions on current sip Use
[email-masked] for new developments on the application of sip

---

From: "Samir Srivastava" <[email-masked]>
Date: Fri, 7 Apr 2006 18:25:07 -0500

After reading 3.3 again, it looks that a UA is going to connect two of
the primary machines from the SRV lookup which will yield in set of
machines. So multiple UA's are distibuting on the "set of primary
machines" using SRV weight.

While secondary is just a backup, No active flow. 

I might be wrong in interpretation :-)

Thx
Samir 

-----Original Message-----
From: Srivastava, Samir [SC100:8826:EXCH] 
Sent: Friday, April 07, 2006 3:58 PM
To: 'Juha Heinanen'; Christer Holmberg (JO/LMF)
Cc: [email-masked]
Subject: RE: [Sip] Outbound: Multiple flows and forking

Thx
Samir

-----Original Message-----
From: Juha Heinanen [mailto:[email-masked]]
Sent: Friday, April 07, 2006 12:50 AM
To: Christer Holmberg (JO/LMF)
Cc: [email-masked]
Subject: RE: [Sip] Outbound: Multiple flows and forking

-- juha