Subject: AW: WG: [Sip] Last Call: 'Suppression of Session Initiation ProtocolREFER Method Implicit Subscription' to Proposed Standard

From: "Tan, Ya-Ching" <[email-masked]>
Date: Tue, 11 Apr 2006 11:43:51 +0200

Please igonore the previous mail.  I realized that the Refer-Sub header has no parameter. 

Ya Ching

-----Ursprüngliche Nachricht-----
Von: Tan, Ya-Ching 
Gesendet: Dienstag, 11. April 2006 11:20
An: Dean Willis
Cc: sip ietf; [email-masked]
Betreff: AW: WG: [Sip] Last Call: 'Suppression of Session Initiation ProtocolREFER Method Implicit Subscription' to Proposed Standard 

Just noticed that the draft also failed to register the header field parameter according to processes of RFC 3968.

Ya Ching

-----Ursprüngliche Nachricht-----
Von: Dean Willis [mailto:[email-masked]] 
Gesendet: Donnerstag, 6. April 2006 19:40
An: Tan, Ya-Ching
Betreff: Re: WG: [Sip] Last Call: 'Suppression of Session Initiation Protocol REFER Method Implicit Subscription' to Proposed Standard 

Yes, very late -- the draft is already in the RFC Editor queue. I'll  
see if the ADs will support fixing with an Instruction to the RFC  
Editor.

Thanks!

--
Dean
>
> -----Ursprüngliche Nachricht-----
> Von: Tan, Ya-Ching
> Gesendet: Donnerstag, 6. April 2006 18:03
> An: [email-masked]'; [email-masked]'
> Betreff: WG: [Sip] Last Call: 'Suppression of Session Initiation  
> Protocol REFER Method Implicit Subscription' to Proposed Standard
>
> Some very late comments :
>
> Section 9 :
>    "Should an intermediary maliciously insert a "Refer-Sub" header  
> field
>    set to "false", two possibilities may occur.  If the REFER- 
> Recipient
>    does not support the extension, the REFER will fail with a "420 Bad
>    Extension" response. The REFER-Issuer will be confused as no  
> "Refer-
>    Sub" was in the request, and the resulting request will fail."
>
> Here we are talking about an unknown header. There is no reason for  
> a recipient of an unknown header to send a 420 response. Unknown  
> headers are normally just discarded.
>
> And the last sentence of the same paragraph :
>
>    "As a result the REFER-Recipient will not learn the outcome of the
>    operation on the Refer-To URI."
>
> It should be the "REFER-Issuer" instead.
>
>
>
> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]] Im Auftrag  
> von The IESG
> Gesendet: Freitag, 3. Februar 2006 15:49
> An: IETF-Announce
> Cc: [email-masked]
> Betreff: [Sip] Last Call: 'Suppression of Session Initiation  
> Protocol REFER Method Implicit Subscription' to Proposed Standard
>
> The IESG has received a request from the Session Initiation  
> Protocol WG to
> consider the following document:
>
> - 'Suppression of Session Initiation Protocol REFER Method Implicit
>    Subscription '
>    <draft-ietf-sip-refer-with-norefersub-04.txt> as a Proposed  
> Standard
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action.  Please send any comments to the
> [email-masked] or [email-masked] mailing lists by 2006-02-17.
>
> The file can be obtained via
> http://www.ietf.org/internet-drafts/draft-ietf-sip-refer-with- 
> norefersub-04.txt
>
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
>

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Dean Willis <[email-masked]>
Date: Tue, 11 Apr 2006 21:50:31 -0500

> Please igonore the previous mail.  I realized that the Refer-Sub  

Oh good. I was about to resign in abject shame and apply for a job in  
Marketing.

--
Dean