Subject: RE: [Sip] How to indicate duringproxydiscoverythataproxysupports"outbound"

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Mon, 3 Apr 2006 22:43:12 +0200

Hi,

I agree with Bob. I don't think the registrar should be required to
support something it absolutely doesn't have to care about... I would
just cause unecessary roundtrips.

Regards,

Christer 

-----Original Message-----
From: Bob Penfield [mailto:[email-masked]] 
Sent: 3. huhtikuuta 2006 21:05
To: Jeroen van Bemmel; Christer Holmberg (JO/LMF); Hadriel Kaplan;
[email-masked]
Subject: Re: [Sip] How to indicate
duringproxydiscoverythataproxysupports"outbound"

inline.
----- Original Message -----
From: "Jeroen van Bemmel" <[email-masked]>

> Christer,
>
> No, I think the outbound proxy shouldn't be touching any Require 
> headers, whether present or not
>
> It is up to the UAC to decide whether the request needs a Require 
> header or not. If people have strong feelings against sending a 
> REGISTER request with reg-id parameters etc, then perhaps the draft 
> could say "UAC SHOULD add
> Require: outbound to the REGISTER request"
>
> Though in RFC3329 the proxy does remove the Require header, it seems 
> that outbound is different from sec-agree in this case.
>

I'm afraid I disagree. I think that 'outbound' is the same as sec-agree
in 
this case.

For outbound we need two option tags to make things unambiguous: One for
the 
reusable connection with keepalive behavior that the first hop must do
(e.g 
'outbound-stun'), and one for the registrar behavior of recognizing
reg-id 
and sip-instance in the Contact (e.g. 'outbound-reg').

Unless the UA knows that the outbound proxy is not the registrar, its
first 
REGISTER will have:

Require: outbound-stun, outbound-reg
Proxy-Require: outbound-stun

outbound-reg is intended for the registrar, and outbound-stun is
intended 
for the first hop.

Remember, for REGISTER, the registrar is the UAS, not a proxy. If the
first 
hop is the registrar, the Require header applies, and 'outbound-stun'
needs 
to be there so the registrar does the reusable connection with
keepalive.

If the first hop is not the registrar, it must remove the
'outbound-stun' 
tag from both the Require and the Proxy-Require. This is because the 
'outbound-stun' feature is applied completely by the first hop proxy.
The 
registrar does not need to do any 'outbound-stun' behavior. It only
needs to 
do 'outbound-reg' behavior. If the tag was left in the Require header,
it 
would a) reject it if it does not support 'outbound-stun'; or b) do the 
wrong thing by applying 'outbound-stun' behavior.

cheers,
(-:bob

> Regards,
>
> Jeroen
>
> ----- Original Message ----- 
> From: "Christer Holmberg (JO/LMF)" <[email-masked]>
> To: "Jeroen van Bemmel" <[email-masked]>; "Hadriel Kaplan" 
> <[email-masked]>; <[email-masked]>
> Sent: Monday, April 03, 2006 9:21 AM
> Subject: RE: [Sip] How to indicate during proxy 
> discoverythataproxysupports"outbound"
>
>
>
> Hi,
>
> In case the outbound proxy and the registrar are NOT the same, I
assume
> that the outbound proxy would not only remove the option tag from the
> Proxy-Require header, but also from the Require header? Because, as
far
> as I can see there is no reason to require the registrar to also
support
> outbound.
>
> Regards,
>
> Christer
>
>
> -----Original Message-----
> From: Jeroen van Bemmel [mailto:[email-masked]]
> Sent: 3. huhtikuuta 2006 9:29
> To: Christer Holmberg (JO/LMF); Hadriel Kaplan; [email-masked]
> Subject: Re: [Sip] How to indicate during proxy
> discoverythataproxysupports"outbound"
>
> Christer,
>
> Besides detection for support, Proxy-Require is also useful for
> backwards compatibility
>
> Consider how the edge proxy decides whether or not it needs to perform
> outbound processing. Without Proxy-Require, it would have to either
look
> for
> 'Require: outbound' or inspect the Contact headers, look for 'reg-id'
> and assume that means the UAC supports / wants to use outbound. From a
> protocol purist perspective, both of these alternatives are less
> preferred than Proxy-Require
>
> BTW, section 3.4 should have some text discussing this. It currently
> says "edge proxy should use Path" but the processing seems to depend
on
> the fact that there is a 'reg-id'. What if there is none?
>
> Regards,
>
> Jeroen
>
> ----- Original Message -----
> From: "Christer Holmberg" <[email-masked]>
> To: "Hadriel Kaplan" <[email-masked]>; <[email-masked]>
> Sent: Monday, April 03, 2006 7:33 AM
> Subject: RE: [Sip] How to indicate during proxy
> discoverythataproxysupports"outbound"
>
>
> Hi Hadriel,
>
> My mail was rabout the OPTIONS alternative. And, you wouldn't even
need
> Require there, because the outbound proxy would simply reply what it
> supports. In fact, no standardization is required for that, so should
we
> mention it as an option?
>
> And, if there are no issues (removal of options tags from the
> P-R/Require header by proxy) with the REGISTER alternative I don't
have
> any issues with that solution - as long as we document the assumptions
> and restriction.
>
> Regards,
>
> Christer
> Regards,
>
> Christr
>
>
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol Use
> [email-masked] for questions on current sip Use
> [email-masked] for new developments on the application of sip
>
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Jeroen van Bemmel" <[email-masked]>
Date: Mon, 3 Apr 2006 22:54:29 +0200

Christer,

In other words, you're saying you want to be able to build a registrar that 
supports outbound-reg but not outbound-stun (to be used only in combination 
with edge proxies)?

Regards,

Jeroen

----- Original Message ----- 
From: "Christer Holmberg (JO/LMF)" <[email-masked]>
To: "Bob Penfield" <[email-masked]>; "Jeroen van Bemmel" 
<[email-masked]>; "Hadriel Kaplan" <[email-masked]>; 
<[email-masked]>
Sent: Monday, April 03, 2006 10:43 PM
Subject: RE: [Sip] How to indicate 
duringproxydiscoverythataproxysupports"outbound"

Hi,

Regards,

Christer

-----Original Message-----
From: Bob Penfield [mailto:[email-masked]]
Sent: 3. huhtikuuta 2006 21:05
To: Jeroen van Bemmel; Christer Holmberg (JO/LMF); Hadriel Kaplan;
[email-masked]

inline.
----- Original Message -----

cheers,
(-:bob

assume
far
support
look
on
need
we
have