Subject: [Sip] Message Headers

From: Rehan Khan <[email-masked]>
Date: Thu, 20 Apr 2006 07:53:00 -0700

HI,

Could anyone please tell me what the following means

m:<sip:[email-masked]>
	contact binding: <SIP:[email-masked]>
		URI: <sip: [email-masked]>
			SIP contact address: sip:[email-masked]

User-Agent:cisco ICD 1.0.1.26.1

f:<sip:[email-masked]>;tag=0h787f 6r
	SIP from address: sip:[email-masked]
	SIP tag:0h787f 6r

t:<sip:[email-masked]>;
	SIP to address: :sip:[email-masked]
L:0

What does these headers imply  ( m, f, t, L). 

Thank you

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Attila Sipos" <[email-masked]>
Date: Thu, 20 Apr 2006 15:57:14 +0100

Hi Rehan,

They are short forms of SIP headers.

"m:" is equivalent to "Contact:"
"f:" is equivalent to "From:"
"t:" is equivalent to "To:"
"L:" is equivalent to "Content-Length:"

(Note that all the above are case-insensitive)

If you look at the RFC3261 grammar, these short forms
are explicitly shown.  For example...
Content-Length  =  ( "Content-Length" / "l" ) HCOLON 1*DIGIT

Regards,

Attila

Attila Sipos
http://www.vegastream.com

>> -----Original Message-----
>> From: Rehan Khan [mailto:[email-masked]]
>> Sent: 20 April 2006 15:53
>> To: [email-masked]'
>> Subject: [Sip] Message Headers
>> 
>> 
>> 
>> HI,
>>