Subject: [Sip] ptime attribute in Offer SDP

From: [email-masked]
Date: Tue, 2 May 2006 14:31:25 +0530

Hi,

How can a UA publish its capabilities of supporting multiple packetization 
time support for a particular codec,

For example:
For codec L8 if it supports both 20 and 30 ms ptime values,
For codec L16, it supports 40 ms

Is following media line is allowed?

m=audio 49230 RTP/AVP 96 97
a=rtpmap:96 L8/8000
a=ptime: 20
a=ptime:30
a=rtpmap:97 L16/8000
a=ptime:40

And is ptime attribute a property of whole media lines or only for a 
codec, I remember in earlier discussions it is a codec attribute.

-Udit

Hi,

How can a UA publish its capabilities of supporting multiple packetization 
time support for a particular codec,

For example:
For codec L8 if it supports both 20 and 30 ms ptime values,
For codec L16, it supports 40 ms

Is following media line is allowed?

m=audio 49230 RTP/AVP 96 97
a=rtpmap:96 L8/8000
a=ptime: 20
a=ptime:30
a=rtpmap:97 L16/8000
a=ptime:40

And is ptime attribute a property of whole media lines or only for a 
codec, I remember in earlier discussions it is a codec attribute.

-Udit

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Tue, 2 May 2006 11:42:06 +0200

Hi,
 
The media line in your example is not allowed. The ptime attribute is
not codec specific, it is given per media description (m= line).
 
The possibility to provide a ptime value for a specific codec has been
discussed on the MMUSIC list. Different alternatives were discussed. One
proposal was to define a new attribute. Another proposal was to use the
"vsel" attribute, defined in RFC3108, which allows you to provide values
per codecs.
 
Regards,
 
Christer

________________________________

From: [email-masked] [mailto:[email-masked]] 
Sent: 2. toukokuuta 2006 12:01
To: sip list
Cc: [email-masked]
Subject: [Sip] ptime attribute in Offer SDP 

Hi, 

How can a UA publish its capabilities of supporting multiple
packetization time support for a particular codec, 

For example: 

-Udit

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Tue, 2 May 2006 13:44:24 +0100

Can you please make requests concerning SDP usage on the MMUSIC lists ( [email-masked] <mailto:[email-masked]> ) unless it impacts some aspect of the SIP protocol.
 
regards
 
Keith

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: 02 May 2006 10:01
To: sip list
Cc: [email-masked]
Subject: [Sip] ptime attribute in Offer SDP 

Hi, 

How can a UA publish its capabilities of supporting multiple packetization time support for a particular codec, 

For example: 

And is ptime attribute a property of whole media lines or only for a codec, I remember in earlier discussions it is a codec attribute. 

-Udit