Subject: [Sip] Question regarding ptime attribute

From: [email-masked]
Date: Tue, 2 May 2006 13:18:19 +0630

Hi,

If SDP contains following media line data:

m=audio 49230 RTP/AVP 96 97 98
 a=rtpmap:96 L8/8000
 a=rtpmap:97 L16/8000
a=rtpmap:98 L16/11025/2
a=ptime: 30

Does it mean that it is using 30 ms packetization period for all the audio 
codecs, or only for codec with PT=98, rest all codecs use 20 ms.

-Udit

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Siddhardha N. Garige" <[email-masked]>
Date: Tue, 2 May 2006 11:48:18 -0700 (PDT)

Udit,
  
  If you have only one "m=" field, ptime is applicable to all the entries in fmt list
  I did see someone previously explaining how to specify different times to different media formats.

m=audio 10000 RTP/AVP 0
a=rtpmap:0 PCMU/8000
a=ptime:10
m=audio 10000 RTP/AVP 4
a=rtpmap:4 G723/8000
a=ptime:30
m=audio 10000 RTP/AVP 18
a=rtpmap:18 G729/8000
a=ptime:20
  Hope this helps..
  
  Regards,
  Sid

[email-masked] wrote: Hi,

-Udit
_______________________________________________
Sip-implementors mailing list
[email-masked]
https://lists.cs.columbia.edu/cucslists/listinfo/sip-implementors

*******************************************************
Siddhardha N. Garige
Tampa, FL.
Ph: (813)-298-4236.

www.pbase.com/garige

*******************************************************
		
---------------------------------
Talk is cheap. Use Yahoo! Messenger to make PC-to-Phone calls.  Great rates starting at 1&cent;/min.

---

From: "Siddhardha N. Garige" <[email-masked]>
Date: Tue, 2 May 2006 11:48:18 -0700 (PDT)

Udit,

m=audio 10000 RTP/AVP 0
a=rtpmap:0 PCMU/8000
a=ptime:10
m=audio 10000 RTP/AVP 4
a=rtpmap:4 G723/8000
a=ptime:30
m=audio 10000 RTP/AVP 18
a=rtpmap:18 G729/8000
a=ptime:20
  Hope this helps..
  
  Regards,
  Sid

-Udit

www.pbase.com/garige