Subject: RE: [Sip] ISSUE 2 in Hitchhikers guide to SIP: What constitutes C ore SIP

From: "Elwell, John" <[email-masked]>
Date: Mon, 08 May 2006 21:23:20 +0100

Jonathan,

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]] 
> Sent: 08 May 2006 20:04
> To: IETF SIP List
> Subject: [Sip] ISSUE 2 in Hitchhikers guide to SIP: What 
> constitutes Core SIP
> 
> One of the categorizations I used for the hitchikers guide were "Core"
> SIP specifications. THe document says that:
> 
> > The core SIP specifications represent essential functionality for 
> > almost any implementation.
> 
> this is somewhat vague. I have in mind a more concrete 
> definition that I
> think makes more sense. I'd propose:
> 
> > The core SIP specifications represent the set of 
> specifications whose
> > functionality is broadly applicable. An extension is broadly
> > applicable if it fits into one of the following categories:
> > 
> > * For specifications that impact SIP session management, the
> > extension would be used for almost every session initiated by a user
> > agent
> > 
> > * For specifications that impact SIP registrations, the extension
> > would be used for almost every registration initiated by a 
> user agent
> > 
> > * For specifications that impact SIP subscriptions, the extension
> > would be used for almost every subscription initiated by a 
> user agent
[JRE] I didn't notice anything that fell into this category and I have a
hard time thinking of something that might (unless you use this to justify
including RFC3265).

John

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 09 May 2006 16:35:53 -0400

Right - this was the justification for RFC3265 itself.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com