Subject: [Sip] REFER and Refer-To header

From: Behrad Zari <[email-masked]>
Date: Mon, 15 May 2006 08:55:33 -0700 (PDT)

Hi All,
I want to know the standard way to put customized
headers into a triggered INVITE of a REFER message (if
any)?
I'm looking for something like:
Refer-To:
<sip:[email-masked]>;myHeader="myValue"
in my REFER message that can be [somehow] put in the
generated INVITE.

--Behrad

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Dale R. Worley" <[email-masked]>
Date: Mon, 15 May 2006 12:20:55 -0400

> headers into a triggered INVITE of a REFER message (if

Use a header-parameter in the Refer-To URI:

REFER target@... SIP/2.0
Refer-To:  <sip:[email-masked]?myHeader=myValue>

Then the INVITE will look like:

INVITE sip:[email-masked]
myHeader: myValue

See section 19.1.1, which describes how header-parameters are to be
processed.

Dale