Subject: AW: [Sip] SIP Call Hold reply

From: "Franz Edler" <[email-masked]>
Date: Sun, 7 May 2006 20:37:31 +0200

> Thanks for your reply.
> But still, whether I use the old or new method to request a hold: how can
> I,
> as the hold requester, determine from the reply whether the recipient has
> agreed or not to the hold request?
> RFC 2543 doesn't mention how the recipient should reply to a hold request.

I agree that's definitely not possible. But maybe it does not hurt very
much. Normally in the case of hold some "music on hold" is rendered. This
should be an additional sign to the session partner that the media stream he
sends is not recognized.

And BTW, how many old (RFC 2543 based) User Agents are still around? 

Franz

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Yonatan Doron" <[email-masked]>
Date: Mon, 8 May 2006 11:34:51 +0200

Actually, I am currently working with a bit old version of eyeBeam (version
3013), and the latest version of Express Talk. Both answer a hold request
according to the old RFC.
Can you recommend of any good free SIP clients out there which comply to the
latest RFC ?

Thanks.

-----Original Message-----
From: Franz Edler [mailto:[email-masked]] 
Sent: Sunday, May 07, 2006 8:38 PM
To: 'Yonatan Doron'
Cc: [email-masked]
Subject: AW: [Sip] SIP Call Hold reply

> Thanks for your reply.
> But still, whether I use the old or new method to request a hold: how 
> can I, as the hold requester, determine from the reply whether the 
> recipient has agreed or not to the hold request?

Franz