Subject: [Sip] SIP bug 760 - Can multiple transports be tried on a single DNS lookup?

From: Bolt Vlatko <[email-masked]>
Date: Tue, 16 May 2006 01:00:06 -0700 (PDT)

Bug 760 in SIP working group, http://bugs.sipit.net/show_bug.cgi?id=760, clarifies that reattempts in case of failures should be limited only to one transport determined by 3263/NAPTR procesing. 
  It still has status NEW (it hasn't been resolved yet).
  Is this well known, recognized fault that should be avoided in implementation of RFC 3263 in SIP products or there are different opinions in SIP working
  group? 
   
  Thanks in advance.
   
  BR, Vlatko

---------------------------------
Yahoo! Messenger with Voice. PC-to-Phone calls for ridiculously low rates.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brett Tate" <[email-masked]>
Date: Thu, 18 May 2006 09:27:51 -0400

> Bug 760 in SIP working group, http://bugs.sipit.net/show_bug.cgi?id=760, 
> clarifies that reattempts in case of failures should be limited 
> only to one transport determined by 3263/NAPTR procesing. 
> Is this well known, recognized fault that should be avoided 
> in implementation of RFC 3263 in SIP products or there 
> are different opinions in SIP working group? 

The selection of only 1 transport by rfc3263 is correct; and devices
desiring compliance must follow the rfc.  

The bug is documented against rfc3261 to ensure it doesn't imply an
incorrect interpretation of rfc3263.