Subject: RE: [Sip] draft-audet-sip-sips-guidelines: usage of transport=tls

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Thu, 18 May 2006 14:48:41 -0400

Also, how does one know that every hop on the way included itself in the
Via header?

... if the intent is to scan the Via header list to verify every hop
used tls or ipsec or whatever.

Mike

> -----Original Message-----
> From: Francois Audet [mailto:[email-masked]] 
> Sent: Wednesday, May 17, 2006 5:03 PM
> To: IETF SIP List
> Subject: [Sip] draft-audet-sip-sips-guidelines: usage of transport=tls
> 
> Another point made by Jonathan is that transport=tls would 
> mean just a particular hop, not end-to-end (like sips).
> 
> I have received the same comments from others. Personally, 
> I'm not sure why this is needed. I think that it could be 
> deprecated entirely (which was my interpretation of RFC 
> 3261). That role in my mind is already fullfilled by the Via 
> header. That would take care of the contact URI.
> 
> I'm not opposed to keeping it, but I just can't understand 
> where it actually helps. 
> 
> If we DO decide to keep it, then, we also need to add a 
> tls-sctp (as was done for the Via field already).
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip 
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Samir Srivastava" <[email-masked]>
Date: Thu, 18 May 2006 16:07:06 -0500

I think this is a bad idea. Why tell your proxy how to do its job. This
means you know something about the network architecture and can micro
manage the proxy. Maybe the proxy wants to use IPSEC to talk to the GW,
or maybe it wants to send it to another trusted proxy over some secure
channel and let that proxy handle it?

SS>> Being a UAC I need to make sure the desired level of security is
not compromised in the path.
If it cannot be provided, It should be rejected and UAC can try with
other secondary proxies. It is asking for level of security, not how it
does.

Cheers,
Charles

> -- juha
> [email-masked] for questions on current sip Use 
> [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol Use
[email-masked] for questions on current sip Use
[email-masked] for new developments on the application of sip

---

From: "Samir Srivastava" <[email-masked]>
Date: Thu, 18 May 2006 16:18:15 -0500

Sorry. I mis-understood the context. 

Samir

-----Original Message-----
From: Srivastava, Samir [SC100:8826:EXCH] 
Sent: Thursday, May 18, 2006 2:07 PM
To: Charles Eckel (eckelcu); Juha Heinanen; Audet, Francois
[SC100:3055:EXCH]
Cc: IETF SIP List
Subject: RE: [Sip] draft-audet-sip-sips-guidelines: usage of
transport=tls

Cheers,
Charles