Subject: RE: [Sip] Outbound: must Registrar also reuse flow?

From: "Jan Rögde" <[email-masked]>
Date: Wed, 3 May 2006 09:43:05 +0200

I agree. The interaction between an EP and a Registrar is not really the same case as the interaction between UA-EP or UA-Registrar. This is not described in the draft.

/Jan

-----Original Message-----
From: Fredrik Thulin [mailto:[email-masked]] 
Sent: den 3 april 2006 17:25
To: [email-masked]
Subject: [Sip] Outbound: must Registrar also reuse flow?

Hi

In the following setup, if the client does Outbound and send a REGISTER
towards the Registrar via the edge-proxy EP,

 UA --|-- EP -- Registrar
     NAT

does the Registrar have to reuse the exact same flow to EP when a new
request arrives at Registrar, targeted for UA?

The EP obviously has to do so, but does the Registrar also have to?

Section 6.1 definately says the Registrar must do so

  "The registrar MUST store enough information to uniquely identify the
   network flow over which the request arrived. "

but I can't see the point in mandating the exact same flow being used to
send subsequent requests from Registrar to EP, if both of them are on
the open Internet?

/Fredrik

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Jan Rögde" <[email-masked]>
Date: Wed, 3 May 2006 09:43:05 +0200

/Jan

-----Original Message-----
From: Fredrik Thulin [mailto:[email-masked]] 
Sent: den 3 april 2006 17:25
To: [email-masked]
Subject: [Sip] Outbound: must Registrar also reuse flow?

Hi

 UA --|-- EP -- Registrar
     NAT

/Fredrik