Subject: RE: [Sip] draft-audet-sip-sips-guidelines: usage of transport=tls

From: "Charles Eckel \(eckelcu\)" <[email-masked]>
Date: Thu, 18 May 2006 13:12:56 -0700

> -----Original Message-----
> From: Juha Heinanen [mailto:[email-masked]] 
> Sent: Wednesday, May 17, 2006 11:14 PM
> To: Francois Audet
> Cc: IETF SIP List
> Subject: [Sip] draft-audet-sip-sips-guidelines: usage of transport=tls
> 
> Francois Audet writes:
> 
>  > I have received the same comments from others. Personally, 
> I'm not sure
>  > why this is needed. I think that it could be deprecated 
> entirely (which
>  > was my interpretation of RFC 3261). That role in my mind 
> is already 
>  > fullfilled by the Via header. That would take care of the contact
>  > URI.
> 
> without transport=tls, how can you, for example, tell to your proxy to
> use tls to a particular PSTN gw?

I think this is a bad idea. Why tell your proxy how to do its job. This
means you know something about the network architecture and can micro
manage the proxy. Maybe the proxy wants to use IPSEC to talk to the GW,
or maybe it wants to send it to another trusted proxy over some secure
channel and let that proxy handle it?

Cheers,
Charles

> 
> -- juha
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Juha Heinanen <[email-masked]>
Date: Thu, 18 May 2006 23:23:35 +0300

> channel and let that proxy handle it?

hello?  take for example a look at openser.  it lcr module has a
database of gateways serving different prefixes and using different
transport protocols.  when a request i given to openser's transaction
machine for forwarding, transport parameter of R-URI tells, which
transport protocol is for used for that destination.  without transport
parameter, it would not have a clue.

-- juha