Subject: RE: [Sip] query regarding BYE request-URI

From: <[email-masked]>
Date: Thu, 4 May 2006 16:42:00 +0530

Hi Sudhir,
U should use the contact header to construct BYE request-URI
and not the record-route,
Regards,
Rathi
 
-----Original Message-----
From: Sudhir [mailto:[email-masked]] 
Sent: Wednesday, May 03, 2006 6:29 PM
To: [email-masked]
Subject: [Sip] query regarding BYE request-URI

Hi All,

If UA received INVITE request with contact and record-route header, when
UA want to built the BYE request.

How BYE request-URI is built? Should I use either record-route or
contact header to construct BYE request-URI?

Any response is appreciated 

Thanks in advance
Sudhir

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Thu, 4 May 2006 17:01:24 +0530

Hi,

I agree with you, but you need to consider the case when the Proxy which 
is record-routing is strict router or loose router.
If the record-routing Proxy is Loose router (next hop) then Contact header 
will be used as the request-URI.
But if the record-routing Proxy is Strict router (next hop) then 
record-route will be used as the request-URI as per the 
routing policy.

Rgds,
Ujjal

<[email-masked]> 
05/04/2006 04:42 PM

To
<[email-masked]>, <[email-masked]>
cc

Subject
RE: [Sip] query regarding BYE request-URI

Hi Sudhir,
 
-----Original Message-----
From: Sudhir [mailto:[email-masked]] 
Sent: Wednesday, May 03, 2006 6:29 PM
To: [email-masked]
Subject: [Sip] query regarding BYE request-URI

Hi All,
If UA received INVITE request with contact and record-route header, when 
UA want to built the BYE request.
How BYE request-URI is built? Should I use either record-route or contact 
header to construct BYE request-URI?

---

From: Sudha <[email-masked]>
Date: Thu, 04 May 2006 17:03:30 +0530

Hi,
The contact header may be used to construct the request uri, if the record  
route has loose route parameter.

But if it is not there, the first entity in the record route must be used  
to construct the request uri and the route header of BYE should have the  
remaining record route headers and the contact uri should be added to the  
end of it.

-- 
Best Regards,
Sudha V.S
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely for the use of the addressee(s). If you are not the intended recipient, please notify the sender by e-mail and delete the original message.Global Edge Software Ltd has taken every reasonable precaution to minimize this risk, but is not liable for any damage you may sustain as a result of any virus in this e-mail. You should carry out your own virus checks before opening the e-mail or attachment. Global Edge Software Ltd reserves the right to monitor and review the content of all messages sent to or from this e-mail address