Subject: [Sip] AW: [Geopriv] Explicit Indication of Location Object Consumer

From: "Tschofenig, Hannes" <[email-masked]>
Date: Mon, 22 May 2006 16:38:46 +0200

Hi James, 

> I am inclined to agree with Brian here.
> 
> I am not sure why a proxy would just pickout a location URI and
> de-reference it unless the proxy needed to use it in some way anyway.
> Perhaps the example is not such a good one. Hannes do you 
> have something
> more concrete in mind? 

The location conveyance draft has emergency and non-emergency
applications in mind. 
With emergency calls you want the proxy and the PSAP (as the other end
of the call) to process the location objects. 
For non-emergency applications you either might want the proxy (for
location-based routing or the end host to process the LO; or even both).
So, do you think there is no need to tell which entity should process
it?

Ciao
Hannes

> > -----Original Message-----
> > From: Brian Rosen [mailto:[email-masked]]
> > Sent: Monday, 22 May 2006 11:05 AM
> > To: 'Hannes Tschofenig'; [email-masked]; [email-masked]
> > Subject: RE: [Geopriv] Explicit Indication of Location 
> Object Consumer
> > 
> > I would say no.  If the location is not needed by proxies, then I
> would
> > say
> > you MUST protect it (S/MIME), or it will not be private.
> > 
> > If you have to route on it (emergency or otherwise), then 
> you have to
> send
> > it with TLS, and the proxies can see it.
> > 
> > Brian
> > 
> > -----Original Message-----
> > From: Hannes Tschofenig [mailto:[email-masked]]
> > Sent: Sunday, May 21, 2006 7:40 AM
> > To: [email-masked]; [email-masked]
> > Subject: [Geopriv] Explicit Indication of Location Object Consumer
> > 
> > Hi James
> > Hi Brian,
> > 
> > do you plan to put additional info into the SIP message to indicate
> who
> > should consume the Location Object (explicity rather than implicit
> info)?
> > 
> > Here is an example: Assume that SIP UA Alice wants to give Bob
> location
> > information (via reference). Now, Alice could easily 
> indicate that it
> > wants Bob to resolve the reference and to process the 
> location object.
> > Stating this explicitly would prevent proxies to resolve it and to
> > process the location object.
> > 
> > Ciao
> > Hannes
> > 
> > 
> > _______________________________________________
> > Geopriv mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/geopriv
> > 
> > 
> > _______________________________________________
> > Geopriv mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/geopriv
> 
> --------------------------------------------------------------
> ----------------------------------
> This message is for the designated recipient only and may
> contain privileged, proprietary, or otherwise private information.  
> If you have received it in error, please notify the sender
> immediately and delete the original.  Any unauthorized use of
> this email is prohibited.
> --------------------------------------------------------------
> ----------------------------------
> [mf2]
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Winterbottom, James" <[email-masked]>
Date: Tue, 23 May 2006 05:36:14 -0500

I guess I don't see an explicit indicator being required.
If the proxy needs it for routing, and it can't get access to it, then
the call will fail.
If the end-point can't get access to it, then the result is application
dependent.

> From: Tschofenig, Hannes [mailto:[email-masked]]
> Sent: Tuesday, 23 May 2006 12:39 AM
> To: Winterbottom, James; Brian Rosen; Hannes Tschofenig; [email-masked];
> [email-masked]
> Subject: AW: [Geopriv] Explicit Indication of Location Object Consumer
> 
> Hi James,
> 

------------------------------------------------------------------------------------------------
------------------------------------------------------------------------------------------------
[mf2]

---

From: "James M. Polk" <[email-masked]>
Date: Tue, 23 May 2006 09:08:40 -0500

>If the proxy needs it for routing, and it can't get access to it, then

the call won't fail, that session request will receive an error, one that 
hopefully has enough information in it for the sending UAC to recover the 
session establishment, and send a new request with altered characteristics 
- hopefully that will not error this time.

The user will likely not notice anything unless the call attempt is 
ultimately rejected.

call me picky.