Subject: [Sip] RE: I-D ACTION:draft-drage-sip-essential-correction-00.txt

From: "Elwell, John" <[email-masked]>
Date: Tue, 24 Oct 2006 08:26:02 +0100

Keith,

In section 3 it states:
"At an appropriate period time, an editor working on behalf of the SIP
working group will compile all changes that have successfully completed
working group last call into a internet draft, along with the contents of
all previous documents that update the SIP RFC requiring correction.
The internet draft will be submitted to IESG as a proposed standards track
RFC for approval for publication, without any further working group last
call."

Just to be clear, this I-D is a compilation of changes, not a copy of the
original RFC with changes applied? Therefore this I-D will update the
original RFC, and not obsolete it? Other documents that reference the
original RFC can still continue to do so?

Is there a plan to trawl all previously reported bugs to see which are
eligible for dealing with in this way?

Would you consider my draft-elwell-sipping-update-pai would qualify for this
process? I guess not, as it concerns an informational RFC that is the
responsibility of SIPPING.

John

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: 18 October 2006 20:50
> To: [email-masked]
> Subject: I-D ACTION:draft-drage-sip-essential-correction-00.txt
> 
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
> 
> 
> 	Title		: A Process for Handling Essential 
> Corrections to the Session  Initiation Protocol (SIP)
> 	Author(s)	: K. Drage
> 	Filename	: draft-drage-sip-essential-correction-00.txt
> 	Pages		: 11
> 	Date		: 2006-10-18
> 	
>    The Session Initial Protocol (SIP) defined in RFC 3261 and a large
>    number of extensions forms a considerable body of work, 
> which through
>    sheer size has a number of errors that require correction.  This
>    document explains the process for managing essential corrections to
>    SIP.
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-drage-sip-essential-
> correction-00.txt
> 
> To remove yourself from the I-D Announcement list, send a message to 
> [email-masked] with the word unsubscribe in 
> the body of 
> the message. 
> You can also visit 
> https://www1.ietf.org/mailman/listinfo/I-D-announce 
> to change your subscription settings.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the 
> username "anonymous" and a password of your e-mail address. After 
> logging in, type "cd internet-drafts" and then 
> "get draft-drage-sip-essential-correction-00.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE 
> /internet-drafts/draft-drage-sip-essential-correction-00.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Drage, Keith \(Keith\)" <[email-masked]>
Date: Tue, 24 Oct 2006 15:19:19 +0200

Thanks for the question. This was drafted to beat the deadline so some
of the text may require clarification. 

Taking the core SIP spec as an example (although the document applies to
core SIP and all extensions), we do not want to get into a process of
revising RFC 3261 itself. That will involve us in a considerable amount
of work that should be devoted either to new work, or to getting RFC
3261 to draft standard.

The idea is to get the main technical corrections into a single document
that can be read in conjunction with RFC 3261, and to give these
corrections standards track RFC status so that:

-	everyone can find them;
-	everyone knows they have to implement them.

With the exception of RFC 4320 and draft-ietf-sip-fork-loop-fix, this is
not happening at the moment.

This ideas in this draft have been discussed amond the SIP chairs and
the ADs and some of our lead authors. We haven't come up with a better
way of doing it. Unless anyone has a better idea then the idea would be
to implement it after IETF#67. I can think of at least two issues that
should be addressed immediately and I am sure that other people have a
list of things that meet the criteria. 

Once we agree this is what we are doing, I will put out a call to
collect things that should be addressed urgently. 

I will be seeking people to write those up.

This activity will not preclude people addressing their own corrections
within the same process. Regard it more as a starter.

Regards

Keith

> From: Elwell, John [mailto:[email-masked]] 
> Sent: 24 October 2006 08:26
> To: Drage, Keith (Keith); SIP
> Subject: [Sip] RE: I-D 
> ACTION:draft-drage-sip-essential-correction-00.txt
> 
> Keith,
> 
> In section 3 it states:
> "At an appropriate period time, an editor working on behalf 
> of the SIP working group will compile all changes that have 
> successfully completed working group last call into a 
> internet draft, along with the contents of all previous 
> documents that update the SIP RFC requiring correction.
> The internet draft will be submitted to IESG as a proposed 
> standards track RFC for approval for publication, without any 
> further working group last call."
> 
> Just to be clear, this I-D is a compilation of changes, not a 
> copy of the original RFC with changes applied? Therefore this 
> I-D will update the original RFC, and not obsolete it? Other 
> documents that reference the original RFC can still continue to do so?
> 
> Is there a plan to trawl all previously reported bugs to see 
> which are eligible for dealing with in this way?
> 
> Would you consider my draft-elwell-sipping-update-pai would 
> qualify for this process? I guess not, as it concerns an 
> informational RFC that is the responsibility of SIPPING.
> 
> John
> 
> >    number of extensions forms a considerable body of work, which 
> > through
> > logging in, type "cd internet-drafts" and then "get 
> > draft-drage-sip-essential-correction-00.txt".
> > 
> > http://www.ietf.org/shadow.html or 
> > ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> > 
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip