Subject: [Sip] SIP SAML: Issue 1 - Multiple SAML Assertions

From: Hannes Tschofenig <[email-masked]>
Date: Sun, 15 Oct 2006 16:00:59 +0200

Hi all,

Shida raised issue#1 (see
http://www.tschofenig.priv.at:8080/saml-sip/issue1
) where he points to the need to carry multiple references to SAML 
assertions in a single SIP message.

I think we should support this functionality based on Shida's usage 
scenario.

Objections?

Ciao
Hannes

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Shida Schubert <[email-masked]>
Date: Mon, 16 Oct 2006 13:49:26 -0700

> I think we should support this functionality based on Shida's usage
Hi Hannes;

Just reposting the question I posted on the SIP-SAML ML.

What to do if we want to embed more than one SAML document?

As far as I understand identity header doesn't allow multiple URIs to be
added so if there is a need to include
more than one SAML document(one by the corporate network that allows the
partner company to allocate
resource once the call is reached and another one possibly provided by
the service provider which has all
the charging information such as SIPPING-PAY to actually make the call
go through.. This may be an
exaggerated example.. and I don't know how much needs for this really
exists but as the trait-authz requirements
does mention that the solution(SAML profile) SHOULD provide means to
include multiple assertions, I
think we should carefully study the possible use-cases.

Regards
Shida

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW dnig.com:8080/saml-sip/issue10
> Suggestions?

---

From: Shida Schubert <[email-masked]>
Date: Mon, 16 Oct 2006 13:49:26 -0700

Hi Hannes;

Regards
Shida

evelopment of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip