Subject: [Sip] New comment to draft-niemi-sip-subnot-etags-01

From: "Schmidt, Christian" <[email-masked]>
Date: Fri, 6 Oct 2006 11:26:38 +0200

Hi Aki,
 
in general, I like your idea, to reduce number and length of messages
for the presence service, by avoiding redundant information - without
adding much complexity.
 
But in case of a subscription refresh (to extend the subscription time),
it could be done easier (e.g. without etag).
- Watcher send a SUBSCRIBE with "no additional notify needed"
- Presence server changes timeout of service and acknowledge it to the
watcher via 200 message.
- If there is any change of presenty information, this specific watcher
will be informed via NOTIFY message, independent from the subscription
refresh. 
What do you think about?
 
PS: The case fetching or polling of resource state should be described
in more details (e.g. messages).
 
Regards 
Christian Schmidt, Siemens 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Aki Niemi <[email-masked]>
Date: Mon, 09 Oct 2006 10:58:43 +0300

> will be informed via NOTIFY message, independent from the subscription

Is there another reason besides saving bytes for doing this instead of
the Suppress-Notify-If-Match with the etag?

> in more details (e.g. messages).

That's a good suggestion. I'm working on an update that will have
examples as well, as those were TODO previously. ;)

Cheers,
Aki