Subject: RE: VS: [Sip] Escaping rules of SIP-URI userpart

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Mon, 2 Oct 2006 11:58:58 +0200

Hi Paul, 

>I'm speculating here, but perhaps AbsoluteURIs are forbidden from
having unescaped # so that a URI-reference, with its use of #, can be
unambiguously 
>parsed.

Yes, that is probably the reason. But, since you can't use a
URI-reference together with a URI in a SIP message anyway (the SIP ABNF
does not allow it), my proposal is that we would allow the usage of #.

Regards.

Christer

> Christer Holmberg (JO/LMF) wrote:
> > Hi Jonathan,
> > 
> > No matter what people have implemented, the SIP ABNF does not allow 
> > the fragment. The SIP-URI does not allow the fragment.
> > 
> > Regards,
> > 
> > Christer
> >  
> > 
> >> -----Original Message-----
> >> From: Jonathan Rosenberg [mailto:[email-masked]]
> >> Sent: 29. syyskuuta 2006 0:50
> >> To: Bob Penfield
> >> Cc: Christer Holmberg (JO/LMF); Juha Heinanen; 
> >> [email-masked]; [email-masked]
> >> Subject: Re: VS: [Sip] Escaping rules of SIP-URI userpart
> >>
> >> I agree here with Bob, Dale and others. The SIP URI is 
> derived from 
> >> RFC
> >> 2396 and inherits its constraints. That is part of the 
> cost of being 
> >> a URI as opposed to a SIP-specific type of identifier. 
> Just because 
> >> some implementations have not followed the spec on this point does 
> >> not change what the spec says or why its there.
> >>
> >> -Jonathan R.
> >>
> >> Bob Penfield wrote:
> >>
> >>> True, but if the SIP-URI is held in a place where a
> >> URI-reference is
> >>> allowed, everything after the # would be interpreted as a 
> fragment. 
> >>> That is why 2396 indicates it needs to be escaped.
> >>>
> >>> cheers,
> >>> (-:bob
> >>>
> >>> Robert F. Penfield
> >>> Chief Software Architect
> >>> Acme Packet, Inc.
> >>> 71 Third Avenue
> >>> Burlington, MA 01803
> >>> [email-masked]
> >>>
> >>> ----- Original Message ----- From: "Christer Holmberg (JO/LMF)" 
> >>> <[email-masked]>
> >>> To: "Bob Penfield" <[email-masked]>; "Juha Heinanen" 
> >>> <[email-masked]>; <[email-masked]>
> >>> Cc: <[email-masked]>
> >>> Sent: Thursday, September 28, 2006 3:28 PM
> >>> Subject: RE: VS: [Sip] Escaping rules of SIP-URI userpart
> >>>
> >>>
> >>>
> >>> Hi,
> >>>
> >>> Again, when I read the SIP ABNF the only URIs that can be 
> used are 
> >>> absoluteURI, and of course SIP-URI, and none of these contain the 
> >>> optional fragment part.
> >>>
> >>> So, instead of:
> >>>
> >>> Request-URI    =  SIP-URI / SIPS-URI / absoluteURI
> >>>
> >>> ...the ABNF should have said something like:
> >>>
> >>> Request-URI   = ((SIP-URI / SIPS-URI)["#" fragment]) / 
> >> URI-reference)
> >>> ...or something like that.
> >>>
> >>>
> >>> Regards,
> >>>
> >>> Christer
> >>>
> >>>
> >>>> -----Original Message-----
> >>>> From: Bob Penfield [mailto:[email-masked]]
> >>>> Sent: 28. syyskuuta 2006 22:10
> >>>> To: Juha Heinanen; [email-masked]
> >>>> Cc: [email-masked]
> >>>> Subject: Re: VS: [Sip] Escaping rules of SIP-URI userpart
> >>>>
> >>>> I suspect it might be because a SIP-URI could be placed 
> elsewhere, 
> >>>> like on some web page or in some other application that 
> parses all 
> >>>> URIs according to RFC 2396. Such a generic URI parser
> >> would interpret
> >>>> everything after the '#'
> >>>> as a fragment. This would result in a mis-interpretation
> >> of the URI.
> >>>> cheers,
> >>>> (-:bob
> >>>>
> >>>> Robert F. Penfield
> >>>> Chief Software Architect
> >>>> Acme Packet, Inc.
> >>>> 71 Third Avenue
> >>>> Burlington, MA 01803
> >>>> [email-masked]
> >>>>
> >>>>
> >>>> ----- Original Message -----
> >>>> From: "Juha Heinanen" <[email-masked]>
> >>>> To: <[email-masked]>
> >>>> Cc: <[email-masked]>
> >>>> Sent: Thursday, September 28, 2006 2:08 PM
> >>>> Subject: Re: VS: [Sip] Escaping rules of SIP-URI userpart
> >>>>
> >>>>
> >>>>> [email-masked] writes:
> >>>>>
> >>>>>> Whether it has any use in a SIP URI is not particularly
> >>>> important --
> >>>>>> as a URI it has to follow the generic syntax of URIs, RFC
> >>>> 2396.  And
> >>>>>> RFC 2396 reserves the use of '#' for fragment identifiers.
> >>>>> there are various exceptions in rfc3261 regarding other
> >>>> standards that
> >>>>> rfc3261 uses.  why can't there be an exception on # too?
> >>>>>
> >>>>> -- juha
> >>>>>
> >>>>> _______________________________________________
> >>>>> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> >>>>> This list is for NEW development of the core SIP Protocol Use 
> >>>>> [email-masked] for questions on
> >> current sip Use
> >>>>> [email-masked] for new developments on the application of sip
> >>>>>
> >>>>
> >>>> _______________________________________________
> >>>> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> >>>> This list is for NEW development of the core SIP Protocol Use 
> >>>> [email-masked] for questions on 
> current sip Use 
> >>>> [email-masked] for new developments on the application of sip
> >>>>
> >>> _______________________________________________
> >>> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> >>> This list is for NEW development of the core SIP Protocol Use 
> >>> [email-masked] for questions on current sip Use 
> >>> [email-masked] for new developments on the application of sip
> >>>
> >>>
> >>> _______________________________________________
> >>> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> >>> This list is for NEW development of the core SIP Protocol Use 
> >>> [email-masked] for questions on current sip Use 
> >>> [email-masked] for new developments on the application of sip
> >>>
> >> -- 
> >> Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
> >> Cisco Fellow                                   Parsippany, NJ 
> >> 07054-2711
> >> Cisco Systems
> >> [email-masked]                              FAX:   
> (973) 952-5050
> >> http://www.jdrosen.net                         PHONE: 
> (973) 952-5000
> >> http://www.cisco.com
> >>
> > 
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments on the application of sip
> > 
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Juha Heinanen <[email-masked]>
Date: Mon, 2 Oct 2006 14:06:41 +0300

perhaps the best solution is to get rid of URIs as sip addresses
altogether and switch to JIDs.  they allow # character and also support
internationalized addresses.  also mapping between sip and xmpp would be
easier.

-- juha

---

From: [email-masked]
Date: Mon, 2 Oct 2006 22:50:47 -0400

From: Juha Heinanen <[email-masked]>

   perhaps the best solution is to get rid of URIs as sip addresses
   altogether and switch to JIDs.

What's that?

Dale

---

From: Juha Heinanen <[email-masked]>
Date: Tue, 3 Oct 2006 07:51:01 +0300

>    altogether and switch to JIDs.

see

http://www.xmpp.org/specs/rfc3920.html#addressing

also this document claims RFC 2396 [URI] compatibility, but still allow
#.

-- juha