Subject: [Sip] Recent List of all SIP headers in IANA registry

From: "Vasudeva M" <[email-masked]>
Date: Wed, 18 Oct 2006 14:59:57 +0530

Hi All,

I wanted to know whether there is ANY Central place to see currently IANA
Registered SIP Headers...
I checked out rfc3968 which gives all the SIP Headers in IANA Registry.
The RFC was itself published in 2004. I could not find any other update to
this RFC.

I would like to get the Latest list of all the SIP Headers in the IANA
registry and the corresponding RFCs/drafts...
Any pointers would be really helpful. (google didn't help much though...)

Thanks and Best Regards,
Vasu
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Drage, Keith \(Keith\)" <[email-masked]>
Date: Thu, 19 Oct 2006 10:32:15 +0200

It also includes those internet-drafts in the RFC editor queue that have
completed the IANA step in that publication process. This may be a
considerable period in advance of publication.

Thus there are IESG approved documents there that are not yet published.

Regards

Keith 

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]] 
> Sent: 18 October 2006 15:11
> To: Drage, Keith (Keith)
> Cc: Vasudeva M; [email-masked]
> Subject: Re: [Sip] Recent List of all SIP headers in IANA registry
> 
> Note that the registry only reflects those headers defined in RFCs. 
> Proposals for new headers, appearing in drafts that haven't 
> yet made RFC, aren't listed anywhere.
> 
> It would be nice if there were some way to have drafts 
> reflected in the registry, with appropriate indication. But 
> that would probably be too much work for IANA.
> 
> 	Paul
> 
> Drage, Keith (Keith) wrote:
> > The IANA registry is externally visible:
> >  
> > http://www.iana.org/numbers.html
> >  
> > and search for Session Initiation Protocol (SIP) Parameters
> > 
> > Specifically they are at:
> > 
> > http://www.iana.org/assignments/sip-parameters
> > 
> > The purpose of RFC 3968 and RFC 3969 was to create these 
> registries so 
> > IANA could continue to populate them from the IANA considerations 
> > sections of subsequent published documents (in accordance with the 
> > rules provided).
> > 
> > Regards
> > 
> > Keith
> > 
> > 
> > ________________________________
> > 
> > 	From: Vasudeva M [mailto:[email-masked]] 
> > 	Sent: 18 October 2006 10:30
> > 	To: [email-masked]
> > 	Subject: [Sip] Recent List of all SIP headers in IANA registry
> > 	
> > 	
> > 	Hi All,
> > 	
> > 	I wanted to know whether there is ANY Central place to 
> see currently 
> > IANA Registered SIP Headers...
> > 	The RFC was itself published in 2004. I could not find 
> any other 
> > update to this RFC.
> > 	
> > 	I would like to get the Latest list of all the SIP 
> Headers in the 
> > IANA registry and the corresponding RFCs/drafts...
> > This list is for NEW development of the core SIP Protocol Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments on the application of sip
> > 
>