Subject: [Sip] Early media query

From: [email-masked]
Date: Mon, 2 Oct 2006 15:27:27 +0530

Hi,

I want to made an application where we can use early media for playing 
initial in-band announcements, and then finally connecting the caller to 
actual callee (eg prepaid card application).

I want to know which is the correct way to support this as per SIP RFC.

Method 1:

                 Caller                        Callee
                   |                             |
                   |                             |
                   |(1) INVITE with offer        |
                   |---------------------------->|
                   |                             |
                   |                             |
                   |(2) 183 with answer 1        |
                   |<----------------------------|
                   |                             |
                   |                             |
                   |(3) 200 OK with SDP          |
                   |<----------------------------|
                   |                             |
                   |                             |
                   |(4) ACK                      |
                   |---------------------------->|
                   |                             |

(2) contains SDP of announcement server
(3) contains SDP of callee

Method 2:

                                        Caller Callee
                   |                             |
                   |                             |
                   |(1) INVITE with offer        |
                   |---------------------------->|
                   |                             |
                   |                             |
                   |(2) 183 with answer 1        |
                   |<----------------------------|
                   |                             |
                   |                             |
                   |(3) PRACK                    |
                   |---------------------------->|
                   |                             |
                   |                             |
                   |(4) 200 PRACK                |
                   |<----------------------------|
                   |                             |
                   |                             |
                   |(5) 200 INVITE with sdp      |
                   |<----------------------------|
                   |                             |
                   |                             |
                   |(6) ACK                      |
                   |---------------------------->|
                   |                             |
                   |                             |
                   |                             |
                   |                             |

(2) contains SDP of announcement server
(5) contains SDP of callee

Method 3:

        Caller                        Callee
                   |                             |
                   |                             |
                   |(1) INVITE with offer        |
                   |---------------------------->|
                   |                             |
                   |                             |
                   |(2) 183 with answer 1        |
                   |<----------------------------|
                   |                             |
                   |                             |
                   |(3) PRACK                    |
                   |---------------------------->|
                   |                             |
                   |                             |
                   |(4) 200 PRACK                |
                   |<----------------------------|
                   |(5) 200 OK                   |
                   |<----------------------------|
                   |                             |
                   |(6) ACK                      |
                   |---------------------------->| 
                   |                             |
                   |(7)Re-INVITE with SDP        |
                   |<----------------------------|
                   |                             |
                   |                             |
                   |(8) 200 OK with SDP          |
                   |---------------------------->|
                   |                             |
                   |(9) ACK                      |
                   |---------------------------->| 

(2) contains SDP of announcement server
(5) contains no SDP
(7) contains SDP of callee
(8) contains answer of caller for callee offer

Her, UDATE can also be used instead of Re-invites.

Method 4:

                                            Caller Callee
                   |                             |
                   |                             |
                   |(1) INVITE with offer        |
                   |---------------------------->|
                   |                             |
                   |                             |
                   |(2) 183 with answer 1        |
                   |<----------------------------|
                   |                             |
                   |                             |
                   |(3) PRACK                    |
                   |---------------------------->|
                   |                             |
                   |                             |
                   |(4) 200 PRACK                |
                   |<----------------------------|
                   |(5) UPDATE (callee offer)    |
                   |<----------------------------|
                   |                             |
                   |(6) 200 UPDATE (answer)      |
                   |---------------------------->| 
                   |                             |
                   |(7) 200 INVITE                   |
                   |---------------------------->|
                   |                             |
                   |(8) ACK                      |
                   |---------------------------->| 

In this case, when callee answers, UPDATE is sent to caller to negoitate 
audio with caller, and then 200 OK is sent for the initial INVITE.

Regards,
Udit

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Mon, 2 Oct 2006 14:57:29 +0200

Hi,
 
You can use Method 2, assuming the 18x and 200 have different To tag
values. Otherwise you can use Method 3 or 4 (message 9 in Method 3, and
message 7 in Method 4, seem to go in the wrong direction, though).
 
Regards,
 
Christer

________________________________

	From: [email-masked] [mailto:[email-masked]] 
	Sent: 2. lokakuuta 2006 12:57
	To: [email-masked]
	Cc: [email-masked]
	Subject: [Sip] Early media query

	Hi, 
	
	I want to made an application where we can use early media for
playing initial in-band announcements, and then finally connecting the
caller to actual callee (eg prepaid card application). 
	
	I want to know which is the correct way to support this as per
SIP RFC. 
	
	Method 1: 

	                 Caller                        Callee 
	                   |                             | 
	                   |                             | 
	                   |(1) INVITE with offer        | 

	Method 2: 
	
	                                        Caller
Callee 
	                   |                             | 
	                   |                             | 
	                   |(1) INVITE with offer        | 

	Method 3: 
	
	        Caller                        Callee 
	                   |                             | 
	                   |                             | 
	                   |(1) INVITE with offer        | 

	
	Method 4: 
	
	                                            Caller
Callee 
	                   |                             | 
	                   |                             | 
	                   |(1) INVITE with offer        | 

	In this case, when callee answers, UPDATE is sent to caller to
negoitate audio with caller, and then 200 OK is sent for the initial
INVITE. 
	
	Regards, 
	Udit

---

From: "Darshan Bildikar" <[email-masked]>
Date: Tue, 3 Oct 2006 09:26:27 +0530

I don't think that even Method 3 and 4 are OK because they will involve a
change in the origin line parameter of the SDP and that is not allowed as
per the RFC. 

BTW, what was the rationale behind not allowing the origin line to change?
It makes implementing apps like prepaid and CRBT very difficult. Could
someone please throw some light on this?

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Retesh Chadha
Sent: Monday, October 02, 2006 5:46 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Sip-implementors] Early media query

Hi Udit
Of all the methods you have specified, Method 1 and 2 are wrong as per
the RFC which states that the sdp of all the provisional and 2xx
response of INVITE should be same if they are present.

Both Method 3 and 4 look fine, with method 4 being better because in
that case 200 ok for INVITE is only sent when the final negotiation
(call media) is done.

Hope this helps.
-- 
With Regards
Retesh Chadha

On 10/2/06, [email-masked] <[email-masked]> wrote:
> Sip-implementors mailing list
> [email-masked]
> https://lists.cs.columbia.edu/cucslists/listinfo/sip-implementors
>
_______________________________________________
Sip-implementors mailing list
[email-masked]
https://lists.cs.columbia.edu/cucslists/listinfo/sip-implementors

---

From: "Retesh Chadha" <[email-masked]>
Date: Mon, 2 Oct 2006 17:45:45 +0530

Hi Udit

Hope this helps.
-- 
With Regards
Retesh Chadha

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 05 Oct 2006 10:51:44 -0400

> change in the origin line parameter of the SDP and that is not allowed as

Which RFC?

I suport Crister's response.

	Paul

---

From: "Brian Stucker" <[email-masked]>
Date: Tue, 10 Oct 2006 16:16:35 -0500

Short answer... It can be done, but it can get ugly and you can run into
other problems.

I recommend that you read the following draft:

http://www.ietf.org/internet-drafts/draft-stucker-sipping-early-media-co
ping-02.txt

Regards,
Brian

> From: Darshan Bildikar [mailto:[email-masked]] 
> Sent: Monday, October 02, 2006 10:56 PM
> To: 'Retesh Chadha'; [email-masked]
> Subject: [Sip] RE: [Sip-implementors] Early media query
> 
> I don't think that even Method 3 and 4 are OK because they 
> will involve a change in the origin line parameter of the SDP 
> and that is not allowed as per the RFC. 
> 
> It makes implementing apps like prepaid and CRBT very 
> difficult. Could someone please throw some light on this?
> 
> Of all the methods you have specified, Method 1 and 2 are 
> wrong as per the RFC which states that the sdp of all the 
> provisional and 2xx response of INVITE should be same if they 
> are present.
> 
> Both Method 3 and 4 look fine, with method 4 being better 
> because in that case 200 ok for INVITE is only sent when the 
> final negotiation (call media) is done.
> 
> Hope this helps.
> --
> With Regards
> Retesh Chadha
> 
>