Subject: RE: [Sip] Re: [Sip-implementors] Early media query

From: "Xia, Zhi Feng \(Bruce\)" <[email-masked]>
Date: Sun, 8 Oct 2006 16:15:00 +0800

Given the restrictions in RFC, all four methods seem invalid.

Before we can change the restrictions in the RFC,  it looks to me using "replaces" is a better approach...

How about this flow:

>        Caller                                     Callee
>                   |                                            |
>                   |                                            |
>                   |(1) INVITE with offer        |
>                   |---------------------------->    |
>                   |                                           |
>                   |                                           |
>                   |(2) 183 with answer 1    |
>                   |<-------------------------------|
>                   |                                           |
>                   |                                           |
>                   |(3) PRACK                       |
>                   |---------------------------->   |
>                   |                                           |
>                   |                                           |
>                   |(4) 200 PRACK               |
>                   |<------------------------------|
>                   |(5) 200 OK                      |
>                   |<----------------------------  |
>                   |                                         |
>                   |(6) ACK                           |
>                   |---------------------------->|
>                   |                                        |
>                   |(7)Re-INVITE(replaces with new call id)
>                   |<----------------------------|
>                   |   NOTIFY                       |
                     |----------------------------->
                     |BYE(the original call id)
                     |----------------------------->
>                   |                                        |
>                   |(8) 200 OK with SDP   |
>                   |---------------------------->|
>                   |                                        |
>                   |(9) ACK                          |
>                   |---------------------------->|

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]]
Sent: 2006?10?5? 22:52
To: Darshan Bildikar
Cc: [email-masked]; [email-masked]; 'Retesh Chadha'
Subject: [Sip] Re: [Sip-implementors] Early media query

Darshan Bildikar wrote:
> I don't think that even Method 3 and 4 are OK because they will involve a
> change in the origin line parameter of the SDP and that is not allowed as
> per the RFC. 

Which RFC?

I suport Crister's response.

	Paul

> BTW, what was the rationale behind not allowing the origin line to change?
> It makes implementing apps like prepaid and CRBT very difficult. Could
> someone please throw some light on this?
> 
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Retesh Chadha
> Sent: Monday, October 02, 2006 5:46 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Sip-implementors] Early media query
> 
> Hi Udit
> Of all the methods you have specified, Method 1 and 2 are wrong as per
> the RFC which states that the sdp of all the provisional and 2xx
> response of INVITE should be same if they are present.
> 
> Both Method 3 and 4 look fine, with method 4 being better because in
> that case 200 ok for INVITE is only sent when the final negotiation
> (call media) is done.
> 
> Hope this helps.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 09 Oct 2006 08:46:51 -0400

The Replaces approach is a possibility. But please explain why you think 
all the possibilities are invalid.

	Paul