Subject: RE: [Sip] Re: 489 status code

From: "Drage, Keith \(Keith\)" <[email-masked]>
Date: Mon, 6 Nov 2006 21:20:26 +0100

(As SIP WG chair)

See http://www.iana.org/assignments/sip-parameters for a list of
currently assigned response codes (with 489 allocated already as Adam
indicates).

As definition of a new response code requires a SIP WG document, can I
suggest that only such documents make any attempt to assign a response
code value - I know this can be useful because the examples have to show
it. If your document is not one of these, use 4xx or something else that
can be replaced later.

I notice also drafts in SIPPING group attempting to assign response
codes.

Regards

Keith

> -----Original Message-----
> From: Adam Roach [mailto:[email-masked]] 
> Sent: 05 November 2006 21:51
> To: Gonzalo Camarillo
> Cc: [email-masked]; [email-masked]; Jonathan Rosemberg
> Subject: [Sip] Re: 489 status code
> 
> On July 31, 2001, Gonzalo Camarillo wrote:
> > A minor comment about 489 status code: In Adam's event 
> draft it means 
> > "Bad Event", and in Jonathan's early media draft it means "Request 
> > Updated". Since both are just I-Ds this is not really an 
> issue right 
> > now, but when they advance to RFCs we will have to resolve this 
> > conflict.
> 
> ...and in draft-gurbani-sip-large-udp-response-00, it means 
> "Use Congestion Controlled Transport."
> 
> I'd offer to move mine somewhere else, but it's been 
> published as an RFC already.
> 
> /a
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip 
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Mon, 6 Nov 2006 21:00:14 -0800

> it. If your document is not one of these, use 4xx or something else that

Using 4xx can be confusing as there will be no way to know if it is an
yet unassigned specific response code in the 4xx class or the whole 4xx
class.  May I suggest 4?? instead?