Subject: RE: [Sip] Re: issue with oubound and the used transport protocol

From: Jeroen Van Bemmel <[email-masked]>
Date: Mon, 20 Nov 2006 08:16:44 +0100

OK, so a SHOULD with explanation then?

Jeroen

-----Oorspronkelijk bericht -----
Van: "Christer Holmberg (JO/LMF)" <[email-masked]>
Aan: "Jeroen van Bemmel" <[email-masked]>; "Rohan Mahy" <[email-masked]>; "Leis, Peter" <[email-masked]>
CC: [email-masked]; "Rohan Mahy" <[email-masked]>; [email-masked]
Verzonden: 20-11-06 06:57
Onderwerp: RE: [Sip] Re: issue with oubound and the used transport protocol

Hi, 

>The outbound draft needs to say: "if a UA establishes a flow using an
unreliable transport, it MUST also establish one 
>over a reliable transport" (to support switch over).

I think it's enough to have a recommendation. In some cases it may not
be possible/feasible to establish a TCP connection - no matter if you
use outbound or not.

Regards,

Christer

>Moreover, I would suggest to add "it is RECOMMENDED that the UA
establishes a flow using a reliable transport"
> Regards,
> Jeroen
> Rohan Mahy wrote:

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Mon, 20 Nov 2006 08:52:30 +0100

I don't even think we should have a SHOULD in this case. As Cullen said,
I think the it's-better-to-use-TCP-than-UDP is a core SIP issue, and not
only related to outbound.

But, yes, we can explain the issue.

Regards,

Christer 

> -----Original Message-----
> From: Jeroen Van Bemmel [mailto:[email-masked]] 
> Sent: 20. marraskuuta 2006 9:17
> To: Christer Holmberg (JO/LMF); Rohan Mahy; Leis, Peter
> Cc: [email-masked]; Rohan Mahy; [email-masked]
> Subject: RE: [Sip] Re: issue with oubound and the used 
> transport protocol
> 
> Aan: "Jeroen van Bemmel" <[email-masked]>; "Rohan Mahy" 
> <[email-masked]>; "Leis, Peter" <[email-masked]>
> I think it's enough to have a recommendation. In some cases 
> it may not be possible/feasible to establish a TCP connection 
> - no matter if you use outbound or not.
> 
> Regards,
> 
> Christer
> 
> 
> 
> 
>