Subject: RE: What controls the lock icon? (Was RE: [Sip] RE: TLS meaning)

From: "Elwell, John" <[email-masked]>
Date: Wed, 01 Nov 2006 20:17:51 +0000

Francois,

I disagree. Just securing the signalling is not sufficient to prevent
impersonation, for example, unless the media is also authenticated and
integrity protected. As a user, what good is it to me if secure signalling
tells me that the caller is Francois, yet somebody is sending me unsecured
media from a different source?

I agree that SIPS != padlock. Therefore I am still trying to discover real
use cases for SIPS.

John 

> -----Original Message-----
> From: Francois Audet [mailto:[email-masked]] 
> Sent: 01 November 2006 17:12
> To: Elwell, John; Juha Heinanen
> Cc: Joel M. Halpern; IETF SIP List
> Subject: RE: What controls the lock icon? (Was RE: [Sip] RE: 
> TLS meaning)
> 
>  
> > > There are cases where you want signalling to be secure (for 
> > > authentication, impersonation, theft of service, etc.), but 
> > you don't 
> > > need, or want, or even can have encrypted media.
> > [JRE] No, but you might want authenticated media. It is all 
> > very well saying that the signalling comes from the person 
> > you think it comes from, but if the media is coming from 
> > somewhere else, that doesn't help the average user.
> 
> Sure, but it's a different problem.
> 
> Media security and Signalling security are two different things.
> 
> SIPS is strictly about hop-by-hop signalling security with TLS. 
> 
> That's why sips != padlock item, otherwise, you'll give a 
> false sense of
> security to the "average user".
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Francois Audet" <[email-masked]>
Date: Wed, 1 Nov 2006 15:05:17 -0600

You mean doing IP address spoofing?

If you don't like impersonation, take theft of service then.

My point is that I have seen places where signalling security was a
requirement
but not media security. 

It does exist in real life. 

> From: Elwell, John [mailto:[email-masked]] 
> Sent: Wednesday, November 01, 2006 12:18 PM
> To: Audet, Francois (SC100:3055); Juha Heinanen
> I disagree. Just securing the signalling is not sufficient to 
> prevent impersonation, for example, unless the media is also 
> authenticated and integrity protected. As a user, what good 
> is it to me if secure signalling tells me that the caller is 
> Francois, yet somebody is sending me unsecured media from a 
> different source?
> 
> I agree that SIPS != padlock. Therefore I am still trying to 
> discover real use cases for SIPS.
> 
> John 
> 
> > > [JRE] No, but you might want authenticated media. It is all very 
> > > well saying that the signalling comes from the person you 
> think it 
> > > comes from, but if the media is coming from somewhere else, that 
> > > doesn't help the average user.
> > 
> false sense 
> > of security to the "average user".
> > 
> 
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip