Subject: [Sip] Null Encryption ciphers

From: "Samir Srivastava" <[email-masked]>
Date: Fri, 3 Nov 2006 23:44:24 -0600

Hi,

  http://www.ietf.org/internet-drafts/draft-ietf-tls-psk-null-03.txt
define NULL Encryption cipher where confidentiality is not permitted.  I
don't know which geographic regions mandated it.

  Hop By hop nature of SIP might mandate the cipher exposure to it due
to the above itself ....
 
Thx
Samir
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 03 Nov 2006 22:01:38 -0800

>   Hop By hop nature of SIP might mandate the cipher exposure to it due

NULL ciphers are nothing new in TLS.

-Ekr

---

From: "Samir Srivastava" <[email-masked]>
Date: Sat, 4 Nov 2006 00:13:32 -0600

Where they are used.. If a proxy on the downstream side has to use the
NULL ciphers (due to configuration etc), then Proxy should reject the
REQUEST, letting the UAC know that request cannot be fullfilled with
Confidentiality specially for MESSAGE method.

Thx
Samir  

>-----Original Message-----
>From: Eric Rescorla [mailto:[email-masked]] 
>Sent: Friday, November 03, 2006 10:02 PM
>To: Srivastava, Samir (SC100:8826)
>Cc: IETF SIP List
>Subject: Re: [Sip] Null Encryption ciphers
>
>> define NULL Encryption cipher where confidentiality is not 
>permitted.  
>> I don't know which geographic regions mandated it.
>>