Subject: RE: [Sip] Draft for review:draft-sreeram-specify-method-00.txt

From: "Drage, Keith \(Keith\)" <[email-masked]>
Date: Sun, 5 Nov 2006 21:39:38 +0100

(As individual)

I had a brief look at this draft.

It would seem to me that proxies could be considered in networks as two
forms:

-	As edge proxies, where we have the only mechanism of routeing to
or from the user.

-	As "routeing" proxies, where the aim is to provide connectivity
from one SIP proxy to another.

For the first set, I think you need to provide some discussion in your
draft of why outbound does not support your needs, i.e. what
capabilities you do not get from outbound but which you do get from your
proposals.

For the second set, we would seem to be straying into the overall area
that touches congestion control (where out of service is an extreme form
of congestion). I would like to see some discussion of how this does not
or does relate to the mechanisms being discussed in SIPPING to support
congestion control.

Finally you have plumped straight away for a new method and header in
SIP. Why is it appropriate to use SIP to do this rather than some other
protocol running between the two entities?

I think you should also consider addressing this document to SIPPING,
and concentrating foremost on the requirements you need to fulfil rather
than the protocol solution.

Regards

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: 31 October 2006 04:15
> To: [email-masked]
> Subject: FW: [Sip] Draft for 
> review:draft-sreeram-specify-method-00.txt
> 
> Fwding the mail to the list.
> I did a reply , should have done reply all.
> 
> Thanks Dale for pointing this.
> 
> -Sreeram.
> 
> -----Original Message-----
> From: Sreeram Kanumuri (WT01 - IP-Multimedia Carrier & Ent Networks)
> Sent: Monday, October 30, 2006 11:21 AM
> To: [email-masked]'
> Subject: RE: [Sip] Draft for 
> review:draft-sreeram-specify-method-00.txt
> 
> Hi Dale,
> 
> There are 2 Cases
> Proxy with backup: Means there is inactive unit. Which will 
> take over when the active proxy is taken out (Duplex)
> 
> Proxy without backup: These are proxies which work as stand-alone.
> Proxies to be stand alone are generally very rare in field 
> but can be possible.
> 
> When we say a Proxy with out backup giving the alternative ip 
> address is the case when standalone proxy (P1) is giving the 
> details of proxy P2 .
> 
> The use cases have shown some of these cases.
> 
> We will take care that the sentence is reformatted in the 
> next release to make it clear.
> 
> Regards,
> Sreeram
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, October 30, 2006 10:19 AM
> To: [email-masked]
> Subject: Re: [Sip] Draft for 
> review:draft-sreeram-specify-method-00.txt
> 
> You write:
> 
>    Similarly, on restart/disconnect of a SIP entity without 
> backup, the
>    same problem exists and there is no way by which SIP entity that is
>    restarting/disconnecting can inform about the alternative 
> IP address
>    (if available) to other SIP entities to which it can communicate so
>    that graceful handling of existing sessions (or calls) or future
>    sessions can be performed using alternate IP address.
> 
> I don't understand what the "alternate IP address" can be -- 
> you've already said the SIP entity does not have a backup, so 
> there can be no alternate IP address at which to contact the backup.
> 
> Dale
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip 
> Use [email-masked] for new developments on the application of sip
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip 
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Drage, Keith \(Keith\)" <[email-masked]>
Date: Sun, 5 Nov 2006 21:39:38 +0100

(As individual)

Regards

Keith

---

From: <[email-masked]>
Date: Tue, 7 Nov 2006 09:17:01 +0530

Thank you very much for the comments.
We will be working on Draft to make it clearer with the comments 
Incorporated.

We will also address the Draft for comments in the SIPPING.

Regards,
Sreeram.

-----Original Message-----
From: Drage, Keith (Keith) [mailto:[email-masked]] 
Sent: Monday, November 06, 2006 2:10 AM
To: Sreeram Kanumuri (WT01 - IP-Multimedia Carrier & Ent Networks);
[email-masked]
Subject: RE: [Sip] Draft for review:draft-sreeram-specify-method-00.txt

(As individual)

Regards

Keith