Subject: RE: [Sip] I-D on handling large UDP responses

From: "Drage, Keith \(Keith\)" <[email-masked]>
Date: Mon, 13 Nov 2006 11:20:58 +0100

Question repeat, as it does not seem to have been answered.

Regards

Keith 

> -----Original Message-----
> From: Drage, Keith (Keith) [mailto:[email-masked]] 
> Sent: 04 October 2006 19:46
> To: Cullen Jennings; Dean Willis
> Cc: IETF SIP List; Vijay K. Gurbani
> Subject: RE: [Sip] I-D on handling large UDP responses
> 
> Can you tell us what you agreed on. The proceedings seem to 
> have missed it, and I don't remember it appearing on the list.
> 
> Regards
> 
> Keith
> 
> > -----Original Messageant that one can find all the errors and potential 
> fixes in one place.
>  Another approach is to have the document produced in the way 
> it is mentioned in the draft but have another document that 
> references all the fixes in a similar fashion that 
> hitch-hiker's guide does for all the core-SIP related RFC/drafts.
> 
>  Regards
>   Shida
> 
> 
> Drage, Keith (Keith) wrote:
> > Thanks for the comments.
> >
> > Inline below: 
> >
> > Regards
> >
> > Keith
> >
> >   
> >> -----Original Message-----
> >> From: Jonathan Rosenberg [mailto:[email-masked]]
> >> Sent: 01 November 2006 22:02
> >> To: Drage, Keith (Keith)
> >> Cc: SIP
> >> Subject: Re: [Sip] Request for views on 
> >> draft-drage-sip-essential-correction-00.txt
> >>
> >> Keith,
> >>
> >> I agree with the final step here, but I'm not so sure about your 
> >> details of the intermediate steps.
> >>
> >> In particular, I think it is too onerous to require one I-D per 
> >> issue.
> >> FOr example it would be nice for someone to go through the 
> bugzilla 
> >> database and submit one I-D with all of the things in it 
> that we need 
> >> to put into the corrections spec. THis is more palatable 
> than having 
> >> to submit 30 separate documents, each 6 pages in length (5.5 pages 
> >> overhead and 1/2 page for the useful content).
> >>     
> >
> > I think flexibility is needed here. Grouping of related 
> issues, are a 
> > number of well understood and non-controversial (but otherwise
> > essential) corrections is probably OK.
> >
> > What we don't want to do is group things that require lots of 
> > discussion time in the WG (SIPS fixes?) with those that 
> don't. Nor do 
> > we want to present two issues together such that one confuses the 
> > understanding and WG discussion of the other.
> >   
> >> Also we need to discuss what happens when more bugs get reported 
> >> after the correction RFC is published. DO we revise that RFC? Or 
> >> issue another corrections document?
> >>
> >>     
> > The idea was that the reader only need read the original RFC plus 1 
> > correction RFC. Thus as more corrections are discovered, we 
> take the 
> > contents of the original correction RFC, the new fixes, and 
> produce a 
> > new RFC that obsoletes the first correction RFC, but which still 
> > updates the original RFC. Remember however that the draft 
> replacement 
> > correction RFC can still be rapidly put together - and it 
> only needs 
> > IESG review and approval, as all the individual components 
> have been 
> > WGLC separately. Therefore I see this process as being reasonably 
> > quick (in IETF terms).
> >
> > Note that in terms of the normal RFC process we would lose the 
> > correction RFC if we ever take any SIP documents from proposed 
> > standard to draft standard, i.e. the proposed standard RFC would 
> > obsolete the
> >
> >   
> >> -Jonathan R.
> >>
> >> Drage, Keith (Keith) wrote:
> >>
> >>     
> >>> I have recently submitted
> >>>
> >>>
> >>>       
> >> 
> http://www.ietf.org/internet-drafts/draft-drage-sip-essential-correct
> >> i
> >>     
> >>> on
> >>> -00.txt
> >>>
> >>> The idea behind this draft, is to put some management 
> into getting 
> >>> real
> >>> bugfixes:
> >>>
> >>> -	into one place where people can find it
> >>> -	give it standards track RFC status so that people know they have
> >>> to implement it.
> >>>
> >>> If people not already consulted have views on this process, then 
> >>> please let them be known.
> >>>
> >>> The idea would be to start this process (taking into
> >>>       
> >> account any input
> >>     
> >>> from the WG) after the next IETF meeting.
> >>>
> >>> Regards
> >>>
> >>> Keith
> >>>
> >>> Keith Drage
> >>> [email-masked]
> >>> tel: +44 1793 776249
> >>>
> >>> _______________________________________________
> >>> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> >>> This list is for NEW development of the core SIP Protocol Use 
> >>> [email-masked] -----
> > From: Cullen Jennings [mailto:[email-masked]]
> > Sent: 04 October 2006 05:32
> > To: Dean Willis
> > Cc: IETF SIP List; Vijay K. Gurbani
> > Subject: Re: [Sip] I-D on handling large UDP responses
> > 
> > 
> > On Oct 3, 2006, at 12:01 PM, Dean Willis wrote:
> > 
> > > So, are we stuck on advancing the hop-limit-diagnostics
> > draft until we
> > > advance something like this draft?
> > 
> > At the last IETF, I think Vijay, Scott and I had come up 
> with a way to 
> > deal with hop-limit-diag without doing this but I have no 
> objections 
> > if folks want to have it wait for something like this.
> > 
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments on the application of sip
> > 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip 
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Scott Lawrence <[email-masked]>
Date: Mon, 20 Nov 2006 12:05:11 -0500

> > have missed it, and I don't remember it appearing on the list.

I am not at all sure that we agreed on anything with respect to this.

-- 
Scott Lawrence  tel:+1-781-938-5306;ext=162 or sip:[email-masked]
  sipXpbx project coordinator - SIPfoundry    http://www.sipfoundry.org/sipX
  Chief Technology Officer    - Pingtel Corp. http://www.pingtel.com/

---

From: Scott Lawrence <[email-masked]>
Date: Mon, 20 Nov 2006 12:05:11 -0500