Subject: [Sip] Outbound-05: Indication of number of flows to register

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Thu, 2 Nov 2006 15:17:35 +0100

Hi,

One issue that has been discussed for outbound is to allow the network
to indicate to the UA how many flows are accepted, and/or how many flows
the user is recommended to register. This value could e.g. be provided
by the registrar. Otherwise, if the maximum number of flows is reached,
registration requests would have to be rejected, which is not good.

So, my proposal is still that it should be added to outbound.

Regards,

Christer
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rohan Mahy <[email-masked]>
Date: Thu, 2 Nov 2006 13:48:24 -0800 (PST)

Hi Christer,

We have explicit consensus not to include this functionality in outbound.

thanks,
-rohan

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Fri, 3 Nov 2006 00:20:47 +0100

Hi, 

>We have explicit consensus not to include this functionality in
outbound.

We do? When was that consensus reached? At least not as part of the "Re:
[Sip] Outbound-04 and "max-flow" in 200 OK for REGISTER" mail thread, as
far as I am aware.

And, no matter if we have that indicator or not, which error code shall
the registrar use if a user has reached the maximum number of flows, and
the registrar does not accept more flows?

Regards,

Christer

> > to indicate to the UA how many flows are accepted, and/or how many 
> > flows the user is recommended to register. This value could e.g. be 
> > provided by the registrar. Otherwise, if the maximum number 
> of flows 
> > is reached, registration requests would have to be 
> rejected, which is not good.
> >

---

From: Rohan Mahy <[email-masked]>
Date: Fri, 3 Nov 2006 11:01:03 -0800 (PST)

Hi Christer,

I sent out an email to the list with the subject "Outbound issues: slide
7".  This topic was also discussed in the meeting and on the mailing list
before the meeting.

I received many, many responses supportive of leaving this functionality
out.  I have heard only one request for its inclusion (from you).

thanks,
-rohan

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Fri, 3 Nov 2006 20:13:01 +0100

Hi Rohan,

I thought that slide 7 was about the discovery of outbound-proxy-set,
but that is really not the same thing.

What I am talking about is a value which is returned in the registration
response, once you have discovered your outbound proxies and sent your
first registrations. 

I didn't even find the max-flow issue in the slides.

And, if I remember at least Erikki Koivusalo indicated that this kind of
value would be useful. I haven't really seen any objection to it on the
mailing list, but I may of course have missed that.

Regards,

Christer

> -----Original Message-----
> From: Rohan Mahy [mailto:[email-masked]] 
> Sent: 3. marraskuuta 2006 21:01
> To: Christer Holmberg (JO/LMF)
> Cc: Rohan Mahy; IETF SIP List
> Subject: RE: Outbound-05: Indication of number of flows to register
> 
> Hi Christer,
> 
> I sent out an email to the list with the subject "Outbound 
> issues: slide 7".  This topic was also discussed in the 
> meeting and on the mailing list before the meeting.
> 
> I received many, many responses supportive of leaving this 
> functionality out.  I have heard only one request for its 
> inclusion (from you).
> 
> thanks,
> -rohan
> 
> 
> 
> > Hi,
> >
> > [Sip] Outbound-04 and "max-flow" in 200 OK for REGISTER" 
> mail thread, 
> > as far as I am aware.
> >
> > And, no matter if we have that indicator or not, which error code 
> > shall the registrar use if a user has reached the maximum number of 
> > flows, and the registrar does not accept more flows?
> >
> > Regards,
> >
> > Christer
> >
> >
> >
> >
> >> > Hi,
> >> >