Subject: RE: [Sip] automatically switches to TCP

From: "Xia, Zhi Feng \(Bruce\)" <[email-masked]>
Date: Mon, 27 Nov 2006 16:56:33 +0800

Hi Manju,
1. Is this documented somewhere? 
2. We had a stack which sends messages over UDP as mandated by UA, if UDP failure or transaction timeout(e.g. after 7 retrys of INVITE) it switches to TCP instead of going into terminated state -- this sounds violate your "MUST"?
 
Thanks,
Bruce

-----Original Message-----
From: Manjunath Warad [mailto:[email-masked]]
Sent: 2006?11?24? 11:07 PM
To: 'Xia, Zhi Feng (Bruce)'; 'IETF SIP List'
Subject: RE: [Sip] automatically switches to TCP

Hi Bruce,
    I think this is other way round, if sending on TCP fails then it is recommended to try on UDP to keep the backward compatibility with RFC 2543. 
After timeout transaction MUST enter into terminated state and will not retry by changing the protocol.
 
Regards,
Manju

***************************************************************************************

            This e-mail and attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient's) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!

  _____  

From: Xia, Zhi Feng (Bruce) [mailto:[email-masked]] 
Sent: Friday, November 24, 2006 4:47 PM
To: IETF SIP List
Subject: [Sip] automatically switches to TCP

Hi,
There're many implementations when transportation on UDP fails or transation timeout without response it will automatically try TCP connection. Is this mandated in any RFCs? I think RFC3261 says if transaction timeouts it should go to terminated state.
 
Is this implementation a violation to RFC3261?
 
Thanks,
Bruce

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Manjunath Warad <[email-masked]>
Date: Tue, 28 Nov 2006 10:50:17 +0530

Hi Bruce,
    See inline...
 
Regards,
Manju

****************************************************************************
***********

            This e-mail and attachments contain confidential information
from HUAWEI, which is intended only for the person or entity whose address
is listed above. Any use of the information contained herein in any way
(including, but not limited to, total or partial disclosure, reproduction,
or dissemination) by persons other than the intended recipient's) is
prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!

  _____  

From: Xia, Zhi Feng (Bruce) [mailto:[email-masked]] 
Sent: Monday, November 27, 2006 2:27 PM
To: [email-masked]; IETF SIP List
Subject: RE: [Sip] automatically switches to TCP

Hi Manju,
1. Is this documented somewhere?  
    About switching of protocol, it is documented in RFC 3261 in sec 18.1.1.
 
"If an element sends a request over TCP because of these message size
constraints, and that request would have otherwise been sent over
UDP, if the attempt to establish the connection generates either an
ICMP Protocol Not Supported, or results in a TCP reset, the element
SHOULD retry the request, using UDP. This is only to provide
backwards compatibility with RFC 2543 compliant implementations that
do not support TCP. It is anticipated that this behavior will be
deprecated in a future revision of this specification. " 
 
    About transaction moving to terminated state, check in the transaction
part of RFC 3261.
 
2. We had a stack which sends messages over UDP as mandated by UA, if UDP
failure or transaction timeout(e.g. after 7 retrys of INVITE) it switches to
TCP instead of going into terminated state -- this sounds violate your
"MUST"?
    I am not sure why this behaviour is implemented; however,  I think this
is violation of standard.
 
Thanks,
Bruce

-----Original Message-----
From: Manjunath Warad [mailto:[email-masked]]
Sent: 2006?11?24? 11:07 PM
To: 'Xia, Zhi Feng (Bruce)'; 'IETF SIP List'
Subject: RE: [Sip] automatically switches to TCP

Hi Bruce,
    I think this is other way round, if sending on TCP fails then it is
recommended to try on UDP to keep the backward compatibility with RFC 2543. 
After timeout transaction MUST enter into terminated state and will not
retry by changing the protocol.
 
Regards,
Manju

****************************************************************************
***********

            This e-mail and attachments contain confidential information
from HUAWEI, which is intended only for the person or entity whose address
is listed above. Any use of the information contained herein in any way
(including, but not limited to, total or partial disclosure, reproduction,
or dissemination) by persons other than the intended recipient's) is
prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!

  _____  

Hi,
There're many implementations when transportation on UDP fails or transation
timeout without response it will automatically try TCP connection. Is this
mandated in any RFCs? I think RFC3261 says if transaction timeouts it should
go to terminated state.

Thanks,
Bruce