Subject: [Sip] Anybody reading draft-ietf-sip-saml-02.txt

From: Dean Willis <[email-masked]>
Date: Wed, 6 Jun 2007 13:37:09 -0500

On May 29, 2007, at 2:50 PM, [email-masked] wrote:

> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Session Initiation Protocol  
> Working Group of the IETF.
>
> 	Title		: SIP SAML Profile and Binding
> 	Author(s)	: H. Tschofenig, et al.
> 	Filename	: draft-ietf-sip-saml-02.txt
> 	Pages		: 46
> 	Date		: 2007-5-29

So does anybody besides the authors care, or is this work just so far  
ahead of the mainstream working group that we need to move the work  
to a lower priority queue?

--
Dean

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 06 Jun 2007 14:39:02 -0500

Dean Willis wrote:
> ahead of the mainstream working group that we need to move the work  to 
> a lower priority queue?

I had read and commented on earlier revision of this work; have
not had the chance to see -02 yet.

So, to be pedantic about a three questions in your short
paragraph above:

1) Does anybody besides the authors care?  Yes.
2) Is this work so far ahed of the mainstream working group?
  Given that we are fighting sips, transport=tls, SRV RR, MIME,
  and SDP rules battles in the last couple of weeks, I would
  say yes.
3) Do we need to move the work to a lower priority queue?  I
  will leave that in the capable hands of Messers Willis and Drage
  to decide ;-)

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
2701 Lucent Lane, Rm. 9F-546, Lisle, Illinois 60532 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
WWW:   http://www.alcatel-lucent.com/bell-labs

---

From: Miguel Garcia <[email-masked]>
Date: Thu, 07 Jun 2007 14:00:05 +0300

Dean Willis wrote:

> So does anybody besides the authors care, 

Yes, I care, I think this is an important functionality that we ought to do.

> or is this work just so far 
> ahead of the mainstream working group that we need to move the work to a 
> lower priority queue?

Probably there are other more important topics. In general, we should 
give higher priority to fixing the current protocol than adding new 
functionality, but this does not advocate for stopping progressing new 
functions until the protocol is totally fixed.

/Miguel

-- 
Miguel A. Garcia           tel:+358-50-4804586
Nokia Siemens Networks     Espoo, Finland

---

From: <[email-masked]>
Date: Thu, 7 Jun 2007 15:22:26 +0300

Hi,

I have also read the draft and to me it seems to be in a
rather good shape. It is worth checking whether the spec
could even be completed soon, instead of letting it just to
wait for better times to appear.

Regards,

Erkki

>-----Original Message-----
>From: ext Dean Willis [mailto:[email-masked]] 
>Sent: 06.June.2007 21:37
>To: SIP IETF
>Cc: Cullen Jennings; Keith Drage
>Subject: [Sip] Anybody reading draft-ietf-sip-saml-02.txt 
>
>

---

From: "Mary Barnes" <[email-masked]>
Date: Thu, 7 Jun 2007 11:45:53 -0500

Per other responses, there are people that care about this work.  But,
unfortunately, it is a bit ahead of the mainstream. However, I think it
is important and I would hate to see it linger forever in the WG (it has
already been around for a while). How far is it from being done? 

Mary

-----Original Message-----
From: Dean Willis [mailto:[email-masked]] 
Sent: Wednesday, June 06, 2007 1:37 PM
To: SIP IETF
Cc: Cullen Jennings; Keith Drage
Subject: [Sip] Anybody reading draft-ietf-sip-saml-02.txt

--
Dean

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 07 Jun 2007 21:56:37 +0200

Hi Mary,

 > already been around for a while). How far is it from being done?

We had implementation work going on (to determine whether things work as 
expected) and investigated different applications in more detail (as 
published in separate drafts).

So, what is missing? We have an issue tracker that contains the open 
issues:
http://www.tschofenig.priv.at:8080/saml-sip/index

I will address some (if not all) of them with the next draft update. 
Planned in about 2 weeks from now.

Ciao
Hannes

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 07 Jun 2007 17:34:30 -0400

Well, given there are still deployments with Remote-Party-ID, who have 
yet to migrate to P-Asserted-ID, let alone SIP identity, I'd say it is a 
  bit ahead of the curve. That said I do think its worth doing, but is 
not  a high priority.

-Jonathan R.

Dean Willis wrote:

>> This draft is a work item of the Session Initiation Protocol  Working 
>> Group of the IETF.
>>

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

---

From: Jeff Hodges <[email-masked]>
Date: Thu, 07 Jun 2007 15:10:15 -0700

RLBob Morgan buttonholed myself and Keith D. (at least) in hallway in San Diego 
  (I believe) and indicated that they (Internet2 Mace, UWash) want to 
implement/use the spec and was curious wrt what it would take to "finish" it.

That said, as Hannes indicated, we'll endeavor to have another rev out, 
addressing more of the issues listed in the tracker, sooner rather than later.

thanks,

=JeffH

---

From: Shida Schubert <[email-masked]>
Date: Thu, 07 Jun 2007 19:41:16 -0700

> So does anybody besides the authors care, 
 I care, I think this work is important.
> or is this work just so far ahead of the mainstream working group that 
> we need to move the work to a lower priority queue?
 I agree as others have mentioned that there are items that are of
higher priority(bug fixes etc.), but having followed the draft from its 
early stage,
much effort has gone into the draft and should be in a fairly good shape if
issues raised in the last few IETFs are well addressed. If the draft is 
well
baked I see no reason to lower its priority (Assuming the work is nearly
done and wouldn't take the resource from more important work that are 
needed
urgently).

 That being said, it may be good to recruit some reviewers and analyze
where the draft is with its maturity and decide its fate.

--
 Shida