Subject: [Sip] INFO and ISUP

From: Eric Burger <[email-masked]>
Date: Sun, 17 Jun 2007 18:19:35 +0900

I cringe every time someone says, "The only acceptable use for INFO is for
ISUP."  ALL of the arguments that apply to "One cannot use INFO for foo"
apply to why "One cannot use INFO for ISUP."

The INFO method is NOT to "carry [arbitrary] mid-session information between
SIP user agents" as RFC 2976 posits.  The one and only one reason one can
use INFO for ISUP today is because the method is ONLY defined for ISUP.

Said another way: the identifier 0x49 0x4E 0x46 0x4F has *NOTHING* to do
with INFO.  It would have much better been called 0x4E 0x53 0x55 0x50
(ISUP).

For legacy reasons, and because we really are talking about a bunch of bits,
not English, I would not offer we change the name of the method.  However, I
would make it clear that the method is NOT the general purpose method
described in RFC 2976.

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

 are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Francois Audet" <[email-masked]>
Date: Mon, 18 Jun 2007 11:34:57 -0500

Actually, it's not just ISUP. It's also QSIG.

But I agree, INFO was supposed to be be used only
for tunnelling legacy PSTN protocols between Media Gateway 
Controllers. 

> -----Original Message-----
> From: Eric Burger [mailto:[email-masked]] 
> Sent: Sunday, June 17, 2007 02:20
> To: [email-masked]
> Subject: [Sip] INFO and ISUP
> 
> I cringe every time someone says, "The only acceptable use 
> for INFO is for ISUP."  ALL of the arguments that apply to 
> "One cannot use INFO for foo"
> The INFO method is NOT to "carry [arbitrary] mid-session 
> information between SIP user agents" as RFC 2976 posits.  The 
> one and only one reason one can use INFO for ISUP today is 
> because the method is ONLY defined for ISUP.
> 
> Said another way: the identifier 0x49 0x4E 0x46 0x4F has 
> *NOTHING* to do with INFO.  It would have much better been 
> called 0x4E 0x53 0x55 0x50 (ISUP).
> 
> For legacy reasons, and because we really are talking about a 
> bunch of bits, not English, I would not offer we change the 
> name of the method.  However, I would make it clear that the 
> method is NOT the general purpose method described in RFC 2976.
> 
> 
> Notice:  This email message, together with any attachments, 
> may contain information  of  BEA Systems,  Inc.,  its 
> subsidiaries  and  affiliated entities,  that may be 
> confidential,  proprietary,  copyrighted  and/or legally 
> privileged, and is intended solely for the use of the 
> individual or entity named in this message. If you are not 
> the intended recipient, and have received this message in 
> error, please immediately return this by email and then delete it.
> 
> 
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip

---

From: "Jesske, R" <[email-masked]>
Date: Tue, 19 Jun 2007 14:22:47 +0200

That is the problems with some RFC's because it is not stated for what they are supposed or what people intended at that former times.
And the text describing the procedures telling an other story...

We have the same problems with RFC 3323 and 3325 for privacy purposes...

Roland

> -----Ursprüngliche Nachricht-----
> Von: Francois Audet [mailto:[email-masked]] 
> Gesendet: Montag, 18. Juni 2007 18:35
> An: Eric Burger; [email-masked]
> Betreff: RE: [Sip] INFO and ISUP
> 
>