Subject: [Sip] Could a UA issue a new NOTIFY before the previous NOTIFY transaction has completed?

From: yan <[email-masked]>
Date: Sat, 16 Jun 2007 01:16:28 +0800 (CST)

hi:  Could anyone answer me the question:Can a UA issue a new NOTIFY before the previous NOTIFY transaction has completed? thx yan

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Robert Sparks <[email-masked]>
Date: Wed, 20 Jun 2007 12:18:07 -0500

Generally speaking, yes.

An individual event package may restrict that behavior though.

RjS

On Jun 15, 2007, at 12:16 PM, yan wrote:

> hi:
>   Could anyone answer me the question:
> Can a UA issue a new NOTIFY before the previous NOTIFY transaction  
> has completed?
>  thx
>
> yan
>
>
> 150 万 人 同 时 在 玩 的 网 游，你 不 试 试 吗 ？

---

From: "Arunachalam Venkatraman \(arunvenk\)" <[email-masked]>
Date: Thu, 21 Jun 2007 08:37:52 -0700

However, if you are using UDP and if the data in the second NOTIFY is additive to and not replacing the prior NOTIFY, you may run into the issue of out-of-sequence delivery.

________________________________

From: Robert Sparks [mailto:[email-masked]] 
Sent: Wednesday, June 20, 2007 12:18 PM
To: yan
Cc: [email-masked]
Subject: Re: [Sip] Could a UA issue a new NOTIFY before the previous NOTIFYtransaction has completed?

Generally speaking, yes.

RjS

hi:

Can a UA issue a new NOTIFY before the previous NOTIFY transaction has completed?

 thx

yan

________________________________

150 万 人 同 时 在 玩 的 网 游，你 不 试 试 吗 ？ <http://event.mail.163.com/chanel/xyq.htm?from=163_NO1>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 21 Jun 2007 19:48:49 -0400

Arunachalam Venkatraman (arunvenk) wrote:
> However, if you are using UDP and if the data in the second NOTIFY is 
> additive to and not replacing the prior NOTIFY, you may run into the 
> issue of out-of-sequence delivery.

This can be a problem even when using TCP if there are proxies in the
path. There is no requirement for proxies to deliver messages in the
order they receive them.

	Paul

> ------------------------------------------------------------------------
> 
> *From:* Robert Sparks [mailto:[email-masked]]
> *Sent:* Wednesday, June 20, 2007 12:18 PM
> *To:* yan
> *Cc:* [email-masked]
> *Subject:* Re: [Sip] Could a UA issue a new NOTIFY before the previous 
> NOTIFYtransaction has completed?
> 
>  
> 
> Generally speaking, yes.
> 
>  
> 
> ------------------------------------------------------------------------
> 
> <http://event.mail.163.com/chanel/xyq.htm?from=163_NO1>
> 
> Use [email-masked] 
> <mailto:[email-masked]> for questions on current sip
> 
> Use [email-masked] <mailto:[email-masked]> for new developments on 
> the application of sip
> 
>  
> 
> 
> ------------------------------------------------------------------------
>

---

From: Bruce Qi <[email-masked]>
Date: Fri, 22 Jun 2007 09:04:31 +0800

Hi Paul:
       Is This issue belong to the internal implementation of SIP production? Beacuse I think there are many similar issues in the development of SIP production.

Thanks and Regards
Burce Qi

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 22 Jun 2007 08:49:07 -0400

>        Is This issue belong to the internal implementation of SIP production? Beacuse I think there are many similar issues in the development of SIP production.

Sorry - I don't understand your question.

But in general there are potential issues of this sort in sending one
request on a dialog before a prior request has completed. It is best to
be avoided, though in certain cases it may be ok.

	Paul

---

From: "Gerald Yan" <[email-masked]>
Date: Wed, 27 Jun 2007 09:32:25 +0800

This issue may occur in the case of issuing NOTIFY to multiple SUBSCRIBE or REFER in a dialog.

Best regards
Gerald
Tel:86-755-26952899 34617

-----邮件原件-----
发件人: Bruce Qi [mailto:[email-masked]] 
发送时间: 2007-06-22 9:05
收件人: SIP; Paul Kyzivat
抄送: Peili Xu
主题: Re: [Sip] Could a UA issue a new NOTIFY before thepreviousNOTIFYtransaction has completed?

Hi Paul:

Thanks and Regards
Burce Qi

---

From: Xiao Wang <[email-masked]>
Date: Wed, 27 Jun 2007 10:36:09 +0800

The Partial Notification mechanism  requires PA issue NOTIFY in regular
sequence.

" The PA MUST NOT send a new NOTIFY request that contains a partial
   notification for the same Request-URI until it has received a final
   response from the watcher for the previous one or the previous NOTIFY
   request has timed out. "

Xiao
> -----Original Message-----
> From: Gerald Yan [mailto:[email-masked]]
> Sent: Wednesday, June 27, 2007 9:32 AM
> To: Bruce Qi; SIP; Paul Kyzivat
> Cc: Peili Xu
> Subject: 答复: [Sip] Could a UA issue a new NOTIFY before
> thepreviousNOTIFYtransaction has completed?
> 
> This issue may occur in the case of issuing NOTIFY to multiple SUBSCRIBE
or
> REFER in a dialog.
> 主题: Re: [Sip] Could a UA issue a new NOTIFY before
> thepreviousNOTIFYtransaction has completed?
> 
> Hi Paul:
>        Is This issue belong to the internal implementation of SIP
production?
> Beacuse I think there are many similar issues in the development of SIP
> production.
> 
> Thanks and Regards
> Burce Qi
> 
> 
> Subject: Re: [Sip] Could a UA issue a new NOTIFY before the previous
NOTIFY
> transaction has completed?
> 
> 
> >
> >

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 27 Jun 2007 11:20:38 -0400

What you say is true, but applies specifically to partial notifications.
Since they send deltas from the previous one they won't work if
processed out of order.

Some event packages also need such restrictions. But it isn't a general
restriction.

	Paul