Subject: [Sip] Effect of SIP T1 timer value on T4 timer

From: "Jagan Mohan" <[email-masked]>
Date: Mon, 18 Jun 2007 13:32:42 +0530

Hi,

   I would like to how T4 timer needs to be set, based on the value of T1?
If round trip delay is, say 20s, then T1 needs to be set to 20s. To what
value should T4 timer, needs to be set now? Should T4 needs to be
set as (Actual value of T1)*(default value of T4/ default value of T1)? If
yes, could you please explain the logic behind this.

Thanks,
Jagan
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Avasarala Ranjit-A20990" <[email-masked]>
Date: Mon, 18 Jun 2007 17:48:36 +0800

Hi Jagan
 
Timer T4 represents the amount of time the network will take to clear
messages between client and server transactions. The default value for
T4 is 5 seconds. Also T4 is a constant and not set based on T1. For more
details refer to Sec 17.1.2.2 of RFC 3261.
 
Regards 
Ranjit 

________________________________

From: Jagan Mohan [mailto:[email-masked]] 
Sent: Monday, June 18, 2007 1:33 PM
To: SIP list
Subject: [Sip] Effect of SIP T1 timer value on T4 timer

Hi,

   I would like to how T4 timer needs to be set, based on the value of
T1?
If round trip delay is, say 20s, then T1 needs to be set to 20s. To what
value should T4 timer, needs to be set now? Should T4 needs to be set as
(Actual value of T1)*(default value of T4/ default value of T1)? If yes,
could you please explain the logic behind this. 

Thanks,
Jagan

---

From: "Jagan Mohan" <[email-masked]>
Date: Mon, 18 Jun 2007 18:39:52 +0530

Hi Ranjit,

    Thanks for replying.

    I haven't completely understood the definition of T4 timer. Could you
please explain it?

Thanks,
Jagan

On 6/18/07, Avasarala Ranjit-A20990 <[email-masked]> wrote:
> messages between client and server transactions. The default value for T4 is
> 5 seconds. Also T4 is a constant and not set based on T1. For more details
> refer to Sec 17.1.2.2 of RFC 3261.
> **
> *Regards*
> *Ranjit *
>
>
>  ------------------------------
> *From:* Jagan Mohan [mailto:[email-masked]]
> *Sent:* Monday, June 18, 2007 1:33 PM
> *To:* SIP list
> *Subject:* [Sip] Effect of SIP T1 timer value on T4 timer
>
>  Hi,
>