Subject: [Sip] Should 420 be returned when UAS(not server) can't support the extension?

From: ji ma <[email-masked]>
Date: Tue, 7 Aug 2007 11:07:35 +0800 (CST)

Hi folks:
   
      I have some doubt about whether a UAS which is not a server(such as a handphone) will return 420 Bad Extension when it doesn't support the extension specified in Require header.
   
  As 21.4.15 said:
   The server did not understand the protocol extension specified in a
   Proxy-Require (Section 20.29) or Require (Section 20.32) header
   field.  The server MUST include a list of the unsupported extensions
   in an Unsupported header field in the response.  UAC processing of
   this response is described in Section 8.1.3.5.
   
  So if not, which response should be returned?

  Regards,
  Ma Ji

---------------------------------
抢注雅虎免费邮箱3.5G容量，20M附件！ 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 07 Aug 2007 08:50:27 +0100

A UAS is a server - User Agent Server
 
John

________________________________

	From: ji ma [mailto:[email-masked]] 
	Sent: 07 August 2007 04:08
	To: [email-masked]
	Subject: [Sip] Should 420 be returned when UAS(not server) can't support theextension?

	Hi folks:

	As 21.4.15 said:

	 
	Regards,
	Ma Ji

________________________________

	抢注雅虎免费邮箱3.5G容量，20M附件！ <http://cn.mail.yahoo.com>

---

From: [email-masked]
Date: Tue, 7 Aug 2007 16:57:47 -0400

From: ji ma <[email-masked]>

   I have some doubt about whether a UAS which is not a server (such as
   a handphone) will return 420 Bad Extension when it doesn't support
   the extension specified in Require header.

In regard to SIP, "UAS" means "user agent server", which means "in
regard to the SIP request under discussion, the user agent which
receives the request and generates the response".

Dale