Subject: [Sip] Allowed SIP Header Fileds

From: "Fries, Steffen" <[email-masked]>
Date: Fri, 31 Aug 2007 10:54:21 +0200

Hi,

just a question regarding the allowed SIP header field in RFC 3261. The Table 2 in section 20 states the corresponding headers for WWW-Authenticate and Authentication-Info but it does only state Proxy-Authenticate. While RFC2617 stated the Proxy-Authentication-Info header, RFC3261 does not. What is the reason for the removal and how is the Proxy Authentication on client side (via digest authentication) to be done in this case?

Ciao
	Steffen

> -------------------------------------------
>  Steffen Fries     
>  Siemens AG, CT IC 3	
>  Otto-Hahn-Ring 6,  81730 Munich, Germany 
>  Phone:	(+49) 89 / 636-53403,    
>  Fax  :   	(+49) 89 / 636-48000
>  email:   	[email-masked]
> -------------------------------------------
Siemens Aktiengesellschaft: Vorsitzender des Aufsichtsrats: Gerhard Cromme;
Vorstand: Peter Löscher, Vorsitzender; Johannes Feldmayer, Heinrich Hiesinger, Joe Kaeser, Rudi Lamprecht, Eduardo Montes, Jürgen Radomski, Erich R. Reinhardt, Hermann Requardt, Uriel J. Sharef, Klaus Wucherer
Sitz der Gesellschaft: Berlin und München,
Registergericht: Berlin Charlottenburg, HRB 12300, München, HRB 6684
WEEE-Reg.-Nr. DE 23691322
> ___________________________________________
> 
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Michael Procter" <[email-masked]>
Date: Fri, 31 Aug 2007 03:14:34 -0700

Hi Steffen,

Proxy authentication on the client side is performed using the headers 'Proxy-Authenticate' and 'Proxy-Authorization' in the same way as user to-user authentication uses the headers 'WWW-Authenticate' and 'Authorization'.

The extra header 'Authentication-Info' is allowed by RFC3261 Section 22.4, last paragraph:

   RFC 2543 did not allow usage of the Authentication-Info header field
   (it effectively used RFC 2069).  However, we now allow usage of this
   header field, since it provides integrity checks over the bodies and
   provides mutual authentication.

Authentication is possible with just the normal 2 headers.  But other benefits occur when using the third header (Authentication-Info) in the user-to-user case, sufficient to make RFC3261 permit it.  Presumably the advantages were not sufficient for the comparable user-to-proxy case.

Regards,

Michael

> -----Original Message-----
> From: Fries, Steffen [mailto:[email-masked]]
> Sent: 31 August 2007 09:54
> To: [email-masked]
> Subject: [Sip] Allowed SIP Header Fileds
> 
> Hi,
> 
> just a question regarding the allowed SIP header field in RFC 3261.
> The Table 2 in section 20 states the corresponding headers for WWW-
> Authenticate and Authentication-Info but it does only state Proxy-
> Authenticate. While RFC2617 stated the Proxy-Authentication-Info
> header, RFC3261 does not. What is the reason for the removal and how
> is the Proxy Authentication on client side (via digest authentication)
> to be done in this case?
> 
> Ciao
> 	Steffen
> 
> 
> Vorstand: Peter Löscher, Vorsitzender; Johannes Feldmayer, Heinrich
> Hiesinger, Joe Kaeser, Rudi Lamprecht, Eduardo Montes, Jürgen
> Radomski, Erich R. Reinhardt, Hermann Requardt, Uriel J. Sharef, Klaus
> Wucherer