Subject: [Sip] [Reg] Diversion Header

From: <[email-masked]>
Date: Thu, 30 Aug 2007 00:30:49 +0530

Hi,
 
I need some clarification regarding the encoding syntax of SIP Diversion header parameters reason & privacy . 
 
I am aware that Diversion header is replaced by History-Info, but I need to support Diversion header for some network implementation. 
 
    diversion-reason = "reason" "="
                    ( "unknown" | "user-busy" | "no-answer" |
                      "unavailable" | "unconditional" |
                      "time-of-day" | "do-not-disturb" |
                      "deflection" | "follow-me" |
                      "out-of-service" | "away" |
                      token | quoted-string )
    diversion-privacy = "privacy" "=" ( "full" | "name" |
                        "uri" | "off" | token | quoted-string )

I like to know which is the correct syntax for the diversion-privacy & diversion-reason parameter i.e. 
 
Diversion: ...;reason="user-busy";privacy="full"
 
or,
 
Diversion: ...;reason=user-busy;privacy=full
 
Cheers,
Subhodeep
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Avasarala Ranjit-A20990" <[email-masked]>
Date: Thu, 30 Aug 2007 03:04:07 +0800

Hi Subhodeep
 
The correct syntax would be: Diversion:
...;reason="user-busy";privacy="full"

Regards 
Ranjit 

________________________________

From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, August 30, 2007 12:31 AM
To: [email-masked]; [email-masked]
Subject: [Sipping] [Reg] Diversion Header

Hi,
 
I need some clarification regarding the encoding syntax of SIP Diversion
header parameters reason & privacy . 
 
I am aware that Diversion header is replaced by History-Info, but I need
to support Diversion header for some network implementation. 

I like to know which is the correct syntax for the diversion-privacy &
diversion-reason parameter i.e. 

or,

Cheers,
Subhodeep

---

From: "Derks, Frank" <[email-masked]>
Date: Thu, 30 Aug 2007 07:06:03 +0200

Hi Ranjit,
 
Please be aware that the Diversion header never made it through the IETF
standardisation process, which makes its use proprietary. Some
manufacturers, among which Microsoft, use it however. The IETF-way of
doing this would be to make use of the request history as per RFC4244.
 
Cheers,
 
Frabj

From: Avasarala Ranjit-A20990 [mailto:[email-masked]] 
Sent: 2007-Aug-29 21:04
To: [email-masked]; [email-masked]; [email-masked]
Subject: [Sip] RE: [Sipping] [Reg] Diversion Header

Hi Subhodeep

Regards 
Ranjit 

Hi,

 

 
or,

Cheers,
Subhodeep

---

From: [email-masked] (Juha Heinanen)
Date: Thu, 30 Aug 2007 08:15:24 +0300

Derks, Frank writes:

 > manufacturers, among which Microsoft, use it however. 

not only microsoft, but also cisco and many others.

-- juha