Subject: Re: Content-Disposition in multiparts WAS (Re: [Sip] Draft slides forbody (MIME) handling)

From: Eric Burger <[email-masked]>
Date: Wed, 01 Aug 2007 10:42:30 -0500

Content-Disposition="advertisement" would never pass MIME review.  It is not
a disposition.

Give it up and move on to more important stuff, like running code :-)

On 7/31/07 8:37 AM, "Dean Willis" <[email-masked]> wrote:

> 
> On Jul 30, 2007, at 8:36 PM, Qian Sun wrote:
> 
>> Hi, Dean
>> 
>> Sorry for late response. Do you mean "advertisement" content always
>> is needed to 'render'? So a single content disposition
>> "advertisement" is enough.
> 
> Well, I'm wondering if advertisements have any other need than
> "render". If not, why not just use "render"?
> 
> If we define an "advertisement" content disposition, we might as well
> call it "ignore", in which case there's hardly any point in sending
> it to start with, right?
> 
> Although I must admit I'm intrigued by the prospect of getting
> advertisers to self-label stuff so that it can be discarded as
> efficiently as possible.
> 
>> In addition, some content body (e.g. Geolocation or advertisement)
>> may be inserted or modified by intermediary. Could we specify a
>> common way for indicating the source of inserted content body? For
>> example, define a new MIME header: Content-Insertedby. A B2BUA may
>> insert a content body including AD like this:
>> 
>> Content-Type: text/plain
>> Content-Disposition: advertisement
>> Content-Insertedby: AD-Agent <sip: [email-masked]>
> 
> I'm sure there has been discussion of this in geopriv, but I don't
> recall the details. I suspect there have been concerns about
> mismatches between the "source" and the "information".
> 
> --
> Dean
> 
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Qian Sun <[email-masked]>
Date: Thu, 02 Aug 2007 10:06:20 +0800

Hi, Eric

An AD bodypart should be marked "advertisement" if it is intended to be displayed in a non-disturbed/non-confusing way. 
The "advertisement" Disposition Type would be a kind of display manner between "Inline" and "Attachment".
For example, a client could display advertisement in a place different from the content window.

Cheers,
Qian

---

From: [email-masked]
Date: Wed, 1 Aug 2007 22:38:00 -0400

From: Qian Sun <[email-masked]>

   An AD bodypart should be marked "advertisement" if it is intended
   to be displayed in a non-disturbed/non-confusing way.  The
   "advertisement" Disposition Type would be a kind of display manner
   between "Inline" and "Attachment".  For example, a client could
   display advertisement in a place different from the content window.

I'd hack my UA so that it wouldn't display "advertisement"s at all!

Dale

---

From: Qian Sun <[email-masked]>
Date: Thu, 02 Aug 2007 12:35:56 +0800

Hi, Dale

Yes, you can do that. But most of people wouldn't use hacked software.
And this kind of advertisement is harmless, it's not worth hacking your UA.

Cheers,
Qian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, August 02, 2007 10:38 AM
To: [email-masked]
Subject: Re: Content-Disposition in multiparts WAS (Re: [Sip] Draft slidesforbody (MIME) handling)

Dale

---

From: Linyi Tian <[email-masked]>
Date: Thu, 02 Aug 2007 13:20:04 +0800

Hi, guys
If you can make money from it, you may not want to hack your UA.
BR,
Linyi

-----Original Message-----
From: Qian Sun [mailto:[email-masked]] 
Sent: Thursday, August 02, 2007 12:36 PM
To: [email-masked]; [email-masked]
Subject: RE: Content-Disposition in multiparts WAS (Re: [Sip] Draftslidesforbody (MIME) handling)

Hi, Dale

Cheers,
Qian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, August 02, 2007 10:38 AM
To: [email-masked]
Subject: Re: Content-Disposition in multiparts WAS (Re: [Sip] Draft slidesforbody (MIME) handling)

Dale

---

From: Ted Hardie <[email-masked]>
Date: Thu, 2 Aug 2007 06:58:37 -0700

>For example, a client could display advertisement in a place different from the content window.

I agree with Eric that "advertisement" is not a disposition; it is a statement about who
is getting paid.  "inline-subordinate" would be a disposition
that said "put this inline, but don't let it block anything with a regular
"inline" tag.   You seem to want people to infer what disposition to give
based on the "advertisement" status.  As you have seen, some are inferring
that they can cheerfully junk the content. I think there are a number of problems
even with something like "inline-subordinate" (what do you do when
you are using text-to-speach rendering for blind users?), but I think your focus should
be on describing what the software should do rather than on the commercial
relationships.

Lastly, I'll point out that introducing a disposition like "advertisement" or
"inline-subordinate" has an impact on the MIME folks in general, and a more
general discussion would be needed before things progressed.

			regards,
				Ted Hardie