Subject: [Sip] PRACK/Offer Answer

From: <[email-masked]>
Date: Fri, 21 Dec 2007 01:46:22 +0530

Hi,
 
I have a call scenario, where UAC had sent an offer (not initial) in PRACK and the UAS needs to refuse the offer. Can the UAS refuse the offer using a 4xx response (e.g. 488) ? I don't find any specific example in the currently available RFCs and/or drafts.
 
Cheers,
Subhodeep

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Sanjay Sinha (sanjsinh)" <[email-masked]>
Date: Thu, 20 Dec 2007 16:40:06 -0500

Please see sec. 2.2 of draft-ietf-sipping-sip-offeranswer-04.txt

________________________________

	From: [email-masked]
[mailto:[email-masked]] 
	Sent: Thursday, December 20, 2007 3:16 PM
	To: [email-masked]; [email-masked]
	Subject: [Sip] PRACK/Offer Answer

	Hi,
	 
	I have a call scenario, where UAC had sent an offer (not
initial) in PRACK and the UAS needs to refuse the offer. Can the UAS
refuse the offer using a 4xx response (e.g. 488) ? I don't find any
specific example in the currently available RFCs and/or drafts.
	 
	Cheers,
	Subhodeep

---

From: <[email-masked]>
Date: Fri, 21 Dec 2007 13:35:33 +0530

OK. But what should be the body of the 200 OK PRACK (Pattern 5)  before sending 488 to INVITE for termination of the dialog.
________________________________

From: Sanjay Sinha (sanjsinh) [mailto:[email-masked]]
Sent: Thu 12/20/2007 10:40 PM
To: Subhodeep Sarkar (WT01 - TES-Mobility & Carrier Infrastructure); [email-masked]; [email-masked]
Subject: RE: [Sip] PRACK/Offer Answer

	From: [email-masked] [mailto:[email-masked]] 
	Sent: Thursday, December 20, 2007 3:16 PM
	To: [email-masked]; [email-masked]
	Subject: [Sip] PRACK/Offer Answer

	Hi,

	Cheers,
	Subhodeep

---

From: "Sanjay Sinha (sanjsinh)" <[email-masked]>
Date: Fri, 21 Dec 2007 08:35:06 -0500

The 200 Ok can have the port number in m line set to 0 to indicate that
the media stream is not acceptable.

	From: [email-masked]
[mailto:[email-masked]] 
	Sent: Friday, December 21, 2007 3:06 AM
	To: Sanjay Sinha (sanjsinh); [email-masked]; [email-masked]
	Subject: RE: [Sip] PRACK/Offer Answer

	OK. But what should be the body of the 200 OK PRACK (Pattern 5)
before sending 488 to INVITE for termination of the dialog.
________________________________

	From: Sanjay Sinha (sanjsinh) [mailto:[email-masked]]
	Sent: Thu 12/20/2007 10:40 PM
	To: Subhodeep Sarkar (WT01 - TES-Mobility & Carrier
Infrastructure); [email-masked]; [email-masked]
	Subject: RE: [Sip] PRACK/Offer Answer

		Hi,

		Cheers,
		Subhodeep

The information contained in this electronic message and any attachments
to this message are intended for the exclusive use of the addressee(s)
and may contain proprietary, confidential or privileged information. If
you are not the intended recipient, you should not disseminate,
distribute or copy this e-mail. Please notify the sender immediately and
destroy all copies of this message and any attachments. 

WARNING: Computer viruses can be transmitted via email. The recipient
should check this email and any attachments for the presence of viruses.
The company accepts no liability for any damage caused by any virus
transmitted by this email.

www.wipro.com