Subject: Re: [Sip] I-D Action:draft-ietf-sip-dtls-srtp-framework-00.txt

From: "Jason Fischl" <[email-masked]>
Date: Mon, 3 Dec 2007 16:06:59 -0800

On Nov 13, 2007 11:50 AM, Francois Audet <[email-masked]> wrote:
> (copying Flemming)
>
> Good draft. Very helpful.
>
> On the SDP side of things.
>
> I didn't seen anything in the SDP format that specifically indicated in the offer that
> you are trying to setup DTLS-SRTP.
>
This is signaled in the SDP with the token "UDP/TLS/RTP/SAVP". See
http://www.ietf.org/internet-drafts/draft-fischl-mmusic-sdp-dtls-04.txt
for more details.

> Is the assumption that if there is no indication besides the RTP/SAVP in the tcap, that
> DTLS-SRTP may be negotiated, and that therefore we do not need an explicit indication
> that DTLS-SRTP is supported?
>
More specifically, UDP/TLS/RTP/SAVP. to signal we're sending SRTP over DTLS.

> Do we think it's good enough? In other words, is RTP/SAVP without a=crypto or a=key-mgmt
> good enough to indicate DTLS-SRTP? Or should we have another attribute?
>
I think this is good enough.

> A side comment is that the example shows usage with Best-Effort SRTP. My take is
> that it could also be used in "DTLS-SRTP-always" mode by having the m-line
> use UDP/TLS/RTP/AVP instead of RTP/AVP and not using a a=tcap/a=pcfg line. It
> would probably be worthwile to describe it in the draft.
>
I can add an example fragment to cover this case.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Francois Audet" <[email-masked]>
Date: Mon, 3 Dec 2007 18:16:24 -0600

See below. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Jason Fischl
> Sent: Monday, December 03, 2007 16:07
> To: Audet, Francois (SC100:3055)
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; Flemming Andreasen
> Subject: Re: [Sip] I-D 
> Action:draft-ietf-sip-dtls-srtp-framework-00.txt
> 
> > I didn't seen anything in the SDP format that specifically 
> indicated 
> > in the offer that you are trying to setup DTLS-SRTP.
> >

Ah.... Can you explicitly say that in the document?
I see there is a reference to this draft, but the document doesn't say 
that it is used for that purpose.

> 
> > Is the assumption that if there is no indication besides 
> the RTP/SAVP 
> > in the tcap, that DTLS-SRTP may be negotiated, and that 
> therefore we 
> > do not need an explicit indication that DTLS-SRTP is supported?
> >
> > Do we think it's good enough? In other words, is RTP/SAVP without 
> > a=crypto or a=key-mgmt good enough to indicate DTLS-SRTP? 
> Or should we have another attribute?
> >

Agreed.

> > A side comment is that the example shows usage with 
> Best-Effort SRTP. 
> > My take is that it could also be used in "DTLS-SRTP-always" mode by 
> > having the m-line use UDP/TLS/RTP/AVP instead of RTP/AVP 
> and not using 
> > a a=tcap/a=pcfg line. It would probably be worthwile to 
> describe it in the draft.
> >

That would be very useful.

Thanks.

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 05 Dec 2007 14:11:49 -0500

The SDP Capability Negotiation part is fine albeit you could argue it 
would be cleaner to have the DTLS-SRTP related attributes encoded as 
attribute capabilities rather than as first-level attributes.

-- Flemming