Subject: [Sip] Re: Comments on draft-ietf-sip-outbound-10

From: Rohan Mahy <[email-masked]>
Date: Sat, 1 Dec 2007 09:36:24 -0800

Hi,

All your comments have been addressed in outbound-11 as noted below.

thanks,
-rohan

On Jul 23, 2007, at 3:25 PM, Alfred E. Heggestad wrote:
> Comments on draft-ietf-sip-outbound-10
>
> by Alfred E. Heggestad <[email-masked]>
> 23. July 2007
>
>
>
>
> > 3.2.  Single Registrar and UA
> >
> >   REGISTER sip:example.com;keep-crlf SIP/2.0
> >   Via: SIP/2.0/TCP 192.0.2.1;branch=z9hG4bK-bad0ce-11-1036
> >   Max-Forwards: 70
> >   From: Bob <sip:[email-masked]>;tag=d879h76
> >   To: Bob <sip:[email-masked]>
> >   Call-ID: 8921348ju72je840.204
> >   CSeq: 1 REGISTER
> >   Supported: path
> >   Contact: <sip:[email-masked]>; reg-id=1;
> >    ;+sip.instance="<urn:uuid:00000000-0000-1000-8000-000A95A0E128>"
> >   Content-Length: 0
>
> I find this example SIP message a bit strange. If the message is sent
> over TCP, shouldn't the URI in the Contact header contain  
> ";transport=tcp" ?
> Also, is the IP address in the Via header supposed to be a private IP
> address (192.168.x.y) or a public IP address?

yes. fixed.

> > 3.5.3.  STUN Keepalive Technique
> >
> >   This technique can only be used for transports, such as UDP,  
> that are
> >   not connection oriented.
>
> Suggest rewriting this sentence:
>
>    "This approach MUST only be used with connection-less transports
>     such as UDP."

accepted.

> > 4.4.3.  Keepalive with STUN
> >
> >   This approach MUST only be used with transports, such as UDP, that
> >   are not connection oriented.
>
> same as above

likewise

> > 12.2.  SIP/SIPS URI Parameters
> >
> >       Parameter Name  Predefined Values  Reference
> >       ____________________________________________
> >       keep-crlf           No            [RFC AAAA]
> >       keep-stun           No            [RFC AAAA]
>
> suggest to merge these two parameters to "keepalive"

ack

> > 12.2.  SIP/SIPS URI Parameters
> >
> >       Parameter Name  Predefined Values  Reference
> >       ____________________________________________
> >       timed-keepalive     No            [RFC AAAA]
> >       ^^^^^^^^^^^^^^^
>
> This URI parameter is referred to as 'timed-keepalives' (with the  
> trailing 's')
> a total of 4 locations in the document. They should be updated to read
> "timed-keepalive"

ack

> apart from these comments, the document is well structured and easy  
> to read.

many thanks,
-rohan

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Alfred E. Heggestad" <[email-masked]>
Date: Tue, 04 Dec 2007 12:31:09 +0100

inline

> All your comments have been addressed in outbound-11 as noted below.

thanks!

>> by Alfred E. Heggestad <[email-masked]>

<snip>

>> suggest to merge these two parameters to "keepalive"

outbound-11 says:

        keep                No            [RFC AAAA]

however, since you have already published the draft with the "keep"
parameter, I dont see any reason to change it now.

/alfred