Subject: [Sip] Record-Route-Header ftag-field and routing

From: "Frank, Marc" <[email-masked]>
Date: Tue, 18 Dec 2007 19:03:50 +0100

Hi guys,

because of some problems with my SIP-Client, I have traced the traffic of a 
snom SIP-phone. Now I'm a little confused about the Record-Route header.

I've made two incoming testcalls with different providers.

At the first test the snom-phone received an invite-message with record-route 
with ftag-field. When the phone hangup it sends it's BYE-Request to the 
IP-address defined in the last route-header-field.

At the second test (2nd provider) the snom-phone received an invite-message 
with record-route and NO ftag-field. When the phone hangup it sends it's 
BYE-Request to the IP-address of the registrar.

Is it correct, that a SIP-application which receives a record-route with ftag 
must send the traffic depending on this call to that destination?

Regards 

Marc :-)

Trace-Snapshot:

Call 1 with re-routing
--------------------------------------------------------------------------------
Received from udp:212.227.15.197:5060 at 18/12/2007 14:00:09:980 (1392 bytes):

INVITE sip:aaaaa at xx.xxx.229.7:2054;line=j3eted9k SIP/2.0
Record-Route: <sip:212.227.15.232;ftag=1937134676;lr=on>
Via: SIP/2.0/UDP 212.227.15.197;branch=z9hG4bK59f8248d2c568739bc7dc8a7de9c4f82
Via: SIP/2.0/UDP 212.227.15.232;branch=z9hG4bK589.5362a815.0
Via: SIP/2.0/UDP 212.227.15.197;branch=z9hG4bK202ed21ce8126c48fd64f9f8458a705d
Via: SIP/2.0/UDP sipgw01.bmcag.com:5060 
;received=62.206.6.140;branch=z9hG4bKterm-2ab0b6-496151951416-496214255114
From: caller <sip:caller at sipgw01.bmcag.com;user=phone>;tag=1937134676
To: called <sip:called at 212.227.15.197;user=phone>
Contact: <sip:caller at sipgw01.bmcag.com:5060>

...

Sent to udp:212.227.15.232:5060 at 18/12/2007 14:00:32:380 (695 bytes):

BYE sip:caller at sipgw01.bmcag.com:5060 SIP/2.0
Via: SIP/2.0/UDP xx.xxx.229.7:2054;branch=z9hG4bK-54bqxvq49o3d;rport
Route: <sip:212.227.15.232;ftag=1937134676;lr=on>
From: "called" <sip:called at 212.227.15.197;user=phone>;tag=ckf1qvklvd
To: "caller" <sip:caller at sipgw01.bmcag.com;user=phone>;tag=1937134676
Call-ID: 7e38a35-4274d41-7d136ce2-b115 at sipgw01.bmcag.com
CSeq: 1 BYE
--------------------------------------------------------------------------------

Call 2 without re-routing
--------------------------------------------------------------------------------

Received from udp:213.218.28.202:5060 at 18/12/2007 18:02:31:170 (1422 bytes):

INVITE sip:user at xx.xxx.229.7:2060;line=i8vjxde1 SIP/2.0
Record-Route: <sip:213.218.28.202;lr=on>
Record-Route: <sip:213.218.28.102;lr=on>
Via: SIP/2.0/UDP 213.218.28.202;branch=z9hG4bKbd69.7040b7b5.0
Via: SIP/2.0/UDP 213.218.28.102;branch=z9hG4bKbd69.b2ae7011.0
Via: SIP/2.0/UDP 213.218.28.164:5060;branch=z9hG4bK00E0F510055C3A
From: "caller" <sip:caller at provider.net;user=phone>;tag=00E0F5100
To: <sip:called at provider.net;user=phone>
Call-ID: [email-masked]
CSeq: 34207 INVITE
Contact: <sip:caller at ip>

...

Sent to udp:213.218.28.202:5060 at 18/12/2007 18:02:43:310 (731 bytes):

BYE sip:called at ip SIP/2.0
Via: SIP/2.0/UDP 80.152.229.7:2060;branch=z9hG4bK-t7jlwh3sb054;rport
Route: <sip:213.218.28.202;lr=on>
Route: <sip:213.218.28.102;lr=on>
--------------------------------------------------------------------------------

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Sanjay Sinha (sanjsinh)" <[email-masked]>
Date: Tue, 18 Dec 2007 14:10:11 -0500

This would've been appropriate on sip-implementers mailer.

The behavior below looks correct to me and has nothing to do with ftag
field in RR header. 

In the 1st case since UAS is getting a request with a RR header, next
request on that dialog is sent to the address in RR header and since the
proxy adding RR supports loose routing, request uri of BYE is contact
address from previous request.

In the 2nd case, since there are 2 RR headers, route set for UAS is:
<sip:213.218.28.202;lr=on>, <sip:213.218.28.102;lr=on>. 
And the next request on that dialog is correctly sent to 213.218.28.202.

Sanjay

>-----Original Message-----
>From: Frank, Marc [mailto:[email-masked]] 
>Sent: Tuesday, December 18, 2007 1:04 PM
>To: [email-masked]
>Subject: [Sip] Record-Route-Header ftag-field and routing
>
>Hi guys,
>
>because of some problems with my SIP-Client, I have traced the 
>traffic of a snom SIP-phone. Now I'm a little confused about 
>the Record-Route header.
>
>At the first test the snom-phone received an invite-message 
>with record-route with ftag-field. When the phone hangup it 
>sends it's BYE-Request to the IP-address defined in the last 
>route-header-field.
>
>At the second test (2nd provider) the snom-phone received an 
>invite-message with record-route and NO ftag-field. When the 
>phone hangup it sends it's BYE-Request to the IP-address of 
>the registrar.
>
>Is it correct, that a SIP-application which receives a 
>record-route with ftag must send the traffic depending on this 
>call to that destination?
>
>Regards 
>
>Marc :-)
>
>
>Trace-Snapshot:
>
>
>Call 1 with re-routing
>Via: SIP/2.0/UDP 
>212.227.15.197;branch=z9hG4bK59f8248d2c568739bc7dc8a7de9c4f82
>Via: SIP/2.0/UDP 
>212.227.15.197;branch=z9hG4bK202ed21ce8126c48fd64f9f8458a705d
>From: caller <sip:caller at 
>sipgw01.bmcag.com;user=phone>;tag=1937134676
>To: "caller" <sip:caller at 
>sipgw01.bmcag.com;user=phone>;tag=1937134676
>This list is for NEW development of the core SIP Protocol Use 
>[email-masked] for questions on current sip