Subject: [Sip] proposed litmus tests for INFO

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 13 Dec 2007 00:13:39 -0500

Based on Hadriels use cases, I'd like to suggest some litmus tests that 
one can use to help determine if something is best done by INFO or 
something else:

Cases where a media-plane session is the best solution:

   * there are requirements for low latency delivery (camera control for 
example)

   * there are requirements that the data shouldn't be retransmitted 
since latency trumps reliability (coordinate updates for a pointer on a 
whiteboard or something like that)

   * the data consists of a large number of messages that are likely to 
be sent during the duration of the session

   * the data is potentially very large

Cases where SUB-NOT is the best solution:

   * the entity that wants to receive the data knows with high 
probability that the other side is likely to send a notification with 
the data, and it knows specifically what type of data it needs to receive

   * the entity that wants to receive the data is likely to receive a 
multiplicity of events containing that data

Cases where INFO is the best solution:

   * the recipient of the data has no idea if the sender will ever 
generate the data; the recipient is just saying that it knows how to 
handle it, should the sender have something to send

   * the recipient could potentially handle many different types of data 
with the above characteristic

   * the size of the data that is to be sent is small and infrequent, at 
most a few times during the session

   * the data needs to be sent reliably and latency is not much of an issue

   * the data has no impact on SIP dialog state, transaction state, 
media session states or intermediate proxy or b2bua states

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   499 Thornall St.
Cisco Fellow                                   Edison, NJ 08837
Cisco, Voice Technology Group
[email-masked]
http://www.jdrosen.net                         PHONE: (408) 902-3084
http://www.cisco.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg" <[email-masked]>
Date: Thu, 13 Dec 2007 17:47:56 +0100

Hi,

I think this is a good start, but I have some comments:

Media-plane stuff:
------------------

This looks rather ok, but I am not sure I understand the retransmission issue. The CSeq will take care of that, won't it?

Or, do you mean that retransmission can delay the information to reach the recevier? If so, isn't it covered with the first bullet (low latency)?

SUB-NOT vs INFO stuff:
----------------------

For INFO I think we should say that it can be used when the data may be sent is associated to the dialog sent within, and is sent only for the duration of that dialog  (unless a media-plane session is more appropriate for that specific data type, of course).

For INFO I think we should also add cases when there are dialog-path intermediates (without media access) interested in the data.

For SUB-NOT I think we should add text about data which is not associated to an invite dialog, or not associated to the lifetime of an invite dialog. 

I think that the current SUB-NOT bullets could be applicable to INFO also. I don't think we can forget the multiple dialog issue with SUB-NOT (which is one of the reasons why people use INFO in the first place). Of course that doesn't automatically mean that people are allowed to use INFO for anything they could also use SUB-NOT for, but I see no reason why INFO can't be used e.g. in cases where it is "very likely that some data will be sent" (ISUP is one example, where in many cases nodes will know it will be sent).

To me one important difference between INFO and SUB-NOT is, as described earlier, whether the data is associated with a specific invite dialog, and whether the data will only be sent during the lifetime of that invite dialog. If not, SUB-NOT is better.

What do you mean by "multiplicity of events containing that data"?

Regards,

Christer

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: 13. joulukuuta 2007 7:14
> To: IETF SIP List
> Subject: [Sip] proposed litmus tests for INFO
>
> Based on Hadriels use cases, I'd like to suggest some litmus
> tests that one can use to help determine if something is best
> done by INFO or something else:
>
>    * there are requirements that the data shouldn't be
> retransmitted since latency trumps reliability (coordinate
> updates for a pointer on a whiteboard or something like that)
>
>    * the data consists of a large number of messages that are
> likely to be sent during the duration of the session
>
>    * the entity that wants to receive the data knows with
> high probability that the other side is likely to send a
> notification with the data, and it knows specifically what
> type of data it needs to receive
>
>    * the entity that wants to receive the data is likely to
> receive a multiplicity of events containing that data
>
>    * the recipient of the data has no idea if the sender will
> ever generate the data; the recipient is just saying that it
> knows how to handle it, should the sender have something to send
>
>    * the recipient could potentially handle many different
> types of data with the above characteristic
>
>    * the size of the data that is to be sent is small and
> infrequent, at most a few times during the session
>
>    * the data has no impact on SIP dialog state, transaction
> state, media session states or intermediate proxy or b2bua states
>
>
> -Jonathan R.
>
> --
> http://www.jdrosen.net <http://www.jdrosen.net/>                          PHONE: (408) 902-3084
> http://www.cisco.com <http://www.cisco.com/> 
>
>