Subject: [Sip] comments on draft-kaplan-sip-secure-call-id-00.txt

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 21 Mar 2009 11:17:32 -0400

Few comments.

While this is not a bad idea, its not clear what the point of it is, 
given draft-kaplan-sip-session-id-01.txt suggests anyway a different 
header field for dialog identification through b2bua. Indeed the 
introduction in this document still talks about dialog correlation. Is 
this meant as a way to fix up existing call-id using extensions in a 
backwards compatible way, while session-id is for future things?

I do apologize I did not follow much of the discussion at the end of 
last year if this was discussed then.

-Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.                   111 Wood Avenue South
Cisco Fellow                                   Iselin, NJ 08830
Cisco, Voice Technology Group
[email-masked]
http://www.jdrosen.net                         PHONE: (408) 902-3084
http://www.cisco.com

---

From: Hadriel Kaplan <[email-masked]>
Date: Sat, 21 Mar 2009 18:50:56 -0400

Hey Jonathan,
Thanks for reviewing the draft!  This draft is just about making UA's send actual Call-ID values which do not reveal sensitive information, so that middleboxes are not made to change them purely for security purposes.

The other draft, session-id, was changed - rev 02 is the latest - and that rev is only about troubleshooting not dialog matching. This secure-call-id draft is the one and only thing I propose for dialog matching purposes (and it is the actual Call-ID header field value).

-hadriel

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Jonathan Rosenberg
> Sent: Saturday, March 21, 2009 11:18 AM
> To: IETF SIP List
> Subject: [Sip] comments on draft-kaplan-sip-secure-call-id-00.txt
> 
> Few comments.
> 
> _______________________________________________
> Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip