Subject: [Sip] New version of draft-holmberg-sip-keep

From: "Christer Holmberg" <[email-masked]>
Date: Thu, 26 Mar 2009 18:41:23 +0100

Hi,

I've submitted a new version (-04) of the keep draft.

The requirement text is now alligned with the text shown on the slides
during the SFO SIP WG presentation.

There are no other changes in the document from the previous version.

Regards,

Christer

---

From: "Mary Barnes" <[email-masked]>
Date: Thu, 26 Mar 2009 18:16:57 -0500

Hi folks,

Christer has updated the document based on the action item from Wednesday's SIP session (chaired by SIPPING chairs and modeled as the proposed DISPATCH WG).  If folks could please review the document and raise any concerns on the document now, that would be appreciated. We ask specifically for an answer to the question:  Do you support the document being adopted as a WG document in RAI (WG tbd)?  A simple "yes" is fine, however, if you don't think we should adopt this document, could you please provide the reason.

For your convenience, here's the link to the document:
http://tools.ietf.org/id/draft-holmberg-sip-keep-04.txt
And, the diff:
http://tools.ietf.org//rfcdiff?url1=http://tools.ietf.org/id/draft-holmberg-sip-keep-03.txt&url2=http://tools.ietf.org/id/draft-holmberg-sip-keep-04.txt
tinyurl: http://tinyurl.com/dfyvxz

Regards,
Mary
SIPPING WG co-chair

-----Original Message-----
From: [email-masked] on behalf of Christer Holmberg
Sent: Thu 3/26/2009 12:41 PM
To: [email-masked]
Subject: [Sip] New version of draft-holmberg-sip-keep

Hi,

Regards,

Christer

---

From: "DOLLY, MARTIN C, ATTLABS" <[email-masked]>
Date: Thu, 26 Mar 2009 19:35:46 -0400

Yes, we support this draft as a WG document.

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Mary Barnes
Sent: Thursday, March 26, 2009 7:17 PM
To: Christer Holmberg; [email-masked]
Subject: Re: [Sip] New version of draft-holmberg-sip-keep

Hi folks,

Christer has updated the document based on the action item from
Wednesday's SIP session (chaired by SIPPING chairs and modeled as the
proposed DISPATCH WG).  If folks could please review the document and
raise any concerns on the document now, that would be appreciated. We
ask specifically for an answer to the question:  Do you support the
document being adopted as a WG document in RAI (WG tbd)?  A simple "yes"
is fine, however, if you don't think we should adopt this document,
could you please provide the reason.

For your convenience, here's the link to the document:
http://tools.ietf.org/id/draft-holmberg-sip-keep-04.txt
And, the diff:
http://tools.ietf.org//rfcdiff?url1=http://tools.ietf.org/id/draft-holmb
erg-sip-keep-03.txt&url2=http://tools.ietf.org/id/draft-holmberg-sip-kee
p-04.txt
<http://tools.ietf.org/rfcdiff?url1=http://tools.ietf.org/id/draft-holmb
erg-sip-keep-03.txt&url2=http://tools.ietf.org/id/draft-holmberg-sip-kee
p-04.txt> 
tinyurl: http://tinyurl.com/dfyvxz

Regards,
Mary
SIPPING WG co-chair

-----Original Message-----
From: [email-masked] on behalf of Christer Holmberg
Sent: Thu 3/26/2009 12:41 PM
To: [email-masked]
Subject: [Sip] New version of draft-holmberg-sip-keep

Hi,

Regards,

Christer

---

From: Hadriel Kaplan <[email-masked]>
Date: Thu, 26 Mar 2009 20:10:25 -0400

"yes"

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mary Barnes
Sent: Thursday, March 26, 2009 7:17 PM
To: Christer Holmberg; [email-masked]
Subject: Re: [Sip] New version of draft-holmberg-sip-keep

Hi folks,

For your convenience, here's the link to the document:
http://tools.ietf.org/id/draft-holmberg-sip-keep-04.txt
And, the diff:
http://tools.ietf.org//rfcdiff?url1=http://tools.ietf.org/id/draft-holmberg-sip-keep-03.txt&url2=http://tools.ietf.org/id/draft-holmberg-sip-keep-04.txt<http://tools.ietf.org/rfcdiff?url1=http://tools.ietf.org/id/draft-holmberg-sip-keep-03.txt&url2=http://tools.ietf.org/id/draft-holmberg-sip-keep-04.txt>
tinyurl: http://tinyurl.com/dfyvxz

Regards,
Mary
SIPPING WG co-chair

-----Original Message-----
From: [email-masked] on behalf of Christer Holmberg
Sent: Thu 3/26/2009 12:41 PM
To: [email-masked]
Subject: [Sip] New version of draft-holmberg-sip-keep

Hi,

Regards,

Christer

---

From: Theo Zourzouvillys <[email-masked]>
Date: Fri, 27 Mar 2009 00:34:26 +0000

On Thu, Mar 26, 2009 at 11:16 PM, Mary Barnes <[email-masked]> wrote:

> Do you support the document being adopted as a WG document in RAI (WG tbd)?

yes

 ~ Theo

Sent from: San Francisco California United States.

---

From: Hans Erik van Elburg <[email-masked]>
Date: Fri, 27 Mar 2009 01:53:31 +0100

"yes"

Mary Barnes wrote:
> document being adopted as a WG document in RAI (WG tbd)?  A simple 
> "yes" is fine, however, if you don't think we should adopt this 
> document, could you please provide the reason.
>
> <http://tools.ietf.org//rfcdiff?url1=http://tools.ietf.org/id/draft-holmberg-sip-keep-03.txt&url2=http://tools.ietf.org/id/draft-holmberg-sip-keep-04.txt>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

---

From: Bob Penfield <[email-masked]>
Date: Thu, 26 Mar 2009 20:58:01 -0400

>Do you support the document being adopted as a WG document in RAI (WG tbd)?  

YES!

Hi folks,

Regards,
Mary
SIPPING WG co-chair

-----Original Message-----
From: [email-masked] on behalf of Christer Holmberg
Sent: Thu 3/26/2009 12:41 PM
To: [email-masked]
Subject: [Sip] New version of draft-holmberg-sip-keep

Hi,

Regards,

Christer

---

From: "Uzelac, Adam" <[email-masked]>
Date: Thu, 26 Mar 2009 21:21:55 -0400

+1

> Theo Zourzouvillys
> Sent: Thursday, March 26, 2009 5:34 PM
> To: Mary Barnes
> Cc: [email-masked]; Christer Holmberg

---

From: "Bharrat, Shaun" <[email-masked]>
Date: Thu, 26 Mar 2009 22:06:41 -0400

yes

-----Original Message-----
From: [email-masked] on behalf of Mary Barnes
Sent: Thu 3/26/2009 7:16 PM
To: Christer Holmberg; [email-masked]
Subject: Re: [Sip] New version of draft-holmberg-sip-keep
 
Hi folks,

Regards,
Mary
SIPPING WG co-chair

-----Original Message-----
From: [email-masked] on behalf of Christer Holmberg
Sent: Thu 3/26/2009 12:41 PM
To: [email-masked]
Subject: [Sip] New version of draft-holmberg-sip-keep

Hi,

Regards,

Christer

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 27 Mar 2009 05:53:03 +0100

As individual

Support

Keith

Sent: Thursday, March 26, 2009 11:17 PM

Hi folks,

Regards,
Mary
SIPPING WG co-chair

-----Original Message-----
From: [email-masked] on behalf of Christer Holmberg
Sent: Thu 3/26/2009 12:41 PM
To: [email-masked]
Subject: [Sip] New version of draft-holmberg-sip-keep

Hi,

Regards,

Christer

---

From: <[email-masked]>
Date: Fri, 27 Mar 2009 05:53:13 +0100

"Yes"
We too.
 
Roland

Von: [email-masked] [mailto:[email-masked]] Im Auftrag von DOLLY, MARTIN C, ATTLABS
Gesendet: Freitag, 27. März 2009 00:36
An: Mary Barnes; Christer Holmberg; [email-masked]
Betreff: Re: [Sip] New version of draft-holmberg-sip-keep

Hi folks,

For your convenience, here's the link to the document:
http://tools.ietf.org/id/draft-holmberg-sip-keep-04.txt
And, the diff:
http://tools.ietf.org//rfcdiff?url1=http://tools.ietf.org/id/draft-holmberg-sip-keep-03.txt&url2=http://tools.ietf.org/id/draft-holmberg-sip-keep-04.txt <http://tools.ietf.org/rfcdiff?url1=http://tools.ietf.org/id/draft-holmberg-sip-keep-03.txt&url2=http://tools.ietf.org/id/draft-holmberg-sip-keep-04.txt> 
tinyurl: http://tinyurl.com/dfyvxz

Regards,
Mary
SIPPING WG co-chair

-----Original Message-----
From: [email-masked] on behalf of Christer Holmberg
Sent: Thu 3/26/2009 12:41 PM
To: [email-masked]
Subject: [Sip] New version of draft-holmberg-sip-keep

Hi,

Regards,

Christer

---

From: Shida Schubert <[email-masked]>
Date: Thu, 26 Mar 2009 22:13:08 -0700

Yes I support this work too.

On 26-Mar-09, at 4:16 PM, Mary Barnes wrote:

> Wednesday's SIP session (chaired by SIPPING chairs and modeled as  
> the proposed DISPATCH WG).  If folks could please review the  
> document and raise any concerns on the document now, that would be  
> appreciated. We ask specifically for an answer to the question:  Do  
> you support the document being adopted as a WG document in RAI (WG  
> tbd)?  A simple "yes" is fine, however, if you don't think we should  
> adopt this document, could you please provide the reason.
>

---

From: "Doken, Serhad" <[email-masked]>
Date: Fri, 27 Mar 2009 00:14:19 -0700

++

From: [email-masked] [mailto:[email-masked]] On Behalf Of DRAGE, Keith (Keith)
Sent: Thursday, March 26, 2009 9:53 PM
To: Mary Barnes; Christer Holmberg; [email-masked]
Subject: Re: [Sip] New version of draft-holmberg-sip-keep

As individual

Support

Keith

Hi folks,

Regards,
Mary
SIPPING WG co-chair

-----Original Message-----
From: [email-masked] on behalf of Christer Holmberg
Sent: Thu 3/26/2009 12:41 PM
To: [email-masked]
Subject: [Sip] New version of draft-holmberg-sip-keep

Hi,

Regards,

Christer

---

From: <[email-masked]>
Date: Fri, 27 Mar 2009 08:14:47 +0100

Yes

De : [email-masked] [mailto:[email-masked]] De la part de Shida Schubert
Envoyé : jeudi 26 mars 2009 22:13
À : Mary Barnes
Cc : [email-masked] List; Christer Holmberg
Objet : Re: [Sip] New version of draft-holmberg-sip-keep

	Hi folks,

	
	Regards,
	Mary
	SIPPING WG co-chair

	-----Original Message-----
	From: [email-masked] on behalf of Christer Holmberg
	Sent: Thu 3/26/2009 12:41 PM
	To: [email-masked]
	Subject: [Sip] New version of draft-holmberg-sip-keep

	Hi,

	
	
	Regards,
	
	Christer

---

From: <[email-masked]>
Date: Fri, 27 Mar 2009 16:15:03 -0000

Yes

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Mary Barnes
Sent: 26 March 2009 23:17
To: Christer Holmberg; [email-masked]
Subject: Re: [Sip] New version of draft-holmberg-sip-keep

Hi folks,

Regards,
Mary
SIPPING WG co-chair

-----Original Message-----
From: [email-masked] on behalf of Christer Holmberg
Sent: Thu 3/26/2009 12:41 PM
To: [email-masked]
Subject: [Sip] New version of draft-holmberg-sip-keep

Hi,

Regards,

Christer

---

From: "Francois Audet" <[email-masked]>
Date: Fri, 27 Mar 2009 11:27:19 -0500

YES.

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Barnes, Mary (RICH2:AR00)
	Sent: Thursday, March 26, 2009 16:17
	To: Christer Holmberg; [email-masked]
	Subject: Re: [Sip] New version of draft-holmberg-sip-keep

	Hi folks,

	
	Regards,
	Mary
	SIPPING WG co-chair

	-----Original Message-----
	From: [email-masked] on behalf of Christer Holmberg
	Sent: Thu 3/26/2009 12:41 PM
	To: [email-masked]
	Subject: [Sip] New version of draft-holmberg-sip-keep

	Hi,

	
	
	Regards,
	
	Christer

---

From: Salvatore Loreto <[email-masked]>
Date: Fri, 27 Mar 2009 18:49:25 +0200

Yes

>     *From:* [email-masked] [mailto:[email-masked]] *On
>     Behalf Of *Barnes, Mary (RICH2:AR00)
>     *Sent:* Thursday, March 26, 2009 16:17
>     *To:* Christer Holmberg; [email-masked]
>     *Subject:* Re: [Sip] New version of draft-holmberg-sip-keep
>
>     Hi folks,
>
>     appreciated. We ask specifically for an answer to the question: 
>     Do you support the document being adopted as a WG document in RAI
>     (WG tbd)?  A simple "yes" is fine, however, if you don't think we
>     should adopt this document, could you please provide the reason.
>

---

From: <[email-masked]>
Date: Fri, 27 Mar 2009 18:47:10 +0100

yes

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Mary Barnes
	Sent: 26 March 2009 23:17
	To: Christer Holmberg; [email-masked]
	Subject: Re: [Sip] New version of draft-holmberg-sip-keep

	Hi folks,

	
	
	Regards,
	Mary
	SIPPING WG co-chair

	-----Original Message-----
	From: [email-masked] on behalf of Christer Holmberg
	Sent: Thu 3/26/2009 12:41 PM
	To: [email-masked]
	Subject: [Sip] New version of draft-holmberg-sip-keep

	Hi,

	The requirement text is now alligned with the text shown on the
slides
	during the SFO SIP WG presentation.
	
	There are no other changes in the document from the previous
version.
	
	Regards,
	
	Christer

---

From: Dean Willis <[email-masked]>
Date: Sun, 29 Mar 2009 22:53:42 -0500

> adopt this document, could you please provide the reason.

So, given the outpouring of support, should we pull back the draft- 
ietf-sip-outbound and re-write it to refer to the keepalive mechanism  
of this draft instead of containing similar but not identical text?

--
Dean

---

From: "Christer Holmberg" <[email-masked]>
Date: Mon, 30 Mar 2009 16:17:41 +0200

Hi,

Personally I have nothing against moving the keep-alive mechanism to
draft-keep, and I guess most people agree it is how it should have been
done.

However, we have previously agreed not to do it, so I hope we will not
spend lots of time to discuss it again.

Regards,

Christer

-----Original Message-----
From: Dean Willis [mailto:[email-masked]] 
Sent: Monday, March 30, 2009 4:54 AM
To: Mary Barnes
Cc: Christer Holmberg; [email-masked]
Subject: Re: [Sip] New version of draft-holmberg-sip-keep

So, given the outpouring of support, should we pull back the draft-
ietf-sip-outbound and re-write it to refer to the keepalive mechanism of
this draft instead of containing similar but not identical text?

--
Dean

---

From: "Francois Audet" <[email-masked]>
Date: Mon, 30 Mar 2009 12:09:54 -0500

Dean, 

There is no reason to do so.

There is no "similar but not identical text" in draft-keep.
Draft-keep only defines a parameter that allows the usage
of the keep-alive defined in draft-ietf-sip-outbound, outside of
the context of the registration procedures
of draft-ietf-sip-outbound. 

Currently, the two drafts are carefully choregraphed to
be consistent. I don't want to undo this at the last minute.

Note that some other drafts in the queue are dependent on 
draft-ietf-outbound (e.g., draft-ietf-sip-sips). I really
don't want us to undo our work for no good reason.

I would recommend moving draft-keep swiftly to WG document.
I believe it should rapidly move into last call.

> Behalf Of Dean Willis
> Sent: Sunday, March 29, 2009 20:54
> To: Barnes, Mary (RICH2:AR00)
> So, given the outpouring of support, should we pull back the 
> draft- ietf-sip-outbound and re-write it to refer to the 
> keepalive mechanism of this draft instead of containing 
> similar but not identical text?
> 
> --
> Dean