Subject: Re: [Sip] WGLC for draft-ietf-sip-ua-privacy

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 2 Mar 2009 11:47:28 +0100

(As WG cochair)

A reminder of the current WGLC on this document which completes today.

Please submit your comments as soon as possible.

If you are reviewing the document, and you consider there may be a delay in your comments appearing, then please send a mail to the chairs so they can ascertain whether more time is needed.

regards

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of DRAGE, Keith (Keith)
> Sent: Tuesday, February 17, 2009 12:01 AM
> To: SIP List
> Cc: [email-masked]; Dean Willis
> Subject: [Sip] WGLC for draft-ietf-sip-ua-privacy
> 
> (As WG cochair)
> 
> This mail is to initiate working group last call on 
> draft-ietf-sip-ua-privacy which may be found here:
> 
> http://tools.ietf.org/internet-drafts/draft-ietf-sip-ua-privacy-05.txt
> 
> Please provide comments to both the authors and to the SIP WG 
> list by Monday 2nd March 2009.
> 
> The intended status of the document is informational.
> 
> regards
> 
> Keith
> _______________________________________________
> Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip 
> Use [email-masked] for new developments on the application of sip
>

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 02 Mar 2009 17:23:25 +0000

1. In 4.1:
"If revealing the domain name in the
   Contact header field is a concern, usage of a third-party GRUU server
   to obtain a temp-gruu that is irrelevant to users' domain, which is
   outside the scope of this document SHOULD be considered."
"SHOULD be considered" is not a testable normative statement. It is not
the user's domain that is outside the scope, but usage of a third-party
GRUU server. The word "irrelevant" in inappropriate here. To take care
of these concerns, I think it should say:
"If revealing the domain name in the  Contact header field is a concern,
use of a third party GRUU server is a possible solution, but this is
outside the scope of this document." 

2. In 5.1.1:
"For out-of-dialog
   request, anonymous URI MAY be set when anonymization is required."
What is the purpose of this statement? I assume out-of-dialog does not
include dialog-forming (which is covered earlier in the paragraph). For
a completely out-of-dialog request such as a MESSAGE request, why would
one include Contact? For REGISTER, one certainly cannot use an anonymous
URI.

John

> Sent: 02 March 2009 10:47
> To: SIP List
> Subject: Re: [Sip] WGLC for draft-ietf-sip-ua-privacy
> 
> (As WG cochair)
> 
> If you are reviewing the document, and you consider there may 
> be a delay in your comments appearing, then please send a 
> mail to the chairs so they can ascertain whether more time is needed.
> 
> regards
> 
> Keith
> 
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip

---

From: Mayumi Munakata <[email-masked]>
Date: Tue, 03 Mar 2009 17:12:34 +0900

Hi John,

Thank you for the comments.

See inline.

 > outside the scope of this document."

I agree and will replace the text with the one you proposed.

 > one include Contact? For REGISTER, one certainly cannot use an anonymous

The out-of-dialog request indeed meant the MESSAGE request.
I checked the RFC and found that MESSAGE requests don't
include the Contact header as you pointed out.
I will delete the sentence.

Thank you!

Mayumi