Subject: Re: [Sip] Question regarding conflicting grammar for IPV6 SIP URI and RFC 3986

From: "Szilagyi, Mike" <[email-masked]>
Date: Mon, 2 Mar 2009 09:20:59 -0500

Could someone let me know where this discussion has been moved?

Regards,
Mike

From: [email-masked] [mailto:[email-masked]] On Behalf Of Szilagyi, Mike
Sent: Thursday, December 18, 2008 10:53 AM
To: [email-masked]
Subject: [Sip] Question regarding conflicting grammar for IPV6 SIP URI and RFC 3986

RFC 3986 defines the following grammar for a URI:

   URI           = scheme ":" hier-part [ "?" query ] [ "#" fragment ]

   hier-part     = "//" authority path-abempty
                 / path-absolute
                 / path-rootless
                 / path-empty

A SIP URI falls into the 'path-rootless' rule:

   path-rootless = segment-nz *( "/" segment )

   segment-nz    = 1*pchar

   pchar         = unreserved / pct-encoded / sub-delims / ":" / "@"

   pct-encoded   = "%" HEXDIG HEXDIG

   unreserved    = ALPHA / DIGIT / "-" / "." / "_" / "~"

   sub-delims    = "!" / "$" / "&" / "'" / "(" / ")"

                 / "*" / "+" / "," / ";" / "="

path-rootless does not allow "[" or "]" characters, so the SIP-URI grammar for IPV6 violates RFC 3986 grammar.

SIP-URI          =  "sip:" [ userinfo ] hostport
                    uri-parameters [ headers ]

hostport         =  host [ ":" port ]
host             =  hostname / IPv4address / IPv6reference
hostname         =  *( domainlabel "." ) toplabel [ "." ]
domainlabel      =  alphanum
                    / alphanum *( alphanum / "-" ) alphanum
toplabel         =  ALPHA / ALPHA *( alphanum / "-" ) alphanum
IPv4address    =  1*3DIGIT "." 1*3DIGIT "." 1*3DIGIT "." 1*3DIGIT
IPv6reference  =  "[" IPv6address "]"  <-- *** violates RFC 3986 ***
IPv6address    =  hexpart [ ":" IPv4address ]
hexpart        =  hexseq / hexseq "::" [ hexseq ] / "::" [ hexseq ]
hexseq         =  hex4 *( ":" hex4)
hex4           =  1*4HEXDIG
port           =  1*DIGIT

These, though valid SIP URIs are not valid URIs:

    <sip:[2001:db8::10]>
    <sip:caller@[2001:db8::1]>

Has this already been addressed?

Regards,
Mike

---

From: Brett Tate <[email-masked]>
Date: Mon, 2 Mar 2009 06:37:23 -0800

Cullen's reply killed or moved the discussion.

http://www.ietf.org/mail-archive/web/sip/current/msg26385.html

"WIth my AD hat on ...

If you want to update/discuss/change/abuse 3986, probably the best place to to that would be on the APPS area list at [email-masked]<mailto:[email-masked]>

It would be up to the Apps ADs, but I suspect that change to the BNF suggested below is too significant a change to be done with an Errata.

Cullen"

From: [email-masked] [mailto:[email-masked]] On Behalf Of Szilagyi, Mike
Sent: Monday, March 02, 2009 9:21 AM
To: [email-masked]
Subject: Re: [Sip] Question regarding conflicting grammar for IPV6 SIP URI and RFC 3986

Regards,
Mike

   segment-nz    = 1*pchar

    <sip:[2001:db8::10]>

Regards,
Mike