Subject: [Sip] One chart //"UPDATE during Re-INVITE" discussion

From: [email-masked]
Date: Thu, 12 Mar 2009 11:46:49 +0800

UAC                   UAS
       | session established |
       |<===================>|
       |                     |
       | F1  re-INVITE (SDP) |
       |-------------------->|
       | F2 1xx-rel (SDP)    |
       |<--------------------|
       | F3   UPDATE         |
       |<--------------------| Target refreshing
       | F4 2xx UPT          |
       |-------------------->|
       |                     |
       | F5/6 Cancel/200OK   |
       |-------------------->|
       | F7    487 INV       |
       |<--------------------|
       | F7     ACK          |
       |-------------------->|
       | F8  re-INVITE (SDP) |
       |-------------------->| Using which dialog state

F3/F4 is about target refreshing.

And if UAC sends Cancel， UAS sends 487. The first Re-INVITE is discarded.

But if UAC sends another Re-INVITE, which dialog state should it use?

I think is the one refreshed by F3. That's the merit of regarding 
UPDATE/200OK's atomicity.

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: "Christer Holmberg" <[email-masked]>
Date: Thu, 12 Mar 2009 08:31:24 +0100

In my opinion 487 should trigger whatever actions/rollback that any other non-200 response sent by the UAS would.
 
Regards,
 
Christer

________________________________

	From: [email-masked] [mailto:[email-masked]] 
	Sent: 12. maaliskuuta 2009 5:47
	To: SIP; SIPPING
	Cc: Christer Holmberg; Gonzalo Camarillo
	Subject: One chart //"UPDATE during Re-INVITE" discussion

	      UAC                   UAS 
	       | session established | 
	       |<===================>| 
	       |                     | 
	       | F1  re-INVITE (SDP) | 
	       |-------------------->| 
	       | F2 1xx-rel (SDP)    | 
	       |<--------------------| 
	       | F3   UPDATE         | 

	
	
	I think is the one refreshed by F3. That's the merit of regarding UPDATE/200OK's atomicity.

---

From: [email-masked]
Date: Thu, 12 Mar 2009 15:40:59 +0800

Hi,

I just mean that if we treat F3 as sub-transaction of F1, then after 
F7(ACK), UAC can discard refreshed dialog state in F3.

And it may make the two parts can not communicate anymore in current 
dialog.

And IMO, this is a counterevidence for treating all UPDATE(during 
Re-INVITE) as sub-transaction of Re-INVITE.

Gao

"Christer Holmberg" <[email-masked]> 
2009-03-12 15:31

收件人
<[email-masked]>, "SIP" <[email-masked]>, "SIPPING" <[email-masked]>
抄送
"Gonzalo Camarillo" <[email-masked]>
主题
RE: One chart  //"UPDATE during Re-INVITE" discussion

In my opinion 487 should trigger whatever actions/rollback that any other 
non-200 response sent by the UAS would.
 
Regards,
 
Christer

      UAC                   UAS 
       | session established | 
       |<===================>| 
       |                     | 
       | F1  re-INVITE (SDP) | 
       |-------------------->| 
       | F2 1xx-rel (SDP)    | 
       |<--------------------| 
       | F3   UPDATE         | 

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is 
solely property of the sender's organization. This mail communication is 
confidential. Recipients named above are obligated to maintain secrecy and 
are not permitted to disclose the contents of this communication to 
others.
This email and any files transmitted with it are confidential and intended 
solely for the use of the individual or entity to whom they are addressed. 
If you have received this email in error please notify the originator of 
the message. Any views expressed in this message are those of the 
individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam 
system.

---

From: "Christer Holmberg" <[email-masked]>
Date: Thu, 12 Mar 2009 12:48:57 +0100

Hi,
 
If the UAC receives the 487 and can't fallback to the pre-reINVITE state, it sends a new re-INVITE with something that it DOES supports. That is also described in Gonzalo's draft, I belive.
 
And, you could have the same problem if the target refresh was done already in the re-INVITE/18x. If the UAC then sends CANCEL, and can't fall back, it will have to send a new re-INVITE.
 
I also think it is bad practise to do a target refresh in a nested UPDATE, but that's a separate issue.
 
Regards,
 
Christer

	From: [email-masked] [mailto:[email-masked]] 
	Sent: 12. maaliskuuta 2009 9:41
	To: Christer Holmberg
	Cc: Gonzalo Camarillo; SIP; SIPPING
	Subject: 答复: RE: One chart //"UPDATE during Re-INVITE" discussion

	Hi, 
	
	I just mean that if we treat F3 as sub-transaction of F1, then after F7(ACK), UAC can discard refreshed dialog state in F3. 
	
	And it may make the two parts can not communicate anymore in current dialog. 
	
	And IMO, this is a counterevidence for treating all UPDATE(during Re-INVITE) as sub-transaction of Re-INVITE. 
	
	Gao 

2009-03-12 15:31 

收件人

	Regards, 
	  
	Christer 

	     UAC                   UAS 
	      | session established | 
	      |<===================>| 
	      |                     | 
	      | F1  re-INVITE (SDP) | 
	      |-------------------->| 
	      | F2 1xx-rel (SDP)    | 
	      |<--------------------| 
	      | F3   UPDATE         |

---

From: Brett Tate <[email-masked]>
Date: Thu, 12 Mar 2009 04:57:06 -0700

Data (like Contact, Session-Expires, and etcetera) that was successfully updated by F3/F4 still apply after F7.  Thus F8 data should reflect (and can attempt to modify) adjustments made during F3/F4.

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, March 11, 2009 11:47 PM
To: SIP; SIPPING
Cc: Gonzalo Camarillo; Christer Holmberg
Subject: [Sip] One chart //"UPDATE during Re-INVITE" discussion

      UAC                   UAS
       | session established |
       |<===================>|
       |                     |
       | F1  re-INVITE (SDP) |
       |-------------------->|
       | F2 1xx-rel (SDP)    |
       |<--------------------|
       | F3   UPDATE         |

---

From: gaoyang <[email-masked]>
Date: Thu, 12 Mar 2009 13:29:47 +0000

I am Gao. And comments inline.

Date: Thu, 12 Mar 2009 12:48:57 +0100
From: [email-masked]
To: [email-masked]
CC: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Sipping] One chart //"UPDATE during Re-INVITE" discussion

Hi,

[Gao] I just mean that the UAC can only use the old dialog state by Gonzalo's draft. Do you think so?
And Re-INVITE using the old dialog state can not be processed by UAS. It is a serious problem.

[Gao] If the target fresh is in Re-INVITE(and there is no F3/F4), the new dialog state is rejected by UAS. And F8 MUST uses old dialog state. It is clear.

[Gao] When UAC send Re-INVITE and UAS moves to a new access network while Re-INVITE in pending state, UAS will send the target refresh UPDATE. It is a real situation.
 
Regards,
 
Christer

Hi, 

Gao 

收件人

抄送

主题

Regards, 
  
Christer 

     UAC                   UAS 
      | session established | 
      |<===================>| 
      |                     | 
      | F1  re-INVITE (SDP) | 
      |-------------------->| 
      | F2 1xx-rel (SDP)    | 
      |<--------------------| 
      | F3   UPDATE         | 

_________________________________________________________________
上Windows Live 中国首页，下载最新版 MSN！
http://im.live.cn/

---

From: gaoyang <[email-masked]>
Date: Thu, 12 Mar 2009 13:36:16 +0000

Hi,

I have same thought about it as yours. 

But in Ganzalo's draft, the new dialog state MUST be discarded by 4xx of Re-INVITE.

The main branching is about the relationship of Re-INVITE and UPDATE. I have seen your supporting of view 2. Abd we need more people to show their standpoint.

Gao

From: [email-masked]
To: [email-masked]; [email-masked]; [email-masked]
Date: Thu, 12 Mar 2009 04:57:06 -0700
Subject: Re: [Sipping] [Sip] One chart //"UPDATE during Re-INVITE" discussion

      UAC                   UAS 
       | session established | 
       |<===================>| 
       |                     | 
       | F1  re-INVITE (SDP) | 
       |-------------------->| 
       | F2 1xx-rel (SDP)    | 
       |<--------------------| 
       | F3   UPDATE         | 

I think is the one refreshed by F3. That's the merit of regarding UPDATE/200OK's atomicity.  
_________________________________________________________________
MSN 表情魔法书，改变你的对话时代！
http://im.live.cn/emoticons/