Subject: Re: [Sip] New version (-05) of the 199 draft - ready for WGLC?

From: Dean Willis <[email-masked]>
Date: Tue, 3 Mar 2009 01:59:15 -0600

We didn't get any real answers due to a bit of confusion between this  
and keepalive. So, let's ask the question again.

Is 199 ready for WGLC?

--
dean

On Feb 19, 2009, at 5:12 AM, Christer Holmberg wrote:

>
> Hi,
>
> I've submitted a new version of draft-ietf-sip-199. I have done  
> changes and updates based on feedback and discussions (please let me  
> know if you think I've forgotten something), and I've also added  
> text to the security chapter.
>
> I propose that we start the WGLC process for the draft.
>
> The draft can also be found at:
>
> http://users.piuha.net/cholmber/drafts/draft-ietf-sip-199-05.txt
>
> Regards,
>
> Christer
>
> _______________________________________________
> Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg" <[email-masked]>
Date: Tue, 3 Mar 2009 13:58:14 +0100

Please note that the latest version is -06.

Regards,

Christer 

> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]] 
> Sent: 3. maaliskuuta 2009 9:59
> To: SIP WG
> Cc: Keith Drage; Christer Holmberg
> Subject: Re: [Sip] New version (-05) of the 199 draft - ready 
> for WGLC?
> 
> 
> We didn't get any real answers due to a bit of confusion 
> between this and keepalive. So, let's ask the question again.
> 
> Is 199 ready for WGLC?
> 
> --
> dean
> 
> 
> > know if you think I've forgotten something), and I've also 
> added text 
> > to the security chapter.
> >
> > This list is for NEW development of the core SIP Protocol Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments on the application of sip
> 
>

---

From: Brett Tate <[email-masked]>
Date: Tue, 3 Mar 2009 06:10:56 -0800

Yes; I think draft-ietf-sip-199-06 is ready for WGLC.

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Dean
> Willis
> Sent: Tuesday, March 03, 2009 2:59 AM
> To: SIP WG
> Subject: Re: [Sip] New version (-05) of the 199 draft - ready for WGLC?
> 
>

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 03 Mar 2009 09:02:25 -0600

> and keepalive. So, let's ask the question again.

Yes; it is well written (I had looked at a much earlier version
and just re-read -06.)

One question for Christer:

- Does 199 carry a message/sipfrag MIME type that conveys the
  nature of the final non-2xx response?  This may have been
  discussed in the past, and if so, please let me know.  I
  do note that rfc3420 is specified in the draft as a normative
  reference, but it is not referred to anywhere in the body
  of the draft.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
Web:   http://ect.bell-labs.com/who/vkg/

---

From: "Christer Holmberg" <[email-masked]>
Date: Tue, 3 Mar 2009 18:07:49 +0100

Hi Vijay, 

>  reference, but it is not referred to anywhere in the body

We discussed it quite much, and the outcome was a compromise: we don't
say anything :)

So, if someone wants to carry message/sipfrag in the 199 it is allowed,
but the base 199 draft does not require it.

Regards,

Christer

---

From: "Doken, Serhad" <[email-masked]>
Date: Tue, 3 Mar 2009 09:19:20 -0800

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Vijay K. Gurbani
> Sent: Tuesday, March 03, 2009 7:02 AM
> To: Dean Willis
> Cc: SIP WG; Christer Holmberg

There was discussion around 199 carrying information about why the fork/dialog was terminated and sipfrag was mentioned to be used to convey that. However, later on Reason header within 199 is agreed to be used for that purpose. Hence, mention of 3420 might be obsolete by now.

Thanks,
Serhad