Subject: [Sip] FW: I-D Action:draft-kaplan-sip-asserter-identity-01.txt

From: Hadriel Kaplan <[email-masked]>
Date: Sun, 8 Mar 2009 15:52:23 -0400

Howdy,
An updated version of SIP Asserter Identity has been uploaded, though with virtually no changes other than to avoid expiration.
But since the topic of SIP Identity is coming up (again) at the upcoming meeting, and this draft is related, I thought I'd post this again.

There was not much feedback to the previous rev, so I'm guessing folks either don't like it, or don't care, or just haven't had the time to read it.

As always, comments are appreciated - including just saying "don't care".

-hadriel

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of [email-masked]
> Sent: Sunday, March 08, 2009 2:30 PM
> To: [email-masked]
> Subject: I-D Action:draft-kaplan-sip-asserter-identity-01.txt
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>         Title           : Private Extensions to the Session Initiation
> Protocol (SIP) for Asserter Identification within Trusted Networks
>         Author(s)       : H. Kaplan
>         Filename        : draft-kaplan-sip-asserter-identity-01.txt
>         Pages           : 17
>         Date            : 2009-03-08
>
> This document describes private extensions to the Session
> Initiation Protocol (SIP) that enable a network of trusted SIP
> servers to identify the asserter of private user identity defined
> in RFC 3325.  The use of these extensions is only applicable
> inside a set of administrative domains with previously agreed-upon
> policies for generation, transport and usage of such information.
> This document does NOT offer a general identity model suitable for
> use between different trust domains, or use in the Internet at
> large.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-kaplan-sip-asserter-identity-
> 01.txt
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 10 Mar 2009 09:28:35 +0000

Hadriel,

An interesting draft, perhaps useful in two ways: first in the way you
intend (as asserter ID in closed domains or federations of closed
domains), but secondly some aspects might be relevant for inclusion in
an eventual solution to the SIP-Identity problem, notably the means of
selecting particular body parts and SDP attributes to sign.

On that particular issue, I am not sure whether the asserter is in a
position to decide on a request-by-request basis which body parts and
SDP attributes to sign, since it cannot know what downstream entities
are likely to need to do to those fields, so we may need some guidance
(e.g., a default list of things to sign).

John

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Hadriel Kaplan
> Sent: 08 March 2009 19:52
> To: [email-masked]
> Subject: [Sip] FW: I-D 
> Action:draft-kaplan-sip-asserter-identity-01.txt
> 
> 
> Howdy,
> An updated version of SIP Asserter Identity has been 
> uploaded, though with virtually no changes other than to 
> avoid expiration.
> But since the topic of SIP Identity is coming up (again) at 
> the upcoming meeting, and this draft is related, I thought 
> I'd post this again.
> 
> There was not much feedback to the previous rev, so I'm 
> guessing folks either don't like it, or don't care, or just 
> haven't had the time to read it.
>

---

From: Hadriel Kaplan <[email-masked]>
Date: Fri, 13 Mar 2009 23:35:15 -0400

Hey John,
Thanks for reviewing the draft!  I was thinking that basically the asserter should decide what it wants to sign, but I think you're right that a default list would be good. 

-hadriel

> From: Elwell, John [mailto:[email-masked]]
> Sent: Tuesday, March 10, 2009 5:29 AM
>