Subject: [Sip] DEFINITION: Target, Address, Name, Retarget, Reroute

From: "Christer Holmberg" <[email-masked]>
Date: Thu, 19 Mar 2009 15:34:27 +0100

Hi,

Hans Erik sent this text already earlier, but I would like to re-send it as a separate thread. It is related to the definitions which I think we should agree on.

Regards,

Christer

Current target

The current target of an initial request for a dialog or standalone
request is the name or address to which the request is targeted, i.e.
either the initial target inserted in the Request-URI by the UAC that
originates the request, or when a retarget occurred, the target
provided in that retarget operation. Reroute and translation
operations never change the current target.

This defintion only makes sense when the following definitions are used:

Name:

A name is a moniker for an entity which refers to it in a way which reveals nothing about where it is in a network. In SIP, tel URI which doesn't represent the location of the entity is a name. 

Address:

An address is an identifier for an entity which describes it by its location on the network. In SIP, the SIP URI itself is a form of address because the host part of the URI, the only mandatory part of the URI besides the scheme itself, indicates the location of a SIP server that can be used to handle the request.

Route:

Finally, a route is a sequence of SIP entities (including the UA itself!) which are traversed in order to forward a request to an address or name.

Retarget (other term might be needed, as this is highly confusing):

A Request-URI rewrite operation that changes the target identity of the request.

Reroute (other term might be needed):

A Request-URI rewrite operation that does not change the current target of the request, but determines the route/next hop taken to reach the target-identity.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 19 Mar 2009 23:47:39 +0100

Your definition of name implies that if a name contains any information at all that could be addressing information, then it cannot be a name. If I receive a greeting card that says "Greetings to the occupants of no. 10", that to me is using "occupants of no. 10" as a name, even though it may also in other circumstances parts of it may form part of an address.
 
So I would suggest something more along the lines of:

"A name is a moniker for an entity which refers to it in a way which is not expected to reveal anything about where it is in a network. In SIP, tel URI which doesn't represent the location of the entity is a name."

Also tel URIs still contain a domain name, so does that no make them potentially addressing information at least in this respect, in the same way as you have described for the SIP URI in respect of addresses.

regards

Keith

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Christer Holmberg
	Sent: Thursday, March 19, 2009 2:34 PM
	To: [email-masked]
	Subject: [Sip] DEFINITION: Target, Address, Name, Retarget, Reroute

	Hi, 

	Regards, 

	Christer 

	Current target

	
	Name:

	Address:

	Route:

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 20 Mar 2009 09:46:54 -0400

> Also tel URIs still contain a domain name, so does that no make them potentially addressing information at least in this respect, in the same way as you have described for the SIP URI in respect of…

Keith, I agreed with you up to this point.
But tel URIs do not contain domain names.
A sip URI, with user=phone contains the essence of a tel uri in its user 
part, and also contains a domain name, but that is still a sip URI, not 
a tel URI.

(A minor exception to the above is a tel uri with a phone-context 
containing a domain name.)

	Thanks,
	Paul

> _______________________________________________
> Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
>