Subject: Re: [Sip] draft-ietf-sip-info-events-03: comments and questions

From: "DOLLY, MARTIN C, ATTLABS" <[email-masked]>
Date: Sat, 7 Mar 2009 18:39:42 -0500

SIP has a state machine??? You could fool me....

Where can I find it? Do not say 3261

Martin

----- Original Message -----
From: [email-masked] <[email-masked]>
To: Bob Penfield <[email-masked]>
Cc: SIP IETF <[email-masked]>; Brett Tate <[email-masked]>
Sent: Sat Mar 07 18:30:22 2009
Subject: Re: [Sip] draft-ietf-sip-info-events-03: comments and questions

Bob said:
I'm inclined to say that since the INFO is not suppose to change
> dialog state, a 489 response to an INFO should not destroy the INVITE
> dialog usage. With SUBSCRIBE/NOTIFY its a failure of the dialog
> establishing/target-refresh request which is essential to the dialog
> usage. But INFO is not essential to the INVITE dialog usage, so
> applying the last sentence above makes sense to me.

Doesn't a 489 in any in-dialog Non-Invite-Transaction destroy the  
dialog usage? It seems like we break the state machine if we make INFO  
a special case.

--
Dean

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Nils Ohlmeier" <[email-masked]>
Date: Mon, 9 Mar 2009 15:16:31 +0100 (CET)

> Where can I find it? Do not say 3261

Search in your favorite SIP stack. Some have it, others not... :-)
Some even have a state per transaction and dialog. But don't get fooled by
the marketing/sales department ;-)

SCNR
  Nils