Subject: [Sip] Question about Accept-Language

From: "Szilagyi, Mike" <[email-masked]>
Date: Wed, 6 May 2009 14:20:01 -0400

In RFC3261, the Accept-Language section defines the headers meaning with a language value present and its meaning when the header is not present.

20.3 Accept-Language

   The Accept-Language header field is used in requests to indicate the
   preferred languages for reason phrases, session descriptions, or
   status responses carried as message bodies in the response.  If no
   Accept-Language header field is present, the server SHOULD assume all
   languages are acceptable to the client.

   The Accept-Language header field follows the syntax defined in
   [H14.4].  The rules for ordering the languages based on the "q"
   parameter apply to SIP as well.

   Example:

      Accept-Language: da, en-gb;q=0.8, en;q=0.7

The grammar for Accept-Language shows the language value as optional:

      Accept-Language  =  "Accept-Language" HCOLON
                              [ language *(COMMA language) ]

What does it mean if the header is present but with an empty language value?

          Accept-Language:

Regards,
Mike

---

From: Dean Willis <[email-masked]>
Date: Thu, 7 May 2009 00:14:17 -0500

I believe it means you have no preferred language, thereby granting  
equal precedence to any language. In other words, the same as not  
putting the header field in at all.

My rule of thumb: a header field with no value has no value.

Honoring the Accept-Language by actually sending reason phrases, etc.  
in-language is not mandatory. As far as I know, most server packages  
ignore it.

And by the way, the SIP working group is now closed. I don't know how  
many folks are still monitoring this mailing list. All remaining work  
has transitioned eitehr to other working groups, or to that  
interminable no-mans land known as "AD sponsored".

--
Dean Willis, Former co-Chair.

On May 6, 2009, at 1:20 PM, Szilagyi, Mike wrote:

> In RFC3261, the Accept-Language section defines the headers meaning  
> with a language value present and its meaning when the header is not  
> present.
>
> 20.3 Accept-Language
>
> _______________________________________________
> Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 11 May 2009 15:49:32 +0200

Aside from the viewpoint that this specific query possibly belongs on the sip-implementors list.

Can I note that people should continue to monitor this list for any issues regarding SIP documents in transit within the IESG (i.e. post publication requested). 

You can only discard your participation when we get the IESG to finish chewing the last one - at the current rate of progress that is about 3 years time.

regards

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Dean Willis
> Sent: Thursday, May 07, 2009 6:14 AM
> To: Szilagyi, Mike
> Cc: [email-masked]
> Subject: Re: [Sip] Question about Accept-Language
> 
> 
> I believe it means you have no preferred language, thereby 
> granting equal precedence to any language. In other words, 
> the same as not putting the header field in at all.
> 
> in-language is not mandatory. As far as I know, most server 
> packages ignore it.
> 
> And by the way, the SIP working group is now closed. I don't 
> know how many folks are still monitoring this mailing list. 
> All remaining work has transitioned eitehr to other working 
> groups, or to that interminable no-mans land known as "AD sponsored".
> 
> --
> >    Accept-Language header field is present, the server 
> SHOULD assume 
> > all
> > What does it mean if the header is present but with an 
> empty language 
> > value?
> >
> >           Accept-Language:
> >
> > Regards,
> > Mike
> > This list is for NEW development of the core SIP Protocol Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments on the application of sip
> 
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip