Subject: [Sip] Multiple registration using single UA

From: E D <[email-masked]>
Date: Mon, 4 Apr 2011 01:10:11 -0500

If I wanted to register two distinct numbers through a single UA Device
say 34111111 and 34111112 through one/single UA Device.
Should I expect the "Call-ID" to be Unique or  Identical?
RFC3261 seem to imply that the only the "SIP Tag"  needs to be unique for
the SIP Server or Registrar to
understand that both Numbers are being registered from one device only.  How
could the SIP Server or
Registrar verify that these two numbers are in fact originating from the
same Device?
Thanks in advance

---

From: Brett Tate <[email-masked]>
Date: Mon, 4 Apr 2011 06:17:24 -0700

> If I wanted to register two distinct numbers through 
> a single UA Device say 34111111 and 34111112 through 
> one/single UA Device.  Should I expect the "Call-ID" 
> to be Unique or Identical?

Unique.  I assume that you are not attempting to use rfc6140 or rfc5626.

> How could the SIP Server or Registrar verify that these 
> two numbers are in fact originating from the same Device?

As far as I know, that is outside of the scope of rfc3261 unless you want to make assumptions/deductions concerning some header values (such as Contact or User-Agent).  RFC 6140 may be of interest.

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 06 Apr 2011 18:17:27 -0400

On 4/4/2011 2:10 AM, E D wrote:
> RFC3261 seem to imply that the only the "SIP Tag"  needs to be unique
> for the SIP Server or Registrar to
> understand that both Numbers are being registered from one device only.
> How could the SIP Server or

Why would a registrar want/need to determine this?

	Thanks,
	Paul

> Thanks in advance
>
>
>
> _______________________________________________
> Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
> This list is essentially closed and only used for finishing old business.
> Use [email-masked] for questions on how to develop a SIP implementation.
> Use [email-masked] for new developments on the application of sip.
> Use [email-masked] for issues related to maintenance of the core SIP specifications.