Subject: [Sip] draft-jennings-sip-dtls: shouldn't it define ; transport=dccp ?

From: Iñaki Baz Castillo <[email-masked]>
Date: Fri, 8 Jul 2011 18:53:04 +0200

Hi, draft-jennings-sip-dtls defines:

- SIP over DTLS over UDP   => Via transport: "DTLS-UDP"
- SIP over DTLS over DCCP => Via transport: "DTLS-DCCP"
- SIP over DCCP                 => Via transport: "DCCP"

The draft just defines new BNF grammar for Via transport field, but
says nothing about SIP URI ;transport param.
IMHO the draft MUST define a new value "dccp" for ;transport param.

Regards,

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 8 Jul 2011 21:10:19 +0200

Given that as far as I can see, the last version of this document expired in 2008, I think you must regard any contents as historical.

It was never picked up by the SIP WG.

Regards

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Iñaki Baz Castillo
> Sent: 08 July 2011 17:53
> To: [email-masked]
> Subject: [Sip] draft-jennings-sip-dtls: shouldn't it define ;
> transport=dccp ?
> 
> _______________________________________________
> Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
> This list is essentially closed and only used for finishing old business.
> Use [email-masked] for questions on how to develop a SIP
> implementation.
> Use [email-masked] for new developments on the application of sip.
> Use [email-masked] for issues related to maintenance of the core SIP
> specifications.

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Fri, 8 Jul 2011 21:52:29 +0200

> It was never picked up by the SIP WG.

Good point, I didn't realize of that. So, is there a draft or RFC
defining SIP over DTLS-UDP?

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 8 Jul 2011 22:32:31 +0200

The only SIP document was RFC 5763. That doesn't define it, and doesn't apparently need it.

Keith

> From: Iñaki Baz Castillo [mailto:[email-masked]]
> Sent: 08 July 2011 20:52
> To: DRAGE, Keith (Keith)
> Cc: [email-masked]
> Subject: Re: [Sip] draft-jennings-sip-dtls: shouldn't it define ;
> transport=dccp ?
> 
> > Given that as far as I can see, the last version of this document
> expired in 2008, I think you must regard any contents as historical.
> >