Subject: [Sipbrandy] hello world (was re: New Version Notification for draft-peterson-sipbrandy-rtpsec-00.txt)

From: "Peterson, Jon" <[email-masked]>
Date: Fri, 8 Jul 2016 22:51:46 +0000

I just posted a new version of the RTPSEC draft, now branded for the brand-new SIPBRANDY working group. For those just joining us, this specification is intended to define best practices for SIP user agents to keep media confidential, with special concern for the threat of pervasive monitoring. As such, this is mostly an umbrella draft collecting existing work and explaining how these pieces come together to provide the needed properties. You can find the draft here:

<https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt><https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt>https://www.ietf.org/id/draft-peterson-sipbrandy-rtpsec-00.txt

Notable changes from the previous (dispatch) version include the following:

- As we heard some interest in making sure this played well with conferencing, there's now a mandate for perc-double, though not much supporting text yet.

- There's now a mandate for ICE, and moreover for STUN consent freshness, as we heard some concern about voice hammering and related attacks.

- The draft now permits the use of self-signed keys to sign rfc4474bis within a "STIR profile for media confidentiality", which also requires that UAs implement the authentication and verification service roles of STIR. That entailed a number of related behaviors.

- There's some tentative text about the interaction between rfc4916 connected identity, ICE, and rfc4474bis, though this clearly requires some more thinking. For now I'm happy to just have some preliminary text there.

- Perhaps most notably, the draft mandates support for DTLS-SRTP, and makes support for other confidentiality mechanisms optional.

At this stage, I want to make sure we've captured the requirements space, and that we're not missing anything in terms of behavior we need to incorporate. But certainly we'd be happy to hear any other comments about the draft.

Jon Peterson
Neustar, Inc.

---

From: Gonzalo Camarillo <[email-masked]>
Date: Sat, 9 Jul 2016 10:11:30 +0300

Hi Jon,

thanks for revising the draft. As you know, we will have a session in
the upcoming IETF meeting in Berlin:

  18:30-19:30 	Thursday Afternoon session III

  https://datatracker.ietf.org/meeting/96/agenda.html

Would you or one of your co-authors be able to discuss this draft in
that session? While I expect presentations to focus on open issues, as
usual, this one could include more introductory material (motivation,
rational, goals, etc.) since we are just starting this WG and we want
everyone to be on the same page regarding what we are trying to do...

Thanks,

Gonzalo

On 09/07/2016 1:51 AM, Peterson, Jon wrote:
> 
> I just posted a new version of the RTPSEC draft, now branded for the
> brand-new SIPBRANDY working group. For those just joining us, this
> specification is intended to define best practices for SIP user agents
> to keep media confidential, with special concern for the threat of
> pervasive monitoring. As such, this is mostly an umbrella draft
> collecting existing work and explaining how these pieces come together
> to provide the needed properties. You can find the draft here:
> 
> - As we heard some interest in making sure this played well with
> conferencing, there's now a mandate for perc-double, though not much
> supporting text yet.
> 
> - There's now a mandate for ICE, and moreover for STUN consent
> freshness, as we heard some concern about voice hammering and related
> attacks.
> 
> - The draft now permits the use of self-signed keys to sign rfc4474bis
> within a "STIR profile for media confidentiality", which also requires
> that UAs implement the authentication and verification service roles of
> STIR. That entailed a number of related behaviors.
> 
> - There's some tentative text about the interaction between rfc4916
> connected identity, ICE, and rfc4474bis, though this clearly requires
> some more thinking. For now I'm happy to just have some preliminary text
> there.
> 
> - Perhaps most notably, the draft mandates support for DTLS-SRTP, and
> makes support for other confidentiality mechanisms optional.
> 
> At this stage, I want to make sure we've captured the requirements
> space, and that we're not missing anything in terms of behavior we need
> to incorporate. But certainly we'd be happy to hear any other comments
> about the draft.
> 
> Jon Peterson
> Neustar, Inc.

---

From: "Peterson, Jon" <[email-masked]>
Date: Sat, 9 Jul 2016 17:52:32 +0000

Yes, do plan on having a presentation from me in Berlin, please. And I will have a bit of tutorial material for those who missed the previous DISPATCH discussion. 

Thanks!

Jon Peterson
Neustar, Inc.

Sent from my iPad

> On Jul 9, 2016, at 12:11 AM, Gonzalo Camarillo <[email-masked]> wrote:
> 
> Hi Jon,
>

---

From: Gonzalo Camarillo <[email-masked]>
Date: Sun, 10 Jul 2016 11:13:34 +0300

Hi Jon,

thanks. I have put together the following draft agenda:

https://www.ietf.org/proceedings/96/agenda/agenda-96-sipbrandy

If somebody else have an agenda request, please let me know.

Cheers,

Gonzalo