Subject: Re: [sipcore] Draft new version: draft-ietf-sipcore-sip-token-authnz-14 (was: Benjamin Kaduk's Discuss on draft-ietf-sipcore-sip-token-authnz-13)

From: Paul Kyzivat <[email-masked]>
Date: Sat, 2 May 2020 09:32:49 -0400

Christer,

I scanned the diff for this and noted a few things:

* In section 2.1.1 the edit to the 3rd paragraph has some mis-edits:

In "the UAC uses it to to request", s/to to/to/

In "before the currently used access token expires token", s/expires 
token/expires/

* In section 2.1.2 some more mis-editing: s/makes have use of/makes use of/

* Section 2.1.2 also says "TLS can still be used for protecting traffic 
between SIP endpoints and the AS." This is only true if there is a 
direct TLS connection between the endpoint and the AS.  How can that be 
assured?

Isn't the general point that TLS can be used to secure the content if 
the connection is direct between the UAC and the UAS? (But I don't know 
how you can assure that other than by knowledge about the network 
architecture in which the UAC is operating.

I didn't notice any other issues.

	Thanks,
	Paul

On 4/30/20 8:08 AM, Christer Holmberg wrote:
> Hi,
> 
> Based on the IESG reviews, we have submitted a new version (-14) of draft-ietf-sipcore-sip-token-authnz.
> 
> We believe and hope that all issues raised in the IESG reviews have been addressed, but please take a look.
> 
> A big Thank You for all the comments and suggestions! :)
> 
> Regards,
> 
> Christer
> 
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
>

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 2 May 2020 13:46:48 +0000

Hi Paul,
    
>    * In section 2.1.2 some more mis-editing: s/makes have use of/makes use of/
  
Will fix everything above.

>    architecture in which the UAC is operating.
  
Note that the traffic between the SIP endpoints and the AS uses HTTPS (perhaps that could be clarified), which uses TLS. 
  
>    I didn't notice any other issues.
  
Thanks for all your comments and feedback!

Regards,

Christer