Subject: [Sipping] Re: draft-ietf-sip-call-flows-05

From: Prem Sumetpong <[email-masked]>
Date: Wed, 11 Jul 2001 11:19:00 -0400 (Eastern Daylight Time)

Hi

  I have questions on the registration services which the call flows didnt
address.

The call flows dont show the location service/server. I understand that the SIP
RFC doesnt specify what that interface and leaves it to implementation.

However, for interoperability when a proxy and registrar share the same store
for location information and if the proxy and registrar are from different
vendors.

to fetch location information or update location information.

Would it be of value if the call flows made assumptions or mentioned as a
typical example ??

        +-----+          +---------+
        |     |          |         |
        |Proxy|          |Registrar|
        +-----+          +---------+
          \             /
           \ ??        /
            \ +----+  / ??
             \|    | /
              |    |/
              +----+
              Location Server or Location Store

If the ?? is LDAP or ODBC/JDBC - waht is the schema/data dictionary

"   "  ?? is SIP - is the location server INVITEd when queried and is
information returned in the 200 OK ??

It could be an API  - Java/C defined
It could be HTTP servlet

Any thoughts ??

Thankyou
Prem

_______________________________________________
Sipping mailing list  http://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 30 Jul 2001 18:55:26 +0300

Hello,

> for location information and if the proxy and registrar are from different

This is something that the SIPPING WG do not need to standardize.
Architectures using SIP can define the protocol to be used between
proxies and location servers in that praticular architecture. Then, SIP
proxies and REGISTRARs from different vendors, developed for that
particular architecture, would inveroperate without problems.

> It could be an API  - Java/C defined

As you mention, that interface could use several protocols. You can
check the 3GPP architecture, for instance, and see how the HSS (location
server) communicates with the I-CSCFs and S-CSCFs.

Best regards,

Gonzalo

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]