Subject: [Sipping] IAM received state handling

From: "Frank W. Miller" <[email-masked]>
Date: Tue, 3 Jul 2001 15:59:03 -0400

Hi,

Greetings to the ISUP draft authors, I have a
question and decided post it here instead of
personal emails.

In the state machine associated with SS7 to SIP
call setup, Figure 7.2, I was wondering if when
an IAM is received an ACM message should be 
generated on the SS7 side in addition to an
INVITE on the SIP side?  This would be an 
additional action in Section 7.2.1.

In Section 7.2.3 you mention that an ACM may have
been generated:

"If no ACM has been sent yet..."

but there is no mention of sending one in 7.2.1?
Did I (probably) overlook something?

Also, there is a reference that is placemarked
with a [x] when referring to a dip for LNP.  First,
is this supposed to be a reference to a Bellcore
document?  Second, if the dip has not been performed,
what are your thoughts on doing it here, prior to
constructing the destination URI?

FM

--
Frank W. Miller, Ph.D.
Chief Technical Officer
sentitO Networks, Inc.
www.sentito.com 

_______________________________________________
Sipping mailing list  http://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 03 Jul 2001 23:26:03 +0300

Hello,

> INVITE on the SIP side?

ACM indicates that the end user has been contacted, and this is not the
case. Therefore, ACM cannot be sent just because an IAM has been
received. Doing this would be like if any switch in the path of a PSTN
call decided that it would like to generate an ACM.

The only ACM that could be generated by the gateway would be an early
ACM (ACM with no indication). But this is only used to reset timers.

Regards,

Gonzalo

 This would be an

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]

---

From: "Frank W. Miller" <[email-masked]>
Date: Tue, 3 Jul 2001 16:52:27 -0400

Thanks for the reply.  If I may be so bold,
then I might recommend a little rewording here
since its a little confusing.  This quote I
talked about in section 7.2.3 should be
removed since theres no way for an ACM to 
be generated prior to this transition.

FM

--
Frank W. Miller, Ph.D.
Chief Technical Officer
sentitO Networks, Inc.
www.sentito.com 

-----Original Message-----
From: Gonzalo Camarillo [mailto:[email-masked]]
Sent: Tuesday, July 03, 2001 4:26 PM
To: Frank W. Miller
Cc: [email-masked]
Subject: Re: [Sipping] IAM received state handling

Hello,

Regards,

Gonzalo

 This would be an

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 4 Jul 2001 01:25:19 -0500

Gonzalo,

You statement is not complete.  ACM may also be returned by a
switch at an "interworking" point (i.e., ISUP to MF interworking).
It might not be returned only to reset timers.  If an ISUP/SIP
gateway also supports an MF interworking....

Well, also if a switch wants to return special messages or
tones which are not provided for on the originating exchange,
it may also return ACM with, say, IB information available
for cutthrough and play the announcement or tone without
returning answer.

Now the first might not be terribly applicable to the state
machine, but the second may.

--Brian

Gonzalo Camarillo wrote:                       (Tue, 03 Jul 2001 23:26:03)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 04 Jul 2001 20:14:37 +0300

Hello,

The ISUP-SIP mapping draft deals only with interworking between ISUP and
SIP. Therefore, we do not include scenarios where the switch has to
provide a special service (like playing an announcement or a tone on its
own). The same way, it is not explained in the draft that if a media
gateway controller wants to play an announcement to the SIP side has to
establish an early media channel with the originating SIP phone, for
instance.

This kind of services fall outside the scope of the draft. Nevertheless,
you are right in your statements. Thanks for the feedback,

Regards,

Gonzalo

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 5 Jul 2001 01:54:06 -0500

Gonzalo,

What about when an MGC wishes to play a special tone or
announcement to the ISUP side?

--Brian

Gonzalo Camarillo wrote:                       (Wed, 04 Jul 2001 20:14:37)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 05 Jul 2001 20:56:51 +0300

Hello,

What I am saying is that this is a particular service that you want to
provide. Therefore, we do not cover it in the ISUP-SIP mapping draft.
The ISUP-SIP mapping draft assumes that the gateway is just a gateway
(that is, a protocol translator). If you want to provide any service
(like playing a special tone or a special announcement) you are better
off implementing that service in another node.

Anyway, it is possible to implement a lot of stuff in a gateway. The
only thing is that it should not be part of the mapping draft.

Regards,

Gonzalo