Subject: [Sipping] Call transfer feature support?

From: "Frank W. Miller" <[email-masked]>
Date: Mon, 2 Jul 2001 18:40:38 -0400

Heres a wacky one...

Suppose we have a phone on the PSTN called P
and a phone on the IP network called S.  There
is a call in progress between P and S.  How
would we go about doing a call transfer to a
new phone called N?  There can be four cases:

1) S wants to transfer to N on the IP network.

S parks P.  S initiates a three-way call where
the mixing is done at S.  S releases its leg
of the call.  Trouble here is this consumes
resources at S and those resources may (depending
on how the switch is implemented) prevent other
calls to S until N and P are finished.  What
would be better is for S to tell P or N to
initiate a three way call where the mixing is
done at P and then drop its leg.

2) S wants to transfer to N on the PSTN.

Same as 1 except the signaling is probably
different.

3) P wants to transfer to N on the IP network.
4) P wants to transfer to N on the PSTN.

Don't think these are supported in the current
residential PSTN service offerings.  I think
you only get this with a PBX, but I'd luv to be
corrected.

Anyone with thoughts?

FM

--
Frank W. Miller, Ph.D.
Chief Technical Officer
sentitO Networks, Inc.
www.sentito.com 

_______________________________________________
Sipping mailing list  http://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Bert Culpepper <[email-masked]>
Date: Wed, 4 Jul 2001 20:05:04 -0400

Call transfer using the REFER method is described in 
http://www.ietf.org/internet-drafts/draft-ietf-sip-cc-transfer-04.txt

more comments below...

> done at P and then drop its leg.

S can "get out" of the call completely using REFER.  There will be no 
mixing.

> Same as 1 except the signaling is probably

Can be done the same as 1 provided P's PSTN gateway supports REFER.

> 3) P wants to transfer to N on the IP network.

Dependent on P's gateway, for both interactions with P and the SIP 
network.

> 4) P wants to transfer to N on the PSTN.

Again, dependent on P's gateway, one possibility is for it to provide 
some PBX-like functionality (as you say below).

regards,
Bert