Subject: RE: [Sipping] 3G entities: Proxy or B2BUA?

From: "Roy, Radhika R, ALCTA" <[email-masked]>
Date: Tue, 30 Oct 2001 11:43:54 -0500

>
> a) reword/clarify the definition of a B2BUA to explicitly
> allow one to act transparently.  (I believe the intent was
> to allow transparent behavior).
>

Since a discussion of a B2BUA was added, it should be "fixed" if it
limits otherwise protocol compliant application.

[RRR] Yes, I agree with you. It is very critical to "fix" for providing the
global interoperability and, there MUST be well defined mechanisms in
standards to define it appropriately leaving no room for ambiguity.
Moreover, a SIP proxy is a very important entity as well as building block
for providing SIP services in the network.

> b) add special language in the proxy behavior section to
> this effect: "A call-stateful proxy which uses Record-Route
> for a call-leg, MAY become a B2BUA for that call-leg."
>

This is one of those aspects that one must "realize" when combining a SIP
proxy with a SIP UA.  Does this need to be added to the specification?
I'll leave that up to the authors/community.

Regards,
Bert

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Neil Deason" <[email-masked]>
Date: Wed, 31 Oct 2001 10:29:53 -0000

> for providing SIP services in the network.

Can someone please suggest the definition they have in mind
for 'transparent' b2bUA. I still find the concept questionable
as a b2bUA breaks end to end connectivity and has the
potential to pervert a future service due to unforeseen side
effects of modifying SIP messages.

> I'll leave that up to the authors/community.

I do not think it needs adding to the spec. It is
an implementation decision if you want a proxy to spoof
being a UA within a dialog not protocol operation.

Cheers,
Neil.
--
Ubiquity Software Corporation, UK        http://www.ubiquity.net