Subject: RE: AW: [Sipping] 3GPP network hiding and session release req'ts

From: "Sean Olson (EUS)" <[email-masked]>
Date: Tue, 23 Oct 2001 08:28:59 -0500

>The only issue I see with this is that making such
>things mandatory in the 3GPP environment would seem
>to require that 3GPP endpoints be always endpoints
>and not proxies.  That is, it sounds like you could
>not have a wireless 3GPP last-mile-replacement to
>act as a proxy for a group of non-3GPP SIP phones
>without also mandating the same requirements.  (i.e.
>no 3GPP enabled computers/PDAs functioning as SIP
>proxies for fax machines, handsets, etc. on a local
>LAN, bluetooth network, etc.  No SIP<->3GPP<->SIP.)

This is not correct. The terminal could very well proxy
the REFER in the same manner that it proxies the INVITE,
BYE, etc.

>
>If no 3GPP endpoint is going to be allowed to 
>function as such a gateway proxy, then it is a
>moot issue.
>
>-- 
>Kim Liu  [email-masked]    :  Everyone is a darn fool for at 
>Senior Software Engineer    :  least five minutes a day;
>Lucent Technologies         :  wisdom consists of not 
>Clearwater, FL, 33761       :  exceeding the limit

BR,
Sean Olson
Ericsson Inc.

---

From: Kim Liu <[email-masked]>
Date: Tue, 23 Oct 2001 09:47:01 -0400

Correct.  However, if you mandate that all 3GPP 
devices support REFER, but in the below situation
the 3GPP terminal proxies the REFER to a SIP endpoint
which DOES NOT support REFER, what happens?

The point I am trying to make is that if you 
mandate that 3GPP terminals MUST support various
extensions, then in the 3GPP proxy situation, all
the SIP devices connected to it MUST also support
the same extensions -- they cannot be SIP devices
that only implement RFC2543 if you expect them
to work gracefully.  

So a 3GPP terminal that was functioning as a proxy
could not be connected to a 'generic' SIP device
that did not also support all mandated 3GPP 
extensions, correct?  Otherwise, what is the
behavior when the REFER reaches an endpoint 
proxied through the 3GPP terminal that does not
support REFER?

Kim

> "Sean Olson (EUS)" wrote:
> 

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP