Subject: RE: [Sipping] Setting headers/body on transfer.

From: "Sriram Parameswar" <[email-masked]>
Date: Wed, 17 Oct 2001 18:51:55 -0500

Dave:
 
The reference is the SIP Refer draft at:
http://search.ietf.org/internet-drafts/draft-ietf-sip-refer-01.txt
<http://search.ietf.org/internet-drafts/draft-ietf-sip-refer-01.txt> .
Actuall I did mean the Referred-By header which is outlined in the draft - I
have pasted a short section below. However please note that the Refer-To is
not allowed in any message other than the REFER. Thus, only the Referred-By
may be passed in the INVITE between B & C (in your earlier example).
 
<<quote draft>>
3.2 The Referred-By Header

   Referred-By is a request-header as defined by [1].  It can appear in
   any request.  It conveys the identity of the original REFERrer to the
   referred-to party.

        Referred-By  =  ("Referred-By" | "b") ":" referrer-url
                       *( ";" generic-param )

        referrer-url = ( name-addr | addr-spec )
<<end quote>>
 
Thus you may put your information in the Referred-By header by extending it
and this **may** be copied into the INVITE from B to C. Note the draft does
not require it to be done, however logically that is the only way to ship
something from a REFER to an INVITE. 
 
Happy reading!

Sriram

__________________________________________ 
Sriram Parameswar              Phone: 972-685-8540 
Interactive Multimedia Server (IMS) Fax: 972-685-3563 
Nortel Networks, Richardson USA  Email: [email-masked] 

-----Original Message-----
From: Calwell, David [mailto:[email-masked]]
Sent: Wednesday, October 17, 2001 6:16 PM
To: Parameswar, Sriram [NGB:B658:EXCH]; [email-masked]'
Subject: RE: [Sipping] Setting headers/body on transfer.

Sriram,
 
Thanks for the reply, to clarify the data being passed is basically text,
something similar to what can be done in the Refer-To header.
 
Eg. Refer-To: sip:user@domain?x=1&y=2&z=3
 
(I'm still unsure as to the use of this syntax? References ?)
 
Which I assume is only passed to the party being referred.
 
I'm guessing by your reference to the Referred-By header you mean the
";generic-param" section.
 
If so 
 
1: Is this automatically passed complete to the referred-to party.
 
2: What a the limitations of this field (size, type etc)
 
Any help or references would be great
 
thanks
 
Dave Calwell
Telstra Research Laboratories
Melbourne, Victoria, Australia

P.S Sorry if this is in the wrong list, i thought sip-implementors was
superceded buy sipping.

---

From: "Naoto MAKINAE" <[email-masked]>
Date: Thu, 18 Oct 2001 09:50:58 +0900

Dear Sriram and David,

Sriram wrote:
> Thus you may put your information in the Referred-By header by
> extending it and this **may** be copied into the INVITE from B to C.
> Note the draft does not require it to be >done, however logically that
> is the only way to ship something from a REFER to an INVITE. 

The REFER draft seems to guarantee to pass the Referred-By header
to the INVITE from B to C. Please see the following excerpt from
section 3.6.1.

  If the URL is a SIP URL, the Referred-By header in the
  REFER request should be copied into the request sent to
  the referred-to resource.

The Referred-By header is designed to convey the identity
of the referrer (A) to the referred party (C). So the use of the
Referred-By header is up to the the nature of the data Divid
wants to pass from B to C.

Regards,
naoto
--
Naoto MAKINAE
Nippon Telegraph & Telephone Co.
Email:[email-masked]

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP