Subject: [Sipping] Setting headers/body on transfer.

From: "Calwell, David" <[email-masked]>
Date: Wed, 17 Oct 2001 11:39:21 +1000

Hello,

I am wondering if anyone can suggest a mechanism or point me to a reference
for the following scenario.

A call exists between A and B.

A transfers B to endpoint C.

I would like to know if there is a way for the transfer (eg. REFER) to set
some header fields or add to the message body in the INVITE from B to C.

The idea here is to pass some data between A and C without using some other
SIP method such as MESSAGE etc, keeping the data transmission "Inband" so to
speak.

Any help will be appreciated.

Dave Calwell

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Sriram Parameswar" <[email-masked]>
Date: Wed, 17 Oct 2001 09:39:32 -0500

Dave:

It would be good if you could clarify what kind of data you want
to pass between B and C.

To answer your question as it is stated - yes, the REFER (A->B) carries
the Referred-By header which may be copied into the INVITE from
B to C. 

Hope this helps,

Sriram

__________________________________________
Sriram Parameswar              Phone: 972-685-8540
Interactive Multimedia Server (IMS) Fax: 972-685-3563
Nortel Networks, Richardson USA  Email: [email-masked]

-----Original Message-----
From: Calwell, David [mailto:[email-masked]]
Sent: Tuesday, October 16, 2001 8:39 PM
To: [email-masked]
Subject: [Sipping] Setting headers/body on transfer.

Hello,

Dave Calwell

---

From: "Calwell, David" <[email-masked]>
Date: Thu, 18 Oct 2001 09:15:48 +1000

Sriram,
 
Thanks for the reply, to clarify the data being passed is basically text,
something similar to what can be done in the Refer-To header.
 
Eg. Refer-To: sip:user@domain?x=1&y=2&z=3
 
(I'm still unsure as to the use of this syntax? References ?)
 
Which I assume is only passed to the party being referred.
 
I'm guessing by your reference to the Referred-By header you mean the
";generic-param" section.
 
If so 
 
1: Is this automatically passed complete to the referred-to party.
 
2: What a the limitations of this field (size, type etc)
 
Any help or references would be great
 
thanks
 
Dave Calwell
Telstra Research Laboratories
Melbourne, Victoria, Australia

P.S Sorry if this is in the wrong list, i thought sip-implementors was
superceded buy sipping.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sun, 21 Oct 2001 18:05:38 -0400

The Refer-To header specifies a URL that the referred party uses to
construct a request to the target of the referral. Like all other SIP URLs,
this URL can contain header parameters and even a body. So, if A and B are
in a call already, and A transfers B to C, it can send a refer like this:

REFER sip:[email-masked] SIP/2.0
Refer-To: sip:[email-masked]?NewHeader=hello&body=thisbody

Which would cause B to send a request to C that looks like, in part:

INVITE sip:[email-masked] SIP/2.0
From: sip:[email-masked]
To: sip:[email-masked]
NewHeader: hello

thisbody

Of course, B may or may not honor such things.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

> From: Naoto MAKINAE [mailto:[email-masked]]
> Sent: Wednesday, October 17, 2001 8:51 PM
> To: Sriram Parameswar; 'Calwell, David'; [email-masked]
> Subject: RE: [Sipping] Setting headers/body on transfer.
> 
> 
> Dear Sriram and David,
> 
> Sriram wrote:
> > Thus you may put your information in the Referred-By header by
> > extending it and this **may** be copied into the INVITE from B to C.
> > Note the draft does not require it to be >done, however 
> logically that
> > is the only way to ship something from a REFER to an INVITE. 
> 
> The REFER draft seems to guarantee to pass the Referred-By header
> to the INVITE from B to C. Please see the following excerpt from
> section 3.6.1.
> 
>   If the URL is a SIP URL, the Referred-By header in the
>   REFER request should be copied into the request sent to
>   the referred-to resource.
> 
> The Referred-By header is designed to convey the identity
> of the referrer (A) to the referred party (C). So the use of the
> Referred-By header is up to the the nature of the data Divid
> wants to pass from B to C.
> 
> Regards,
> naoto
> --
> Naoto MAKINAE
> Nippon Telegraph & Telephone Co.
> Email:[email-masked]
>