Subject: RE: [Sipping] ISUP and SIP mapping - 06

From: "Peterson, Jon" <[email-masked]>
Date: Mon, 2 Sep 2002 15:38:18 -0500

Some responses below.
 
Jon Peterson
NeuStar, Inc.

-----Original Message-----
From: Subhodeep Sarkar [mailto:[email-masked]]
Sent: Thursday, August 29, 2002 10:59 PM
To: [email-masked]
Subject: [Sipping] ISUP and SIP mapping - 06

Hi, 

I have couple of queries regarding the mapping. The first one I suppose had
been 
discussed previously, but I thought of asking once again to clarify the
same. 

1. In section 7.2.1, the following statement is bit confusing to me . 

" Before sending an IAM the gateway SHOULD connect the backward media 
path (unless provider policy dictates that doing so is unsafe; see Section
15)." 

The message sequences in the draft depicts that the backward media path is 
opened by the PSTN node, immediately after the reception of the IAM.  Is
there 
any specific reason for that ? Doesn't it make more sense to open a backward

media path after receiving of the ACM - which at least concludes that enough

info is received to proceed with the call. Otherwise, there is a possibility
that the 
media path may carry undesired info (or even a dead air). 
[Peterson, Jon] Yeah, this is a chunk of holdover text from the 04->05
changes. There have been substantial discussions of early media on the
mailing list in the past couple of weeks that resulted in important
revisions to much of the text, but this little tidbit here went unnnoticed -
so, good catch. I'll make sure this is corrected before the draft is
advances. The rest of the text in this section is fine; I'll probably just
remove the sentence above.

2. Mapping of INVITE and IAM : The tel URI mapping can support more than
simple CDN 
mapping i.e. fax, modem, etc. Why is the same has not been explored in the
draft or 
we can expect some other drafts detailing on the same ? i.e. for example CGS
, CDS can 
be mapped to isdn-subaddress field (isub) to felicitate supplementary
services like DDI, etc. 
Also the USI information can be mapped to different tel URI's like fax and
modem URI to 
pass on more information about the call other than mapping the same to/from
SDP info. 
[Peterson, Jon] This draft is scoped, as the introduction suggests, to
minimal interoperability, which largely means mapping routing information
between the protocols. That much said, we recognize that there are other
aspects of interworking that might warrant exploration, but as far as I
know, no one is currently planning to undertake the mapping of the features
you describe above.

Cheers, 
Subhodeep 

Subhodeep Sarkar 
Wipro Technologies 
*:[email-masked] 
*:+91-(0)80-8411990 x1289

---

From: "Subhodeep Sarkar" <[email-masked]>
Date: Wed, 4 Sep 2002 17:52:27 +0530

See comment inline
 
Cheers,
Subhodeep

	-----Original Message-----
	From: Peterson, Jon [mailto:[email-masked]] 
	Sent: Tuesday, September 03, 2002 2:08 AM
	To: Subhodeep Sarkar; [email-masked]
	Subject: RE: [Sipping] ISUP and SIP mapping - 06

	Some responses below.
	 
	Jon Peterson
	NeuStar, Inc.

		-----Original Message-----
		From: Subhodeep Sarkar
[mailto:[email-masked]]
		Sent: Thursday, August 29, 2002 10:59 PM
		To: [email-masked]
		Subject: [Sipping] ISUP and SIP mapping - 06

		Hi, 

		I have couple of queries regarding the mapping. The
first one I suppose had been 
		discussed previously, but I thought of asking once again
to clarify the same. 

		1. In section 7.2.1, the following statement is bit
confusing to me . 

		" Before sending an IAM the gateway SHOULD connect the
backward media 
		path (unless provider policy dictates that doing so is
unsafe; see Section 15)." 

		The message sequences in the draft depicts that the
backward media path is 
		opened by the PSTN node, immediately after the reception
of the IAM.  Is there 
		any specific reason for that ? Doesn't it make more
sense to open a backward 
		media path after receiving of the ACM - which at least
concludes that enough 
		info is received to proceed with the call. Otherwise,
there is a possibility that the 
		media path may carry undesired info (or even a dead
air). 
		[Peterson, Jon] Yeah, this is a chunk of holdover text
from the 04->05 changes. There have been substantial discussions of
early media on the mailing list in the past couple of weeks that
resulted in important revisions to much of the text, but this little
tidbit here went unnnoticed - so, good catch. I'll make sure this is
corrected before the draft is advances. The rest of the text in this
section is fine; I'll probably just remove the sentence above.
		[Subhodeep Sarkar] But the issue of opening of backward
media before an ACM at the PSTN side still remains. Is it expected that
the backward media path will be opened by the PSTN before an ACM is sent
? 

		2. Mapping of INVITE and IAM : The tel URI mapping can
support more than simple CDN 
		mapping i.e. fax, modem, etc. Why is the same has not
been explored in the draft or 
		we can expect some other drafts detailing on the same ?
i.e. for example CGS , CDS can 
		be mapped to isdn-subaddress field (isub) to felicitate
supplementary services like DDI, etc. 
		Also the USI information can be mapped to different tel
URI's like fax and modem URI to 
		pass on more information about the call other than
mapping the same to/from SDP info. 
		[Peterson, Jon] This draft is scoped, as the
introduction suggests, to minimal interoperability, which largely means
mapping routing information between the protocols. That much said, we
recognize that there are other aspects of interworking that might
warrant exploration, but as far as I know, no one is currently planning
to undertake the mapping of the features you describe above.
		[Subhodeep Sarkar] Agreed for the supplementary
services. But TMR/USI are important parameters in ISUP (mandatory in
certain national variants) and incorrect info can lead to a call
failure. Don't u think we should closely look into the TMR/USI mapping
to/from SIP header and SDP ?  

		Cheers, 
		Subhodeep 

		Subhodeep Sarkar 
		Wipro Technologies