Subject: RE: [Sipping] Re: [Sip] Originating Line Information

From: "Peterson, Jon" <[email-masked]>
Date: Thu, 12 Sep 2002 15:14:04 -0400

Just as an aside on this matter, I think that a telephone number
traditionally does identify a 'jack-in-the-wall' moreso than a person
answering, and the attributes identified by the Originating Line Information
in particular are attributes of the terminal and not any individual using
the terminal. Staging OLI in the tel URL prevents this telephony-specific
usage from contaminating the SIP URI, perhaps at the cost of some redundancy
with potential usages of caller-prefs.

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Thursday, September 12, 2002 12:02 PM
> To: Jonathan Rosenberg
> Cc: Peterson, Jon; 'Romel Khan'; [email-masked]
> Subject: Re: [Sipping] Re: [Sip] Originating Line Information
> 
> 
> In general, I think the basic rule should be "if the URI is different, 
> the resource is a different resource". This doesn't have to be true all 
> the time, but the URI is after all an *identifier*, not a description. 
> The URI should also be somewhat permanent and publishable.
> 
> At least for the prison or motel phone, these are hopefully temporary 
> conditions, unless the URI identifies the jack-in-the-wall rather than 
> the person answering.
> 
> Jonathan Rosenberg wrote:
> > Moving to sipping.
> > 
> > Another option is caller preferences. We could register 
> parameters for 
> > these various things, which would allow you to do things like:
> > 
> > INVITE
> > Contact: 
> <sip:1.2.3.4>;prison="TRUE";methods="INVITE,BYE,BLOWUPMYPHONE"
> > 
> > and so on.
> > 
> > This leads to a question we haven't really discussed in too 
> much depth 
> > yet - when does descriptive information belong as a tel/SIP URI 
> > parameter, and when does it belong as a caller prefs 
> contact parameter?
> > 
> > My general take on this is that things which describe 
> characteristics of 
> > a URI - such as the MIME type of the document being 
> referenced, or the 
> > color of the phone it desribes, are not part of the URI, 
> but belong in 
> > the realm of things like caller prefs which desribe URIs. 
> The URI, IMHO, 
> > should contain the minimal amount of stuff.
> > 
> > -Jonathan R.
> > 
> > Peterson, Jon wrote:
> > 
> >> This is more a SIPPING issue than a SIP issue... but yes, 
> I was hoping 
> >> that
> >> my proposal for a calling party's category tel URL parameter cover 
> >> this (it
> >> speaks to the fact that in North American networks, the 
> OLI is often the
> >> repository for information that appears in the CPC 
> elsewhere). The draft
> >> happens to be expired at the moment, though I will be 
> resubmitting it 
> >> fairly
> >> soon.
> >>
> >> Jon Peterson
> >> NeuStar, Inc.
> >>
> >>
> >>> -----Original Message-----
> >>> From: Romel Khan [mailto:[email-masked]]
> >>> Sent: Wednesday, September 11, 2002 2:47 PM
> >>> To: [email-masked]'
> >>> Subject: [Sip] Originating Line Information
> >>>
> >>>
> >>> Is there any existing internet draft that talks about how to pass
> >>> Originating Line Information (e.g. hotel, motel, prison) in SIP?
> >>> _______________________________________________
> >>> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> >>> This list is for NEW development of the core SIP Protocol
> >>> Use [email-masked] for questions on current sip
> >>> Use [email-masked] for new developments on the 
> application of sip
> >>>
> >>
> >> _______________________________________________
> >> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> >> This list is for NEW development of the core SIP Protocol
> >> Use [email-masked] for questions on current sip
> >> Use [email-masked] for new developments on the application of sip
> >>
> > 
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 12 Sep 2002 16:26:58 -0400

Peterson, Jon wrote:
 >  answering, and the attributes identified by the Originating Line
 > Information in particular are attributes of the terminal and not any
 > individual using the terminal.

That to me is not an argument that these parameters are part of the URI; 
it just means that they are fairly static. Anyway I would think number 
portability would argue that numbers really don't ever identify jacks in 
the wall any more.

URIs identify a resource, they don't describe it.

Staging OLI in the tel URL prevents
 > this telephony-specific usage from contaminating the SIP URI, perhaps
 > at the cost of some redundancy with potential usages of caller-prefs.

I don't see that its desirable to have two ways of doing the same thing.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com