Subject: [Sipping] SIP Gateway Controller

From: "Yadavalli, Satyamurthy" <[email-masked]>
Date: Tue, 3 Sep 2002 09:59:10 -0400

Is there any effort at IETF to use SIP in a call agent model (instead of the
peer-peer model that SIP is popular as) where the endpoints are not
'intelligent' and instead are controlled by a central controller - as in the
case of MGCP/Megaco - to which all events (e.g., telephony events) are
reported to and the callAgent/controller instructs the endpoint to setup
media sessions or play signals etc.,?
Is the SIP's "third party call control (3pcc)" effort anything towards this
direction? 
-Satya

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Yadavalli, Satyamurthy" <[email-masked]>
Date: Tue, 3 Sep 2002 14:08:54 -0400

One of the advantages of SIP providing such a capability is that
supplementary features (which may be implemented in several ways and so are
NOT standardized for SIP environments) need not be implemented in the User
Agents.

A "SIP feature server" may implement new supplementary services for the
endpoints without changes in the endpoint software which results in easier
maintanance. For example basic call setup etc., may still happen in a
peer-peer fashion but when it comes to supplementary services the "feature
server" may play a role.

This is similar to H323 Annex-L which specifies a mechanism to have megaco
embedded into H323. SIP also may still use Megaco mechanisms inherently with
a "sip wrapper" to accomplish this. But inorder to have a SIP entity
"support megaco" and also have the "SIP feature server" involved a
specification may need to be layed out.

-satya

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, September 03, 2002 11:12 AM
> To: Yadavalli, Satyamurthy
> Subject: Re: [Sipping] SIP Gateway Controller
> 
> 
> 
> 
> Why not use Megaco?
> 
> 
> 
> 
> 
> "Yadavalli, Satyamurthy" <[email-masked]>@ietf.org on 
> 09/03/2002
> 09:59:10 AM
> 
> Sent by:  [email-masked]
> 
> 
> To:   "[email-masked]'" <[email-masked]>
> cc:
> Subject:  [Sipping] SIP Gateway Controller
> 
> 
> Is there any effort at IETF to use SIP in a call agent model 
> (instead of
> the
> 'intelligent' and instead are controlled by a central 
> controller - as in
> the

---

From: [email-masked]
Date: Wed, 4 Sep 2002 09:10:10 -0400

I've heard this sort of idea before. When I first created the following
question I realised that it could be misinterpreted as being sarcastic. it
is not intended that way and is a real question about proposals of this
type. The basic architecture described below is very similar to the AIN.
Why, if one wanted this functionality, would one not just use the AIN.?

Thanks

Tom Gray

"Yadavalli, Satyamurthy" <[email-masked]>@ietf.org on 09/03/2002
02:08:54 PM

To:   "[email-masked]'" <[email-masked]>
cc:   "[email-masked]'" <[email-masked]>
Subject:  RE: [Sipping] SIP Gateway Controller

embedded into H323. SIP also may still use Megaco mechanisms inherently
with

-satya

---

From: "Yadavalli, Satyamurthy" <[email-masked]>
Date: Wed, 4 Sep 2002 14:04:42 -0400

True, one option that SIP providers may choose (for atleast some features)
is to use existing AIN infrastructure. 
But they may not want to be limited to(by) features offered by AIN.

- Satya

> Sent: Wednesday, September 04, 2002 9:10 AM
> Cc: [email-masked]'; [email-masked]'

---

From: Adam Roach <[email-masked]>
Date: Wed, 4 Sep 2002 13:35:53 -0500

I'm a bit confused.

SIP is inherently peer-to-peer. Trying to force a centralized
model of control on it can only lead to spectactular failure.

I'm really trying to understand your motivation here. It's almost
like you're saying, "I really like this word 'SIP' that I keep
hearing, but I don't like anything about how the protocol to which
it refers works. Is there any work ongoing to make it act like
ISDN instead?"

So, I'll restate Tom's earlier question a bit more directly:
You have already identified that Megaco operates in this model.
You have already identified that H.323 can operate in this model,
when used with the Annex-L extensions. There are protocols in
existence that fill the ecological niche you describe. Why are
you looking for yet another one?

/a

> From: Yadavalli, Satyamurthy [mailto:[email-masked]]
> Sent: Wednesday, September 04, 2002 13:05
> To: [email-masked]'; Yadavalli, Satyamurthy
> Cc: [email-masked]'
> > > Sipping mailing list  
https://www1.ietf.org/mailman/listinfo/sipping

---

From: [email-masked]
Date: Thu, 5 Sep 2002 12:47:46 EDT

In a message dated 9/4/02 2:52:52 PM Eastern Daylight Time, 
[email-masked] writes:

I'm a bit confused.

[MAP] No one is trying to "force" anything. We're only asking that it be 
"allowed".

If SIP does not fill the need ("niche"?) of the "real" service provider 
network by considering a centralized model of control (see 
draft-pierce-sipping-assured-service-arch-00), then it will never be used in 
that environment. The other protocols you mentioned will "win", and SIP will 
be relegated to the cases in which end-to-end (peer-to-peer) is the 
appropriate model, such as home hobbyist user. That is fine, but please stop 
claiming that the "peer-to-peer", no central control model will take over and 
replace the existing world-wide telephone system.

My 2 cents worth.

Mike Pierce
Artel

---

From: Adam Roach <[email-masked]>
Date: Thu, 5 Sep 2002 12:05:33 -0500

> [MAP] No one is trying to "force" anything. We're only asking 

After two such responses, I realize that there might be some
confusion. The intended meaning when I said "force" is along
the lines of "hack" or "jury-rig."

/a

---

From: "Arjun Roychowdhury" <[email-masked]>
Date: Thu, 5 Sep 2002 15:02:32 -0400

Could not resist jumping into this one :-)

ARC> I would think what is really allowed will be what will actually be 
deployed
and what will be deployed is what customers want [err translates to what 
makes money] :-)
In the meantime , we can spend as much time as we need arguing what should 
not 
be done :-)

[MAP] That is fine, but please stop 
claiming that the "peer-to-peer", no central control model will take over 
and 
replace the existing world-wide telephone system.

ARC> Amen ! Could be a combination of both.

--
Arjun Roychowdhury @ Hughes Software Systems
11717 Exploration Lane, Germantown MD 20876
(O): 301-212-7860        (M): 240-997-0066

---

From: [email-masked]
Date: Fri, 6 Sep 2002 07:29:05 -0400

Would it to be too bold to say that SIP is evolving away from the pure
peer-to-peer model and towards a distributed component model which contains
many attributes of a centralised framework.  The pure peer-to-peer model
has issues in regard to performance and management that makes such an
evolution essential.

Tom Gray

Adam Roach <[email-masked]> on 09/05/2002 01:05:33 PM

To:   "[email-masked]'" <[email-masked]>, Adam Roach
      <[email-masked]>, [email-masked], [email-masked]
cc:   [email-masked]
Subject:  RE: [Sipping] SIP Gateway Controller

/a