Subject: RE: [Sipping] I-D ACTION:draft-fujimoto-sipping-header-lang-00.tx t

From: Adam Roach <[email-masked]>
Date: Thu, 26 Sep 2002 14:28:13 -0500

> -----Original Message-----
> From: Shingo Fujimoto [mailto:[email-masked]]
> 
> Adam Roach wrote:
> > 
> > You appear to be confused about the nature of SIP.
> > 
> > SIP is encoded using UTF-8. Period. If you are using UTF-8 data,
> > there is no encoding necessary. You just drop the values directly
> > into the headers
> 
> RFC2231 doesn't allow "not specifying encoding" from its syntax.

I think we might be talking past each other.

The fundimental disconnect appears to be that you are assuming
that the solution to this problem should be MIME-like. I'm
arguing that since MIME was optimized for 7-bit pipes, it is
needlessly inefficient for SIP, and consequently inappropriate.

/a
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Shingo Fujimoto <[email-masked]>
Date: Fri, 27 Sep 2002 10:55:46 +0900

Adam Roach wrote:
> needlessly inefficient for SIP, and consequently inappropriate

As I wrote on my previous post, I tried to take away MIME's 
inefficiency. After that is just markup for language tags with SIP 
syntax-safe characters.

I think "Unicode Language Tagging" is also possible alternative, if 
all SIP implementation will support it as the mandatory 
specification. But if some of SIP implementation doesn't support it, 
that may cause problem, which described in Unicode Specification.

-- 
======================================
          SHINGO FUJIMOTO
     FUJITSU LABORATORIES LIMITED
E-mail: [email-masked]