Subject: RE: [Sipping] SIP Gateway Controller

From: "Yadavalli, Satyamurthy" <[email-masked]>
Date: Fri, 6 Sep 2002 12:43:18 -0400

I was under the impression (before this discussion) that it is evolving to
support a centralized framework as well so that a hybrid of peer-peer and
centralised framworks could offset the disadvantages of both....but now I
don't believe so.

-Satya

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, September 06, 2002 7:29 AM
> To: Adam Roach
> Cc: [email-masked]'; Adam Roach; [email-masked];
> [email-masked]; [email-masked]
> Subject: RE: [Sipping] SIP Gateway Controller
> 
> 
> 
> 
> Would it to be too bold to say that SIP is evolving away from the pure
> peer-to-peer model and towards a distributed component model 
> which contains
> many attributes of a centralised framework.  The pure 
> peer-to-peer model
> has issues in regard to performance and management that makes such an
> evolution essential.
> 
> Tom Gray
> 
> 
> 
> 
> Adam Roach <[email-masked]> on 09/05/2002 01:05:33 PM
> 
> To:   "[email-masked]'" <[email-masked]>, Adam Roach
>       <[email-masked]>, [email-masked], 
> [email-masked]
> cc:   [email-masked]
> Subject:  RE: [Sipping] SIP Gateway Controller
> 
> 
> > SIP is inherently peer-to-peer. Trying to force a centralized
> > model of control on it can only lead to spectactular failure.
> >
> > [MAP] No one is trying to "force" anything. We're only asking
> > that it be
> > "allowed".
> 
> After two such responses, I realize that there might be some
> confusion. The intended meaning when I said "force" is along
> the lines of "hack" or "jury-rig."
> 
> /a
> 
> 
> 
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Cullen Jennings" <[email-masked]>
Date: Sun, 15 Sep 2002 14:01:13 -0700

I think there is more than one vendor who has build SIP based "IP Centerex"
or "IP PBX" like systems with a very centralized control and implementation
of features. The center controller acts like a B2BUA and sets up the call
legs either side. Though this may not be the best way to use SIP it is a way
that works. In this case the centralized controller is one of the peers. I
imagine many of the SIP conference models will involve central servers as
one of the peers.

My point is, saying SIP is peer-peer is not the same as saying that the
peers must be phones and using SIP with a centralized controller does not
require the UA to support tunneling MGCP or H.450 over SIP.

Cullen

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Yadavalli, Satyamurthy
> Sent: Friday, September 06, 2002 9:43 AM
> To: [email-masked]'; Adam Roach
> Cc: [email-masked]'; Adam Roach; Yadavalli, Satyamurthy;
> [email-masked]