Subject: RE: [Sipping] Associating SIP sessions with PSTN calls

From: "Michael O'Doherty" <[email-masked]>
Date: Wed, 18 Sep 2002 19:16:13 +0100

Tom,

The first option in the draft below looks at ENUM.

The main problem is if the user wants to use their PSTN phone for voice
calls (even from SIP phones) and their SIP device for other media sessions
(like PSTN associated sessions).

How do we indicate with an ENUM response that voice calls should go to the
PSTN number and other media/mixed media calls to a SIP device (one
suggestion here was that if ENUM returns a tel URL as one of the options for
routing then that option MUST be used if the call is a voice call) ?

We couldn't see any nice clean way to do this with ENUM as it stands today -
option 4 in the draft (using a well know domain to do the CLI lookup) just
seemed to be less messy and more obvious.

Comments ?

Cheers,

Mick. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: 18 September 2002 18:35
To: O'Doherty, Michael [MDN05:MD01:EXCH]
Cc: [email-masked]'
Subject: Re: [Sipping] Associating SIP sessions with PSTN calls

Why can't the answer to this be ENUM?

"Michael O'Doherty" <[email-masked]>@ietf.org on 09/18/2002
11:43:55 AM

Sent by:  [email-masked]

To:   "[email-masked]'" <[email-masked]>
cc:
Subject:  [Sipping] Associating SIP sessions with PSTN calls

Hi,

The draft below describes a number of schemes to allow a SIP session be
associated with a PSTN call, plus the authors choice of the best approach
from the options briefly described.

We'd be interested to see if anyone has any comments, in particular if
there are any options we missed.

Additionally, looking at this problem domain threw up a more general
requirement also:

 - the ability to route a SIP request differently depending on the media
service that the request is requesting

Do people feel this is a valid requirement in a  SIP networks and if so has
anybody any thoughts on how it might be addressed ?

Cheers,

Mick.

The draft can be retrieved form the link below until it shows up in the
archives:

http://ties.itu.int/~watsonm/draft-odoherty-sipping-pstn-number-association-
01.txt

---

From: "David R. Oran" <[email-masked]>
Date: Wed, 18 Sep 2002 14:35:11 -0400

--On Wednesday, September 18, 2002 7:16 PM +0100 Michael O'Doherty 
<[email-masked]> wrote:

> calls (even from SIP phones) and their SIP device for other media
> sessions (like PSTN associated sessions).
>
> How do we indicate with an ENUM response that voice calls should go to
> the PSTN number and other media/mixed media calls to a SIP device (one
> suggestion here was that if ENUM returns a tel URL as one of the options
> for routing then that option MUST be used if the call is a voice call) ?
>
You don't. This is what caller prefs is for, right?

> We couldn't see any nice clean way to do this with ENUM as it stands
> today - option 4 in the draft (using a well know domain to do the CLI
> lookup) just seemed to be less messy and more obvious.
>
right. You don't want to encode policy or preferences in addresses or names.

> Do people feel this is a valid requirement in a  SIP networks and if so
> has  anybody any thoughts on how it might be addressed ?
>
> Cheers,
>
> Mick.
>
> http://ties.itu.int/~watsonm/draft-odoherty-sipping-pstn-number-associati
> on-01.txt
>
>
>

------------------------
David R. Oran
Cisco Systems
7 Ladyslipper Lane
Acton, MA 01720
Office: +1 978 264 2048
VoIP: +1 408 571 4576
Email: [email-masked]
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 18 Sep 2002 21:30:38 -0400

I agree with Dave. ENUM can simply translate to an address served by a proxy. Multiple contacts can be registered to that address. One can send the call to a PSTN gateway. Another can send the the call to your multimedia endpoint. Callerprefs can be used to cause the proper call routing. The recent drafts of callerprefs automatically insert default media preferences based on contained SDP, so simple cases could work automatically.

	Paul