Subject: Re: AW: [Sipping] Re: [Sip] Originating Line Information

From: Michael Hammer <[email-masked]>
Date: Fri, 13 Sep 2002 11:56:16 -0400

Roland,

I understand that today a single CPC is used.  Just wondered if it is worth 
exploring whether multiple values may allow richer functionality and 
decision-making to occur.

Generic Address is the same as Generic Number.  The OLI is the ANI 
information digits (II).  Below is a list of the types of values that may 
need coverage.

The CPC is in addition to the identification of the party as calling, 
called, or redirected, which already has expression as SIP headers.  I 
don't know that it is necessary to have separate sets 
(headers/parameters/fields) of values depending on whether it is original 
calling, calling, called, redirecting, or some other party that the call 
touched at some point.  One data set of labels of the CPC type may be 
sufficient.

Calling Party Category values in various standards:
      00 - unknown
      01 - operator, Language French
      02 - operator, Language English
      03 - operator, Language German
      04 - operator, Language Russian
      05 - operator, Language Spanish
      06 - admin1
      07 - admin2
      08 - admin3
      09 - ordinary calling subscriber
      10 - ordinary calling subscriber with customer meter
      11 - calling subscriber with priority
      12 - data call (voice band data)
      13 - test call
      14 - customer payphone
      15 - public   payphone
      16 - emergency service call
      17 - high priority emergency service call
      18 - national security and emergency preparedness (NS/EP call)
      19 - trunk offering
      20 - mobile customer
      21 - PBX subscriber
      22 - operator with forward facility
      23 - intercept operator
      24 - cross-border operator
      25 - long distance payphone
      26 - international payphone
      27 - international test equipment
      28 - check calling party number
      29 - national operator

BCI has a Called Party Category
      0 - no indication
      o - ordinary
      p - payphone

Originating Line Information
      00 - pots
      01 - multiparty line
      02 - ANI failure
      06 - Station Level Rating
      07 - special operator handling required
      08 - inter-LATA restricted
      10 - test call
      20 - AIOD-listed DN sent
      23 - coin or non-coin on calls using database access
      24 - 800 service call
      25 - 800 service call from a pay station
      27 - payphone using coin control signaling
      29 - prison/inmate service
      30 - intercept (blank)
      31 - intercept (trouble)
      32 - intercept (regular)
      34 - telco operator handled call
      36 - CPE
      52 - OUTWATS
      60 - TRS call from unrestricted line
      61 - wireless/cellular PCS (type 1)
      62 - wireless/cellular PCS (type 2)
      63 - wireless/cellular PCS (roaming)
      66 - TRS call from hotel
      67 - TRS call from restricted line
      68 - inter-LATA restricted hotel
      78 - inter-LATA restricted coin-less
      70 - private pay-stations
      93 - private virtual network

Also, Opt. BCI also includes an indication of MLPP user.  There may be 
other fields I overlooked.

Mike

At 07:04 AM 9/13/2002 +0200, Jesske, R wrote:
>Hi Mike,
>within ISUP the CPC is only used once. In some countries there are 
>national CPC that could be set additionally or instead of the CPC.
>
>I have a question regarding the OLI is it the same as an Generic number 
>(ACgPN)?
>
>For the  Redirecting Party there is a own Parameter within ISUP/BICC that 
>is called redirecting number but there are some parameters more that are 
>used for redirection like call diversion information, Redirecting 
>information....I think that's about 10 Parameters for international and/or 
>national use.
>
>But if you like to have the complete picture you should read the Q.761-764 
>and 1902.X and of course the service descriptions regarding Call diversion.
>
>Roland
>
>-----Ursprungliche Nachricht-----
>Von: Michael Hammer [mailto:[email-masked]]
>Gesendet: Donnerstag, 12. September 2002 14:59
>An: Peterson, Jon
>Cc: 'Henning Schulzrinne'; Jonathan Rosenberg; 'Romel Khan';
>[email-masked]
>Betreff: RE: [Sipping] Re: [Sip] Originating Line Information
>
>
>Jon,
>
>Some thoughts as you re-write the draft (I don't recall this one off-hand):
>
>Will you be able to normalize the value set across CPC and OLI?
>Will this be usable for more than just the calling party?
>     (can nature of a called or redirecting party be indicated?)
>Will it be possible to apply more than one value simultaneously?
>     (like prison and payphone and emergency)
>
>Mike
>
>
>
>At 03:14 PM 9/12/2002 -0400, Peterson, Jon wrote:
>
> >Just as an aside on this matter, I think that a telephone number
> >traditionally does identify a 'jack-in-the-wall' moreso than a person
> >answering, and the attributes identified by the Originating Line Information
> >in particular are attributes of the terminal and not any individual using
> >the terminal. Staging OLI in the tel URL prevents this telephony-specific
> >usage from contaminating the SIP URI, perhaps at the cost of some redundancy
> >with potential usages of caller-prefs.
> >
> >Jon Peterson
> >NeuStar, Inc.
> >
> > > -----Original Message-----
> > > From: Henning Schulzrinne [mailto:[email-masked]]
> > > Sent: Thursday, September 12, 2002 12:02 PM
> > > To: Jonathan Rosenberg
> > > Cc: Peterson, Jon; 'Romel Khan'; [email-masked]
> > > Subject: Re: [Sipping] Re: [Sip] Originating Line Information
> > >
> > >
> > > In general, I think the basic rule should be "if the URI is different,
> > > the resource is a different resource". This doesn't have to be true all
> > > the time, but the URI is after all an *identifier*, not a description.
> > > The URI should also be somewhat permanent and publishable.
> > >
> > > At least for the prison or motel phone, these are hopefully temporary
> > > conditions, unless the URI identifies the jack-in-the-wall rather than
> > > the person answering.
> > >
> > > Jonathan Rosenberg wrote:
> > > > Moving to sipping.
> > > >
> > > > Another option is caller preferences. We could register
> > > parameters for
> > > > these various things, which would allow you to do things like:
> > > >
> > > > INVITE
> > > > Contact:
> > > <sip:1.2.3.4>;prison="TRUE";methods="INVITE,BYE,BLOWUPMYPHONE"
> > > >
> > > > and so on.
> > > >
> > > > This leads to a question we haven't really discussed in too
> > > much depth
> > > > yet - when does descriptive information belong as a tel/SIP URI
> > > > parameter, and when does it belong as a caller prefs
> > > contact parameter?
> > > >
> > > > My general take on this is that things which describe
> > > characteristics of
> > > > a URI - such as the MIME type of the document being
> > > referenced, or the
> > > > color of the phone it desribes, are not part of the URI,
> > > but belong in
> > > > the realm of things like caller prefs which desribe URIs.
> > > The URI, IMHO,
> > > > should contain the minimal amount of stuff.
> > > >
> > > > -Jonathan R.
> > > >
> > > > Peterson, Jon wrote:
> > > >
> > > >> This is more a SIPPING issue than a SIP issue... but yes,
> > > I was hoping
> > > >> that
> > > >> my proposal for a calling party's category tel URL parameter cover
> > > >> this (it
> > > >> speaks to the fact that in North American networks, the
> > > OLI is often the
> > > >> repository for information that appears in the CPC
> > > elsewhere). The draft
> > > >> happens to be expired at the moment, though I will be
> > > resubmitting it
> > > >> fairly
> > > >> soon.
> > > >>
> > > >> Jon Peterson
> > > >> NeuStar, Inc.
> > > >>
> > > >>
> > > >>> -----Original Message-----
> > > >>> From: Romel Khan [mailto:[email-masked]]
> > > >>> Sent: Wednesday, September 11, 2002 2:47 PM
> > > >>> To: [email-masked]'
> > > >>> Subject: [Sip] Originating Line Information
> > > >>>
> > > >>>
> > > >>> Is there any existing internet draft that talks about how to pass
> > > >>> Originating Line Information (e.g. hotel, motel, prison) in SIP?
> > > >>> _______________________________________________
> > > >>> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > > >>> This list is for NEW development of the core SIP Protocol
> > > >>> Use [email-masked] for questions on current sip
> > > >>> Use [email-masked] for new developments on the
> > > application of sip
> > > >>>
> > > >>
> > > >> _______________________________________________
> > > >> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > > >> This list is for NEW development of the core SIP Protocol
> > > >> Use [email-masked] for questions on current sip
> > > >> Use [email-masked] for new developments on the application of sip
> > > >>
> > > >
> > >
> >_______________________________________________
> >Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> >This list is for NEW development of the application of SIP
> >Use [email-masked] for questions on current sip
> >Use [email-masked] for new developments of core SIP
>
>_______________________________________________
>Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
>This list is for NEW development of the application of SIP
>Use [email-masked] for questions on current sip
>Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 13 Sep 2002 13:18:59 -0400

This seems like another version of the *-Info header field, as it 
describes a particular request.

Michael Hammer wrote:
> Roland,
> 
> I understand that today a single CPC is used.  Just wondered if it is 
> worth exploring whether multiple values may allow richer functionality 
> and decision-making to occur.
> 
> information digits (II).  Below is a list of the types of values that 
> may need coverage.
> 
> (headers/parameters/fields) of values depending on whether it is 
> original calling, calling, called, redirecting, or some other party that 
> the call touched at some point.  One data set of labels of the CPC type 
> may be sufficient.
>