Subject: RE: [Sipping] Fwd: WGLC on draft-ietf-sipping-content-indirect-01.txt

From: "Eric Burger" <[email-masked]>
Date: Mon, 9 Sep 2002 13:54:35 -0400

I'd be very careful how this gets worded.  What I would not want to see is
an interpretation that says that you MUST fetch the indirected content,
because if it was in-line, you would be reading it.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Adam Roach
> Sent: Friday, August 30, 2002 5:04 PM
> To: 'Sean Olson'; Adam Roach; Rohan Mahy; [email-masked]
> Subject: RE: [Sipping] Fwd: WGLC on
> draft-ietf-sipping-content-indirect-01.txt
>
>
> Sean Olson wrote:
>
> > To address your comment directly, I would like to propose the
> > following additional requirement:
> >
> >    It MUST be possible for an application supporting content
> >    indirection to process messages containing indirect
> >    content identically to messages without content
> >    indirection aside from the transfer of that indirect
> >    content.
> >
> > The text is a bit awkward and I would appreciate any
> > alternative wording people can come up with.
>
> That's a much better statement of what I was trying to say.
> I'll try to work out some of the awkwardness. How about:
>
>    It MUST be possible for an application to process
>    messages containing indirect content identically
>    to messages that do not, aside from the actual
>    transfer of content.
>
> /a

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Sean Olson" <[email-masked]>
Date: Tue, 10 Sep 2002 13:54:40 -0700

There is a requirement hiding in there somewhere. I don't want to
disallow
alternative processing of content indirection (we can't really). But it
should be clear that content indirection is just another way to get the
content.
It is NOT an alternative way of interpreting or processing the content
(which
I'm positive people will try unless there is some normative text on
this)

I will put Eric's text in the intro. unless I can find a better way to
word
things.

/sean

-----Original Message-----
From: David R. Oran [mailto:[email-masked]] 
Sent: Tuesday, September 10, 2002 1:35 PM
To: [email-masked]; Sean Olson; Adam Roach; Rohan Mahy;
[email-masked]

Eric's proposed working seems to capture the essence of what we want
here.i 
don't see what the normative MUST language does for us here.

Dave.

--On Tuesday, September 10, 2002 4:06 PM -0400 Eric Burger 
<[email-masked]> wrote:

> What does "MUST be possible for an application to process messages" 
> mean? There is no requirement there: "MUST be possible" isn't a MUST 
> strength... I can always decide to do different processing, even 
> though I *could* do it the same way.
>
> While I think it is inappropriate to create a non-requirement with 
> MUST strength, I agree we should make some sort of statement, similar 
> to the
> following:
>
> The purpose of content indirection is purely to provide an alternative

> transport mechanism for SIP MIME body parts.  With the exception of 
> the transport mechanism, indirected body parts are equivalent, and 
> should have the same treatment, as in-line body parts.
>
>> From: Sean Olson [mailto:[email-masked]]
>> Sent: Monday, September 09, 2002 1:56 PM
>> To: [email-masked]; Adam Roach; Rohan Mahy; [email-masked]
>> My plan is to use Adam's wording below. Do you have alternative text 
>> you would prefer?
>>
>> Thanks,
>> Sean
>>
>> From: Eric Burger [mailto:[email-masked]]
>> Sent: Monday, September 09, 2002 10:55 AM
>> To: Adam Roach; Sean Olson; Rohan Mahy; [email-masked]
>> I'd be very careful how this gets worded.  What I would not want to 
>> see is an interpretation that says that you MUST fetch the indirected

>> content, because if it was in-line, you would be reading it.
>>
>> > From: [email-masked] [mailto:[email-masked]]On 
>> > Behalf Of Adam Roach
>> > > The text is a bit awkward and I would appreciate any alternative 
>> > > wording people can come up with.
>> >
>> > That's a much better statement of what I was trying to say. I'll 
>> > try to work out some of the awkwardness. How about:
>> >
> This list is for NEW development of the application of SIP Use 
> [email-masked] for questions on current sip Use 
> [email-masked] for new developments of core SIP

-----------------------------------------------------------
David R. Oran                   Phone/Fax: +1 978 264 2048
Cisco Systems                   VoIP: +1 408 571 4576
7 Ladyslipper Lane              Email: [email-masked]
Acton, MA 01720