Subject: RE: [Sipping] Re: Early media draft

From: "Hearty, John" <[email-masked]>
Date: Wed, 27 Nov 2002 09:44:39 -0700

The American Airlines thread was interesting back when it came up.  That thread was primarily concerned with forward media cut through before 200, where this thread seems to be more concerned with backwards media and if/when to cut it through.

For the forward case with PSTN interworking (or even if the AA IVR was a SIP endpoint), it would seem it could be the carrier's local policy to allow forward media cut through before a 200 OK.  If the carrier did not want forward media cut through, they could either express that desire in the offer/answer, or just not render forward early media at the PSTN gateway or SIP endpoint.  The latter might be bad as the caller would not know that what they send is not getting to the endpoint.

I'll remain on the sidelines for now regarding the backwards media cut through.  Many valid points have been raised.  I sympathize with those viewpoints that stress the importance of cutting through any tones/announcements a PSTN interworking point may be forwarding to the caller.

It might be worth considering clearly defining some signaling indication when the UAS asserts there IS inband indications in early media that SHOULD be rendered, vs. the UAS indicating there MAY be inband indications in early media.

John Hearty
Level3

-----Original Message-----
From: William Marshall [mailto:[email-masked]]
Sent: Wednesday, November 27, 2002 8:16 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Sipping] Re: Early media draft

Henry wrote:
> I good example I remember we were wrestling with is calling certain
> airline info system and getting voice prompts before the call with the
> regular IVR is established, such as American Airlines. Has there been a
> similar experience, and how was it solved?

I do worry that all this "local policy" in the caller will lead to
two types of UA's - those that can call American Airlines, and those
that can't.  Not a good situation.

Bill Marshall
[email-masked]

-----original message-----
Date: Wed, 27 Nov 2002 06:27:47 -0600
From: Henry Sinnreich <[email-masked]>
Subject: RE: [Sipping] Re: Early media draft
To: "'William Marshall'" <[email-masked]>,
        [email-masked]
Cc: [email-masked]

I good example I remember we were wrestling with is calling certain
airline info system and getting voice prompts before the call with the
regular IVR is established, such as American Airlines. Has there been a
similar experience, and how was it solved?

Thanks, Henry
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Bob Penfield" <[email-masked]>
Date: Wed, 27 Nov 2002 13:29:35 -0500

----- Original Message -----
From: "Hearty, John" <[email-masked]>

> The American Airlines thread was interesting back when it came up.
> That thread was primarily concerned with forward media cut through
> before 200, where this thread seems to be more concerned with backwards
> media and if/when to cut it through.

Although forward media cut-thru was an issue (so that the AA IVR could
received DTMFs pressed by the caller), this is really an example where
backwards media is essential for the call to work. The AA IVR primarily
provides information to the caller. This information is "played" to the
caller before the call is answered (actually, as far as I can tell, the call
is never "answered"). A caller using a UAC which did not play the early
media would never hear any of AA's information.

>
> For the forward case with PSTN interworking (or even if the AA IVR was
> a SIP endpoint), it would seem it could be the carrier's local policy
> to allow forward media cut through before a 200 OK.  If the carrier did
> not want forward media cut through, they could either express that
> desire in the offer/answer, or just not render forward early media at
> the PSTN gateway or SIP endpoint.  The latter might be bad as the
> caller would not know that what they send is not getting to the
> endpoint.
>
> I'll remain on the sidelines for now regarding the backwards media cut
> through.  Many valid points have been raised.  I sympathize with those
> viewpoints that stress the importance of cutting through any
> tones/announcements a PSTN interworking point may be forwarding
> to the caller.
>
> It might be worth considering clearly defining some signaling
> indication when the UAS asserts there IS inband indications in early
> media that SHOULD be rendered, vs. the UAS indicating there MAY be
> inband indications in early media.
>
> John Hearty
> Level3
>
>