Subject: RE: [Sipping] Comments on johnston-sipping-cc-conferencing-00.txt (the second duck in theline ;-)

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 1 Nov 2002 10:27:02 -0500

Hmmm, I hope we haven't confused folks too much.
The framework I-D should hit the I-D archive any moment,
but as announced it's:
http://www.jdrosen.net/papers/draft-rosenberg-sipping-conferencing-framework
-00.txt

I believe we have all agreed on the term focus, which -framework 
defines as:
    Focus: The focus is a SIP user agent that is addressed by a
    conference URI. The focus maintains a SIP signaling
    relationship with each participant in the conference. The
    focus is responsible for insuring, in some way, that each
    participant receives the media that make up the conference.
    The focus also implements conference policies. The focus is
    a logical role.

I don't see where cc-conferencing diverges from this definition,
other than expanding the functions by including the focus URI.
In the model we are (all) working toward, each participant
has a 1 on 1 SIP call with the focus.

The requirements document needs an update to reflect this
terminology and definitions.  Framework is closest to our
current consensus thinking as a design team, although as the
document points out, there is still disagreements on some
aspects.  cc-conference is a welcome start at fleshing out 
the sip call control aspects of what -framework describes.
There are still some requirements that are not covered,
but I think at the moment, the requirements document,
as it is the oldest work, is the most out of date.

As with all design team efforts:
	Unanimity of opinion is not in sight, nor do we expect it
	There is no special status given the work, and
		it's the sipping community as a whole
		that decides what we do

Brian

> -----Original Message-----
> From: Orit Levin [mailto:[email-masked]]
> Sent: Friday, November 01, 2002 9:44 AM
> To: 'Paul Kyzivat'; Arjun Roychowdhury
> Cc: [email-masked]; Orit Levin; [email-masked]
> Subject: RE: [Sipping] Comments on
> johnston-sipping-cc-conferencing-00.txt (the second duck in 
> theline ;-)
> 
> 
> Guys!
> If somebody is curious to put the ducks in the chronological 
> order, you will
> find out that the "requirements" comes first, the 
> "cc-conferencing" comes
> second, the "framework" hasn't been published yet. It would 
> be interesting
> to see how the submitted (on time) version of the "framework" 
> would look
> like.
> 
> To clarify the focus issue itself, both the "requirements" and the
> "cc-conferencing" have definitions referring to SIP itself - 
> i.e. the call
> control part ONLY of the whole conferencing application. The 
> "framework"
> (while derived and built upon the definitions found in the 
> Framework chapter
> of the "requirements" document) takes a broader perspective without
> (unfortunately) keeping the intention of the original 
> definitions in tact.
> 
> I feel terribly sorry that we were unable to resolve these 
> issues within the
> Conferencing team before "publishing" the "framework" 
> document on this list.
> 
> Orit.
> 
> 
> > -----Original Message-----
> > From: Paul Kyzivat [mailto:[email-masked]]
> > Sent: Friday, November 01, 2002 9:22 AM
> > To: Arjun Roychowdhury
> > Cc: [email-masked]; [email-masked]; [email-masked]
> > Subject: Re: [Sipping] Comments on 
> johnston-sipping-cc-conferencing-00.txt
> > (the second duck in theline ;-)
> > 
> > 
> > 
> > Arjun Roychowdhury wrote:
> > >
> > > ... May be useful to use the same terminology across both
> > > of the new drafts...
> > 
> > Yes, I also found this distracting. The most distracting is that the
> > definition of Focus in this doc is different than in Jonathan's.
> > 
> > 	Paul
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 01 Nov 2002 11:24:09 -0500

Comments below...

> has a 1 on 1 SIP call with the focus.

What is confusing is that cc-conference has both a Focus URI and a Conference URI. But the Focus URI doesn't reference the Focus as defined above - the Conference URI does. 

As best I can tell, there is nothing in the framework document that corresponds exactly to the Focus URI.  The closest would seem to be to consider the Focus URI as one way to invoke the conference policy control protocol of a conference server.

I think the concept of the Focus URI is good, but the name is bad. Perhaps it could be called something like Conference Factory URI, or Conference Server URI.

	Paul