Subject: RE: [Sipping] Tags in respones to CANCEL WAS: Re: Question about Section 3.8 ofdraft-ietf-sipping-basic-call-flows-01.txt(Eiji Tomimu ra)

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Tue, 5 Nov 2002 16:28:39 -0000

Hang on. You are discussing a set of example flows on the sipping list.

That discussion should not be used to rewrite SIP.

The example flows should merely show an example of what is legitimate in RFC 3261.

If you think RFC 3261 needs fixing, then it should be discussed on the SIP list, which an appropriate bug fix finally agreed and listed.

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked] 

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]]
> Sent: 05 November 2002 15:34
> To: Jonathan Rosenberg
> Cc: Bob Penfield; Jiri Kuthan; Jiri Kuthan; manoj mallik;
> [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Sipping] Tags in respones to CANCEL WAS: Re: Question
> about Section 3.8 ofdraft-ietf-sipping-basic-call-flows-01.txt(Eiji
> Tomimura)
> 
> 
> Hi,
> 
> Let's try to finish this discussion. Summarizing:
> 
> Should the 200 OK responses to CANCEL have a To tag?
> 
> Reasons for NO:
> 
> CANCEL is hop-by-hop, and therefore, 200 OK responses for CANCEL are
> also hop-by-hop. If we look at 100 Trying responses, which are
> hop-by-hop as well, we see that they do not have a tag.
> 
> Reasons for YES:
> 
> Final responses to any request have tags. Even non-2xx final responses
> for INVITE, which are hop-by-hop, have a tag.
> 
> Note that user agents and proxies will have to be prepared to receive
> 200 OK responses for CANCEL with or without tags anyway, to improve
> interoperability. So, this is not a big deal after all. Our 
> decision is
> only useful as long as it helps develop a coherent spec.
> 
> 
> I would suggest to go for YES, document it, and move on.
> 
> Comments?
> 
> Thanks,
> 
> Gonzalo
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 06 Nov 2002 08:09:02 +0200

Keith,

You are actually right. I have moved this thread to SIP now.

Thanks,

Gonzalo

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip