Subject: [Sipping] Diagnostics again -- really

From: Jiri Kuthan <[email-masked]>
Date: Sun, 03 Nov 2002 13:47:07 +0100

I'm wondering there has been no echo on draft-kuthan-sipping-diag-00.txt
on the mailing list. I do not think we can afford ignoring diagnostics --
whoever tried to deploy SIP will surely confirm that.

I'd really like to see WG's feedback on this piece of work, I will drop
it otherwise.

Thanks,

-Jiri

>Date: Thu, 24 Oct 2002 13:08:00 +0200
>To: [email-masked]
>From: Jiri Kuthan <[email-masked]>
>Subject: [Sipping] Diagnostics I-D: draft-kuthan-sipping-diag-00.txt
>Sender: [email-masked]
>
>I just submitted a new, tiny I-D with a proposal to add
>more diagnostic info in SIP to facilitate troubleshooting.
>I think it is one of issues which deserves more attention
>than it has received so far -- it is important to operation. 
>I will appreciate WG's comments and any other help to advance 
>this piece of work before the upcoming meeting.
>
>Thanks,
>
>-Jiri
>
>ps -- until is is in the IETF repository, the memo is available
>at http://www.iptel.org/~jiri/etc/draft-kuthan-sipping-diag-00.txt
>Abstract follows:
>
>   Session Initiation Protocol (SIP) provides only limited space for
>   communicating diagnostic information when errors occur. To facilitate
>   troubleshooting, automated error detection, and reporting we propose
>   to create new protocol extensions. The extensions will be used for
>   richer reporting on request processing status. Particularly, we
>   suggest that User Agent Servers (UAS) include additional information
>   about error reasons in negative replies, and proxy servers indicate
>   in relayed requests the routing logic they used.
>
>--
>Jiri Kuthan            http://iptel.org/~jiri/
>
>_______________________________________________
>Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
>This list is for NEW development of the application of SIP
>Use [email-masked] for questions on current sip
>Use [email-masked] for new developments of core SIP 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Jiri Kuthan <[email-masked]>
Date: Tue, 05 Nov 2002 20:43:56 +0100

Was it on purpose you posted privately?

Cheers,

-Jiri

At 06:19 AM 11/4/2002, Dean Willis wrote:
>Hey y'all, pay attention -- if you ever had to try and debug my totally
>messed up phone settings (okay, my life IS complicated) you'd KNOW that
>some better diagnostic tools are definitely in order.
>
>There have been a couple of different drafts on this general issue that
>have suffered from neglect on our lists. Please, let us not have this
>pattern persist.
>
>--
>Dean
>
>On Sun, 2002-11-03 at 06:47, Jiri Kuthan wrote: