Subject: RE: [Sipping] Focus URI, Focus Factory URI, Conference URI

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 26 Nov 2002 18:29:40 -0500

A bit late for me to respond to this, but I was ferociously busy last week.
First off, "control" implies that the controller is asking the controllee to
do something.  I see some difference between this and the prototypical SIP
application where two peers are negotiating a session between them.  Using
SIP to direct a media server seems more like a control application than a
peer-to-peer negotiation.  If the shoe fits ...

> -----Original Message-----
> From: Eric Burger [mailto:[email-masked]] 
> Sent: Thursday, November 21, 2002 10:49 AM
> To: Garland Sharratt
> Cc: Sipping (E-mail)
> Subject: RE: [Sipping] Focus URI, Focus Factory URI, Conference URI
> 
> 
> I still don't see the difference between "SIP" and "Control 
> SIP".  If they are different, let's say what's different.  If 
> they are not different, then it is all "SIP".
> 
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Eric Burger" <[email-masked]>
Date: Tue, 26 Nov 2002 19:37:36 -0500

You mean that when a user agent CLIENT makes a request of a user agent SERVER, there is something different going on then when a client makes a request of a server?

I don't understand how this client-server interaction changes SIP.  SIP is SIP is SIP.

> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Tuesday, November 26, 2002 6:30 PM
> To: Eric Burger; Garland Sharratt
> Cc: Sipping (E-mail)

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 27 Nov 2002 11:22:18 -0500

I agree that the point is rather subtle, and more to do with the semantics
of the situation than the protocol, but I think there is a perceptible
difference in intent which is hidden by SIP terminology.  In the
prototypical SIP application I referred to, the asymmetry between UAC and
UAS is specifically a protocol matter: once the session is established, the
asymmetry disappears.  In the sort of situation the term "Control SIP" might
apply to, the asymmetry persists throughout the duration of the dialog.  I'm
not sure the term "Control SIP" itself is useful, but the distinction
between application types may be useful in deciding where the limits of
applicability of SIP itself lie.

> Sent: Tuesday, November 26, 2002 7:38 PM
> To: Sipping (E-mail)
> You mean that when a user agent CLIENT makes a request of a 
> user agent SERVER, there is something different going on then 
> when a client makes a request of a server?
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>