Subject: [Sipping] RE: fully-featured early media system

From: "Peterson, Jon" <[email-masked]>
Date: Tue, 5 Nov 2002 16:38:49 -0500

I think we still have some work to do on a couple of open issues associated
with SDP and SIP-ISUP mapping. Early media is one area where we can make
some recommendations, though there are other noteworthy issues that require
clarification. I wasn't able to work on any Internet-Drafts on this subject
for the coming meeting, but future direction of SIP-ISUP mapping work is
something we might consider discussing in Atlanta.

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: Alexeitsev, D [mailto:[email-masked]]
> Sent: Tuesday, November 05, 2002 6:47 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: fully-featured early media system
> 
> 
> Hello All
> 
> Does anyone have current status on the progress in the 
> development of fully-featured SIP early media system? Is it a 
> mandatory 183/PRACK exchange before the 200 OK? 
> 
> Greetings,
> Denis Alexeitsev
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Alexeitsev, D" <[email-masked]>
Date: Wed, 6 Nov 2002 10:08:35 +0100

Hello Jon, Gonzalo

I would definitely support the work on this issues.

Greetings,
Denis Alexeitsev

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 6 Nov 2002 09:19:18 -0500

What about the constraint that the sender of an offer must be prepared to
receive media according to that offer before receiving an answer?  Your
answer only applies to early media sent to the called (UAS), surely.

> From: Gonzalo Camarillo [mailto:[email-masked]] 
> Sent: Tuesday, November 05, 2002 10:01 AM
> To: Alexeitsev, D
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Sipping] fully-featured early media system
> 
> 
> Hi,
> 
> If you do not send any provisional response before the 200 
> OK, you will not have early media. Early media, by 
> definition, happens before the 200 OK. Otherwise, the session 
> has been accepted, and your media is not "early" anymore.
> 
> Gonzalo
> 
> "Alexeitsev, D" wrote:
> > 
> > Hello All
> > 
> development of 
> > fully-featured SIP early media system? Is it a mandatory 183/PRACK 
> > exchange before the 200 OK?
> > 
> > Greetings,
> > Denis Alexeitsev
> > 
> > This list is for NEW development of the application of SIP Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments of core SIP
> 
> -- 
> Gonzalo Camarillo         Phone :  +358  9 299 33 71
> Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
> Telecom R&D               Fax   :  +358  9 299 30 52
> FIN-02420 Jorvas          Email :  [email-masked]
> Finland                   http://www.hut.fi/~gonzalo
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>