Subject: RE: [Sipping] draft-ietf-sipping-isup-06 : reception of 380

From: "Peterson, Jon" <[email-masked]>
Date: Fri, 1 Nov 2002 12:26:34 -0500

draft-ietf-sipping-isup-06 suggests a default Q.850 status code that is used
for all conditions that have no mapping in the draft: 31 "normal
unspecified".

In this instance, an interworking status code would probably also be
suitable.

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: guilherme bastos [mailto:[email-masked]]
> Sent: Thursday, October 31, 2002 9:12 AM
> To: [email-masked]
> Subject: [Sipping] draft-ietf-sipping-isup-06 : reception of 380
> 
> 
> 
> Hi,
> 
> If an ISUP/SIP gw receives a 380(alternative service) response
> and does not understand the body or is not able to access the
> alternative service, the call failed and consequently
> an isup REL should be generated. Which cause should this REL
> contain? I didn't find anything about 380 in 
> draft-ietf-sipping-isup-06.
> 
> Thanks,
> Guilherme.
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: guilherme bastos <[email-masked]>
Date: Wed, 06 Nov 2002 13:58:44 -0200

Yes, the draft says that 

...Any SIP status codes not listed below (associated with SIP
   extensions, versions of SIP subsequent to the issue of this document,
   or simply omitted) should be mapping to cause code 31 "Normal,
   unspecified"...

But it's said in the section 8.2.6.1 which is a subsection of 
"8.2.6 4xx-6xx Received"
As 380 not in this range it seems that there is no support for this
error code in the draft. Maybe something could be said in the next 
release since I'm not the first one to have this doubt...
Anyway, I'll use isup REL code 31 "normal uspecified" meanwhile

Thanks,
Guilherme.

I'll map isup REL cause 31 (normal unspecified)
when I receive a sip 380 (alternative service) response, as recommen.
Furthermore, show in the 
programming code that this was a deliberated decision.

Thanks again,
Guilherme.