Subject: RE: [Sipping] Comments on johnston-sipping-cc-conferencing-00.txt (the second duck in theline ;-)

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 1 Nov 2002 13:53:18 -0500

We went round and round on names, and we agreed on 
focus.  Of course we can go round and round again,
but the design team got there by agreeing that
the name needed to be something that did not
imply multiple things to multiple people based on
past experience.  "Focus" has that characteristic,
Where "Conference Server" doesn't.

The confusion of focus URI and conference URI I think
is pretty small.  The focus entity could be the focus
for multiple conferences, thus you need to distinguish
between conferences, and the conference URI is the
way you do that.  The cc-conference draft proposes that
the focus be able to create a conference URI as a result
of a sip request to the focus entity.  The way it
proposes is to have a URI that accepts a request to
create a conference URI.  There are other ways you could
request the focus to create a conference URI.  For example,
the focus could have a web page and you could ask it
to make you a conference URI which you then cut/paste, email
or otherwise disseminate.  The cc-conference proposal to
use a focus URI is a new one, and I think it has some merit.
If "focus URI" is too confusing, we could try to come up
with another name.  "conference URI factory" perhaps?

Brian

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: Friday, November 01, 2002 11:24 AM
> To: Rosen, Brian
> Cc: 'Orit Levin'; [email-masked]
> Subject: Re: [Sipping] Comments on
> johnston-sipping-cc-conferencing-00.txt(the second duck in theline ;-)
> 
> 
> Comments below...
> 
> "Rosen, Brian" wrote:
> > 
> > I believe we have all agreed on the term focus, which -framework
> > defines as:
> >     Focus: The focus is a SIP user agent that is addressed by a
> >     conference URI. The focus maintains a SIP signaling
> >     relationship with each participant in the conference. The
> >     focus is responsible for insuring, in some way, that each
> >     participant receives the media that make up the conference.
> >     The focus also implements conference policies. The focus is
> >     a logical role.
> > 
> > I don't see where cc-conferencing diverges from this definition,
> > other than expanding the functions by including the focus URI.
> > In the model we are (all) working toward, each participant
> > has a 1 on 1 SIP call with the focus.
> 
> What is confusing is that cc-conference has both a Focus URI 
> and a Conference URI. But the Focus URI doesn't reference the 
> Focus as defined above - the Conference URI does. 
> 
> As best I can tell, there is nothing in the framework 
> document that corresponds exactly to the Focus URI.  The 
> closest would seem to be to consider the Focus URI as one way 
> to invoke the conference policy control protocol of a 
> conference server.
> 
> I think the concept of the Focus URI is good, but the name is 
> bad. Perhaps it could be called something like Conference 
> Factory URI, or Conference Server URI.
> 
> 	Paul
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 01 Nov 2002 14:36:28 -0500

> Where "Conference Server" doesn't.

I *like* the term "Focus" as used in the framework. 

> is pretty small. 

Technically it is small - certainly it is easily fixed.
But I think it is important.

If you have an entity called a "Focus" that can be identified by a URI, and you also have something called a "Focus URI", then it only makes sense that the Focus URI should identify a Focus. It is the violation of this common sense that I find troubling. 

> The focus entity could be the focus
> for multiple conferences,

Here you depart from the framework document. Are you suggesting that there is something else, called a "Focus Entity" that is different from a "Focus", or are you simply referencing the "Focus" entity?

In the framework, each distinct conference has its own, separately addressable, Focus. So you would not have the case of a single Focus for multiple conferences.

The framework doesn't seem to have a term for what you are calling "Focus Entity". I believe such a term would be useful, but "Focus Entity" seems like a poor choice because it is too easily confused with "Focus".

> thus you need to distinguish
> way you do that. 

One way would be to use the term "Focus URI" to reference the Focus. But Conference URI also seems well (better) suited for this.

> The cc-conference draft proposes that
> of a sip request to the focus entity. 

Once again the underlying concepts are fine, but the the terminology is unnecessarily confusing. You have a "Focus Entity", identified by a "Focus URI" (not "Focus Entity URI"), interacting with a "Focus" (different from the "Focus Entity") to create a "Conference URI" that identifies the "Focus".

> The way it
> create a conference URI. 

I like this approach.

> There are other ways you could
> or otherwise disseminate. 

Is it the "Focus", or the "Focus Entity" that you ask to create a conference URI?

In principle, you can't ask the Focus until it exists. And it won't exist until the conference is created. So presumably you must first ask the Focus Entity to create the conference, and then ask the Focus to create a Conference URI for the conference.

Seems like it would be simpler to describe this as asking the "Focus Entity" to create the Conference and the Conference URI. The Focus itself need not come into existence until the first attempt to contact it.

> The cc-conference proposal to

My *only* issue here is naming of things. Here is a suggestion:

 OLD NAME		NEW NAME		COMMENT

 Focus Entity		Conference Factory
 Focus URI		Conference Factory URI
 Focus			Focus			unchanged
 Conference URI		Conference URI		unchanged
 Conference URI		Focus URI		synonym

I am suggesting considering "Conference URI" and "Focus URI" as synonyms. Alternatively "Focus URI" could simply become a term that is intentionally undefined. In practice, the term is likely to be used informally even if it isn't defined, so its important that it not get a conflicting definition.

Sorry to be a pain in the ass, but I think this is unnecessarily confusing, and fixing it now will save a lot of grief later.

	Paul

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 02 Nov 2002 15:09:21 -0500

To reiterate Brian's points, we are still working the inconsistencies
between the two documents, which are the result of lots of folks with
lots of ideas working in parallel without having figured out exactly
what each document is supposed to cover.

So, you are right that the framework doesnt have the concept of "focus
URI" as discussed in the cc-conferencing draft.

 > Conference URI		Focus URI		synonym

To me, "focus entity" is really the "conference server" as defined in 
the framework. The conference server hosts many addressable resources - 
many conference URIs, many conference policy URIs, etc. I would argue 
that the conference server might also host a "conference factory URI", 
used to create conference URIs. I like this factory term.

The key point I am making is that the notion of a "focus entity" as a 
URI is nonsensical; it makes more sense to address LOGICAL resources, 
each of which represents a specific component of what you would find in 
a conference server.

 > I am suggesting considering "Conference URI" and "Focus URI" as
 > synonyms. Alternatively "Focus URI" could simply become a term that
 > is intentionally undefined. In practice, the term is likely to be
 > used informally even if it isn't defined, so its important that it
 > not get a conflicting definition.

Agreed.

In fact, one might even make the argument that focus URI is BETTER than 
conference URI as a term. But, I like the idea of explicitly defining 
both as synonyms. I will add that to the framework doc.

-Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com