Subject: Re: [Sipping] Comments on johnston-sipping-cc-conferencing-00.txt (the second duck in theline ;-)

From: Paul Kyzivat <[email-masked]>
Date: Fri, 01 Nov 2002 09:21:43 -0500

Arjun Roychowdhury wrote:
> 
> ... May be useful to use the same terminology across both
> of the new drafts...

Yes, I also found this distracting. The most distracting is that the definition of Focus in this doc is different than in Jonathan's.

	Paul
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Orit Levin <[email-masked]>
Date: Fri, 1 Nov 2002 09:44:21 -0500

Guys!
If somebody is curious to put the ducks in the chronological order, you will
find out that the "requirements" comes first, the "cc-conferencing" comes
second, the "framework" hasn't been published yet. It would be interesting
to see how the submitted (on time) version of the "framework" would look
like.

To clarify the focus issue itself, both the "requirements" and the
"cc-conferencing" have definitions referring to SIP itself - i.e. the call
control part ONLY of the whole conferencing application. The "framework"
(while derived and built upon the definitions found in the Framework chapter
of the "requirements" document) takes a broader perspective without
(unfortunately) keeping the intention of the original definitions in tact.

I feel terribly sorry that we were unable to resolve these issues within the
Conferencing team before "publishing" the "framework" document on this list.

Orit.

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: Friday, November 01, 2002 9:22 AM
> To: Arjun Roychowdhury
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Sipping] Comments on johnston-sipping-cc-conferencing-00.txt
> (the second duck in theline ;-)
> 
> 
> 
> Yes, I also found this distracting. The most distracting is that the
> definition of Focus in this doc is different than in Jonathan's.
> 
> 	Paul

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 1 Nov 2002 14:55:54 -0500

I'm happy to agree on all points.

It may be that we need a better name than "focus entity"
If a conference factory URI creates a conference URI
perhaps a "focus factory" instantiates a "focus" when 
first presented a conference URI,

Brian

> Sent: Friday, November 01, 2002 2:36 PM
> To: Rosen, Brian
> Cc: 'Orit Levin'; [email-masked]
> Subject: Re: [Sipping] Comments on
> johnston-sipping-cc-conferencing-00.txt(the second duck in theline ;-)
> 
> 
> 
> 
> "Rosen, Brian" wrote:
> > 
> > We went round and round on names, and we agreed on
> > focus.  Of course we can go round and round again,
> > but the design team got there by agreeing that
> > the name needed to be something that did not
> > imply multiple things to multiple people based on
> > past experience.  "Focus" has that characteristic,
> > Where "Conference Server" doesn't.
> 
> I *like* the term "Focus" as used in the framework. 
> 
> > 
> > The confusion of focus URI and conference URI I think
> > is pretty small. 
> 
> Technically it is small - certainly it is easily fixed.
> But I think it is important.
> 
> If you have an entity called a "Focus" that can be identified 
> by a URI, and you also have something called a "Focus URI", 
> then it only makes sense that the Focus URI should identify a 
> Focus. It is the violation of this common sense that I find 
> troubling. 
> 
> > The focus entity could be the focus
> > for multiple conferences,
> 
> Here you depart from the framework document. Are you 
> suggesting that there is something else, called a "Focus 
> Entity" that is different from a "Focus", or are you simply 
> referencing the "Focus" entity?
> 
> In the framework, each distinct conference has its own, 
> separately addressable, Focus. So you would not have the case 
> of a single Focus for multiple conferences.
> 
> The framework doesn't seem to have a term for what you are 
> calling "Focus Entity". I believe such a term would be 
> useful, but "Focus Entity" seems like a poor choice because 
> it is too easily confused with "Focus".
> 
> > thus you need to distinguish
> > between conferences, and the conference URI is the
> > way you do that. 
> 
> One way would be to use the term "Focus URI" to reference the 
> Focus. But Conference URI also seems well (better) suited for this.
> 
> > The cc-conference draft proposes that
> > the focus be able to create a conference URI as a result
> > of a sip request to the focus entity. 
> 
> Once again the underlying concepts are fine, but the the 
> terminology is unnecessarily confusing. You have a "Focus 
> Entity", identified by a "Focus URI" (not "Focus Entity 
> URI"), interacting with a "Focus" (different from the "Focus 
> Entity") to create a "Conference URI" that identifies the "Focus".
> 
> > The way it
> > proposes is to have a URI that accepts a request to
> > create a conference URI. 
> 
> I like this approach.
> 
> > There are other ways you could
> > request the focus to create a conference URI.  For example,
> > the focus could have a web page and you could ask it
> > to make you a conference URI which you then cut/paste, email
> > or otherwise disseminate. 
> 
> Is it the "Focus", or the "Focus Entity" that you ask to 
> create a conference URI?
> 
> In principle, you can't ask the Focus until it exists. And it 
> won't exist until the conference is created. So presumably 
> you must first ask the Focus Entity to create the conference, 
> and then ask the Focus to create a Conference URI for the conference.
> 
> Seems like it would be simpler to describe this as asking the 
> "Focus Entity" to create the Conference and the Conference 
> URI. The Focus itself need not come into existence until the 
> first attempt to contact it.
> 
> > The cc-conference proposal to
> > use a focus URI is a new one, and I think it has some merit.
> > If "focus URI" is too confusing, we could try to come up
> > with another name.  "conference URI factory" perhaps?
> 
> My *only* issue here is naming of things. Here is a suggestion:
> 
> 
>  OLD NAME		NEW NAME		COMMENT
> 
>  Focus Entity		Conference Factory
>  Focus URI		Conference Factory URI
>  Focus			Focus			unchanged
>  Conference URI		Conference URI		unchanged
>  Conference URI		Focus URI		synonym
> 
> I am suggesting considering "Conference URI" and "Focus URI" 
> as synonyms. Alternatively "Focus URI" could simply become a 
> term that is intentionally undefined. In practice, the term 
> is likely to be used informally even if it isn't defined, so 
> its important that it not get a conflicting definition.
> 
> Sorry to be a pain in the ass, but I think this is 
> unnecessarily confusing, and fixing it now will save a lot of 
> grief later.
> 
> 	Paul
>

---

From: "Mary Barnes" <[email-masked]>
Date: Fri, 1 Nov 2002 15:33:45 -0600

I like the term "factory" as I think it's very useful in clarifying things.
One thing, however, that I think would be useful is to precede the use of
the term Focus with conference as I've done below. I think this helps cement
this new term Focus and I'd almost suggest, although I know it reopens an
already agreed point, that we use the term Conference Focus URI (also, I
think the terms are getting quite long and we could get into trouble with
some of the abbreviations that folks would want to start using). 

Conference Factory: Produces conference "Focus URIs". The "Conference
Factory" is addressed via the "Conference Factory URI". 

Focus Factory: Instantiates a conference "Focus" using the conference "Focus
URI" as an identifier for the created conference "Focus"   

Regards,
Mary H. Barnes
[email-masked]

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Friday, November 01, 2002 1:56 PM
To: 'Paul Kyzivat'
Cc: 'Orit Levin'; [email-masked]
Subject: RE: [Sipping] Comments on
johnston-sipping-cc-conferencing-00.txt (the second duck in theline ;-)

Brian

---

From: Orit Levin <[email-masked]>
Date: Sat, 2 Nov 2002 23:43:56 -0500

I don't mind how many synonyms we are going to have for a single thing. A
also don't mind too much how many unused definitions we are going to have.

My key point is that we need a logical SIP call control entity that is
capable of creating SIP conferences and maintaining them (using SIP cc
means). This entity is a part of a Conferencing Server application, which in
addition typically handles policies, media, etc.

Now, I don't mind how this logical entity will be called in the end: host /
focus / conferencing server / conference factory. 

Just for the sake of the innocent readers: this exact entity is called FOCUS
in the cc-conferencing draft.

Orit.

> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Saturday, November 02, 2002 3:09 PM
> To: Paul Kyzivat
> Cc: Rosen, Brian; 'Orit Levin'; [email-masked]
> Subject: Re: [Sipping] Comments on johnston-sipping-cc-conferencing-
> 00.txt(the second duck in theline ;-)
> 
> To reiterate Brian's points, we are still working the inconsistencies
> between the two documents, which are the result of lots of folks with
> lots of ideas working in parallel without having figured out exactly
> what each document is supposed to cover.
> 
> So, you are right that the framework doesnt have the concept of "focus
> URI" as discussed in the cc-conferencing draft.
> 
> Regarding your naming:
> 
> 
> To me, "focus entity" is really the "conference server" as defined in
> the framework. The conference server hosts many addressable resources -
> many conference URIs, many conference policy URIs, etc. I would argue
> that the conference server might also host a "conference factory URI",
> used to create conference URIs. I like this factory term.
> 
> The key point I am making is that the notion of a "focus entity" as a
> URI is nonsensical; it makes more sense to address LOGICAL resources,
> each of which represents a specific component of what you would find in
> a conference server.
> 
> 
>  > I am suggesting considering "Conference URI" and "Focus URI" as
>  > synonyms. Alternatively "Focus URI" could simply become a term that
>  > is intentionally undefined. In practice, the term is likely to be
>  > used informally even if it isn't defined, so its important that it
>  > not get a conflicting definition.
> 
> Agreed.
> 
> In fact, one might even make the argument that focus URI is BETTER than
> conference URI as a term. But, I like the idea of explicitly defining
> both as synonyms. I will add that to the framework doc.
> 
> -Jonathan R.
> --
> Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com