Subject: RE: [Sipping] Re: Comments on revised 'sos' draft

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Mon, 16 Dec 2002 13:04:54 -0000

See below

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked] 

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: 13 December 2002 20:53
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Sipping] Re: Comments on revised 'sos' draft
> 
> 
> Indeed; I don't want to go there since that's the wrong 
> solution. From 
> what I've heard, 112 is built into GSM devices and works everywhere, 
> even in the US. Is there any country where 911 or 112 means something 
> other than emergency (or nothing)?
> 
It may work fine for US related numbers, but do we want this document to reflect a US centric view.

The normal example quoted of difficulties in 3GPP circles is "192" which is an emergency number in some South American companies, and is (currently) directory enquiries in the UK. I understand that there are other local service number conflicts.

It is worth pointing out that 3GPP has addressed this issue for SIP, and discovered that it CANNOT rely on local configuration of the phone due to just such conflicts. In addition to local configuration of the phone and the SIM, it therefore also relies on two mechanisms:

1)	downloading information to the phone when it registers (to the local cellular network - information provided by the SGSN or local MSC)

2)	analysing calls made at the outbound proxy against a database and making decisions based on the roamed-to network (Mobile Country Code + Mobile Network Code) which are sent with each call, as to whether the call is an emergency call in that network or not.

I agree that neither of these two mechanisms can be generally applicable in SIP, as they both rely on some intermediate entity support.

Keith
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 20 Dec 2002 23:10:10 -0500

>> what I've heard, 112 is built into GSM devices and works
 >> everywhere, even in the US. Is there any country where 911 or 112
 >> means something other than emergency (or nothing)?
 >>
 >

Certainly not. Are you arguing that 112 does *not* work on GSM phones in 
the US? (I don't know; I don't want to try on mine...)

 >
 > The normal example quoted of difficulties in 3GPP circles is "192"
 > which is an emergency number in some South American companies, and is
 > (currently) directory enquiries in the UK. I understand that there
 > are other local service number conflicts.

That's why I argued that incorporating all local numbers is not feasible 
nor desirable. I'm still undecided whether favoring 112 or 911 is a good 
idea (I suspect it may not be since it's hard to draw the line).

 >
 > It is worth pointing out that 3GPP has addressed this issue for SIP,
 > and discovered that it CANNOT rely on local configuration of the
 > phone due to just such conflicts. In addition to local configuration
 > of the phone and the SIM, it therefore also relies on two mechanisms:
 >
 >
 > 1)	downloading information to the phone when it registers (to the
 > local cellular network - information provided by the SGSN or local
 > MSC)
 >
 > 2)	analysing calls made at the outbound proxy against a database and
 > making decisions based on the roamed-to network (Mobile Country Code
 > + Mobile Network Code) which are sent with each call, as to whether
 > the call is an emergency call in that network or not.
 >
 > I agree that neither of these two mechanisms can be generally
 > applicable in SIP, as they both rely on some intermediate entity
 > support.

About the only entity which has a reasonable chance to be local to the 
SIP device is the DHCP server. However, there are really two separate 
problems:

- having an emergency identifier that works as widely as possible, so 
that travelers don't have to look up what it is

- making sure that the number painted on the local police car works

Also, there are two functions that are needed:

- reaching the correct destination (police, not directory assistance)
- possibly disabling various authentication mechanisms

The latter is probably more of a problem if you're running a walled SIP 
garden, 3G-style.

The latter is somewhat easier as long as you use a local outbound proxy 
or a local gateway service. If the call reaches your home gateway 
service (like many phone-to-phone VoIP services do today), this is not 
possible.