Subject: RE: [Sipping] WGLC: draft-ietf-sipping-mwi-01.txt

From: "Eric Tremblay" <[email-masked]>
Date: Thu, 5 Dec 2002 13:24:17 -0500

Rohan,

Some quick comments:

1)
From 3265:
  "If no "Expires" header is present in a SUBSCRIBE request, the implied
   default is defined by the event package being used."

From draft-ietf-sipping-mwi-01.txt

3.4 Subscription Duration

   Subscriptions to this event package MAY range from minutes to weeks.
   Subscriptions in hours or days are more typical and are RECOMMENDED.

I understand that the "expires" parameter is not mandatory in the Subscription-State of the NOTIFY. I think a default subscription expiration value should be specified to conform to 3265.

I suggest adding something like:

"The default subscription duration for this event package is defined as x hours."

I suggest one hour, but really don't mind any other value, as long as it is at least one hour.

2)
3.8 Notifier generation of NOTIFY requests

   Immediately after a subscription is accepted, the Notifier MUST send
   a NOTIFY with the current message summary information.  This allows
   the Subscriber to resynchronize its state.  This initial
   synchronization NOTIFY MUST NOT include the optional message headers.

I would suggest changing the last sentence to "... MUST NOT include the optional RFC 2822 [9]-style message headers."  Althoug it is already described previously, I think it helps for clarity.

Regards,

EricT

-----Original Message-----
From: Gonzalo Camarillo [mailto:[email-masked]]
Sent: Wednesday, November 20, 2002 1:55
To: sipping
Cc: Rohan Mahy; Dean Willis
Subject: [Sipping] WGLC: draft-ietf-sipping-mwi-01.txt

Folks,

we would like to WGLC the draft below:
http://www.ietf.org/internet-drafts/draft-ietf-sipping-mwi-01.txt

The WGLC will finish on December 20th.

Thanks,

Gonzalo, Rohan & Dean
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Rohan Mahy <[email-masked]>
Date: Thu, 5 Dec 2002 11:55:12 -0800

ok, thanks.

I will make these changes for the next version.

thanks,
-rohan

On Thursday, December 5, 2002, at 10:24 AM, Eric Tremblay wrote:

> I understand that the "expires" parameter is not mandatory in the 
> Subscription-State of the NOTIFY. I think a default subscription 
> expiration value should be specified to conform to 3265.
>
> I would suggest changing the last sentence to "... MUST NOT include 
> the optional RFC 2822 [9]-style message headers."  Althoug it is 
> already described previously, I think it helps for clarity.
>
>
> Regards,
>
> EricT
>
>
>