Subject: RE: [Sipping] History info and privacy

From: "Elwell, John" <[email-masked]>
Date: Thu, 19 Dec 2002 17:49:59 +0000

Mark,
 
OK, this is a problem with redirects. Perhaps we just have to conclude that
this privacy feature that is available in ISDN/QSIG is not achievable in
SIP. It means C has to trust B not to use a redirect (unless it is sent back
to another trusted entity) and to configure B's proxy in a way that does not
disclose the identity of C back towards A.
 
Regards,
 
John Elwell
e-mail: mailto:[email-masked] <mailto:[email-masked]>  
 
 -----Original Message-----
From: Mark Watson [mailto:[email-masked]]
Sent: 19 December 2002 13:36
To: 'Elwell, John'; [email-masked]'
Subject: RE: [Sipping] History info and privacy

John, 

Yes, I agree, but I do not see there is any other choice than for C to so
rely on B. In particular, history-info aside, if B's proxy uses redirect to
forward the call, rather then re-targeting, then A will discover C's
address.

...Mark 

> -----Original Message----- 
> From: Elwell, John [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> Sent: 19 December 2002 13:23 
> To: Watson, Mark [MOP:EP10:EXCH]; [email-masked]' 
> Subject: RE: [Sipping] History info and privacy 
> 
> 
> Mark, 
>  
> The question is whether it is acceptable for C to rely on B 
> to configure his 
> proxy appropriately. 
>  
> Regards, 
> 
> John 
> 
> John Elwell 
> e-mail: mailto:[email-masked] <mailto:[email-masked]>  
> < mailto:[email-masked] <mailto:[email-masked]> >  
> 
> 
> -----Original Message----- 
> From: Mark Watson [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> Sent: Wednesday, December 18, 2002 3:43 PM 
> To: 'Elwell, John'; [email-masked]' 
> Subject: RE: [Sipping] History info and privacy 
> 
> 
> 
> My opinion is as follows: 
> 
> For the first aspect, that B may not wish A to be informed 
> that the request 
> has been retargeted, or the address to which it has been 
> retargeted, seems 
> valid. B should be able to specify this, in which case the 
> proxy would not 
> send the History Information to A. 
> 
> For the second aspect, the information that B is passing to A 
> is just the 
> information 'B has retargeted this request to C'. This does 
> not give A any 
> information about the validity or meaning of address C. 
> 
> If B is not entitled to give this information to A (for example C has 
> requested that it should not be disclosed and local privacy 
> laws require 
> such requests to be honoured) then B should configure their 
> proxy to keep it 
> private (according to the first aspect above). The system 
> should not need to 
> 'police' such settings by referring to C in real-time before 
> revealing the 
> information. 
> 
> Regards, 
> 
> Mark 
> 
> > -----Original Message----- 
> > From: Elwell, John [ mailto:[email-masked]
<mailto:[email-masked]>  
> < mailto:[email-masked] <mailto:[email-masked]> > ] 
> > Sent: 18 December 2002 15:14 
> > To: [email-masked]' 
> > Subject: [Sipping] History info and privacy 
> > 
> > 
> > I have a concern that I don't think is addressed by 
> > draft-ietf-sipping-req-history-00 and 
> > draft-barnes-sipping-history-info-00. 
> > I have had some discussion with the authors, but after 
> > failing to come to a 
> > conclusion on this particular point I would like to seek 
> > further opinions. 
> > 
> > Suppose a call from A towards B is retargeted by B's proxy 
> towards C. 
> > Amongst other things the history-info draft provides a 
> > History-info header 
> > to A (if A has indicated support for this header). This 
> > header will reveal 
> > to A the request-URI of C. The question is whether this is a 
> > good thing from 
> > a privacy point of view. 
> > 
> > One aspect of privacy is that B might not wish A to know that he is 
> > retargeting his calls to C (or even that he is retargeting 
> > his calls at 
> > all). 
> > 
> > A second aspect is that C might not wish A to know C's 
> > identity. One example 
> > is where B is in a company and retargets his calls to a 
> > colleague's home AOR 
> > (e.g., to [email-masked] as opposed to [email-masked]). The 
> > colleague, C, 
> > has obviously made his home AOR available to B (and hopefully 
> > has authorised 
> > B to target calls to that AOR). However, C may not have made 
> > his address 
> > public and would not wish it to be disclosed to any caller A. 
> > 
> > I would like opinions as to whether each of these privacy 
> concerns are 
> > valid. 
> > 
> > 
> > John Elwell 
> > e-mail: mailto:[email-masked] <mailto:[email-masked]>

> < mailto:[email-masked] <mailto:[email-masked]> >  
> > 
> > _______________________________________________ 
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
<https://www1.ietf.org/mailman/listinfo/sipping>  
> < https://www1.ietf.org/mailman/listinfo/sipping
<https://www1.ietf.org/mailman/listinfo/sipping> >  
> > This list is for NEW development of the application of SIP 
> > Use [email-masked] for questions on current sip 
> > Use [email-masked] for new developments of core SIP 
> > 
> 
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 20 Dec 2002 10:27:46 -0500

Elwell, John wrote:
> SIP. 

Clearly that is not the case. Its just an issue of proper configuration 
at B's proxy. Indeed, I would argue that if C was so concerned about 
their identity being revealed, they would provide B with an alternate 
identity, C', which routes to a privacy service before getting forwarded 
to them.

> It means C has to trust B not to use a redirect (unless it is sent back

If C provides an alternate identity, as I propose above, it doesn't 
matter whether B redirects or not.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com