Subject: RE: [Sipping] I-D ACTION:draft-camarillo-sipping-exploders-00.txt

From: [email-masked]
Date: Thu, 25 Sep 2003 20:26:47 +0300

Hi,

I think something like this would be very useful, and support the requirements expressed in the draft. 

Some thougths about the possible solution:
- A new token for Require header to demand that the UAS needs to support exploder capability?
- A new header to contain the addresses of the final destinations, and maybe some other information that would need to be copied for the requests sent by the exploder?
- Some way to convey back the responses from the destinations. Implicit subscription? New provisional response codes?

Without this at least SIP instant messaging is rather poor compared to other IM systems, and also conferencing would definitely become much more effective.

Markus

> -----Original Message-----
> From: ext [email-masked] [mailto:[email-masked]]
> Sent: 11 September, 2003 21:50
> Cc: [email-masked]
> Subject: [Sipping] I-D ACTION:draft-camarillo-sipping-exploders-00.txt
> 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> 
> 
> 	Title		: Requirements for Session Initiation 
> Protocol (SIP) 
>                           Exploder Invocation
> 	Author(s)	: G. Camarillo
> 	Filename	: draft-camarillo-sipping-exploders-00.txt
> 	Pages		: 7
> 	Date		: 2003-9-11
> 	
> This document describes the need for SIP exploders and provides
> requirements for their invocation.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-camarillo-sipping-ex
ploders-00.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-camarillo-sipping-exploders-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-camarillo-sipping-exploders-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: [email-masked]
Date: Thu, 25 Sep 2003 21:10:59 +0300

Hi,

Actually I propose two additional requirements that at least to me would make the exploders more useful:
- The UA MUST be able to provide the set of destinations to the exploder as indirect content, i.e. using the mechanism defined in draft-ietf-sip-content-indirect-mech-03.
- The UA MUST be able to provide the set of destinations to the exploder by referring to a list as defined in draft-rosenberg-simple-xcap-list-usage-00, i.e. a list in XML format that can be manipulated by XCAP. The XML list can be inherently associated with the exploder, but  the exploder SHOULD support fetching lists referenced by their HTTP URI ad hoc. 

The wording of the requirements cound be refined, but the idea anyway is that in addition to sending the set of destinations within the SIP request to the exploder (which is quite OK in itself), it must be possible to use pre-provisioned lists. The preferred way would be to use lists according to XCAP. 

The service I have in mind is that the user could setup a list (via XCAP), and use that same list for multiple purposes: SUBSCRIBE to presence, send MESSAGE, initiate a session with INVITE. It may actually be that the same exploder does not even support all of these, as supporting INVITE might also require supporting media as B2BUA/mixer, which may not be feasible for an exploder implementing just e.g. presence/messaging list support. However, the list should be the same.

Rgs,
	Markus

> From: ext [email-masked] [mailto:[email-masked]]
> Sent: 25 September, 2003 20:27
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: [Sipping] I-D
> ACTION:draft-camarillo-sipping-exploders-00.txt
> 
> 
> Hi,
> 
> - A new header to contain the addresses of the final 
> destinations, and maybe some other information that would 
> need to be copied for the requests sent by the exploder?
> - Some way to convey back the responses from the 
> destinations. Implicit subscription? New provisional response codes?
> 
> Without this at least SIP instant messaging is rather poor 
> compared to other IM systems, and also conferencing would 
> definitely become much more effective.
> 
> Markus
> 
> > Subject: [Sipping] I-D 
> ACTION:draft-camarillo-sipping-exploders-00.txt
> > 
> > 
> 	"FILE 
> /internet-drafts/draft-camarillo-sipping-exploders-00.txt".
>