Subject: [Sipping] 3pcc Call Initiation from a UA?

From: "Eagan, Christopher" <[email-masked]>
Date: Mon, 22 Sep 2003 11:14:49 -0400

Hello all,

I am wondering if there is any (SIP) way for a UA to initiate a 3pcc call where the initiating UA is not the controller.  I.e. I want to compel a 3rd party controller to INVITE me and someone else to a call.

I am wondering about this for the case of Multilevel Precedence and Preemption (MLPP) implementation where calls might need to initiated somewhat normally but also be under control of a 3rd party for preemption events.

Thanks!

Chris

Christopher Eagan
Software Engineer
Lockheed Martin
[email-masked] 
301-240-6328

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 22 Sep 2003 18:50:37 -0400

> I am wondering if there is any (SIP) way for a UA to initiate a 3pcc call where the initiating UA is not the controller.  I.e. I want to compel a 3rd party controller to INVITE me and someone else…

Sure. Let A be the UA that wants to initiate this process, B is the 
someone else you want to call, and C is the 3rd party controller.

- A sends REFER to C, Refer-To: B
- A receives NOTIFY back, with dialog id of call.
- A sends INVITE to C, with Join header referencing the C-B dialog.

	Paul

---

From: Rohan Mahy <[email-masked]>
Date: Fri, 26 Sep 2003 09:07:23 -0700

Christopher,

Preemption in MLPP should only ever occur for SIP resources at the 
originating or terminating UA, not at any intermediaries.  Your UA 
(possibly a TDM gateway) should preempt a lower-level call when it 
receives a higher-level one and can't handle any more calls. In other 
words, there is no reason to have a 3pcc controller involved in an MLPP 
session.

thanks,
-rohan

On Monday, September 22, 2003, at 08:14 AM, Eagan, Christopher wrote:

> Hello all,
>
> I am wondering if there is any (SIP) way for a UA to initiate a 3pcc 
> call where the initiating UA is not the controller.  I.e. I want to 
> compel a 3rd party controller to INVITE me and someone else to a call.
>
> I am wondering about this for the case of Multilevel Precedence and 
> Preemption (MLPP) implementation where calls might need to initiated 
> somewhat normally but also be under control of a 3rd party for 
> preemption events.
>
> Thanks!
>
> Chris
>
> Christopher Eagan
> Software Engineer
> Lockheed Martin