Subject: Re: [Sipping] :draft-jain-sipping-srtp-00.txt

From: Jari Arkko <[email-masked]>
Date: Tue, 02 Sep 2003 16:24:09 +0300

Cullen Jennings wrote:
> I had a read of this and got a little lost on how it would work -
> specifically how you would know there was not a man in the middle attack
> going on and if you are assuming the SIP is secure, they do you need to send
> DH keys. 

Right. As far as I can see, this is an unauthenticated D-H
operation, i.e. MITMs can get in between. Or maybe we both
missed something...

You could also compare this to draft-ietf-msec-mikey-07.txt and
draft-mmusic-kmgmt-ext-07.txt, which DO provide authentication
as well.

(Now, I'm not going to say unauthenticated D-Hs are always bad.
In fact, they can offer some protection against massive wiretapping
by forcing the attackers to be active. However, it appears to me
that a much better approach can be provided if this really what
we want. Namely, we could use the SIP "leap of faith" key learning
facility to register the keys of the other side on first contact.
Subsequent communications can then be protected using MIKEY + SRTP,
and where signaling security is needed, with S/MIME. This would
be better in the sense that the attacker would have to be a MITM
on every connection, not just the one that he wants to hear.)

Also, there's more to setting up a secure connection than agreeing
on the key. Some other cryptographic parameters may also have to
be agreed.

--Jari

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Cullen Jennings <[email-masked]>
Date: Sun, 31 Aug 2003 22:32:41 -0700

I think folks imagined the SRTP keys would be stuck in SDP and the SDP would
be encrypted end to end in SIP using S/MIME. Have a look at
draft-ietf-mmusic-sdescriptions for how the keys for SRTP could be described
in SDP - I think that is probably a better approach.

Cullen

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 22 Sep 2003 18:04:55 -0700

Kavita, John,

Are you familiar with draft-ietf-mmusic-sdescriptions-01.txt?

-d

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: Friday, August 29, 2003 8:32 AM
> To: IETF-Announce:
> Cc: [email-masked]
> Subject: [Sipping] I-D ACTION:draft-jain-sipping-srtp-00.txt
> 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> 
> 
> 	Title		: Using SRTP with SIP
> 	Author(s)	: K. Jain, J. Albert
> 	Filename	: draft-jain-sipping-srtp-00.txt
> 	Pages		: 0
> 	Date		: 2003-8-29
> 	
> The Secured Real Time Protocol (SRTP) is a lightweight protocol that 
> secures voice data between two end points. The Session Initiation 
> Protocol (SIP) is a simple and adaptive session-controlling 
> protocol. Efforts have been underway to get these two protocols 
> working together. Several ideas have been presented in different 
> documents in past. This document describes one more way to 
> accomplish this task. The proposed approach is simple and does 
> not consume too much CPU cycles. However, some assumptions need 
> to be made in lack of the specific SIP and SDP fields.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-jain-sipping-srtp-00.txt
> 
> To remove yourself from the IETF Announcement list, send a message to 
> ietf-announce-request with the word unsubscribe in the body of 
> the message.
> 
> Internet-Drafts are also available by anonymous FTP. Login with 
> the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-jain-sipping-srtp-00.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-jain-sipping-srtp-00.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>