Subject: Re: [Sipping] Requesting remote-target in draft-ietf-sipping-dialog-package-02.txt

From: Alan Johnston <[email-masked]>
Date: Fri, 26 Sep 2003 09:29:32 -0500

At 01:13 PM 9/26/2003 +0200, Stach Thomas wrote:
>Hello,
>
>draft-ietf-sipping-dialog-package-02.txt states in 4.1.7 (and 3.3 last
>bullet)
>"The remote-target ... should generally not be included in notifications,
>unless explicitly requested by the subscriber."
>
>I can't find a mechanism in the document how to place such a request.
>Should I use a filter according to
>draft-olson-sipping-dialog-package-extensions-00 in the SUBSCRIBE?
>Since the remote-target URI is used e.g. for Pick-up in
>draft-ietf-sipping-service-examples-05, I would be interested how I can make
>sure to receive the remote-target in a NOTIFY.

Thomas,

You have a very good point.  I think the default should be the other way 
around, as many, many call control applications (a common user of the 
dialog package) need the remote-target URI.

Right now, the filtering necessary is not define anywhere.

Thanks,
Alan Johnston
MCI

>Thanks a lot for your help.
>
>Thomas
>
>
>
>_______________________________________________
>Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
>This list is for NEW development of the application of SIP
>Use [email-masked] for questions on current sip
>Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Sean Olson <[email-masked]>
Date: Fri, 26 Sep 2003 17:08:44 -0700 (PDT)

My two cents are that both local and remote target
will be fairly common to include in the dialog
package. Or to be more precise, I see there being two
common usages for the dialog package:

1) Where the bare minimum information is exposed.
basically these two AORs are in a dialog

2) Where basically everything about the dialog is
exposed: local and remote target, estatus of the
dialog,  potentially status of the media, call-IDs, 
etc.

The first for most "anonymous" requests. The second
for strictly authorized requests.

--- Alan Johnston <[email-masked]> wrote:
> >Sipping mailing list 
> https://www1.ietf.org/mailman/listinfo/sipping
> Sipping mailing list 
> https://www1.ietf.org/mailman/listinfo/sipping

__________________________________
Do you Yahoo!?
The New Yahoo! Shopping - with improved product search
http://shopping.yahoo.com