Subject: RE: [Sipping] Forking is just plain wrong ...

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Mon, 7 Mar 2005 13:49:18 -0500

For what it's worth, forking reminds me of the teenage kid who throws a
party while the parents are away, only to have the invitation to one kid
result in many kids showing up unexpectedly and in un-manageable
fashion.  Starting a feature at one point in the network and completing
it in another place seems like a recipe for complexity and confusion.

Mike

>-----Original Message-----
>From: [email-masked] 
>[mailto:[email-masked]] On Behalf Of Eric Burger
>Sent: Friday, March 04, 2005 6:11 PM
>To: Cullen Jennings (fluffy)
>Cc: sipping
>Subject: RE: [Sipping] Forking is just plain wrong ...
>
>Was I the only person to hum when Dean said "Who wants to 
>deprecate Forking?" :)
>
>
>-----Original Message-----
>From: [email-masked] 
>[mailto:[email-masked]]On Behalf Of Cullen Jennings
>Sent: Thursday, March 03, 2005 6:17 PM
>To: sipping; Jonathan Rosenberg
>Cc: Dean Willis
>Subject: [Sipping] Forking is just plain wrong ...
>
>
>
>My favorite line in the sippging-sip-arch  
>
>    "Forking, which allows multiple devices to be wrong at once, ..."
>
>Ok this is just a typo - but it amused me greatly. 
>
>_______________________________________________
>Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
>This list is for NEW development of the application of SIP Use 
>[email-masked] for questions on current sip 
>Use [email-masked] for new developments of core SIP
>

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Gordon Ledgard" <[email-masked]>
Date: Mon, 7 Mar 2005 15:10:17 -0500

I take it that this is a joke?  Or are people seriously considering
deprecating forking?  

Frankly I think it would be a wonderful idea but I'd be surprised if
there weren't too many implementations that depended on it.

That said, it seems that forking was designed to solve one basic
problem:
Q. When someone is trying to contact another person who may be at one of
several places, how do you keep the caller from loosing patience while
a series of devices are rung in turn? 
A. You don't. You ring them all.

(Or are there other fundamental things this was aimed to address that
I'm
not aware of?)

However, it seems to me that this is fundamentally an application
problem,
not one that should be solved by a protocol. Is the issue that an
application would not work fast enough for the impatient caller?

Gordon Ledgard
Iperia, Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Michael Hammer (mhammer)
Sent: Monday, March 07, 2005 1:49 PM
To: Eric Burger; Cullen Jennings (fluffy)
Cc: sipping
Subject: RE: [Sipping] Forking is just plain wrong ...

Mike

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Mon, 7 Mar 2005 15:50:54 -0500

Perhaps we are crying over last winter's snow.  (Doesn't do any good.)
And as you say, it is already in many implementations.
 
Mike

>From: Gordon Ledgard [mailto:[email-masked]] 
>Sent: Monday, March 07, 2005 3:10 PM
>To: Michael Hammer (mhammer); Eric Burger; Cullen Jennings (fluffy)
>Cc: sipping
>I take it that this is a joke?  Or are people seriously 
>considering deprecating forking?  
>
>Frankly I think it would be a wonderful idea but I'd be 
>surprised if there weren't too many implementations that 
>depended on it.
>
>Q. When someone is trying to contact another person who may be 
>at one of several places, how do you keep the caller from 
>loosing patience while a series of devices are rung in turn? 
>(Or are there other fundamental things this was aimed to 
>address that I'm not aware of?)
>
>However, it seems to me that this is fundamentally an 
>application problem, not one that should be solved by a 
>protocol. Is the issue that an application would not work fast 
>enough for the impatient caller?
>
>Gordon Ledgard
>Iperia, Inc.
>
>
>
>
>[mailto:[email-masked]] On Behalf Of Michael Hammer (mhammer)
>For what it's worth, forking reminds me of the teenage kid who 
>throws a party while the parents are away, only to have the 
>invitation to one kid result in many kids showing up 
>unexpectedly and in un-manageable fashion.  Starting a feature 
>at one point in the network and completing it in another place 
>seems like a recipe for complexity and confusion.
>
>Mike
>
>
>>Was I the only person to hum when Dean said "Who wants to deprecate 
>>Forking?" :)
>>
>>
>>[email-masked] for questions on current sip Use 
>>[email-masked] for new developments of core SIP
>>
>

---

From: "Nasir Khan" <[email-masked]>
Date: Mon, 7 Mar 2005 21:51:15 -0800

Well, maybe it is not a typo after all... multiple devices *are*
"wrong", only *one* is "right"!  Unless someone *wrongly* picks up a
phone intended for someone else. (j/k)

The architecture draft is a great reading. 
One question that I had when I read the MESSAGE RFC is now rekindled
after going through this draft.
 
- What were the reasons to implement MESSAGE the way it is now? Why was
it not implemented as an extension to SDP where the "description" could
have been the "description of a mechanism" to transport text?
Why this one exception was made in SIP? 
SIP could have assisted this text session providing presence,
subscription and other events besides session establishment [say chat
session] but actual media [in this case text] passing through all the
proxies in the network still eludes me.

+ Nasir 

Date: Mon, 7 Mar 2005 13:49:18 -0500
From: "Michael Hammer \(mhammer\)" <[email-masked]>
Subject: RE: [Sipping] Forking is just plain wrong ...
To: "Eric Burger" <[email-masked]>,	"Cullen Jennings
	\(fluffy\)" <[email-masked]>
Cc: sipping <[email-masked]>
Message-ID:
	
<[email-masked]>
Content-Type: text/plain;	charset="us-ascii"

Mike