Subject: [Sipping] Vedio On Demand with SIP

From: "Debashis Mohapatra" <[email-masked]>
Date: Fri, 11 Mar 2005 18:59:45 +0530

Hi All,
	We are trying to implement Vedio On Demand using SIP. Where a UAC (SIP
phone) can request for a perticular vedio file to be displayed. Now the idea
is the UAC will subscribe for a list of file avialable in the server and
server will notify the UAC with list of file.
	Now the UAC will send the request for the particular file in the Request
URI of the invite message. Is it possible to send a file name in the Request
URI of the INVITE message?
	We have been sending the file name in the Request URI, but the SIP proxy is
stripping it of from the Request URI header. Is there any way avialable to
send the request of a media file to be played by server through SIP message?

	Waiting for an your valuable suggestions..

Regards

Debashis Mohapatra
Technical Associate(CoE-IN-VoIP)
Mahindra British Telecom, PUNE
Ph:020-56018100, Ext:2869/2867
www.mahindrabt.com

*********************************************************
Disclaimer:

The contents of this E-mail (including the contents of the enclosure(s) or attachment(s) if any) are privileged and confidential material of MBT and should not be disclosed to, used by or copied in any manner by anyone other than the intended addressee(s).   In case you are not the desired addressee, you should delete this message and/or re-direct it to the sender.  The views expressed in this E-mail message (including the enclosure(s) or attachment(s) if any) are those of the individual sender, except where the sender expressly, and with authority, states them to be the views of MBT.

This e-mail message including attachment/(s), if any, is believed to be free of any virus.  However, it is the responsibility of the recipient to ensure that it is virus free and MBT is not responsible for any loss or damage arising in any way from its use

*********************************************************

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: David R Oran <[email-masked]>
Date: Fri, 11 Mar 2005 09:38:30 -0500

> 	Waiting for an your valuable suggestions..
Yes. SIP is the wrong protocol for this. Use RTSP.

> The contents of this E-mail (including the contents of the 
> enclosure(s) or attachment(s) if any) are privileged and confidential 
> material of MBT and should not be disclosed to, used by or copied in 
> any manner by anyone other than the intended addressee(s).   In case 
> you are not the desired addressee, you should delete this message 
> and/or re-direct it to the sender.  The views expressed in this E-mail 
> message (including the enclosure(s) or attachment(s) if any) are those 
> of the individual sender, except where the sender expressly, and with 
> authority, states them to be the views of MBT.
>
> This e-mail message including attachment/(s), if any, is believed to 
> be free of any virus.  However, it is the responsibility of the 
> recipient to ensure that it is virus free and MBT is not responsible 
> for any loss or damage arising in any way from its use
>
David R. Oran
Cisco Fellow
Cisco Systems
7 Ladyslipper Lane
Acton, MA 01720 USA
Tel: +1 978 264 2048
Email: [email-masked]