Subject: RE: [Sipping] Re: RFC 3262 and Offer Answer Model.

From: "Elwell, John" <[email-masked]>
Date: Tue, 29 Mar 2005 11:27:00 +0100

Venkatesh,

I am not sure why the UAC would wish to delay sending the SDP answer, even
in a forking situation. If the UAC were to delay until answer, the UAS would
be unable to start sending media until ACK is received. This might result in
the phenomenon known as clipping.

John

> -----Original Message-----
> From: Venkatesh [mailto:[email-masked]] 
> Sent: 28 March 2005 19:01
> To: [email-masked]
> Subject: [Sipping] Re: RFC 3262 and Offer Answer Model.
> 
> Hi:
> 
> Reposting query....
> 
> Per section 5 of RFC 3262, a UA MUST generate an 'answer' in a PRACK
> request if it received an offer in a reliable provisional response.
> This is kind of limiting from the UA's perspective in scenarios where
> it is not ready to issue an answer until the far end actually answers
> the call (for example in cases where a request got forked and the UA
> is receiving multiple 1xx responses with SDP, it might want to delay
> providing an answer until one of the branches answer the call). Is
> there any rational as to why this is a MUST requirement
> ??
> 
> Regards,
> Venkatesh
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Venkatesh <[email-masked]>
Date: Tue, 29 Mar 2005 06:24:23 -0800

There are a couple of reasons I can think of as to why I want to do this.

1. In cases like 3PCC call control, where a 3PCC controller has sent
an INVITE w/o SDP on behalf of a user, the 3PCC call controller would
want to wait for the destination to answer the call before initiating
any SDP exchange.

2. I want to avoid processing of media from multiple sources before
call answer? In cases like forking, what if I receive 1xx responses
with SDP from multiple branches?

Venkatesh