Subject: Re: [Sipping] Draft: Functions of Current SBCs

From: Ben Campbell <[email-masked]>
Date: Tue, 1 Mar 2005 09:12:15 -0600

While I normally hesitate to disagree with Henry, I think this taxonomy 
talks more about business models than anything technical. I have 
personally built out SIP networks where no "carrier" in the sense of a 
VoIP (or other media) provider existed at all. (I assume you are not 
including an IP carrier that is not somehow participating in the VoIP 
stuff other than moving bits around--if this assumption is incorrect 
than disregard my comment).

If we do need to distinguish these two SBC roles, I suggest we examine 
what makes them different, not just what sort of company is deploying 
them.

On Feb 27, 2005, at 3:00 PM, [email-masked] wrote:

> Two names for two very different devices: In the carrier network or at 
> the perimeter of the customer location.
>  
> The location changes many security aspects (we need to specify which) 
> and also the media performance, as well as bandwidth consumption. 
> Multi-homing of customer networks is an issue here as well.
>  
> Henry
>
>
> From: Roy, Radhika [mailto:[email-masked]]
>  Sent: Sunday, February 27, 2005 2:24 PM
> To: Christer Holmberg (JO/LMF); [email-masked]; Medhavi Bhatia; 
> Brian Rosen; Richard Fogel; [email-masked]
> Subject: RE: [Sipping] Draft: Functions of Current SBCs
>
> Yes, they are all B2BUAs (e.g., Transcoder, 3rd Party Call Controller, 
> etc.). However, all of them have specific names based on the services 
> that are being provided by each one of them among the SIP UAs.
>  
> So, this one (e.g., SBC) should also need to have a name, I believe.
>  
> Best regards,
>  
> Radhika R. Roy
> SAIC
>
>
> From: [email-masked] on behalf of Christer Holmberg (JO/LMF)
> Sent: Sun 2/27/2005 1:35 PM
> To: [email-masked]'; 'Medhavi Bhatia'; 'Brian Rosen'; 'Richard 
> Fogel'; [email-masked]
> Subject: RE: [Sipping] Draft: Functions of Current SBCs
>
> If we can't call them SBCs, I'll give my hum for calling them B2BUAs...
>  
> Regards,
>  
> Christer Holmberg
> Ericsson Finland
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of [email-masked]
> Sent: 24. helmikuuta 2005 23:23
> To: 'Medhavi Bhatia'; 'Brian Rosen'; 'Richard Fogel'; [email-masked]
> Subject: RE: [Sipping] Draft: Functions of Current SBCs
>
> We have now a good agenda item for the SIPPING WG: Humming on various 
> name proposals  :-)
>  
> Henry
>
>
> From: Medhavi Bhatia [mailto:[email-masked]]
>  Sent: Thursday, February 24, 2005 2:39 PM
> To: [email-masked]; 'Brian Rosen'; 'Richard Fogel'; 
> [email-masked]
> Subject: RE: [Sipping] Draft: Functions of Current SBCs
>
>
> I'd still vote for something like P-SBC and N-SBC. We already know 
> these are kinds of SBCs. The word customer premise needs to be 
> captured, so P-SBC should be "Premises-SBC". I can't get the same 
> understanding just by the word perimeter.
>
>  
>
>
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Thursday, February 24, 2005 12:14 PM
> To: 'Brian Rosen'; 'Medhavi Bhatia'; 'Richard Fogel'; [email-masked]
> Subject: RE: [Sipping] Draft: Functions of Current SBCs
>
>  
>
> >How about client side and network side?
>
>  
>
> 1. The intermediaries used in carrier networks (often referred to as 
> SBC in a confusing manner) could be called "Network based Session 
> Controllers" or NSC.
>
>  
>
> 2. The intermediaries at the perifery of private IP networks, 
> colocated with the NAT/FW could be called "Perimeter Session 
> Controllers" or PSC.
>
>  
>
> Any other, more accurate names?
>
>  
>
> Thanks, Henry
>
>  
>
>
> From: Brian Rosen [mailto:[email-masked]]
>  Sent: Thursday, February 24, 2005 10:43 AM
> To: [email-masked]; 'Medhavi Bhatia'; 'Richard Fogel'; 
> [email-masked]
> Subject: RE: [Sipping] Draft: Functions of Current SBCs
>
> Henry
>
>  
>
> As always, you wield a sharp sword.  I think you are correct, we need 
> to differentiate a client side SBC from a network side SBC and we need 
> names.
>
> How about client side and network side?
>
>  
>
> Brian
>
>  
>
>  
>
>
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Thursday, February 24, 2005 10:45 AM
> To: 'Medhavi Bhatia'; 'Richard Fogel'; [email-masked]
> Subject: RE: [Sipping] Draft: Functions of Current SBCs
>
>  
>
> Medhavi,
>
>  
>
> It appears the location of such intermediaries makes the critical 
> difference:
>
>  
>
> 1. SBC placed in the network (in the C.O.) of the carrier, or
>
>   
>
> 2. A perimeter device (such as Borderware or SIP media Proxy - these 
> are product names ) that is collocated as CPE with the NAT and 
> Firewall. This co-location changes many security aspects (we need to 
> specify which) and also the media performance, as well as bandwidth 
> consumption. Multi-homing is an issue here, not to forget.
>
>  
>
> I suggest we should always make this distinction. Maybe someone 
> proposes some definitions or names for each.
>
>  
>
> Thanks, Henry
>
>  
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Tom Taylor <[email-masked]>
Date: Tue, 01 Mar 2005 10:28:16 -0500

Two possible distinctions that I see, but maybe we could position them in a 
spectrum of classifications of borders:
  (1) Trust models are likely to differ for inter-carrier as opposed to 
subscriber-carrier handoff.
  (2) QOS model is more likely to be governed by SLA when going inter-carrier. 
Here, for sure, the enterprise-carrier boundary falls somewhere between.

Ben Campbell wrote:
> what makes them different, not just what sort of company is deploying them.
> 
...

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 02 Mar 2005 04:37:51 -0500

Ultimately, required functions at a border depend on the business 
relationships between those entities. Even for carrier-carrier 
relationships, we have lots of different types: consumer voip providers 
connecting to termination providers, consumer providers peering with 
other consumer providers, wholesalers peering with other wholesalers, 
and so on. I agree with Tom that there is a bigger gulf in the nature of 
the relationships when you go from subscriber-carrier to 
carrier-carrier, but its just a matter of degree.

I think that an attempt to classify the breadth of business 
relationships between entities is ultimately futile. Since I don't 
believe we need to standardize what an SBC is, we don't need to 
standardize what a client facing SBC is vs. an inter-carrier SBC. We do 
need to consider whether any of the relationships folks have seen in the 
market have pushed functions into SBC products that are solving problems 
not currently considered by existing standards.

-Jonathan R.

Tom Taylor wrote:

> Two possible distinctions that I see, but maybe we could position them 
> in a spectrum of classifications of borders:
>  (2) QOS model is more likely to be governed by SLA when going 
> inter-carrier. Here, for sure, the enterprise-carrier boundary falls 
> somewhere between.
> 
> Ben Campbell wrote:
> 
>> While I normally hesitate to disagree with Henry, I think this 
>> taxonomy talks more about business models than anything technical. I 
>> have personally built out SIP networks where no "carrier" in the sense 
>> of a VoIP (or other media) provider existed at all. (I assume you are 
>> not including an IP carrier that is not somehow participating in the 
>> VoIP stuff other than moving bits around--if this assumption is 
>> incorrect than disregard my comment).
>>
>>> Two names for two very different devices: In the carrier network or 
>>> at the perimeter of the customer location.
>>>  

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

---

From: [email-masked]
Date: Thu, 3 Mar 2005 18:59:25 -0500

Interesting to note that all leading public VoIP providers work just fine
without QoS and SLAs  :-)

Who is daydreaming here?

Henry 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Tom Taylor
Sent: Tuesday, March 01, 2005 10:28 AM
To: Ben Campbell
Cc: sipping
Subject: Re: [Sipping] Draft: Functions of Current SBCs

inter-carrier. 

them.
...

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP Use
[email-masked] for questions on current sip Use
[email-masked] for new developments of core SIP

---

From: "Medhavi Bhatia" <[email-masked]>
Date: Wed, 9 Mar 2005 16:37:55 -0500

Several things could explain this:

- it's probably OK at this point since there is enough bandwidth
- we will invent a new protocol or mechanism when the problem really hits us

My skype does work most of the time for domestic calls. For international
calls, there is occasional packet loss or high latency. I had to revert back
to good old PSTN... These kind of things would definitely improve over time,
but I guess this creates a kind of FUD factor for SPs. I don't know of a
single SP or major VoIP vendor who does not talk about QoS solutions.

-Medhavi.

> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> [email-masked]
> Sent: Thursday, March 03, 2005 6:59 PM
> To: 'Tom Taylor'; 'Ben Campbell'
> Cc: 'sipping'