Subject: Re: [Sipping] Doubt regarding B2BUA

From: [email-masked]
Date: Mon, 1 Aug 2005 08:19:53 -0400

On Jul 29, 2005, at 3:35 PM, Amarendra Kumar wrote:

> Hi,
>
> Can forking be implemented in B2BUA?
> I mean to say can B2B do forking like Proxy servers on receiving  
> the request.
> Lets say in my implementation there is a single server probably a  
> stand-alone
> B2B. Is B2B is the right place to implement application like Shared
> Call Appearance.
>
A B2BUA can do anything it likes, as long as its UAC side is a  
compliant UAC and its UAS side is a compliant UAS. For example, If it  
wants to use SETI@home calculations to choose the endpoints to send  
invites to in Andromeda galaxy, it can do that. Of course, this can  
produce surprising behavior for source UA...

Dave.

> -- 
> Rgds,
> Amar
> Mobile: +919886395894
> The greatest enemy of best is "good." If you're willing to accept  
> "good"
> you'll never be the "Best."
>
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
>

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Dale Worley" <[email-masked]>
Date: Mon, 1 Aug 2005 15:08:42 -0400

> From: Amarendra Kumar
> I mean to say can B2B do forking like Proxy servers on
> receiving the request.

No, it cannot.  It can do similar things, such as being the server for one
incoming dialog, and creating two outgoing dialogs in response.  But it
cannot fork in the sense of RFC 3261 because the connections "on each side"
of the B2BUA are *different* dialogs and thus *must* have different
Call-IDs.  Forking is within a dialog, and all the messages involved have
the same Call-ID.

Dale

---

From: "Arunachalam Venkatraman \(arunvenk\)" <[email-masked]>
Date: Mon, 1 Aug 2005 12:20:14 -0700

I would argue that forking is possible at a B2BUA. It is true that a B2BUA will have to generate two (or more) new calls due to an incoming request. It could then forward the responses (status code and bodies) to these requests as responses to the original incoming call by using unique tags on the To headers of the responses.
Forking in RFC3261 terms is defined by means of a unique dialog leg and the To tag is the way for a UAC to detect that forking has occurred.

________________________________

From: [email-masked] on behalf of Dale Worley
Sent: Mon 8/1/2005 2:08 PM
To: [email-masked]
Subject: RE: [Sipping] Doubt regarding B2BUA

Dale

---

From: Amarendra Kumar <[email-masked]>
Date: Tue, 2 Aug 2005 09:22:58 +0530

I agree with you.

On 8/2/05, Arunachalam Venkatraman (arunvenk) <[email-masked]> wrote:
>  
>  
> I would argue that forking is possible at a B2BUA. It is true that a B2BUA
> will have to generate two (or more) new calls due to an incoming request. It
> could then forward the responses (status code and bodies) to these requests
> as responses to the original incoming call by using unique tags on the To
> headers of the responses. 
> Forking in RFC3261 terms is defined by means of a unique dialog leg and the
> To tag is the way for a UAC to detect that forking has occurred. 
> 
> Sipping mailing list 
> https://www1.ietf.org/mailman/listinfo/sipping
> Sipping mailing list 
> https://www1.ietf.org/mailman/listinfo/sipping

-- 
Rgds,
Amar
Mobile: +919886395894
The greatest enemy of best is "good." If you're willing to accept "good"
you'll never be the "Best."