Subject: RE: [Sipping] Inter-Domain Requirements for SIP/SIMPLE

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Mon, 1 Aug 2005 11:08:07 -0400

Henry,

What is the difference between a community, domain, and a walled garden?

It seems like the nanosecond you cede control to some intermediary in
the network (no matter what you call it) to provide some sort of
censorship over traffic in and out of a domain, you have a walled
garden.

It seems that to be non-walled-garden, it must be P2P, so why not call
it P2P SIP/SIMPLE requirements?

Help me understand the distinction you are making.

Mike

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: Saturday, July 30, 2005 2:53 AM
> To: Cullen Jennings (fluffy); [email-masked]
> Subject: RE: [Sipping] Inter-Domain Requirements for SIP/SIMPLE
> 
> >I really want to us solve the interdomain issues for a non walled 
> >garden case.
> 
> Glad we are on the same page. IMHO this document can be 
> developed into a BCP how to do it. Please state what may be missing.
> 
> Henry
> 
> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Friday, July 29, 2005 10:48 PM
> To: [email-masked]
> Subject: RE: [Sipping] Inter-Domain Requirements for SIP/SIMPLE
> 
> 
> I'm confused - the document seems largely about doing stuff 
> that existing
> RFC and documents say you must do. The rest the document 
> seems about saying
> that how interdomain should work is in a walled garden. We 
> already have a
> solution for that with the 3GPP stuff.
> 
> I really want to us solve the interdomain issues for a non 
> walled garden
> case.
> I'm glad to see this as list discussion but I don't yet 
> understand what the
> concrete things are in this that would help deployments.
> 
> 
> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf
> Of Henry Sinnreich
> Sent: Saturday, July 23, 2005 10:54 AM
> To: [email-masked]
> Subject: [Sipping] Inter-Domain Requirements for SIP/SIMPLE
> 
> The I-D Inter-Domain Requirements for SIP/SIMPLE
> http://www.ietf.org/internet-drafts/draft-levin-simple-interdo
> main-reqs-02.t
> xt
> 
> is not only a very good document but is also very timely for other
> inter-domain communications, such as between all the emerging 
> VoIP islands
> (the islands are a regrettable fact at present).
> 
> I suggest therefore having a 5 minute hum so as to make it a 
> SIPPING WG
> item.
> 
> Small nits can be discussed on the list. For example eliminate various
> options, unless there is some automatic negotiation mechanism.
> 
> Also, what is the simplest set from the above so as to have 
> something that
> "is good enough but not better". In other words, the I-D 
> should recommend
> the default option in all cases where there are some choices.
> 
> Thanks, Henry
> 
> 
> 
> 
> 
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP Use
> [email-masked] for questions on current sip Use
> [email-masked] for new developments of core SIP
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 
> 
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Henry Sinnreich" <[email-masked]>
Date: Thu, 4 Aug 2005 18:35:52 +0200

Mike,

>censorship over traffic in and out of a domain, you have a walled

This is an excellent question, but I am not sure if the people on the list
are interested. If there is interest, maybe we collect some opinions here.

Thanks, Henry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Michael Hammer (mhammer)
Sent: Monday, August 01, 2005 5:08 PM
To: [email-masked]; Cullen Jennings (fluffy); [email-masked]
Subject: RE: [Sipping] Inter-Domain Requirements for SIP/SIMPLE

Henry,

Mike

---

From: Arjun Roychowdhury <[email-masked]>
Date: Thu, 4 Aug 2005 14:37:15 -0400

Personal Mail: 

Community = a group of users who live under the false impression that
there is no censorship in their world till all of a sudden the truth
comes crashing down. They then progress to the next stage:

Walled Garden = a group of users who live under the truth knowing that
there is censorship in the world and believe its their right to fight
against it till their last breath. Eventually they have their way and
they fall back to stage #1 above.

Therein lies the cycle of life and the reason for existance.

Domain = a group of enlightened users who realize that its all a state
of mind and the real answer is always 42. The trick is simply to use a
term when it suits the need the best.

regds
arjun

---

From: Juha Heinanen <[email-masked]>
Date: Thu, 4 Aug 2005 21:53:19 +0300

>censorship over traffic in and out of a domain, you have a walled

take cisco.com email server as an example.  most likely it does not have
a predefined list of peers it accepts emails from.  also, most likely it
forwards emails directly to destination domains even it has no previous
knowledge of them.

-- juha

---

From: Mika Lehtinen <[email-masked]>
Date: Thu, 4 Aug 2005 23:02:58 +0300

This has to be the case, but on the other hand, isn't this one of the
reasons why internet email is spam infested and mostly survives by
some king of rule and (domain?!?) based filtering?

Mika Lehtinen

---

From: Juha Heinanen <[email-masked]>
Date: Fri, 5 Aug 2005 09:13:12 +0300

> some king of rule and (domain?!?) based filtering?

there are heuristic rules, no all inclusive listing of trusted peers,
like walled gardens do.

-- juha

---

From: "Arvind Gopalakrishnan" <[email-masked]>
Date: Fri, 5 Aug 2005 18:02:44 +0530

More or less the same view as arjun

Community: a group which knows there is an outside world and have
intrusions once in a while

Walled garden: a group which assumes there is no intrusion and have
their own rules (krikkit?)

Domain: intrusions part of life here though 42 is an answer that takes
me way back.:)

regards
arvind

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Arjun Roychowdhury
Sent: Friday, August 05, 2005 12:07 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Sipping] Personal - Inter-Domain Requirements for SIP/SIMPLE

Personal Mail: 

regds
arjun
> This is an excellent question, but I am not sure if the people on the 
> list are interested. If there is interest, maybe we collect some 
> opinions here..
> 
> Thanks, Henry
> 
> 
>

Use [email-masked] for questions on current sip Use