Subject: RE: [Sipping] Draft Notes from Ad-hoc on SIP peer-to-peer

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Fri, 19 Aug 2005 12:53:09 -0400

Jose,

I think you are making a couple big assumptions:

1) That there is no infrastructure.  I think the presence of DNS and
ENUM immediately eliminate that thought.  The question is whether the
current directory systems can provide enough information to allow direct
connect to a P2P-PSAP.

2) That PSAPs are only reachable through a legacy or (hopefully soon)
infrastructure VoIP network.  This is a regulatory question in many
respects, since it could be technologically possible for direct PSAP to
Internet connection, but whether those emergency centers are willing to
do so, may require some regulation to "encourage" such implementation.

Mike

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: Monday, August 15, 2005 10:15 AM
> To: Richard Shockey
> Cc: Cullen Jennings (fluffy); sipping; Brijesh Kumar; Dean Willis
> Subject: Re: [Sipping] Draft Notes from Ad-hoc on SIP peer-to-peer
> 
> Hi,
> 
> I tend to agree that 911 services and security are two items 
> that should be part of P2P VoIP services.
> 
> However, this pose some requirements that contradict the 
> nature of P2P networks.
> 
> If we consider a P2P network without any infrastructure 
> support how do we provide the required support for 911 services?
> who is hosting the emergency service in an Ad hoc network?
> Only when the P2P network is an extension of a fixed network 
> then we will have a GW available to provide the connectivity 
> for accessing the emergency services.
> 
> Therefore, P2P SIP networks will provide emergency services 
> conditioned to the fact that we have a linkage to fixed 
> networks. The only thing P2P SIP can do is to provide the 
> basic framework such as addressing/naming to identify 
> emergency calls, locate the GW for accessing the fixed infra 
> and route E911 calls throughoutt that GW.
> Rgds
> Jose
> 
> 
> 
> > Philip Patrick wrote:
> >
> > >I believe emergency services should be within the scope of 
> P2P SIP.  
> > >As a
> > network operator enabling VoIP SPs to become custom telephone 
> > companies, we at Pac West Telecom endorse the FCC Order 
> requiring VoIP 
> > SPs to support Enhanced 911 service for nomadic VoIP users. 
>  And, in 
> > order for P2P VoIP to become a ubiquitous means of 
> communication, the 
> > routing of calls to the correct PSAP and rendering of location 
> > information for use by a 911 dispatcher is essential.
> > >
> > >Phil
> > >
> > I couldnt agree more ... I think the VoIP community should support 
> > Enhanced 911 services ..just as soon as the wireless industry gets 
> > around to supporting E911 as well.
> >
> > --
> >
> >
> > >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
> > Richard Shockey, Director - Member of Technical Staff NeuStar Inc.
> > 46000 Center Oak Plaza  -   Sterling, VA  20166
> > sip:rshockey(at)iptel.org   sip:57141(at)fwd.pulver.com
> > ENUM +87810-13313-31331
> > PSTN Office +1 571.434.5651 PSTN Mobile +1 703.593.2683
> > Fax: +1 815.333.1237
> > <mailto:richard(at)shockey.us> or
> > <mailto:richard.shockey(at)neustar.biz>
> > <http://www.neustar.biz> ; <http://www.enum.org> 
> > <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
> >
> >
> > _______________________________________________
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments of core SIP
> >
> 
> 
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: [email-masked]
Date: Sat, 20 Aug 2005 11:01:29 -0500

Mike,

>2) That PSAPs are only reachable through a legacy 
> or (hopefully soon) infrastructure VoIP network.

As Juha has pointed out, PSAPs need to be connected to the Internet and use
SIP. That's all.

Keeping PSAPs on the PSTN only is a regrettable backwardness and quite
irresponsible by regulators. 

Thanks, Henry

-----Original Message-----
From: Michael Hammer (mhammer) [mailto:[email-masked]] 
Sent: Friday, August 19, 2005 11:53 AM
To: [email-masked]; Richard Shockey
Cc: Cullen Jennings (fluffy); sipping; Brijesh Kumar; Dean Willis
Subject: RE: [Sipping] Draft Notes from Ad-hoc on SIP peer-to-peer

Jose,

Mike

---

From: Juha Heinanen <[email-masked]>
Date: Sat, 20 Aug 2005 19:22:44 +0300

> irresponsible by regulators. 

yes, voip cannot just have requirements placed on it without any rights.

-- juha