Subject: RE: [Sipping] Comments on BLA draft

From: "Christian Stredicke" <[email-masked]>
Date: Wed, 3 Aug 2005 18:08:45 +0200

Paul, we are talking here about emulation of legacy stuff... People
simply want to see LED blinking in the same way they did it with their
good old PBX. The "line" is used to identify the LED or button on the
phone that should start blinking.

As far as I understood it.-)

CS

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Paul Kyzivat
> Sent: Wednesday, August 03, 2005 10:17 AM
> To: Venkatesh
> Cc: Sipping (E-mail)
> Subject: Re: [Sipping] Comments on BLA draft
> 
> 
> 
> Venkatesh wrote:
> > As the name suggests, the feature is all about 'sharing' a 
> > resource/line across multiple users. The draft does not impose any 
> > limit on the number of simultaneous outgoing calls a UA can 
> place. It 
> > only proposes to associate each of these calls with a 
> unique line id. 
> > There is a section in the draft that talks about multiple 
> UAC's trying 
> > to use the same line ID simultaneously and how the same could be 
> > resolved. Dale's suggestion is an alternate approach to 
> solve the same.
> 
> Why is it necessary to have a line id at all? As long as 
> existing calls in progress can be seen from different devices 
> the concept of a line seems unnecessary. Then there is no 
> reason to seize a line. The existing calls can be mapped onto 
> the UI of each device in any way that works for the 
> capabilities of the device.
> 
> 	Paul
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 
> 
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 04 Aug 2005 04:48:54 -0400

> As far as I understood it.-)

I note the -)

I see some similarity here between this draft and the TISPAN 
requirements draft. Namely that we go to a lot of trouble to emulate 
behavior that is largely justified by historical legacy rather than 
current utility.

Personally, in a shiny new VoIP office telephony system (which I prefer 
to *not* call a PBX) I would much prefer to have status info displayed 
for each active call. Then you can yell that you want me to pick up the 
call with Joe or the call with Sam.

The association with "lines" is just historical baggage. If you insist 
in associating with lines, It should be possible to define a mapping 
that can be done independently in each UA simply by hashing some of the 
call state data.

	Paul