Subject: RE: [Sipping] Draft Notes from Ad-hoc on SIP peer-to-peer

From: "Khan, Sohel Q [NTK]" <[email-masked]>
Date: Wed, 10 Aug 2005 11:30:10 -0500

The following functions also need to be incorporated:

1. Lawful intercept 
2. E911 access
3. Quality of service (in reliability ?)
4. DoS protection (in Trust models?) 
5. Privacy (in trust models?)

Thanks.

Sohel Khan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Cullen Jennings
Sent: Wednesday, August 10, 2005 7:40 AM
To: 'sipping'
Cc: 'Rohan Mahy'; 'David Bryan'; 'Dean Willis'; 'Allison Mankin';
'Gonzalo Camarillo'; 'Henning Schulzrinne'
Subject: [Sipping] Draft Notes from Ad-hoc on SIP peer-to-peer

Summary:

There was substantial interest in the topic of P2P SIP and around 125
people
showed up. It is clear that work in this area is being done by many
people
including, universities, start up companies, small and large established
vendors, and large service providers.

The group discussed some deployment scenarios that might be able to take
advantage of P2P technology including:

1. Emergency Ad-Hoc: Disaster and emergencies situations where
connectivity
to the global internet, including DNS root servers, was not possible

2. SOHO - Small offices or home networks where the devices discover the
other nearby devices and can perform services across them

3. Large Scale: Networks with no central server so that they are very
cheap
to operate and run but support many users

The group discussed some problems where P2P approaches might be a good
solution including:
1. Distributed Location Server: Use a distributed P2P system to
distribute
the register/location server information
2. Configuration Storage: Store configuration details for a phone across
the
networks
3. Voice Mail:
4. Address Book Storage
5. Reputation Systems
6. Gateway
7. Media Relay: (Distributed TURN servers)
8. Media Anonymization

Some issues that people would like to work on:
1. Scale: Both scaling up and down
2. Reliability
3. Federations
4. Trust Models
5. Identity
6. Namespaces
7. Data Storage

All the systems described had somewhat common approaches in that they
were
using DHTs as the underlying approach. Attention should be paid to when
it
is the right time to use P2P technology and when other approaches such
as
DNS and Multicast can provide a better solution.

Interesting comment that we should publish some of this before it all
gets
patented.

The HIP folks has formed both an IRTF and an IETF group. The folks here
should probably go look at these to gain a better understanding of the
function of both.

Next steps: There was some talk about what it might take to form a IETF
working group. There was substantially more talk about forming a IRTF
Research Group. There was not much feeling that this overlapped with the
interests of the current p2prg. Many people has a strong desire to have
a
full day metering where we could discuss this work in depth. Having this
in
Vancouver just before the November IETF meeting seemed like the most
realistic possibility and many people said they would come to this if it
happened.

Henry called for volunteers to help with this and help manage this, And
offered to provide help himself. Everyone provided mutual encouragement
to
join the email list and send some comments.

Raw Notes Below
------------------------------------------------------------------------
----
---

David Bryan presented a few slides on what he is working on.
Uses a DHT based on sip message to build a distributed a
Very many different ways that you could implement this

Work to be done
* use a DHT to do location vs. doing it in SIP
* traversing NATs
* using media relay NATs
* how do you know who is who
* security
* various routing algorithm, which to use

Use case
- Small enterprises simple admin
- Emergency - ad hoc comm.
- Large scale global communications

Problems Mentioned:
- Identity issues
- How to deal with DHT parameters for this type problem

There is p2psip.org page - community page. Glad to add stuff from
everyone
to page.

Folk Mathews - Nimcat
* having small office system
* working on commercial system today
* interested in DHT methods
* robustness important
* wrote a draft at previous IETF
* talks about things that are important
* what we need:
* Interesting problem s: How to scale,
* Their P2P layer is separate from SIP level.
* Interesting question - Alan J. draft, separate the P2P layer from SIP
and
doing it SIP. Not 100% clear what is best...
* Also use multicast to discover nodes. Also broadcast presence
information
via multicast.
* Everyone knows where everyone is via multicast registrations

Henning: 3 ways he has herd of to map
Cord like system
Copy of registration everywhere
Use DNS to map

Panasonic:
Conducting research in P2P
Want to connect consumer devices using SIP. Many types of works.
Similar to some of existing work.
Consumers devices have very intermittent network connectivity
Concerned about DHT stability in these.

Marc Bailly
France Telecom
Working P2P SIP. Understanding distribution of services. Use separation
of
SIP and DHT layer. Looking at IMS style services.

Henning's system:
Do ICE on each node
Use DHT to build a registration table

What can we use P2P for
- Rendezvous signaling
- Configuration storage
- Media storage - is this voicemail. Store voicemail for person who's
phone
is not available. Need .to work even when persons phone is not there.
Privacy of media. Trust model of forwarding information.
- Identity Assertion - Use P2P node to lead credibility to claim of
identity.
- Gateway - use gateways is home phones. Cheap gateways. Free World
Dialup
was originally this
- NAT/Media Relay - two sub cases - traversal - overlay network. Work on
picking optimal node. - overlay networks that route around problems to
avoid
congestion. Not BGP routing but higher layer.

- David Bryan add -> connect farms of proxies (like autonomic computing)
self organizing . Completely conventional SIP UA but use P@P in proxies.
- Interconnect of classical systems and P2P systems

- Cullen add -> Anonymize Signalling and Media
- Cullen -> Address Book
- Nick Papadoglou Vodaphone looked at P2P for ringbones and voicemail.
Always run into security and trust problems. Also looked at IMS and p2p
for
service discovery. Looking at where can I find this server or
distributed
finding out ring tones.

Problems

Scale
Reliability
Federation
Trust Modeless
Identity
How  do you do identity. Namespace. Stopping identity threat. Trusting
who
someone is.
Interconnect
Data Storage

Separation of basic uses and advanced user. Diagnosis and how to debug a
P2P
system How does administrator deal with it.

It is hard to debug P2P system because messages are all over places.

Jonathan Rosenberg - don't have to do everything P2P..

What's next:

There is a lot of interest in this. Document this soon before it all
gets
patented.
Henry S.  is willing to write up notes to make them understandable for
people who were not at the meeting.

Very roughly 125 people

Eunsoo Shim - Proposal to get a SIP P2P WG and start working on charter
for
BOF.

Henning had proposal of IRTF group.

Gonzales explaining about HIP. There is an IRTF HIP group and a HIP WG.
May
want to look at this model.

Concern about IRTF - there is no end to research. Progress is very slow.

Need more time to talk about points of commonality. Workshop, interim
meeting. Concrete proposal to have 1.5 day workshop around Vancouver.
Perhaps some demos of real things.

May be fairly close to experimental agreement -

John from Panasonic - P2p WG is chaired by co-author of JXTA. Do not
have
impression. - modeling of HIP approach. IRTF is very long term research
thing. Spending next few months for BOF that could happen next year
makes
sense.

Current  p2prg is all over the place. We are focusing very specific
problems
need faster better thing.

Trying to bring carrier in this effort

At the p2prg at IETF 61, it was less than 10 people. It was place to
meet
and present what they were doing.

Henry ask for some volunteers to spread the talent and get some project
management to get this done.

Things to do
* talk to p2p
* consider IRTF list
* consider setting up meeting around Vancouver

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Richard Shockey <[email-masked]>
Date: Fri, 12 Aug 2005 09:57:20 -0400

>5. Privacy (in trust models?)
This is absurd ... why dont you just call this the IMS P2P BOF instead.

-- 

Richard Shockey, Director - Member of Technical Staff
NeuStar Inc.
46000 Center Oak Plaza  -   Sterling, VA  20166
sip:rshockey(at)iptel.org   sip:57141(at)fwd.pulver.com
ENUM +87810-13313-31331
PSTN Office +1 571.434.5651 PSTN Mobile +1 703.593.2683
Fax: +1 815.333.1237
<mailto:richard(at)shockey.us> or 
<mailto:richard.shockey(at)neustar.biz>
<http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 12 Aug 2005 07:59:38 -0700

I was just reporting what happened in the meeting and I don't recall that
any of the 5 items below came up in the meeting. I pretty sure they did not.

---

From: Eunsoo Shim <[email-masked]>
Date: Fri, 12 Aug 2005 11:25:59 -0400

I don't recall those items either.
Regards,

Eunsoo

---

From: Juha Heinanen <[email-masked]>
Date: Fri, 12 Aug 2005 17:11:31 +0300

> This is absurd ... why dont you just call this the IMS P2P BOF

i fully agree.  my requirement would be that it MUST be impossible for
the network to figure out that a p2p sip session is in progress and what
is going on in it.

-- juha

---

From: "Dale Worley" <[email-masked]>
Date: Fri, 19 Aug 2005 13:13:12 -0400

> From: Juha Heinanen

> the network to figure out that a p2p sip session is in
> progress and what is going on in it.

In the strictest sense, that is impossible, because the network (in theory)
can examine all packets, and there's no way to notify the other end to start
a session without sending some packet that tells the other end to start a
session.

Barring absolute secrecy, though, what achievable reqirements would you
favor?

Dale

---

From: Juha Heinanen <[email-masked]>
Date: Fri, 19 Aug 2005 20:28:29 +0300

> a session without sending some packet that tells the other end to start a

yes, it is possible to detect that SOME session is in progress between
the parties, but not that that is a sip session.

 > Barring absolute secrecy, though, what achievable reqirements would you

see above.

-- juha