Subject: [Sipping] draft-rosenberg-sipping-acr-code-00.txt

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Thu, 5 Jan 2006 11:24:39 -0000

At the ad-hoc SIPPING meeting in Vancouver to discuss ETSI TISPAN issues, http://www.ietf.org/internet-drafts/draft-rosenberg-sipping-acr-code-00.txt was presented as the appropriate solution to the TISPAN issue of how to reject anonymous calls. Note that an anonymous call (where the identity has been explicitly withheld), and a call where the identity has failed to be transferred by the intervening signalling, are different things and the new proposed new status-code only applies to the former.

The need for users to be able to reject such calls, and the need to explicitly indicate the reason for rejection, are part of European regulatory requirements for voice calls.

The alternative approach identified by TISPAN was to include the existing PSTN/ISDN cause value in a Reason header in a response, but SIPPING people concluded that this was not a good idea.

ETSI TISPAN has agreed to use the proposed new status-code to solve this problem. The draft looks to be uncontentious and complete. Can I ask the WG chairs how they intend to progress the draft?

regards

Keith

Keith Drage
Lucent Technologies
[email-masked]
tel: +44 1793 776249

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Dean Willis <[email-masked]>
Date: Tue, 10 Jan 2006 11:34:48 -0600

Since the draft defines a new SIP response code, I believe it would  
need to be progressed through the SIP working group as a standards- 
track document.

Do we have a consensus in SIPPING on the fundamental requirements and  
the general approach? If so, we can forward this work to SIP for  
completion.

--
Dean

On Jan 5, 2006, at 5:24 AM, Drage, Keith (Keith) wrote:

> At the ad-hoc SIPPING meeting in Vancouver to discuss ETSI TISPAN  
> issues, http://www.ietf.org/internet-drafts/draft-rosenberg-sipping- 
> acr-code-00.txt was presented as the appropriate solution to the  
> TISPAN issue of how to reject anonymous calls. Note that an  
> anonymous call (where the identity has been explicitly withheld),  
> and a call where the identity has failed to be transferred by the  
> intervening signalling, are different things and the new proposed  
> new status-code only applies to the former.
>
> The need for users to be able to reject such calls, and the need to  
> explicitly indicate the reason for rejection, are part of European  
> regulatory requirements for voice calls.
>
> The alternative approach identified by TISPAN was to include the  
> existing PSTN/ISDN cause value in a Reason header in a response,  
> but SIPPING people concluded that this was not a good idea.
>
> ETSI TISPAN has agreed to use the proposed new status-code to solve  
> this problem. The draft looks to be uncontentious and complete. Can  
> I ask the WG chairs how they intend to progress the draft?
>
> regards
>
> Keith
>
> Keith Drage
> Lucent Technologies
> [email-masked]
> tel: +44 1793 776249
>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 10 Jan 2006 14:25:28 -0500

I vote YES.

Dean Willis wrote:
>> TISPAN issue of how to reject anonymous calls. Note that an  anonymous 
>> call (where the identity has been explicitly withheld),  and a call 
>> where the identity has failed to be transferred by the  intervening 
>> signalling, are different things and the new proposed  new status-code 
>> only applies to the former.
>>
>> existing PSTN/ISDN cause value in a Reason header in a response,  but 
>> SIPPING people concluded that this was not a good idea.
>>
>> this problem. The draft looks to be uncontentious and complete. Can  I 
>> ask the WG chairs how they intend to progress the draft?
>>
>> regards
>>
>> Keith
>>
>> Keith Drage
>> Lucent Technologies
>> [email-masked]
>> tel: +44 1793 776249
>>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 11 Jan 2006 00:42:09 -0500

I think the one and only requirement was to define a way to inform a 
caller that the call was rejected because the caller was anonymous, and 
the called party does not accept anonymous calls. I think there was 
general agreement on that requirement.

As such, I'm fine to forward this on to sip.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 11 Jan 2006 22:50:50 +0200

H Jonathan,

can you then submit a new revision of the draft as a SIP WG item? If 
there are no remaining open issues, it could be WGLCed right away... but 
that is up to the SIP WG chairs.

Cheers,

Gonzalo

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 11 Jan 2006 16:27:14 -0500

There is one minor issue raised by John, which I just responded to. Once 
thats concluded (should be easy) I'll resubmit as a SIP item.

Thanks,
Jonathan R.

Gonzalo Camarillo wrote:

>> caller that the call was rejected because the caller was anonymous, 
>> and the called party does not accept anonymous calls. I think there 
>> was general agreement on that requirement.
>>
>>> Do we have a consensus in SIPPING on the fundamental requirements 
>>> and  the general approach? If so, we can forward this work to SIP 
>>> for  completion.
>>>
>>> -- 
>>> Dean
>>>
>>>

---

From: Dean Willis <[email-masked]>
Date: Thu, 12 Jan 2006 10:26:19 -0600

It's also up to the area directors, who have to approve any new SIP  
work item. They usually say yes, but I failed the request yesterday  
and haven't seen a response yet.

--
Dean

On Jan 11, 2006, at 2:50 PM, Gonzalo Camarillo wrote:

> H Jonathan,
>
> can you then submit a new revision of the draft as a SIP WG item?  
> If there are no remaining open issues, it could be WGLCed right  
> away... but that is up to the SIP WG chairs.
>
> Cheers,
>
> Gonzalo
>
>> I think the one and only requirement was to define a way to inform  
>> a caller that the call was rejected because the caller was  
>> anonymous, and the called party does not accept anonymous calls. I  
>> think there was general agreement on that requirement.
>>> Since the draft defines a new SIP response code, I believe it  
>>> would  need to be progressed through the SIP working group as a  
>>> standards- track document.
>>>
>>>> At the ad-hoc SIPPING meeting in Vancouver to discuss ETSI  
>>>> TISPAN  issues, http://www.ietf.org/internet-drafts/draft- 
>>>> rosenberg-sipping- acr-code-00.txt was presented as the  
>>>> appropriate solution to the  TISPAN issue of how to reject  
>>>> anonymous calls. Note that an  anonymous call (where the  
>>>> identity has been explicitly withheld),  and a call where the  
>>>> identity has failed to be transferred by the  intervening  
>>>> signalling, are different things and the new proposed  new  
>>>> status-code only applies to the former.
>>>>
>>>> The need for users to be able to reject such calls, and the need  
>>>> to  explicitly indicate the reason for rejection, are part of  
>>>> European  regulatory requirements for voice calls.
>>>>
>>>> The alternative approach identified by TISPAN was to include  
>>>> the  existing PSTN/ISDN cause value in a Reason header in a  
>>>> response,  but SIPPING people concluded that this was not a good  
>>>> idea.
>>>>
>>>> ETSI TISPAN has agreed to use the proposed new status-code to  
>>>> solve  this problem. The draft looks to be uncontentious and  
>>>> complete. Can  I ask the WG chairs how they intend to progress  
>>>> the draft?
>>>>
>>>> regards
>>>>
>>>> Keith
>>>>
>>>> Keith Drage
>>>> Lucent Technologies
>>>> [email-masked]
>>>> tel: +44 1793 776249
>>>>

---

From: Dean Willis <[email-masked]>
Date: Thu, 12 Jan 2006 10:30:07 -0600

Restate. I FILED the request yesterday. -- that is, I sent it to  
Allison.

But I "failed" to say that clearly below. ;-)

--
Dean

On Jan 12, 2006, at 10:26 AM, Dean Willis wrote:

>>> I think the one and only requirement was to define a way to  
>>> inform a caller that the call was rejected because the caller was  
>>> anonymous, and the called party does not accept anonymous calls.  
>>> I think there was general agreement on that requirement.
>>>> Do we have a consensus in SIPPING on the fundamental  
>>>> requirements and  the general approach? If so, we can forward  
>>>> this work to SIP for  completion.
>>>>
>>>> -- 
>>>> Dean
>>>>
>>>>
>>>>> The need for users to be able to reject such calls, and the  
>>>>> need to  explicitly indicate the reason for rejection, are part  
>>>>> of European  regulatory requirements for voice calls.
>>>>>
>>>>> response,  but SIPPING people concluded that this was not a  
>>>>> good idea.
>>>>>