Subject: RE: [Sipping] The latest version of draft-xu-sipping-uruu-01.txttobediscussed on Friday Session

From: "Brian Stucker" <[email-masked]>
Date: Thu, 23 Mar 2006 23:12:50 -0600

Xu,

How does this draft differ in operation from RFC-3840 and RFC-3841 using the sip.class tag and the Accept-Contacts header? Seems redundant with existing mechanisms.

Regards,
Brian

-----Original Message-----
From: xupeili [mailto:[email-masked]]
Sent: Thursday, March 23, 2006 8:51 PM
To: Srivastava, Samir [SC100:8826:EXCH]
Cc: [email-masked]
Subject: Re: [Sipping] The latest version of
draft-xu-sipping-uruu-01.txttobediscussed on Friday Session

Hi Samir,

Thanks for your comments, please see inline.

----- Original Message ----- 
From: "Samir Srivastava" <[email-masked]>
To: "xupeili" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, March 23, 2006 7:08 PM
Subject: RE: [Sipping] The latest version of draft-xu-sipping-uruu-01.txtto bediscussed on Friday Session

Hi,

1. Section 4 states

"When the request with the extension name reaches the serving proxy of
   the callee, the proxy would query the location service with the AOR
   and extension name together as the key to find the exact contact of
   the associated UA instance.  After that, the proxy will forward the
   request to the destined UA(s) according to the query result.  Note
   that if the extension name is mapped to multiple contacts, the proxy
   may apply forking or some other policy. "

   How the existing Find Me / Follow Me kind of services will work with
this ?  I have configuration for my home phone to forward to Cell phone
unconditionally. Caller calls me on my home phone with extension name
whether it will be rejected in this case, or forwarded to cell phone. I
think it need more text explaining this. This extension looks to
supersede all other stuff, and callers wants to reach the particular
extension. 

<peili> 
There is an open issue whether uruu could have service treatment property.

If not, the forwarding logic may only apply to those part of the URI, e.g. AOR which have 
service treatment property and ommit the part of sub name when considering related services. 

If the AOR have service treatment property, the service profile should consider the existence of sub-names togother with its AOR.  For example, you may config forwarding on AOR, AOR with subname 1, AOR with subname 2, separately. And also you could have policy on the priority of those configurations.
</peili>

2.

      Req 6: if the user just provide the extension name when making the
      call, it mean he is to dial the other UAs under the same AOR.  And
      the system should treat the call as if he provide the AOR and
      extension name together.

SS>> How does complete AOR will be found, if user is dialing extension
(i.e. REQ URI has
 extension ), Where is the translation happening ? Or Serving Proxy with
this extension looks into other headers ?

<peili>
For this user requirment, it may be reasonable for UA to perfom the translation. 

The action depends on the forming of URUU and also the function of User Interface of UA.
For example, if there is extension button on the phone, the may know that; or if the user dial some special prefix....

Anyway this still need a lot of consideration.
</peili>

Thx
Samir

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "xupeili" <[email-masked]>
Date: Thu, 23 Mar 2006 23:53:58 -0600

Hi Brian,

This draft is not to invent the same mechanism as to repeat what rfc3840/3841 says.
It talks about such kind of services which may facility exiting mechanism, even though, how 
and how much to be used is not certain.

Also there are still sth more to be considered: 
1: Whether to use Accept-Contact? Since the uruu have some property of naming, and it may normally be published as a whole to others. The caller UA may not know this is a feature tag and should put it into Accept-Contact, since the caller just normally provide the whole address info got from say name card or url-link as the destination address.
2: Whether the uruu have the property of service treatment property?
3: Whether one UA may have multiple sub-name?

Thanks,
Peili

----- Original Message ----- 
From: "Brian Stucker" <[email-masked]>
To: "xupeili" <[email-masked]>; "Samir Srivastava" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, March 23, 2006 11:12 PM
Subject: RE: [Sipping] The latest version of draft-xu-sipping-uruu-01.txttobediscussed on Friday Session

Xu,

Regards,
Brian

-----Original Message-----
From: xupeili [mailto:[email-masked]]
Sent: Thursday, March 23, 2006 8:51 PM
To: Srivastava, Samir [SC100:8826:EXCH]
Cc: [email-masked]
Subject: Re: [Sipping] The latest version of

Hi Samir,

----- Original Message ----- 
From: "Samir Srivastava" <[email-masked]>
To: "xupeili" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, March 23, 2006 7:08 PM
Subject: RE: [Sipping] The latest version of draft-xu-sipping-uruu-01.txtto bediscussed on Friday Session

Hi,

1. Section 4 states

<peili> 

2.

<peili>

Thx
Samir