Subject: RE: [Sipping] Requirements for the identification of IMS communic ationservices.

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Sun, 26 Mar 2006 17:24:58 +0100

I am not aware that 3GPP specifies how any of these capabilities are partitioned up to application servers.

In particular for the telephony application server that I know you keep referring to, this is based on the current TISPAN specifications for provision of services using ISDN supplementary service definitions. TISPAN has not indicated any requirement to place all these on a single application server.

That may be the manner that a vendor chooses to package these to sell, but it is not what the specifications say.

regards

Keith

> -----Original Message-----
> From: Stephen Terrill (E2/EEM) [mailto:[email-masked]]
> Sent: 21 March 2006 19:06
> To: Paul Kyzivat
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; Gonzalo Camarillo (JO/LMF)
> Subject: RE: [Sipping] Requirements for the identification of IMS
> communicationservices.
> 
> 
> 
> Hi Paul,
> 
> >What is supposed to happen when interoperating with users that don't
> have the same concept of how to >partition capabilities into services?
> 
> This is what I thought that the identifier is to solve.
> 
> 
> 
> 
> So far, PoC; Messaging and Telephony have different 
> applications servers
> supporting them - they can, as an option, by combined, but 
> not required
> - do you agree with that?
> 
> Best Regards,
> 
> Stephen Terrill
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 27 Mar 2006 10:18:28 -0500

> I am not aware that 3GPP specifies how any of these capabilities are partitioned up to application servers.

I guess the question was originally addressed to me, and I never 
answered directly. Its good that Keith did, because I don't know the 
answer to Steve's question.

I am *concerned* that IMS may be suggesting/encouraging the partitioning 
of services in the way that Steve suggests, into mutually exclusive 
bundles - ignoring the potential value of combining them in a single call.

A mechanism that associates a request with a *single* service identifier 
substantiates my concern. But I am not yet certain the intent is to have 
a *single* service identifier.

I would be far less concerned if 3gpp had in their requirements the 
notion that services *are not* mutually exclusive, but rather a single 
request may desire multiple services.

> In particular for the telephony application server that I know you keep referring to, this is based on the current TISPAN specifications for provision of services using ISDN supplementary service d…

Since this "telephony application server" seems to be an important use 
case, perhaps it needs to be discussed in more detail are part of the 
process of defining the service identifier mechanism. More than any 
other, this may have the potential to break interoperability of sip 
telephony services implemented by different communities.

Similarly, the "messaging" service could harm interop of SIMPLE. It 
seems to me that we should all be striving for ways to enhance interop.

	Paul