Subject: [Sipping] The latest version of draft-xu-sipping-uruu-01.txt to be discussed on Friday Session

From: "xupeili" <[email-masked]>
Date: Thu, 23 Mar 2006 06:58:24 -0600

Hi All,

This is the updated draft-xu-sipping-uruu-01.txt which will be discussed at the Friday morning SIPPING session.

I have to send it as attachment before it can be seen on the id announce list.

The presentation will be based on the content provided in this version.
Please give your comments.

Best regards!
Peili

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Shida Schubert <[email-masked]>
Date: Thu, 23 Mar 2006 09:05:31 -0800

Hi Xu;

I had quick glance of the draft.

Can't you just use the opaque parameter
defined in GRUU? GRUU allows one to pre-configure
the opaque parameter on the Registrar prior to
its actual use.(As far as I remember from 06)

And using this property, I can easily imagine an
environment where SP provides an administrative
interface(Web) where user can map the instanceId
and user-defined name to be used in opaque
parameter.

I might have misinterpreted the GRUU spec, but
reading the 06 spec, something along the line of
what's mentioned above seems possible.

Also, user being able to change this naming property
on their end-device might not be desirable as mis
configuration and accident in configuration can
easily make the contact used before to be invalid.
i.e) My friend calls me at contact;uruu=home, I
unintentionally Register with uruu=rome, I
am no longer reachable with uruu=home.

Regards
Shida

xupeili wrote:
> Hi All,
> This is the updated draft-xu-sipping-uruu-01.txt which will be
> discussed at the Friday morning SIPPING session.

---

From: "xupeili" <[email-masked]>
Date: Thu, 23 Mar 2006 15:58:53 -0600

Hi Shida,

I am trying to answer your question:

1: The intention of GRUU and URUU is different.

a: GRUU is to make sure that the Call route to a specific UA 
instance, while URUU don`t have such property, one extention name
may still mappped to multiple UA instance, in this case GRUU must 
be used to specifically each of the UA instances even when they have 
the same extention name.

b: They are independent from each other, URUU may function even when 
the UA don`t support GRUU.

c: Your suggestion to map opaque to extention name actually put GRUU and URUU 
property on the same shoulder. This might work, but changes both mechanism.
One problem is that the user might not be interested in instance-id, he even can`t get it
when it is embeded in the phone.

2: For the miss-config problem.

Every coin have two sides. In your case if the caller make call to 
the AOR of the user, the call can still go through. If the caller really 
want to call the phone with uruu=home, and the callee really config his 
phone with uruu=room, the call will fail. But the same thing happens
when you mis-config other features, I don`t know if it can be solved techinically.