Subject: [Sipping] target parameter in History Info header

From: "Jesske, R" <[email-masked]>
Date: Mon, 27 Mar 2006 09:17:16 +0200

Dear all,
In the draft draft-jennings-sip-voicemail-uri-05 I found the following example of an INVITE:

5.4.  Endpoint forwards busy to Voicemail with History Info
...  

  F7: INVITE proxy.example.com -> um.example.com

    INVITE sip: [email-masked];\
           target=sip:+15555551002%40example.com;user=phone;\
           cause=486  SIP/2.0
    Via: SIP/2.0/TCP 192.0.2.4:5060;branch=z9hG4bK-ik80k7g-2
    Via: SIP/2.0/TCP 192.0.2.1:5060;branch=z9hG4bK-74bf9
    From: Alice <sip:[email-masked];user=phone>;tag=9fxced76sl
    To: sip:[email-masked];user=phone
    Call-ID: c3x842276298220188511
    CSeq: 1 INVITE
    Max-Forwards: 70
    Contact: <sip:[email-masked]>
    History-Info: <sip:[email-masked];user=phone >;index=1,
                  <sip:[email-masked]?Reason=SIP%3Bcause%3D302;\
                   text="Moved Temporarily">;index=1.1
                  <sip: [email-masked];\
                   target=sip:+15555551002%40example.com;user=phone;\
                   cause=486>;index=2
    Contact: <sip:[email-masked]>
    Content-Type: application/sdp
    Content-Length: *Body length goes here*

    * SDP goes here*

My question is now, if the use of the target parameter within the History-Info header is allowed or not. Or at least if the full Request URI content must be copied into the History-Info header.

Best Regards

Roland

Deutsche Telekom AG
T-Com Zentrale
Roland Jesske, TE332-2
Section TE33; Signalling, Gateways and Switching Systems 
 64307 Darmstadt, Germany
Phone:  +49 6151 83-5940 
Fax:      +49 6151 83-4577 
email:   [email-masked]

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 29 Mar 2006 11:19:55 +0100

Roland,
 
The complete URI must be copied into History-Info.
 
John

  _____  

From: Jesske, R [mailto:[email-masked]] 
Sent: 27 March 2006 08:17
To: [email-masked]
Cc: [email-masked]; [email-masked]; Elwell, John
Subject: target parameter in History Info header

Dear all, 
In the draft draft-jennings-sip-voicemail-uri-05 I found the following
example of an INVITE: 

    * SDP goes here* 

My question is now, if the use of the target parameter within the
History-Info header is allowed or not. Or at least if the full Request URI
content must be copied into the History-Info header.

Best Regards 

Roland 

Deutsche Telekom AG
T-Com Zentrale
Roland Jesske, TE332-2