Subject: RE: [Sipping] Use cases of [email-masked]

From: "LAI, SHOU WEN -HCHBJ" <[email-masked]>
Date: Tue, 7 Mar 2006 15:58:33 +0800

Hi, Kang,
 
I think I am still a little confused,
 
In the example as follows, there should be two way to avoid quality deterioration,
 
   +--+--+          +--+--+         +--+--+      +--+--+        +--+--+
   |    A   |-SIP->| T1'   |-SIP->| T2' |-SIP->| T3'   |-SIP->|  B   |
   |         |  a       | a-b  |            | b-c  | d        |  c-d  |  d       |        |
   |  a     |           | a-d  |            | a-d  |           |         |           |  d    |
   +-----+          +-----+        +-----+        +-----+          +-----+
1.  A(a) - T1'(a-d) - T2'(bypass) - T3'(bypass)-B(d) : just only time transcoding
2.  A(a) - T1'(bypass) - T2'(bypass) - T3'(bypass)-B(d) : just only time transcoding
 
Which one should be use? or if there are much more complex scenarios, for example,just two selection as follows, 
1.  A(a) - T1'(a-b) - T2'(b-d) - T3'(bypass)-B(d) : just only time transcoding 
2.  A(a) - T1'(bypass) - T2'(b-c) - T3'(c-d)-B(d) : just only time transcoding
The two have same quality deterioration, which one should be selected finally?
If there is such a rule you mentioned, it maybe difficult to design an algorithm to carry out the rule.
 
Thanks,
 
Lai

-----Original Message-----
From: Kang Tae-Gyu [mailto:[email-masked]]
Sent: Tuesday, March 07, 2006 3:10 PM
To: LAI, SHOU WEN -HCHBJ
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Sipping] Use cases of [email-masked]

Hi, Lai
 
Thank you for your comments.
some more comments in line.
 
Kang
=====================
From: "LAI, SHOU WEN -HCHBJ" <[email-masked]>
>From Date: 2006-03-07 PM 1:39:09
To: "Kang Tae-Gyu" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: [Sipping] Use cases of multi-transcoding

Hi Kang,
I think there are some problems in the draft.
In section 7, "Multi-transcoding Scenario",
The intention of the part is to explain how to build a transcoding chain from multiple transcoding node.
The case Scenario 1 is very simple and it is easy to build such a chain.
However, if T1 has also the capability of a-d, and T2 has also the capability b-d, and T3 also the campability c-d, how to build such a chain?
In this way? 

   +--+--+          +--+--+         +--+--+           +--+--+        +--+--+
   |    A   |-SIP->| T1'   |-SIP->| T2' |-SIP->| T3'   |-SIP->|  B   |
   |         |  a       | a-b  |  d       | b-c | d       |  c-d  |  d      |         |
   |  a     |           | a-d  |           | b-d  |          |          |           |  d    |
   +-----+          +-----+           +-----+           +-----+          +-----+

- -> Good comment.

- -> There are three kinds of alternetives.

- -> A1: A(a) - T1'(a-b) - T2'(b-c) - T3'(c-d) - B(d) : three times transcodings

- -> A2: A(a) - T1'(a-b) - T2'(b-d) - T3'(bypass)-B(d) : two times transcodings

- -> A3: A(a) - T1'(a-d) - T2'(bypass) - T3'(bypass)-B(d) : just only time transcoding

- -> We should A3 to avoide quality deterioration. 

- -> So, we explained the reordering rule in the draft.

or in this way?

   +--+--+          +--+--+         +--+--+           +--+--+        +--+--+
   |    A   |-SIP->| T1'   |-SIP->| T2' |-SIP->| T3'   |-SIP->|  B   |
   |         |  a       | a-b  |  b       | b-c |  d       |  c-d   |  d      |         |
   |  a     |           |         |           | b-d  |          |          |           |  d    |
   +-----+          +-----+           +-----+           +-----+          +-----+
or in another way? just as the one in the draft.    

- -> Good comment.

- -> There are two kinds of alternetives.

- -> A1: A(a) - T1'(a-b) - T2'(b-c) - T3'(c-d) - B(d) : three times transcodings

- -> A2: A(a) - T1'(a-b) - T2'(b-d) - T3'(bypass)-B(d) : two times transcodings

- -> same as above case.

- -> So, we need more consideration of a reodering rule, selection rule, and some response code for more perfect draft.

So when each transcoding node has multiple transcoding capabilities, the draft is not enough to deal with Multi-transcoding.

Lai

Disclaimer:
The contents of this e-mail, and its attachments, if any, are confidential and may be protected
by law against any unauthorized use.  If you have received this e-mail by mistake or have
reason to believe that you are not the intended recipient, please notify the sender by reply
e-mail as soon as possible and delete it from your computer system immediately thereafter.
If you are not the intended recipient, you must not copy this e-mail or attachment or disclose
the contents to any other person.  While we have made every effort to keep our network virus free,
we take no responsibility for any computer virus which might be transferred by way of this e-mail.

  <http://umail.etri.re.kr/External_ReadCheck.aspx?email=[email-masked]&name=LAI%2c+SHOU+WEN+-HCHBJ&fromemail=[email-masked]&messageid=[email-masked]%3E> 

Disclaimer:
The contents of this e-mail, and its attachments, if any, are confidential and may be protected
by law against any unauthorized use.  If you have received this e-mail by mistake or have
reason to believe that you are not the intended recipient, please notify the sender by reply
e-mail as soon as possible and delete it from your computer system immediately thereafter.
If you are not the intended recipient, you must not copy this e-mail or attachment or disclose
the contents to any other person.  While we have made every effort to keep our network virus free,
we take no responsibility for any computer virus which might be transferred by way of this e-mail.
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Kang Tae-Gyu" <[email-masked]>
Date: Tue, 7 Mar 2006 20:59:54 +0900

Hi, Lai

Thanks
- - > inline

Kang
------------------------------

Hi, Kang,

- -> 2.  A(a) - T1'(bypass) - T2'(a-d) - T3'(bypass)-B(d) : just only one time transcoding:  I modified at T2(a-d). Am I right?

- -> It should be used number 1 not 2. The reason is that T2' does not produce d because T2' received already d from T1'.  Also, T2' should not invoke the transcoder of T2' a-d.  Therefore the transcoder T1 can be used, not T2.

- -> It's depending on the codec quality among b, c, and d. If the quality is same, the transcoders can be selected number 1. Because the priority should be applied as OFFER/ANSWER; First come is higher priority.

If we make the rule as a standard, the algorithm to carry out the rule will be simple and easy.

If not, it will be mix up.

- -> Thanks for your question. Your question makes the draft more clarification.

Thanks,

Lai

-----Original Message-----
From: Kang Tae-Gyu [mailto:[email-masked]]
Sent: Tuesday, March 07, 2006 3:10 PM
To: LAI, SHOU WEN -HCHBJ
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Sipping] Use cases of [email-masked]

Hi, Lai

Kang

=====================

Hi Kang,

- -> Good comment.

or in this way?

- -> Good comment.

- -> same as above case.

Lai

Disclaimer:

Disclaimer: The contents of this e-mail, and its attachments, if any, are confidential and may be protected by law against any unauthorized use. If you have received this e-mail by mistake or have reason to believe that you are not the intended recipient, please notify the sender by reply e-mail as soon as possible and delete it from your computer system immediately thereafter. If you are not the intended recipient, you must not copy this e-mail or attachment or disclose the contents to any other person. While we have made every effort to keep our network virus free, we take no responsibility for any computer virus which might be transferred by way of this e-mail.