Subject: RE: [Sipping] Use cases of multi-transcoding

From: "LAI, SHOU WEN -HCHBJ" <[email-masked]>
Date: Tue, 7 Mar 2006 12:39:09 +0800

Hi Kang,

I think there are some problems in the draft.

In section 7, "Multi-transcoding Scenario",
 
The intention of the part is to explain how to build a transcoding chain from multiple transcoding node.
 
The case Scenario 1 is very simple and it is easy to build such a chain. 
 
However, if T1 has also the capability of a-d, and T2 has also the capability b-d, and T3 also the campability c-d, how to build such a chain?
 
In this way?  

   +--+--+          +--+--+         +--+--+           +--+--+        +--+--+ 
   |    A   |-SIP->| T1'   |-SIP->| T2' |-SIP->| T3'   |-SIP->|  B   | 
   |         |  a       | a-b  |  d       | b-c |  d       |          |  d      |         | 
   |  a     |           | a-d  |           | b-d  |          |          |           |  d    | 
   +-----+          +-----+           +-----+           +-----+          +-----+ 
or in this way?

   +--+--+          +--+--+         +--+--+           +--+--+        +--+--+ 
   |    A   |-SIP->| T1'   |-SIP->| T2' |-SIP->| T3'   |-SIP->|  B   | 
   |         |  a       | a-b  |  b       | b-c |  d       |          |  d      |         | 
   |  a     |           |         |           | b-d  |          |          |           |  d    | 
   +-----+          +-----+           +-----+           +-----+          +-----+ 

or in another way? just as the one in the draft.                                                    

So when each transcoding node has multiple transcoding capabilities, the draft is not enough to deal with Multi-transcoding.
 
Lai

Disclaimer:
The contents of this e-mail, and its attachments, if any, are confidential and may be protected
by law against any unauthorized use.  If you have received this e-mail by mistake or have
reason to believe that you are not the intended recipient, please notify the sender by reply
e-mail as soon as possible and delete it from your computer system immediately thereafter.
If you are not the intended recipient, you must not copy this e-mail or attachment or disclose
the contents to any other person.  While we have made every effort to keep our network virus free,
we take no responsibility for any computer virus which might be transferred by way of this e-mail.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Kang Tae-Gyu" <[email-masked]>
Date: Tue, 7 Mar 2006 16:10:16 +0900

Hi, Lai

Thank you for your comments.

some more comments in line.

Kang

=====================
From: "LAI, SHOU WEN -HCHBJ" <[email-masked]>
From Date: 2006-03-07 PM 1:39:09
To: "Kang Tae-Gyu" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: [Sipping] Use cases of multi-transcoding

Hi Kang,

|         |  a       | a-b  |  d       | b-c | d       |  c-d  |  d      |         |

- -> Good comment.

- -> There are three kinds of alternetives.

- -> A1: A(a) - T1'(a-b) - T2'(b-c) - T3'(c-d) - B(d) : three times transcodings

- -> A2: A(a) - T1'(a-b) - T2'(b-d) - T3'(bypass)-B(d) : two times transcodings

- -> A3: A(a) - T1'(a-d) - T2'(bypass) - T3'(bypass)-B(d) : just only time transcoding

- -> We should A3 to avoide quality deterioration.

- -> So, we explained the reordering rule in the draft.

or in this way?

|         |  a       | a-b  |  b       | b-c |  d       |  c-d   |  d      |         |

- -> Good comment.

- -> There are two kinds of alternetives.

- -> A1: A(a) - T1'(a-b) - T2'(b-c) - T3'(c-d) - B(d) : three times transcodings

- -> A2: A(a) - T1'(a-b) - T2'(b-d) - T3'(bypass)-B(d) : two times transcodings

- -> same as above case.

- -> So, we need more consideration of a reodering rule, selection rule, and some response code for more perfect draft.

Lai

Disclaimer:

---

From: "Kang Tae-Gyu" <[email-masked]>
Date: Tue, 7 Mar 2006 16:30:29 +0900

Hi, Henry

If industry has a specific "internet codec", SIP/SDP will be more simple signaling protocol.

But, I believe that SIP/SDP tries to support any codec and any media.

I think that the making default codec is another issue.

Thanks,

Kang

--------------------------------------------------------
The numerous wireline legacy ITU-T G.7xx codecs and other countless codecs
deployed for mobile phones are a disgrace IMHO.

The industry would be better off adopting "Internet codecs":
The iLBC RFC 3951 and RFC 3952 as the default codec and SPEEX for variable
rate wideband
(ftp://ftp.rfc-editor.org/in-notes/internet-drafts/draft-ietf-avt-rtp-speex-
00.txt).

Thanks, Henry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, February 21, 2006 8:29 AM
To: Kang Tae-Gyu
Cc: [email-masked]
Subject: Re: [Sipping] Use cases of multi-transcoding

Hi Kang,

just a comment to the transcoding scenario between two different WB codecs
(WB1<->WB2).

Transcoding as such should be avoided because it is inherently decreasing
the audio/speech quality ("adds e.g., delay impairments and Ie, equipment
impairment factors") and an "expensive" network function.
There must be therefore an agreed justifaction, particularly for WB1<->WB2
transcoding scenarios!

Transcoding between two different NB codecs (NB1<->NB2) is often
inevitable.

The difference with WB codecs is that terminals "should support a fallback
mode to a NB codec" in my opinion. There are two possibilities:
NB mode is part of the WB codec modes of operation (e.g., G.729EV
with G.729A as NB mode), or
separate NB codec (e.g., terminal concept according G.725).

The inconsistent "WB1<->WB2" E2E scenario might then lead to fallbacks to
(default) NB codecs. In case of a then "NB1<->NB2" inconsistency to NB
transcoding in the network.

Comments?

Albrecht

"Kang Tae-Gyu"

<[email-masked].         To:      <[email-masked]>

kr>                      cc:      [email-masked],
[email-masked], [email-masked],
[email-masked]

21.02.2006 03:12         Subject: [Sipping] Use cases
of multi-transcoding
Please respond

to Kang Tae-Gyu

Hello,

I would like to discuss about the use case of multi-transcoding. First of
all, I am sorry for that I could not answer about its use case when I
received the question from the floor, IETF 64 Vancouver meeting, because of
poor English. Also, thank you for the minutes(chairmen and note takers).

There are three kinds of use cases of multi-transcoding.
-    one or two more heterogeneous networks
-    one or two more ITSPs
-    one or two more wideband speech codecs

There are one or two more heterogeneous networks: enterprise networks using
IP-PBX, ITSP(Internet Telephony Service Provider), IMS in 3GPP2,
PacketCable, and Wibro. They will not use a common codec. So, they need
multi transcoding such as;
-    use case 1: A(a) - IP PBX T1(a-b) - ITSP T2(b-c, b-d) - IMS T3(a-d,
d-e) - D(d)
-    use case 2: A(a) - IP PBX T1(a-b) - ITSP T2(b-c, b-d) - PacketCable
T4(c-d) - F(d)
-    use case 3: E(e) - IMS T3(a-d, e-d) - ITSP T2(b-c, b-d) - Wibro
T4(a-d, d-c) - G(c)

There are one or two more ITSPs or SBC because all of internet telephony
subscribers will not subscribe only one ITSP. There are a lot of domestic
ITSPs and international ITSPs or ITXP. Internet telephony should be
supported any kind of terminal vendor even though it supports any specific
codec. It also supports multi call forwarding service. So, they need multi
transcoding such as;
-    use case 4: C(c) - ITSP T2(c-b, b-d) - ITSP T6(b-a, b-d) - ITSP7
T7(a-d, d-e) - G(d)

There are one or two more wideband speech codecs. There has been developing
one or two more wideband speech codecs for internet telephony: AMR-WB in
3GPP, VMR-WB in 3GPP2, G.729EV in ITU-T SG 16 Question 10, a wideband codec
in ITU-T SG 16 Question 9, and AAC in ISO/IEC. In this convention, Capital
letter means a node and lowercase(a, b, c, d, and e) means a codec.

A wideband codec encodes voice using 16,000 samples per second (50 ~
7,000Hz), as opposed to the 8,000 samples per second (300 ~ 3,400Hz) by
narrowband codec. A voice quality of wideband codec is better than one of
narrowband codec due to support wider band. A tandem transcoding means to
encode narrowband codec such as G.711. So, it makes down sampling and worse
the voice quality. If two parties(calling party and called party) have two
different wideband codecs, transcoders should transcode a wideband codec to
another wideband codec without tandem transcoding. If we use a common codec
with G.711(tandem), there is no more need multi-transcoding. But, we need a
multi-transcoding for supplying a wideband speech high quality to each
sides.
-    use case 5: wideband codec to wideband codec without tandem
transcoding

Multi transcoding signaling can be useful for internet telephony
environments supported by standard; an example VoIP network in quality of
service for next generation Voice over IP networks, MSF-TR-QoS-001.final,
2003 Feb, and Telecommunications and Internet Protocol Harmonization over
Networks (TIPHON) Release 3; End-to-End Quality of Service in TIPHON
Systems; Part 3: Signalling and Control of End-to-End Quality of Service
(QoS)-V2.1.2, 2002.

Multi trascoder can cover the use case using one or two more conference
bridge transcoding model.

We would like to discuss open these use cases or another use case. Comments
are welcome.

Thanks,
Kang

---

From: "Henry Sinnreich" <[email-masked]>
Date: Tue, 7 Mar 2006 08:23:43 -0600

Kang,

It seems there are several issues in this debate (in increasing order of
disruption :-) ):

1.	Are there too many codecs around? If yes, what is the minimum number
of codecs that should be supported? What is the recommended default codec?
(As mentioned, my pick is iLBC as the default and SPEEX for wideband).

2.	Can transcoding between domains be avoided or at least minimized?
(Hint: Avoided at all cost).

3.	Why are intermediate VoIP domains necessary at all, when e2e
services like Skype have proven to be successful and having the best audio
quality (apart from the e2e QoS debate)? Editorial: Intermediate VoIP
domains are IMHO a revenue objective, but have no technical justification on
the e2e Internet and no amount of politics can prevail in the long term over
sound technology.

Thanks, Henry

  _____  

From: Kang Tae-Gyu [mailto:[email-masked]] 
Sent: Tuesday, March 07, 2006 1:30 AM
To: Henry Sinnreich; [email-masked]
Cc: [email-masked]
Subject: RE: [Sipping] Use cases of multi-transcoding

Hi, Henry

If industry has a specific "internet codec", SIP/SDP will be more simple
signaling protocol.

Thanks, 

Kang

Thanks, Henry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, February 21, 2006 8:29 AM
To: Kang Tae-Gyu
Cc: [email-masked]
Subject: Re: [Sipping] Use cases of multi-transcoding

Hi Kang,

Comments?

Albrecht

                      "Kang Tae-Gyu"

                      to Kang Tae-Gyu

Hello,

Thanks,
Kang

 
<http://umail.etri.re.kr/External_ReadCheck.aspx?email=[email-masked]&name
=Henry+Sinnreich&fromemail=[email-masked]&messageid=%3C8ebc20e7-ea62-438c
[email-masked]%3E>

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 8 Mar 2006 12:52:31 -0000

Laudible aim, but is this not like trying to mandate a single operating sustem for the Internet.
 
And your decision will depend on what percentage of traffic you see interworking with existing telephony systems using your non-preferred codecs versus those which can be IP telephone end-to-end. If you need to interwork, then to avoid transcoding you need to use the default of the network you are interworking with (and therefore one of G.711, AMR or EVRC). The decision of the optimum coding will depend on whether transcoding there reduces the need to transcode on other types of call.
 
And I assume of course that once IETF have made this decision Skype will also change?
 
regards
 
Keith

-----Original Message-----
From: Roy, Radhika R. [mailto:[email-masked]]
Sent: 07 March 2006 19:08
To: [email-masked]
Subject: RE: [Sipping] Use cases of multi-transcoding

Hi, Kang, Henry, and all:

It is the time to select "DEFAULT" codec by the IETF for the Internet. SIPPING/SIP WG needs to mandate this. 

(In olden days, ITU-T defined their default G.711 audio codec for the IP Network mandating PSTN network interoperability [ridiculous!!]. Then IMTC did something mandating a lower-speed codec.)

Some proposals are coming from your side. Can we get the consensus to mandate these requirements for the Internet to the benefit of the users?

Best regards,

Radhika

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of Henry Sinnreich
Sent: Tuesday, March 07, 2006 9:24 AM
To: Kang Tae-Gyu; [email-masked]
Cc: [email-masked]
Subject: RE: [Sipping] Use cases of multi-transcoding

Kang,

It seems there are several issues in this debate (in increasing order of disruption :-) ):

1.	Are there too many codecs around? If yes, what is the minimum number of codecs that should be supported? What is the recommended default codec? (As mentioned, my pick is iLBC as the default and SPEEX for wideband). 

2.	Can transcoding between domains be avoided or at least minimized? (Hint: Avoided at all cost). 

3.	Why are intermediate VoIP domains necessary at all, when e2e services like Skype have proven to be successful and having the best audio quality (apart from the e2e QoS debate)? Editorial: Intermediate VoIP domains are IMHO a revenue objective, but have no technical justification on the e2e Internet and no amount of politics can prevail in the long term over sound technology. 

Thanks, Henry

  _____  

Hi, Henry

Thanks, 

Kang

The industry would be better off adopting "Internet codecs":
The iLBC RFC 3951 and RFC 3952 as the default codec and SPEEX for variable
rate wideband
( ftp://ftp.rfc-editor.org/in-notes/internet-drafts/draft-ietf-avt-rtp-speex- <ftp://ftp.rfc-editor.org/in-notes/internet-drafts/draft-ietf-avt-rtp-speex-> 
00.txt).

Thanks, Henry

-----Original Message-----
From: [email-masked] [ mailto:[email-masked] <mailto:[email-masked]> ]
Sent: Tuesday, February 21, 2006 8:29 AM
To: Kang Tae-Gyu
Cc: [email-masked]
Subject: Re: [Sipping] Use cases of multi-transcoding

Hi Kang,

Comments?

Albrecht

                      "Kang Tae-Gyu"

                      to Kang Tae-Gyu

Hello,

Thanks,
Kang

Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping <https://www1.ietf.org/mailman/listinfo/sipping> 

Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping <https://www1.ietf.org/mailman/listinfo/sipping> 

  <http://umail.etri.re.kr/External_ReadCheck.aspx?email=[email-masked]&name=Henry+Sinnreich&fromemail=[email-masked]&messageid=[email-masked]%3E>

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Wed, 8 Mar 2006 16:21:06 -0500

Henry,

Free != IPR-free

Mike

> From: Henry Sinnreich [mailto:[email-masked]] 
> Sent: Wednesday, March 08, 2006 8:32 AM
> To: [email-masked]; 'Roy, Radhika R.'; [email-masked]
> Brian,
> >I don't think vendor's opinion has changed, and I don't 
> think you can 
> >mandate any standard except G.711.
> 
> In pessimistic mood today? :-)>
> 
> Not only has Skype shown that VoIP quality can go over the 
> deplorable 5.0 MOS scale, but that also echo control, side 
> tone control, automatic level control, noise cancellation, 
> wideband audio, etc. can be deployed in a free download 150 
> million times! (5,467,770 users right now on line).
> 
> Opinions of many decision makers has changed as a consequence.
> 
> G.7xx codecs should however be paid due reverence is history books.
> 
> Roy is right:
> 
> >It is the time to select “DEFAULT” codec by the IETF for the 
> Internet. >SIPPING/SIP WG needs to mandate this.
> 
> Thanks, Henry 
> 
> 
> From: Brian Rosen [mailto:[email-masked]]
> Sent: Wednesday, March 08, 2006 7:05 AM
> To: 'Roy, Radhika R.'; [email-masked]
> You know, I've always thought the default codec for VoIP 
> should be a wideband codec, with G.711 provided for backwards 
> compatibility only.  If VoIP always implied 
> better-than-"toll-quality", it would mean something different 
> than it does now.  We showed this in user trials.  Skype 
> showed how true this is in the wild. 
> 
> Vendors never agreed; they were all looking to duplicate 
> black phones.  Customers don't know enough to ask; it only 
> rarely shows up on wish lists and almost never on 
> requirements documents.  They don't know what they are 
> missing and how little it costs to substantially improve user 
> experience.
> 
> We found really odd problems trying to do it.  The one that 
> really hurt was if you want a handset that was wideband AND 
> met disability requirements for hearing aid compatibility, 
> there were no choices; you had to literally build your own 
> handset, with hard-to-find components.
> 
> I don't think vendor's opinion has changed, and I don't think 
> you can mandate any standard except G.711.  I don't think 
> I've seen a wired SIP phone that didn't do G.711.  Not really 
> sure if there has been a wireless one offered.  
> 
> Brian
> 
> 
> 
> ________________________________________
> Sent: Tuesday, March 07, 2006 2:08 PM
> To: [email-masked]
> It is the time to select “DEFAULT” codec by the IETF for the 
> Internet. SIPPING/SIP WG needs to mandate this. 
> 
> (In olden days, ITU-T defined their default G.711 audio codec 
> for the IP Network mandating PSTN network interoperability 
> [ridiculous!!]. Then IMTC did something mandating a 
> lower-speed codec.)
> 
> Some proposals are coming from your side. Can we get the 
> consensus to mandate these requirements for the Internet to 
> the benefit of the users?
> 
> Best regards,
> Radhika
> 
> ________________________________________
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Henry Sinnreich
> It seems there are several issues in this debate (in 
> increasing order of disruption ☺ ):
> 
> 1. Are there too many codecs around? If yes, what is the 
> minimum number of codecs that should be supported? What is 
> the recommended default codec? (As mentioned, my pick is iLBC 
> as the default and SPEEX for wideband).
> 
> 3. Why are intermediate VoIP domains necessary at all, when 
> e2e services like Skype have proven to be successful and 
> having the best audio quality (apart from the e2e QoS 
> debate)? Editorial: Intermediate VoIP domains are IMHO a 
> revenue objective, but have no technical justification on the 
> e2e Internet and no amount of politics can prevail in the 
> long term over sound technology.
> Thanks, Henry
> ________________________________________
> The numerous wireline legacy ITU-T G.7xx codecs and other 
> countless codecs deployed for mobile phones are a disgrace IMHO.
> 
> The iLBC RFC 3951 and RFC 3952 as the default codec and SPEEX 
> for variable rate wideband
> just a comment to the transcoding scenario between two 
> different WB codecs (WB1<->WB2).
> 
> Transcoding as such should be avoided because it is 
> inherently decreasing the audio/speech quality ("adds e.g., 
> delay impairments and Ie, equipment impairment factors") and 
> an "expensive" network function.
> There must be therefore an agreed justifaction, particularly 
> for WB1<->WB2 transcoding scenarios!
> 
> Transcoding between two different NB codecs (NB1<->NB2) is 
> often inevitable.
> 
> The difference with WB codecs is that terminals "should 
> support a fallback mode to a NB codec" in my opinion. There 
> are two possibilities:
> (default) NB codecs. In case of a then "NB1<->NB2" 
> inconsistency to NB transcoding in the network.
> 
> Comments?
> 
> Albrecht
> 
> 
> 
> 
> 
> 
>                       "Kang Tae-Gyu"
> 
>                       <[email-masked].         To:      
> <[email-masked]>
> 
>                       kr>                      cc:      
> [email-masked],
> I would like to discuss about the use case of 
> multi-transcoding. First of all, I am sorry for that I could 
> not answer about its use case when I received the question 
> from the floor, IETF 64 Vancouver meeting, because of poor 
> English. Also, thank you for the minutes(chairmen and note takers).
> 
> There are one or two more heterogeneous networks: enterprise 
> networks using IP-PBX, ITSP(Internet Telephony Service 
> Provider), IMS in 3GPP2, PacketCable, and Wibro. They will 
> not use a common codec. So, they need multi transcoding such as;
> There are one or two more ITSPs or SBC because all of 
> internet telephony subscribers will not subscribe only one 
> ITSP. There are a lot of domestic ITSPs and international 
> ITSPs or ITXP. Internet telephony should be supported any 
> kind of terminal vendor even though it supports any specific 
> codec. It also supports multi call forwarding service. So, 
> they need multi transcoding such as;
> There are one or two more wideband speech codecs. There has 
> been developing one or two more wideband speech codecs for 
> internet telephony: AMR-WB in 3GPP, VMR-WB in 3GPP2, G.729EV 
> in ITU-T SG 16 Question 10, a wideband codec in ITU-T SG 16 
> Question 9, and AAC in ISO/IEC. In this convention, Capital 
> A wideband codec encodes voice using 16,000 samples per 
> second (50 ~ 7,000Hz), as opposed to the 8,000 samples per 
> second (300 ~ 3,400Hz) by narrowband codec. A voice quality 
> of wideband codec is better than one of narrowband codec due 
> to support wider band. A tandem transcoding means to encode 
> narrowband codec such as G.711. So, it makes down sampling 
> and worse the voice quality. If two parties(calling party and 
> called party) have two different wideband codecs, transcoders 
> should transcode a wideband codec to another wideband codec 
> without tandem transcoding. If we use a common codec with 
> G.711(tandem), there is no more need multi-transcoding. But, 
> we need a multi-transcoding for supplying a wideband speech 
> high quality to each sides.
> Multi transcoding signaling can be useful for internet 
> telephony environments supported by standard; an example VoIP 
> network in quality of service for next generation Voice over 
> IP networks, MSF-TR-QoS-001.final,
> 2003 Feb, and Telecommunications and Internet Protocol 
> Harmonization over Networks (TIPHON) Release 3; End-to-End 
> Quality of Service in TIPHON Systems; Part 3: Signalling and 
> Control of End-to-End Quality of Service (QoS)-V2.1.2, 2002.
> 
> Multi trascoder can cover the use case using one or two more 
> conference bridge transcoding model.
> 
> We would like to discuss open these use cases or another use 
> case. Comments are welcome.
> 
> Thanks,
> Kang
> 
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 
> 
> 
> 
> 
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 
> 
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 
> 
> 
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>

---

From: "Kang Tae-Gyu" <[email-masked]>
Date: Fri, 10 Mar 2006 12:38:09 +0900

Henry,

in line

Thanks, Kang
----------------------------------

It seems there are several issues in this debate (in increasing order of disruption J ):

Are there too many codecs around? If yes, what is the minimum number of codecs that should be supported? What is the recommended default codec? (As mentioned, my pick is iLBC as the default and SPEEX for wideband).

--> Yes, there are too many codecs; G.711 in PSTN, AMR in GSM/3GPP, EVRC, QCELP
or SMV in 3GPP2, G.723.1, G.729, G.711, internet Low Bit Rate Codec (iLBC) for narrowband VoIP, AMR-WB in 3GPP,  VMR-WB in 3GPP2, G.729EV in ITU-T SG 16 Question 10, a wideband codec
in ITU-T SG 16 Question 9, AAC(Advanced Audio Coding), and Speex.

--> I wonder whether we are able to select a default codec. I believe that open market is better than closed one.

Can transcoding between domains be avoided or at least minimized? (Hint: Avoided at all cost).

--> I agree with you that we should make an effort to avoide or at least minimized transcoding between domains even if  we have a default speech codec.

--> But, minimized transcoding is inevitable in real networks.

--> So, my draft is a kind of efforts for minimizing transcoding in multi-network, multi-ITSP, multi-terminal verdor, and multi-codec existence environment.

Why are intermediate VoIP domains necessary at all, when e2e services like Skype have proven to be successful and having the best audio quality (apart from the e2e QoS debate)? Editorial: Intermediate VoIP domains are IMHO a revenue objective, but have no technical justification on the e2e Internet and no amount of politics can prevail in the long term over sound technology.

--> I prefer to share a VoIP industry rather than to dominate by powerful something.

Hi, Henry

Thanks,

Kang

Thanks, Henry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, February 21, 2006 8:29 AM
To: Kang Tae-Gyu
Cc: [email-masked]
Subject: Re: [Sipping] Use cases of multi-transcoding

Hi Kang,

Comments?

Albrecht

"Kang Tae-Gyu"

to Kang Tae-Gyu

Hello,

Thanks,
Kang

---

From: "Roy, Radhika R." <[email-masked]>
Date: Fri, 10 Mar 2006 11:49:11 -0500

Folks:

I am just reacting to default codec vs. codecs in the Open market. The
important points are as follows:

1.	Is it worthwhile to bear the burden of price and (degrading)
quality/QoS through supporting all possible codecs and transcoding by
general public if there is no default codec?
2.	Is not the objective of the standardization to improve the price and
quality/QoS for the sake of mass marketing?
3.	If the default codec is not chosen, who is going to be benefited?
Will the mass population of the whole world reap benefits as the IETF is
after if the default codec is not chosen?
4.	Is it not the time the SIP/SIPPING and IETF

Best regards,

Radhika

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Kang Tae-Gyu
Sent: Thursday, March 09, 2006 10:38 PM
To: Henry Sinnreich; [email-masked]
Cc: [email-masked]
Subject: RE: [Sipping] Use cases of multi-transcoding

Henry,

in line 

Thanks, Kang

--> Yes, there are too many codecs; G.711 in PSTN, AMR in GSM/3GPP, EVRC,
QCELP 
   or SMV in 3GPP2, G.723.1, G.729, G.711, internet Low Bit Rate Codec
(iLBC) for narrowband VoIP, AMR-WB in 3GPP,  VMR-WB in 3GPP2, G.729EV in
ITU-T SG 16 Question 10, a wideband codec 
   in ITU-T SG 16 Question 9, AAC(Advanced Audio Coding), and Speex.

--> I wonder whether we are able to select a default codec. I believe that
open market is better than closed one.

      --> I agree with you that we should make an effort to avoide or at
least minimized transcoding between domains even if  we have a default
speech codec.

      --> So, my draft is a kind of efforts for minimizing transcoding in
multi-network, multi-ITSP, multi-terminal verdor, and multi-codec existence
environment.

      --> I prefer to share a VoIP industry rather than to dominate by
powerful something.

  _____  

Hi, Henry

Thanks, 

Kang

The industry would be better off adopting "Internet codecs":
The iLBC RFC 3951 and RFC 3952 as the default codec and SPEEX for variable
rate wideband
(ftp://ftp.rfc-editor.org/in-notes/internet-drafts/draft-ietf-avt-rtp-speex-
<ftp://ftp.rfc-editor.org/in-notes/internet-drafts/draft-ietf-avt-rtp-speex-
00.txt).

Thanks, Henry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]
<mailto:[email-masked]> ]
Sent: Tuesday, February 21, 2006 8:29 AM
To: Kang Tae-Gyu
Cc: [email-masked]
Subject: Re: [Sipping] Use cases of multi-transcoding

Hi Kang,

Comments?

Albrecht

                      "Kang Tae-Gyu"

                      to Kang Tae-Gyu

Hello,

Thanks,
Kang

<https://www1.ietf.org/mailman/listinfo/sipping> 

<https://www1.ietf.org/mailman/listinfo/sipping> 

<http://umail.etri.re.kr/External_ReadCheck.aspx?email=[email-masked]&name
=sipping%40ietf.org&fromemail=[email-masked]&messageid=%3Ca1c4039b-1e73-4
[email-masked]%3E>