Subject: RE: [Sipping] RE: Status of draft-ietf-sipping-toip-04.txt

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Mon, 13 Mar 2006 11:11:30 -0000

Can I remind everybody that this draft is meant to be a working group item.

It is not meant to reflect the opinion of any author, but the opinion of the working group. If an author disagrees with the contents of a working group item, then tough - the author either implements the working group agreement or resigns - - or if sufficient problems are created, is removed.

I would suggest the main problem with this draft is that potentially there has been two much internal discussion about the contents between the authors, and insufficient expression of working group opinion by the working group. If I remember correctly, Gonzalo's comments about scope way back got nil, or pretty much nil, response.

Perhaps we need to address the lack of involvement of the working group.

regards

Keith

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: 12 March 2006 21:11
> To: Tom-PT Taylor; [email-masked]; Dean Willis; Rohan
> Mahy
> Cc: Gunnar Hellstrom; sipping
> Subject: Re: [Sipping] RE: Status of draft-ietf-sipping-toip-04.txt
> 
> 
> 
> I have no idea what the right thing to do here is but I note 
> that our fine
> chairs could also slim down the list of editors on this 
> document if they
> thought that was the right thing. So if Dean feels like moping up some
> spilled beer....
> 
> Seriously, if this draft (I underline draft) was published 
> without some
> authors permission, one way or another, we can clean that up 
> as soon as the
> black out period ends. If any individual, author or not, has 
> strong opinions
> about what is right or wrong with the document I'm sure the 
> folk on the list
> would be interested in constructive feedback about how to 
> improve things. As
> Tom points out, drafts are a great way to do this.
> 
> Cullen  
> 
> On 3/12/06 12:54 PM, "Tom-PT Taylor" <[email-masked]> wrote:
> 
> > I have a serious suggestion to end this silly discussion. 
> Why don't you
> > remove yourself as author and write the document you 
> believe should be
> > written? AFAIK this isn't really your area of expertise, 
> but if you have
> > some important ideas to contribute, don't hobble yourself with
> > co-authors who have differing views.
> > 
> > Roy, Radhika R. wrote:
> >> Gunnar and all:
> >>  
> >> The editor is saying that the draft is complete. You are 
> saying that the
> >> draft has been sent as in interim to take care of 
> comments. Why is this
> >> contradiction? Does the editor is working in good faith? 
> When I raised the
> >> question you told that it is good to send the to show some 
> "progress." So,
> >> you also agreed that this is an "interim" draft.
> >>  
> >> With respect to WGLC, I did not provide my comments 
> officially in the IETF
> >> list as this draft was sent without my approval white it 
> has been sent to
> >> take care of WGLCs. So, I waited to work with the group to 
> provided my
> >> comments. The editor did NOT sent the draft while I was 
> requesting almost
> >> for the last 3 months. To our surprise, the editor sent 
> the draft to all of
> >> us only couple of days ago. I raised the objections, and 
> then I provided my
> >> comments. The editor failed to act accordingly.
> >>  
> >> The day before yesterday, the editor wanted to know couple 
> of things when I
> >> sent my comments in the IETF mailing list such as what it 
> is the difference
> >> QoS support over the LAN and the IP network for ToIP. I 
> explained to him to
> >> clarifying his mis-conceptions (I have copies of emails). 
> I told him that we
> >> need to clarify this for ToIP for implementations. Same is 
> the case for all
> >> other comments.
> >>  
> >> You point about WGLCs is interesting. Why do you also 
> think that these are
> >> also our obligations to clarify those? For example, a 
> simple point about QoS
> >> that Arnoud wanted to know show how the draft is 
> INCOMPLETE even to take of
> >> the QoS over the LAN for ToIP.
> >>  
> >> This draft's scope is the "Implementation Requirements 
> Framework of ToIP."
> >> It dealing with the networking environments as follows:
> >>  
> >> a. Real-Time Text only users (p2p, mpt), b. Combination of 
> Real-Time Text
> >> and Audio users only (p2p, mpt), and c. Combination of 
> Real-Time Text +
> >> Video + Non-Real-Time Data/Applications users and Audio + Video +
> >> Non-Real-Time Data/Applications users (p2p, mpt).
> >>  
> >> Therefore, your comments that the draft does not need to 
> deal with p2p, mpt,
> >> or mobility are technically INCONSISTENT so far the scope 
> and objectives of
> >> the draft are concerned.
> >>  
> >> The draft has mentioned those networking environments, but 
> have NOT stated
> >> the "implementation requirements" of ToIP for those 
> environments. That is
> >> why, I have raised those issues. If the draft does NOT 
> deal with those
> >> issues, the draft will remain technically INCONSISTENT.
> >>  
> >> You have raised an interesting issue related WGLCs. My 
> comments are also NOW
> >> officially a part of WGLCs.
> >>  
> >> So, we all need to deal with those comments as well.
> >>  
> >> Best regards,
> >> Radhika
> >> 
> >>   _____  
> >> 
> >> From: Gunnar Hellstrom [mailto:[email-masked]]
> >> Sent: Sat 3/11/2006 2:14 AM
> >> To: Roy, Radhika R.; [email-masked]
> >> Subject: RE: [Sipping] RE: Status of draft-ietf-sipping-toip-04.txt
> >> 
> >> 
> >> 
> >> Radhika and all,
> >> The main WGLC comment was that it was unclear if the draft 
> intended to point
> >> 
> >> at required protocol additions or state user requirements.
> >> 
> >> We have made an effort to clear that issue. We are just 
> pointing at how to
> >> use existing mechanisms to include real time text in the 
> general SIP
> >> environment, and how to solve the specific 
> interoperability issues with real
> >> 
> >> time text in other networks. We also have separated user 
> requirements from
> >> solutions. The draft is a profiling document, isolating a 
> set of user
> >> requirements and pointing at mechanisms to use for solving 
> them in a
> >> harmonized way, so that interoperability is maximised.
> >> 
> >> We have not been requested to mention p2p or mobility, and 
> we do not need to
> >> 
> >> do it in this draft. From now on I expect all sipping 
> authors to bring in
> >> real-time text in the media examples in their drafts. Once 
> you are in the
> >> SIP environment, real-time text is just one medium among others.
> >> 
> >> We made extensive rewording, so I just think that the 
> draft needs a thorough
> >> 
> >> review to check if we covered the WGLC comments properly.
> >> 
> >> We will surely touch the text medium again in other 
> drafts, but let us get
> >> this finalized without bringing in new topics that can be 
> covered better in
> >> joint SIP-related specifications.
> >> 
> >> Gunnar 
> >> 
> >> 
> --------------------------------------------------------------
> --------------
> >> 
> >> - 
> >> Gunnar Hellström, Omnitor
> >> 
> >> 
> >> --- 
> >> 
> >> 
> >> Arnoud: 
> >> 
> >> You have touched couple of good points, but still it falls 
> short off what I
> >> have been saying all along. Few points are as follows:
> >> 
> >> 1. 
> >> 
> >>         I am NOT talking about future drafts at all. I 
> clearly know what I
> >> have to do in the future drafts as I started this one in 
> the beginning both
> >> as editor and co-author. I would not wait for anyone to do 
> those if I have
> >> time. 
> >> 2. 
> >> 
> >>         We  agreed that the draft you have sent is 
> INCOMPLETE and it was
> >> sent, as Gunnar explained, it is a work-in-progress.
> >> 3. 
> >> 
> >>         What I am saying to complete the work-in-progress 
> part. That is all
> >> about. It is nothing to do with Rome that was not in a 
> day. It is common
> >> technical sense that the draft has to live with its implementation
> >> requirements. As it was hurriedly sent all on a sudden to show as
> >> work-in-progress, the remaining technical issues need to 
> be completed, and
> >> it is the framework of the implementation requirements for 
> which the draft
> >> has set the stage (a. p2p, b. mpt, c. toip only media, d. 
> multiple media
> >> along with toip, d. ip only, e. ip + LANs, f. ip + pstn, 
> g. ip + pstn +
> >> cellular, f. mobility [user + terminal]) .
> >> 4. 
> >> 
> >>         Are you saying the draft is COMPLETE as it stands NOW?
> >> 
> >> 
> >> Best regards, 
> >> Radhika 
> >> 
> >>   _____ 
> >> 
> >> 
> >> 
> >> _______________________________________________
> >> Sipping mailing list  
https://www1.ietf.org/mailman/listinfo/sipping
>> This list is for NEW development of the application of SIP
>> Use [email-masked] for questions on current sip
>> Use [email-masked] for new developments of core SIP
>> 
>> 
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Arnoud van Wijk" <[email-masked]>
Date: Mon, 13 Mar 2006 13:10:28 +0100

Hi Keith,
We specifically addressed the WGLC comments that there were. And Gonzalo's
comments.

That the WG has been a bit lacking in feedback, I think it is because we
already addressed many comments/issues before it went into WGLC.
And hey! 

Maybe we are so perfect that everybody agrees with this :-)

But what I see is that real-time text over IP, RFC4103 text or just as we
call: ToIP is not getting much interest from many IETF draft writers.
They keep writing drafts and only address audio and sometimes video and
forgetting ToIP. Not keeping in mind that Total Conversation is possible and
quite natural in an IP network with SIP. Audio, video and real-time
character by character text. (VoIP, video-over-IP and ToIP).

While some authors did include text as communication medium (kudos!), they
keep saying text messaging. That only suggests IM.

This draft is specially about real-time character by character text as RTP
media and not a messaging system like IM, which is line/block of text.

That awareness needs to be increased more.

But I do understand, VoIP is around for
yeeeeeeeeeaaaaaaaaaaaaaaaaaaaaaaaaars
Video is a logical extension of it and is also around for
yeeeeeeeeeeeeeeeeaaaaaaaaaaaaaaaaaaaaaaaaars.
ToIP is compared to VoIP and Video-over-IP still a young puppy.

Cheers

Arnoud

Arnoud A. T. van Wijk
AnnieS New Technology
www.AnnieS.nl
Mobile textphone (SIP): [email-masked]

> From: Drage, Keith (Keith) [mailto:[email-masked]]
> Sent: maandag 13 maart 2006 12:11
> To: Cullen Jennings; Tom-PT Taylor; [email-masked]; Dean
> Willis; Rohan Mahy
> Cc: sipping; Gunnar Hellstrom
> It is not meant to reflect the opinion of any author, but the opinion of
> the working group. If an author disagrees with the contents of a working
> group item, then tough - the author either implements the working group
> agreement or resigns - - or if sufficient problems are created, is
> removed.
> 
> I would suggest the main problem with this draft is that potentially there
> has been two much internal discussion about the contents between the
> authors, and insufficient expression of working group opinion by the
> working group. If I remember correctly, Gonzalo's comments about scope way
> back got nil, or pretty much nil, response.
>