Subject: [Sipping] Re: draft-xu-sipping-uruu-00.txt

From: Paul Kyzivat <[email-masked]>
Date: Wed, 01 Mar 2006 17:15:45 -0500

Peili,

I read this, but I still don't have any clear understanding of what the 
intent is or what the proposal to achieve that intent is. It would 
appear to be a bit like gruu, but different is some way I can't quite 
discern. Can you clarify further?

	Thanks,
	Paul

[email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
> 	Title		: The User-registered Routable UA URL
> 	Author(s)	: P. Xu
> 	Filename	: draft-xu-sipping-uruu-00.txt
> 	Pages		: 9
> 	Date		: 2006-3-1
> 	
>    This document analyse those kind of services which allow user to
>    allocate its extention address which can be used as indications to
>    route to its currently associated UA.
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-xu-sipping-uruu-00.txt
> 
> To remove yourself from the I-D Announcement list, send a message to 
> [email-masked] with the word unsubscribe in the body of the message.  
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
> to change your subscription settings.
> 
> 
> Internet-Drafts are also available by anonymous FTP. Login with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-xu-sipping-uruu-00.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-xu-sipping-uruu-00.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/i-d-announce

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 01 Mar 2006 17:33:51 -0500

I think I understood it; here was my interpretation, at least.

The idea is that I have multiple phones, each of which share the AOR. 
I'd like to be able to give each phone an extension name, say "mobile" 
for my mobile phone, "home" for my home landline phone, and "office" for 
my office phone. The requirement is that I, the user of those phones, 
get to pick these extension names, and define which devices they route 
to. So, if I get a new device, and I call it "newdevice", I could tell 
the network that calls for "newdevice" would route to my new phone. 
Then, I'd be able to tell other people that calls to 
sip:[email-masked], with the extension "newdevice" would route to 
this device. Should anyway call the combination of my AOR and this 
extension name, it would route to just that device.

If my intepretatoin of the requirements is right, this can be done today 
with caller prefs. The extension names could be the 'description' callee 
caps attribute, and a caller would route a call to a specific UA 
instance with that attribute using the Accept-Contact header field.

-Jonathan R.

Paul Kyzivat wrote:

>> [email-masked] with the word unsubscribe in the body of 
>> the message.  You can also visit 
>> https://www1.ietf.org/mailman/listinfo/I-D-announce to change your 
>> subscription settings.
>>
>>
>> http://www.ietf.org/shadow.html or 
>> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>>
>>

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

---

From: Aki Niemi <[email-masked]>
Date: Thu, 02 Mar 2006 01:02:33 +0200

So I guess we're talking about a similar thing that JIDs already have? I
can name several use cases that would benefit having such an extension
in a SIP AOR. Currently, in many of those cases people end up having to
construct naming conventions for the userpart of the AoR to identify
such sub-resources.

Cheers,
Aki

ext Jonathan Rosenberg wrote:
>> I read this, but I still don't have any clear understanding of what
>> the intent is or what the proposal to achieve that intent is. It would
>>> [email-masked] with the word unsubscribe in the body
>>> of the message.  You can also visit

---

From: Peili Xu <[email-masked]>
Date: Tue, 07 Mar 2006 17:32:23 +0800

I have to say that the current draft is too brief. 
Thanks for Jonathan`s interpretation.

The intent is to allow the user to have the right to name the
'sub-resources' under his/her AOR.
In this way, more user-friendly and personalized naming related service
can be provided.

Unlike GRUU, the naming of such kind of sub-resource is under the
control of user instead of operator.
The sub-resource may also be logic and can have one or more
corresponding device which have it`s own GRUU.

Peili

-----Original Message-----
From: Aki Niemi [mailto:[email-masked]] 
Sent: Thursday, March 02, 2006 7:03 AM
To: ext Jonathan Rosenberg
Cc: [email-masked]; Paul Kyzivat; sipping
Subject: Re: [Sipping] Re: draft-xu-sipping-uruu-00.txt

Cheers,
Aki

> for my mobile phone, "home" for my home landline phone, and "office" 
> for my office phone. The requirement is that I, the user of those 
> phones, get to pick these extension names, and define which devices 
> they route to. So, if I get a new device, and I call it "newdevice", I

> could tell the network that calls for "newdevice" would route to my 
> new phone. Then, I'd be able to tell other people that calls to 
> If my intepretatoin of the requirements is right, this can be done 
> today with caller prefs. The extension names could be the 
> 'description' callee caps attribute, and a caller would route a call 
> to a specific UA instance with that attribute using the Accept-Contact

> header field.
>> the intent is or what the proposal to achieve that intent is. It 
>> would appear to be a bit like gruu, but different is some way I can't

>> quite discern. Can you clarify further?
>>
>>     Thanks,
>>     Paul
>>

>>> Internet-Drafts are also available by anonymous FTP. Login with the 
>>> username "anonymous" and a password of your e-mail address. After 
>>> logging in, type "cd internet-drafts" and then
>>>               Below is the data which will enable a MIME compliant 
>>> mail reader implementation to automatically retrieve the ASCII 
>>> version of the Internet-Draft.
>>>
>>>
>> This list is for NEW development of the application of SIP Use 
>> [email-masked] for questions on current sip Use 
>> [email-masked] for new developments of core SIP
>>
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip Use
[email-masked] for new developments of core SIP