Subject: RE: [Sipping] The latest version of draft-xu-sipping-uruu-01.txtto be discussed on Friday Session

From: "Samir Srivastava" <[email-masked]>
Date: Thu, 23 Mar 2006 19:08:00 -0600

Hi,

1. Section 4 states

"When the request with the extension name reaches the serving proxy of
   the callee, the proxy would query the location service with the AOR
   and extension name together as the key to find the exact contact of
   the associated UA instance.  After that, the proxy will forward the
   request to the destined UA(s) according to the query result.  Note
   that if the extension name is mapped to multiple contacts, the proxy
   may apply forking or some other policy. "

   How the existing Find Me / Follow Me kind of services will work with
this ?  I have configuration for my home phone to forward to Cell phone
unconditionally. Caller calls me on my home phone with extension name
whether it will be rejected in this case, or forwarded to cell phone. I
think it need more text explaining this. This extension looks to
supersede all other stuff, and callers wants to reach the particular
extension. 

2.

      Req 6: if the user just provide the extension name when making the
      call, it mean he is to dial the other UAs under the same AOR.  And
      the system should treat the call as if he provide the AOR and
      extension name together.

SS>> How does complete AOR will be found, if user is dialing extension
(i.e. REQ URI has
 extension ), Where is the translation happening ? Or Serving Proxy with
this extension looks into other headers ?

Thx
Samir

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "xupeili" <[email-masked]>
Date: Thu, 23 Mar 2006 20:50:38 -0600

Hi Samir,

Thanks for your comments, please see inline.

----- Original Message ----- 
From: "Samir Srivastava" <[email-masked]>
To: "xupeili" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, March 23, 2006 7:08 PM
Subject: RE: [Sipping] The latest version of draft-xu-sipping-uruu-01.txtto bediscussed on Friday Session

Hi,

1. Section 4 states

<peili> 
There is an open issue whether uruu could have service treatment property.

If not, the forwarding logic may only apply to those part of the URI, e.g. AOR which have 
service treatment property and ommit the part of sub name when considering related services. 

If the AOR have service treatment property, the service profile should consider the existence of sub-names togother with its AOR.  For example, you may config forwarding on AOR, AOR with subname 1, AOR with subname 2, separately. And also you could have policy on the priority of those configurations.
</peili>

2.

<peili>
For this user requirment, it may be reasonable for UA to perfom the translation. 

The action depends on the forming of URUU and also the function of User Interface of UA.
For example, if there is extension button on the phone, the may know that; or if the user dial some special prefix....

Anyway this still need a lot of consideration.
</peili>

Thx
Samir