Subject: RE: [Sipping] Expert review of draft-ejzak-sipping-p-em-auth-00.t xt

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Wed, 19 Apr 2006 11:02:31 -0400

This makes it sound more like a preconditions case.

Mike

> -----Original Message-----
> From: Paul Kyzivat (pkyzivat) 
> Sent: Wednesday, April 19, 2006 9:35 AM
> To: Jeroen van Bemmel
> Cc: sipping
> Subject: Re: [Sipping] Expert review of 
> draft-ejzak-sipping-p-em-auth-00.t xt
> 
> 
> 
> Jeroen van Bemmel wrote:
> > Paul,
> > 
> >> If the policy is "local" then why does the draft single out a 
> >> particular policy at all?
> >>
> >>    "... if the proxy controls the gating of early media in both
> >>    directions for the User Agent Client, it SHALL use the 
> contents of
> >>    the P-Early-Media header to gate the early media 
> according to the
> >>    ..."
> >>
> >> That in fact *excludes* the policy I suggested that leaves 
> it to the 
> >> UA to request that the gate be closed.
> >>
> > 
> > You mean "UAC" here, right? So you're suggesting to allow 
> > P-Early-Media to appear in requests too? (currently only 
> provisional 
> > responses to INVITE)
> 
> Yes, I meant UAC. I was suggesting that it should ultimately 
> be up to the UAC whether early media will be accepted, with 
> the potential that if early media is accepted then it *might* 
> result in a charge. To handle the case where the UAC isn't 
> willing to pay a charge to receive the early media, there 
> could be *some* mechanism by which the UAC could request that 
> early media not be delivered if it will result in a charge.
> 
> I suppose one mechanism might be for the UAC to include the 
> P-Early-Media header in the original request. But that 
> doesn't give enough information - it could only authorize 
> acceptance in all cases. 
> Would probably need a way to say "I will take early media if 
> it is free, but not if it will cost me."
> 
> Putting in a negotiation mechanism could have some other 
> benefits as well. For instance, it might be reasonable to say 
> "I can take early media as long as I don't get concurrent 
> early media from multiple sources." Then a forking proxy may 
> be able to adjust its behavior and the authorization so that 
> there are never multiple UASs doing early media in parallel.
> 
> 	Paul
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 19 Apr 2006 11:38:00 -0400

> This makes it sound more like a preconditions case.

A problem with preconditions is that, because they are exchanged in a 
body, they may not be modified by proxies.

But I do agree, especially given the relationship to media, it does look 
like that.

	Paul