Subject: [Sipping] CCBS discussions in TISPAN

From: "Sachin Kamat" <[email-masked]>
Date: Thu, 13 Apr 2006 21:34:20 +0530

Hi all ,
 
        There have been talks about providing Communication Completion Busy Subscriber and similar  services in the TISPAN community. 
 
If anybody has any information / recent drafts about this then please let me know.

Thanks,
Sachin

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Mike Chack" <[email-masked]>
Date: Fri, 14 Apr 2006 11:58:09 -0700

James,

It is the ability to automatically retry a call when the first attempt
fails.  Subsequent reattempts could be driven by presence (near or far
end) or blind call attempts.  

Thanks,
Mike

-----Original Message-----
From: James M. Polk [mailto:[email-masked]] 
Sent: Friday, April 14, 2006 11:46 AM
To: Sachin Kamat; [email-masked]
Subject: Re: [Sipping] CCBS discussions in TISPAN

Sachin

please define "Communication Completion Busy Subscriber"

At 09:34 PM 4/13/2006 +0530, Sachin Kamat wrote:
>content-class: urn:content-classes:message
>Content-Type: text/plain;
>  charset=utf-8
>
>Hi all ,
>
>         There have been talks about providing Communication Completion

> Busy Subscriber and similar  services in the TISPAN community.
>
>If anybody has any information / recent drafts about this then please
let 
>me know.

---

From: "Francois Audet" <[email-masked]>
Date: Mon, 17 Apr 2006 15:05:11 -0500

Also see section 2.18 of
http://www.ietf.org/internet-drafts/draft-ietf-sipping-service-examples-
10.txt

> From: Paul Kyzivat [mailto:[email-masked]] 
> Sent: Monday, April 17, 2006 08:43
> To: Sachin Kamat
> Cc: James M. Polk; [email-masked]
> I think CCBS is an ISDN feature. There is a similar Telcordia 
> feature: 
> AC (Automatic Callback). I have been involved to various degrees in 
> several efforts to define a sip implementation for one or the 
> other of 
> these. What I have observed is that there are many, radically 
> different, 
> ways to implement these features. Choosing an implementation approach 
> depends on which feature you are trying to implement, how 
> faithfully you 
> want to emulate the legacy feature, to what extent you require 
> interoperation with a legacy implementation, how complex an 
> implementation you are willing to tolerate, how much you are 
> willing to 
> pervert the architecture of your sip system to do it, and how 
> suitable 
> you want the resulting feature to be in a non-legacy environment that 
> includes different UIs, added media and features, etc.
> 
> So I don't think there will be any single conclusion about how to 
> provide this and similar features. There will multiple decisions for 
> different operating environments.
> 
> 	Paul
> 
> Sachin Kamat wrote:
> > Thanks Eric.
> > 
> > I could see some drafts like
> > draft-jesske-sipping-tispan-requirements-02.txt but looks like we
> > haven't come to any conclusion about how to provide these services.
> > 
> > Thanks all,
> > Sachin
> > 
> > From: Erick Sasaki [mailto:[email-masked]]
> > Sent: Saturday, April 15, 2006 3:29 AM
> > To: James M. Polk; Sachin Kamat; [email-masked]
> > Subject: RE: [Sipping] CCBS discussions in TISPAN
> > 
> > James,
> > 
> > The definition for CCBS can be found in 
> > draft-jesske-sipping-tispan-requirements-02.txt.  In short:
> > 
> > 	Communication Completion on Busy Subscriber (CCBS) provides the
> >    caller with the ability to complete a requested 
> communication to a
> >    busy callee without having to make a new communication 
> attempt when
> >    the callee becomes not busy anymore.  It is possible for 
> the caller
> >    to request several communications to be under the CCBS requested
> >    status.  Also the callee can be subject to several CCBS
> >    communications from different callers.  Additionally, the service
> >    provides queue management to arbitrate several CCBS 
> requests to the
> >    same callee.
> > 
> > Have a good weekend,
> > 
> > Erick
> > 
> >

---

From: "Sachin Kamat" <[email-masked]>
Date: Tue, 18 Apr 2006 10:16:12 +0530

Thanks a lot !!!

-----Original Message-----
From: Francois Audet [mailto:[email-masked]] 
Sent: Tuesday, April 18, 2006 1:35 AM
To: Paul Kyzivat; Sachin Kamat
Cc: James M. Polk; [email-masked]
Subject: RE: [Sipping] CCBS discussions in TISPAN

Also see section 2.18 of

---

From: GARCIN Sébastien RD-CORE-ISS<[email-masked]>
Date: Tue, 18 Apr 2006 09:22:55 +0200

Sachin,

TISPAN is currently working on an internet-draft (possibly two) for
extending SIP in order to provide CCBS/CCNR service close to the ISDN flavor
and that interworks properly with the legacy CCBS service.

We are planning to submit this material in a couple of weeks. 

If you need further information check the following URL:

http://portal.etsi.org/docbox/TISPAN/Open/NGN%20LATEST%20DRAFTS/RELEASE%202/
03035v009.pdf
   
sébastien

-----Message d'origine-----
De : Sachin Kamat [mailto:[email-masked]] 
Envoyé : mardi 18 avril 2006 06:46
À : Francois Audet; Paul Kyzivat
Cc : James M. Polk; [email-masked]
Objet : RE: [Sipping] CCBS discussions in TISPAN

Thanks a lot !!!

-----Original Message-----
From: Francois Audet [mailto:[email-masked]]
Sent: Tuesday, April 18, 2006 1:35 AM
To: Paul Kyzivat; Sachin Kamat
Cc: James M. Polk; [email-masked]
Subject: RE: [Sipping] CCBS discussions in TISPAN

Also see section 2.18 of

> several efforts to define a sip implementation for one or the other of 
> different, ways to implement these features. Choosing an 
> implementation approach depends on which feature you are trying to 
> implement, how faithfully you want to emulate the legacy feature, to 
> what extent you require interoperation with a legacy implementation, 
> how complex an implementation you are willing to tolerate, how much 
> you are willing to pervert the architecture of your sip system to do 
> it, and how suitable you want the resulting feature to be in a 
> non-legacy environment that includes different UIs, added media and 
> features, etc.
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP Use
[email-masked] for questions on current sip Use
[email-masked] for new developments of core SIP
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP