Subject: [Sipping] Dual Stack UAC in draft-ietf-sipping-v6-transition-02.txt?

From: "James M. Polk" <[email-masked]>
Date: Thu, 27 Apr 2006 16:58:38 -0500

How is a UAC going to include both v4 and v6 addressing in its 
INVITE/Offer?  There doesn't seem to be text or an example given in this ID 
discussing this case.  This ID seems to be dealing more with translation 
from v4 to v6 and visa-versa.  Am I wrong?

The usecase is a dualstack UAC that doesn't know which stack a UAS has 
(OPTIONS may be prevented), but wants to have a session/dialog in v6 if all 
SIP elements support it, and will go with v4 if that's the common demoninator.

Thanks
James 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 27 Apr 2006 17:10:50 -0500

James M. Polk wrote:
> INVITE/Offer?  There doesn't seem to be text or an example given in this 
> ID discussing this case.  This ID seems to be dealing more with 
> translation from v4 to v6 and visa-versa.  Am I wrong?

Text from Section 4.1:

    It is RECOMMENDED that user agents gather IPv4 and IPv6 addresses
    using the ICE procedures to generate all their offers.
    ...
    User agents that use SDP SHOULD support the ANAT semantics for the
    SDP grouping framework.  ANAT allows user agents to include both IPv4
    and IPv6 addresses in their SDP session descriptions.

The example for an ANAT SDP is in rfc4091.

Thanks,

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Bell Laboratories, Lucent Technologies, Inc.
2701 Lucent Lane, Rm. 9F-546, Lisle, Illinois 60532 (USA)
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "James M. Polk" <[email-masked]>
Date: Thu, 27 Apr 2006 21:46:12 -0500

Vijay

Excellant.

I saw the mention of ICE, but didnt' put it together with ANAT semantics.

Thank you