Subject: RE: [Sipping] Expert review of draft-ejzak-sipping-p-em-auth-00.t xt

From: "Ejzak, Richard P (Richard)" <[email-masked]>
Date: Mon, 17 Apr 2006 11:24:23 -0500

Paul Kyzivat wrote:
> It is the redefining of behavior that is concerning me. If it 
> was just 
> affecting the billing policy then I don't think I would have any 
> concern. But it isn't just affecting billing policy. It is actually 
> redefining the policy for whether the early media is delivered.

And in the presence of parallel forking, also according to RFC 3960:
"It is difficult to decide which early media sessions carry more important information from the caller's perspective.  In fact, in some scenarios, the UA cannot even correlate media packets with their particular SIP early dialog.  Therefore, UACs typically pick one early dialog randomly and mute the rest."

So there is no way that a UAS can know that its early media will get through in a given situation anyway.  My draft DOES NOT CHANGE THIS.

> The passage you quote is from section 3.2 (Ringing Tone Generation). 
> Earlier in that section is: "a UAC should develop its local policy 
> regarding local ringing generation".
> 
> IMO the section you quote pertains to a policy for local ring tone 
> generation, not a policy for processing of early media.

Local ringing generation is described in 3.2 as being inextricably linked with early media.  The example policy given after the text you quote describes how one might decide to provide local ringing depending on the presence of early media.  Since this is completely up to local policy, then (as in the parallel forking example) it is a completely legitimate local policy to generate local ringing in place of early media.

Richard

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 17 Apr 2006 13:01:44 -0400

Ejzak, Richard P (Richard) wrote:
> "It is difficult to decide which early media sessions carry more
> important information from the caller's perspective.  In fact, in
> some scenarios, the UA cannot even correlate media packets with their
> particular SIP early dialog.  Therefore, UACs typically pick one
> early dialog randomly and mute the rest."
> 
> So there is no way that a UAS can know that its early media will get
> through in a given situation anyway.  My draft DOES NOT CHANGE THIS.

Are you are saying that because parallel forking can result in a case 
where early media is lost, it is ok to introduce additional cases that 
lose early media?

> Local ringing generation is described in 3.2 as being inextricably
> linked with early media. 

Yes, but the converse is not true - early media is meaningful without 
reference to ring tone generation.

> The example policy given after the text
> you quote describes how one might decide to provide local ringing
> depending on the presence of early media.  Since this is completely
> up to local policy, then (as in the parallel forking example) it
> is a completely legitimate local policy to generate local ringing
> in place of early media.

Legitimate perhaps, but misguided. If a UA does this routinely, even in 
the absence of forking, then it will miss all the in-band announcements 
about sevice disconnect, etc. that are routinely provided by the PSTN.

The fact of the matter is, early media is important, and losing it is a 
problem. Efforts should be taken to avoid losing it.

IMO what you propose is a system where early media only works to/from 
sources inside the walled garden, while early media to/from outside the 
garden walls is blocked.

	Paul