Subject: RE: [Sipping] Expert review of draft-ejzak-sipping-p-em-auth-00.t xt

From: "Ejzak, Richard P (Richard)" <[email-masked]>
Date: Mon, 17 Apr 2006 13:28:01 -0500

Hi Hadriel,
I don't understand how I can write about a P header that is only for use in a private network without describing its use in the private network.

Richard

Hadriel Kaplan wrote:
> I re-read the draft trying to figure out why the argument is about not
> delivering early media to the UAC, as opposed to the UAC 
> simply deciding
> what to do based on it, and I think I see the problem.
> 
> Section 7.2 says "In addition, if the proxy controls the 
> gating of early
> media in both directions for the User Agent Client, it SHALL use the
> contents of the P-Early-Media header to gate the early media 
> according to
> the definition of the direction parameter defined in clause 7."
> That should be removed IMO, because there is no such "proxy" 
> concept in the
> IETF.  Nothing in the media path between UAC-UAS can block delivery of
> media.  If TISPAN or 3G wants to define that it's up to them 
> to do so in
> their specs.
> 
> The draft should purely be about the P-header returned to a 
> UAC, with which
> the UAC can do what it wants.  E.g., pure voip UACs could 
> ignore it, and
> PSTN-GWs could use it for something specific to their local policies.
> 
> -hadriel

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Hadriel Kaplan" <[email-masked]>
Date: Mon, 17 Apr 2006 21:04:36 -0400

Hi Richard,
Do all private networks which want to use this P-header have to block early
media at a proxy?  
Because the use can simply be a UAC's use - the UAC being the PSTN GW, or
any UAC initiating the call which supports the header.  For example, a
non-3G/TISPAN private network can use this P-header, so long as the
trust-boundary proxies support it; but those proxies shouldn't have to block
media - only UACs which want to would.
If specific private networks defined by other bodies want to go further, why
couldn't they just define that behavior themselves?

-hadriel

> -----Original Message-----
> From: Ejzak, Richard P (Richard) [mailto:[email-masked]]
> Sent: Monday, April 17, 2006 2:28 PM
> To: 'Hadriel Kaplan'; 'Paul Kyzivat'
> Cc: 'Cullen Jennings'; 'Jon Peterson'; 'Gonzalo Camarillo'; 'Mary Barnes';
> 'sipping'; 'Aki Niemi'
> Subject: RE: [Sipping] Expert review of draft-ejzak-sipping-p-em-auth-00.t
> xt
> 
> Hi Hadriel,
> I don't understand how I can write about a P header that is only for use
> in a private network without describing its use in the private network.
> 
> Richard
> 
> Hadriel Kaplan wrote: