Subject: RE: [Sipping] Expert review of draft-ejzak-sipping-p-em-auth-00.t xt

From: "Ejzak, Richard P (Richard)" <[email-masked]>
Date: Tue, 18 Apr 2006 09:09:47 -0500

Hi Hadriel,
I agree with you that the UAC may also enforce early media policy if it is trusted (such as a PSTN gateway).  I thought this option was clear in the draft but I will review it again to be sure.

Richard

Hadriel Kaplan wrote:
> Hi Richard,
> Do all private networks which want to use this P-header have 
> to block early
> media at a proxy?  
> Because the use can simply be a UAC's use - the UAC being the 
> PSTN GW, or
> any UAC initiating the call which supports the header.  For example, a
> non-3G/TISPAN private network can use this P-header, so long as the
> trust-boundary proxies support it; but those proxies 
> shouldn't have to block
> media - only UACs which want to would.
> If specific private networks defined by other bodies want to 
> go further, why
> couldn't they just define that behavior themselves?
> 
> -hadriel
> 
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Wed, 19 Apr 2006 11:09:44 -0400

That is all I am saying; don't give fraudsters a leg to stand on.  There
may be legal requirements for the UAS to deliver legal mumbo jumbo
before proceeding to charge for the call.  This is usually in small
print or deliverd by a very fast speaker.

The issue is that the service provider may assume legal liability to pay
for the call if the early media is unreliable.

Mike

> -----Original Message-----
> From: Hadriel Kaplan [mailto:[email-masked]] 
> Sent: Tuesday, April 18, 2006 9:10 PM
> To: Michael Hammer (mhammer)
> Cc: 'sipping'
> Subject: RE: [Sipping] Expert review of 
> draft-ejzak-sipping-p-em-auth-00.t xt
> 
> Inline...
> 
> > -----Original Message-----
> > From: Michael Hammer (mhammer) [mailto:[email-masked]]
> > Sent: Tuesday, April 18, 2006 7:52 PM
> > 
> > You missed the point.  Rounding up to nearest half hour 
> meant you get 
> > charged minimum 30 minutes x $10 or $300.  Are you not aware of the 
> > incidents where people called 800 numbers only to be 
> forwarded to 900 
> > numbers that charged them by the minute?  Those folks were 
> surprised 
> > when it showed up on the bill and the carriers said hey you enjoyed 
> > the call, so pay up.  It took quite a few complaints before such 
> > shenanigans were overcome.  The problem here is that there is 
> > financial incentive for the "UAS" to get the "UAC" side to make the 
> > connection, so they can be charged.  They aren't interested 
> in grace 
> > periods.  Don't aid and abet them.
> 
> I'm not sure how that is germane to this header use.  If a 
> UAS owner wants to charge, and doing so merely involves 
> sending a 200ok, then that's totally under the UAS' power - 
> regardless of what the called number is and who called it.  I 
> fail to see how playing early media at the UAC helps the UAC 
> stop that, if the UAS truly wants to charge.  Why would the 
> UAS even bother sending early media if it did not really wish 
> to help avoid the charges?
> Just so it can say "we tried to warn you"?  Under your 
> scenario they were charging 900 rates for an 800 number. 
> (yes, I've heard it happens) I'd rather not give them a fake 
> leg to stand on - that would be aiding and abetting.  There 
> are too many cases where early media doesn't work anyway.
> 
> People have already pointed out a provider can charge for 
> early media if they're worried about fraud.  So there is no 
> recourse to stop the charging without the provider wishing 
> to.  The point of this draft is to give them a way of safely 
> playing early media without charging.  IF the provider is the 
> one doing the 900-charging, and the UAS wants to help avoid 
> charges, then they can either use a provider which lets them 
> send early media for free, or ask the provider to be granted 
> such grace period, or use this draft's header. 
> 
> -hadriel
>