Subject: [Sipping] What's "Private dialing plan"?

From: "Roy Yang" <[email-masked]>
Date: Tue, 18 Apr 2006 14:30:14 -0700

Hi,
   One basic telephony feature on Henning<http://www.cs.columbia.edu/%7Ehgs>'s
website is called " Private dialing plan".
   What does the word mean? Is this a legacy feature or a new one emerging
with VoIP?
   So many terms come out, and no clear definition! Is there draft or
document to
   standard or describe these terms?
   Thanks a lot.

   Regards

--Cundong
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Roy Yang" <[email-masked]>
Date: Wed, 19 Apr 2006 10:17:42 -0700

Hi, Gordon:
     I understand what you said.
     Here is the new questions. SIP is end-to-end proctocol
and SIP proxies or IP PBX is optional, though in practice,
 IP PBX/ SIP proxies is a must.
     If SIP-based terminals work in the so called end-to-end way,
  how does the terminal know where the digit it should send, internal or
external network. Perhaps this will depends on the
" dialing plan" implemented in the termials.
    If terminals supported " Dialing Plan", when they moved, the dialing
plan has to be adjust because IP PBX/SIP proxies also has
a copy of " dialing plan", they should be consistent or at least have
have overlaps.
    In summary, in order to conform the SIP standard, "Dialing Plan" has to
be implemented in the terminal. However, there is
the consistency problem when it runs in practical VoIP network,
cause SIP proxies/IP PBX always sit there.

 Regards

--Cundong

On 4/19/06, Roy Yang <[email-masked]> wrote:
>
> Thanks.
>  It is reasonable.
>  Some phones have implemented
>  the "Dialing Plan", it is a little weird.
> Regards
> --Cundong
>
>
> On 4/19/06, Gordon Ledgard <[email-masked]> wrote:
> >
> >  no difference.
> >
> >
> >
> > It has to be implemented by the PBX or the SIP proxies and servers.
> >
> > To implement it in the phones is a mistake. They can be moved around.
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >   ------------------------------
> >
> > *From:* Roy Yang [mailto:[email-masked]]
> > *Sent:* Wednesday, April 19, 2006 12:29 PM
> > *To:* Gordon Ledgard; [email-masked]
> > *Subject:* Re: [Sipping] What's "Private dialing plan"?
> >
> >
> >
> > Thanks a lot!
> > It seems " Private Dialing Plan" is the same as "Dialing Plan".
> > If not so, what's the difference between them?
> > If it implemented in VoIP system, should it be realized on termial side
> > or IP PBX side ?
> >
> > A lot of terms on http://www.cs.columbia.edu/sip/features.html is not
> > clearly defined or just described briefly. If there is such a
> > dictionary,
> > that will be better.
> >
> > Regards
> >
> > --Cundong
> >
> >  On 4/18/06, *Gordon Ledgard* <[email-masked] > wrote:
> >
> > It's a term that usually means "within a company or organization you can
> > dial a portion
> >
> > of an entire telephone number and reach someone else within the
> > organization".
> >
> >
> >
> > More generally, it is a description of how a telephone network is
> > programmed to be
> >
> > able to interpret a variety of lengths of string of digits in order to
> > interpret how
> >
> > to route a call. For example if I dial four numbers I get an extension
> > within my
> >
> > organization. If I dial 7 digits, I get a phone in my general
> > geographical dialing area.
> >
> > If I dial 10 digits I get someone within my country, and if I dial 13
> > digits, I get someone
> >
> > somewhere else in the world.
> >
> >
> >
> > Hope this helps.
> >
> >
> >
> > G. R. Ledgard
> >
> >
> >
> >
> >   ------------------------------
> >
> > *From:* Roy Yang [mailto: [email-masked]]
> > *Sent:* Tuesday, April 18, 2006 5:30 PM
> > *To:* [email-masked]
> > *Subject:* [Sipping] What's "Private dialing plan"?
> >
> >
> >
> > Hi,
> >    What does the word mean? Is this a legacy feature or a new one
> > emerging with VoIP?