Subject: [Sipping] Differences between SIP-T and SIP-I

From: "Konstantin Savin" <[email-masked]>
Date: Fri, 26 Jan 2007 12:32:01 +0300

Hello everybody!

There are two similar protocols (or versions of SIP) are used now : SIP-T
and SIP-I.

But can anybody explain me the differences between them? Is the only point
in the owner (IETF, ITU-T).

Thank you very much and best regards,

Stan

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Fri, 26 Jan 2007 11:44:33 -0500

Besides ownership, there are technical differences in the message
handling.
 
Mike

________________________________

	From: Konstantin Savin [mailto:[email-masked]] 
	Sent: Friday, January 26, 2007 4:32 AM
	To: [email-masked]
	Subject: [Sipping] Differences between SIP-T and SIP-I

	Hello everybody!

	There are two similar protocols (or versions of SIP) are used
now : SIP-T and SIP-I.

	But can anybody explain me the differences between them? Is the
only point in the owner (IETF, ITU-T).

	Stan

---

From: "Konstantin Savin" <[email-masked]>
Date: Mon, 29 Jan 2007 10:33:54 +0300

Thank you Mike!

I saw that there are some differences in message handling in part of
converting the causes of ISUP to 4xx series responses. And may be some more
detailed than in RFC 3372 or 3398 description of several procedures.

But I wonder if there any 'global' differences between them?

Why does ITU-T create this SIP-I? SIP-T is not enough?

Best regards,

Stan

  _____  

From: Michael Hammer (mhammer) [mailto:[email-masked]] 
Sent: Friday, January 26, 2007 7:45 PM
To: Konstantin Savin; [email-masked]
Subject: RE: [Sipping] Differences between SIP-T and SIP-I

Besides ownership, there are technical differences in the message handling.

Mike

  _____  

Hello everybody!

Stan

__________ Hmtnpl`vh NOD32 2009 (20070126) __________

]rn qnnayemhe opnbepemn @mrhbhpsqmni qhqrelni NOD32.
http://www.nod32.com

---

From: "David Schwartz" <[email-masked]>
Date: Mon, 29 Jan 2007 11:15:26 +0200

My limited understanding of the "global" differences between the two is
that SIP-T is used more in an environment where SIP is used for transit
between two SS7 networks. In this case the transit SIP network does not
really care about the cause of a problem and just sends this info back
to the originating SS7 network. As such all that is really needed is to
pass the ISUP message in a SIP message body to the terminating SS7
network. 

SIP-I on the other hand is used when ISUP messages are used by the SIP
network itself.

Cheers,

David

From: Konstantin Savin [mailto:[email-masked]] 
Sent: Monday, January 29, 2007 9:34 AM
To: 'Michael Hammer (mhammer)'
Cc: [email-masked]
Subject: RE: [Sipping] Differences between SIP-T and SIP-I

Thank you Mike!

I saw that there are some differences in message handling in part of
converting the causes of ISUP to 4xx series responses. And may be some
more detailed than in RFC 3372 or 3398 description of several
procedures.

Best regards,

Stan

Mike

	Hello everybody!

	Stan

---

From: "He, Jingtong" <[email-masked]>
Date: Mon, 29 Jan 2007 18:22:37 +0800

To my knowledge：
SIP-T (by IETF) just provides translation and encapsulation for PSTN parameters in interconnection with SIP soft switch. SIP-I (by ITU-T, based on SIP-T) is more accurate and explicitly defines the parameters between PSTN and SIP, also detailedly defines the supplementary services for telecommunication interconnection, which is not support by SIP-T. SIP-I is widely accepted by manufacturers, carriers and organizations (e.g., 3GPP) instead of SIP-T.

--
Regards,
Jingtong 
________________________________________
From: Konstantin Savin [mailto:[email-masked]] 
Sent: Monday, January 29, 2007 3:34 PM
To: 'Michael Hammer (mhammer)'
Cc: [email-masked]
Subject: RE: [Sipping] Differences between SIP-T and SIP-I

Thank you Mike!

I saw that there are some differences in message handling in part of converting the causes of ISUP to 4xx series responses. And may be some more detailed than in RFC 3372 or 3398 description of several procedures.

But I wonder if there any ‘global’ differences between them?
Why does ITU-T create this SIP-I? SIP-T is not enough?

Best regards,
Stan
________________________________________

Mike

________________________________________
From: Konstantin Savin [mailto:[email-masked]] 
Sent: Friday, January 26, 2007 4:32 AM
To: [email-masked]
Subject: [Sipping] Differences between SIP-T and SIP-I
Hello everybody!

There are two similar protocols (or versions of SIP) are used now : SIP-T and SIP-I.
But can anybody explain me the differences between them? Is the only point in the owner (IETF, ITU-T).

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Tue, 30 Jan 2007 20:24:03 -0500

ITU-T SG11 wished to verify that the interworking did not impact the PSTN networks, while still staying true to the intended operation of the SIP network.

Mike

> -----Original Message-----
> From: He, Jingtong [mailto:[email-masked]] 
> Sent: Monday, January 29, 2007 5:23 AM
> To: 'Konstantin Savin'; Michael Hammer (mhammer)
> Cc: [email-masked]; Rocky Wang
> SIP-T (by IETF) just provides translation and encapsulation 
> for PSTN parameters in interconnection with SIP soft switch. 
> SIP-I (by ITU-T, based on SIP-T) is more accurate and 
> explicitly defines the parameters between PSTN and SIP, also 
> detailedly defines the supplementary services for 
> telecommunication interconnection, which is not support by 
> SIP-T. SIP-I is widely accepted by manufacturers, carriers 
> and organizations (e.g., 3GPP) instead of SIP-T.
> 
> --
> Regards,
> Jingtong
> I saw that there are some differences in message handling in 
> part of converting the causes of ISUP to 4xx series 
> responses. And may be some more detailed than in RFC 3372 or 
> 3398 description of several procedures.
> 
> Subject: [Sipping] Differences between SIP-T and SIP-I Hello 
> everybody!
> 
> But can anybody explain me the differences between them? Is 
> the only point in the owner (IETF, ITU-T).
>