Subject: Re: [Sipping] I-DACTION:draft-loreto-sipping-dialog-correlation-00.txt/ use of same-session header with KMPL

From: Paul Kyzivat <[email-masked]>
Date: Tue, 02 Jan 2007 14:01:19 -0500

It seems to me that if the B2BUA is going to stick its ugly nose into 
this, then it has the obligation to figure out the mess it has made and 
fix it. That should be part of the work in B2BUA-"proxying" the 
SUBSCRIBE, without any extra hints from the subscriber.

	Paul

CHADLI Youssef RD-CORE-ISS wrote:
>  
> Hi,
> 
> KPML allows to correlate the KPML requests with an existing SIP dialog.
> This correlation is done by indicating the dialog identifiers within the
> KMPL request included in SUBSCRIBE. However, if a B2BUA entity is
> located between the tow UA, the dialog identifiers received by the
> notifier UA will not match any known SIP dialog . Here is an
> illustration of this problem:
> 
>    UA1					    B2BUA
> UA2
> 
>     | -----INVITE dialog D1 ------------- | -------INVITE dialog
> D2--------------  | 
>     |							|
> |	
>     | <-----SUBSCRIBE dialog D4 ----------| -------- SUBSCRIBE dialog
> D3-------    |  
>     |        KPML request (D2)	      |		KPML request (D2)
> |	
>     |							|
> |
>    
> UA2 receives a KPML request indicating D2 which it does not know.	
> It is assumed that the B2BUA does not inderstand KPML, for exemple a SIP
> ALG performing NAT.      
> 
> The use of  the Same-Session header can resolve this problem : UA2
> inserts the Same-Session header in the SUBSCRIBE request set to D2, then
> the B2BUA entity modifies this header and sets it to D1 before
> forwarding the request to UA1. Consequently, UA2 knows that KPML request
> is correlated with the media session corresponding to dialog D1. 
> Do you see any problem for doing that ?
> 
> Regards,
> 
> Youssef  
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: [email-masked]
Date: Thu, 18 Jan 2007 17:18:05 -0500

> Do you see any problem for doing that ?

   From: Paul Kyzivat <[email-masked]>

I agree -- It is much more likely that having the B2BUA understand and
adjust the KPML will work correctly, than that all UAs in the world
will look for a Same-Session header and process it correctly.

Dale