Subject: [Sipping] draft-vanelburg-sipping-served-user-01.txt

From: "Hans Erik van Elburg (RY/ETM)" <[email-masked]>
Date: Tue, 26 Jun 2007 13:08:23 +0200

Just to notify you that a new version of this draft is available, taking
into account  the received comments.
Best Regards,
/Hans Erik

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, June 22, 2007 9:50 PM
To: [email-masked]
Subject: I-D ACTION:draft-vanelburg-sipping-served-user-01.txt 

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title		: The Session Initiation Protocol (SIP)
P-Served-User Private-Header (P-Header)
	Author(s)	: H. van Elburg
	Filename	: draft-vanelburg-sipping-served-user-01.txt
	Pages		: 14
	Date		: 2007-6-22
	
This document specifies the SIP P-Served-User P-header.  This header
   field addresses an issue that was found in the 3rd-Generation
   Partnership Project (3GPP) IMS (IP Multimedia Subsystem) between an
   S-CSCF (Serving Call Session Control Function) and an AS (Application
   Server) on the ISC (IMS Subsystem Service Control) interface to
   convey the identity of the served user and the session case that
   applies to this particular communication session and application
   invocation.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-vanelburg-sipping-served-user-
01.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of 
the message. 
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the 
username "anonymous" and a password of your e-mail address. After 
logging in, type "cd internet-drafts" and then 
"get draft-vanelburg-sipping-served-user-01.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE
/internet-drafts/draft-vanelburg-sipping-served-user-01.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail
readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Peili Xu <[email-masked]>
Date: Fri, 29 Jun 2007 18:17:33 +0800

Hi Hans Erik,

I have two comments on your draft.

1: For the case in section 3.2&3.3(Call Diversion), 

Since this extention is only used between S-CSCF and AS
through ISC interface, and the AS should forward the 
information transparenty back to the S-CSCF. One simple
way is to add such information into the Route header,
just like the handling of Original Dialog Identifier in
current IMS specifications. Thus no header extention is
needed.

2: For the case in section 3.4(Call on behalf of user B,
but policies&charging of service identity C),

This is an interesting senario but the requirement is
very different from Call Diversion. 
Could you please provide more detailed requirements from
the 3GPP. 
My feeling is that the underlying requirement is general
to SIP and may not limited to 3GPP IMS, 
I suggest to do more detailed analysis on the
requirements first.

BR
Peili 

-----Original Message-----
From: Hans Erik van Elburg (RY/ETM)
[mailto:[email-masked]] 
Sent: Tuesday, June 26, 2007 7:08 PM
To: [email-masked]
Subject: [Sipping]
draft-vanelburg-sipping-served-user-01.txt

Just to notify you that a new version of this draft is
available, taking into account  the received comments.
Best Regards,
/Hans Erik

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]
Sent: Friday, June 22, 2007 9:50 PM
To: [email-masked]
Subject: I-D
ACTION:draft-vanelburg-sipping-served-user-01.txt 

A New Internet-Draft is available from the on-line
Internet-Drafts directories.

	Title		: The Session Initiation
Protocol (SIP)
P-Served-User Private-Header (P-Header)
	Author(s)	: H. van Elburg
	Filename	:
draft-vanelburg-sipping-served-user-01.txt
	Pages		: 14
	Date		: 2007-6-22
	
This document specifies the SIP P-Served-User P-header.
This header
   field addresses an issue that was found in the
3rd-Generation
   Partnership Project (3GPP) IMS (IP Multimedia
Subsystem) between an
   S-CSCF (Serving Call Session Control Function) and an
AS (Application
   Server) on the ISC (IMS Subsystem Service Control)
interface to
   convey the identity of the served user and the
session case that
   applies to this particular communication session and
application
   invocation.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-vanelburg-sipp
ing-served-user-
01.txt

To remove yourself from the I-D Announcement list, send
a message to [email-masked] with the word
unsubscribe in the body of the message. 
You can also visit
https://www1.ietf.org/mailman/listinfo/I-D-announce
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP.
Login with the username "anonymous" and a password of
your e-mail address. After logging in, type "cd
internet-drafts" and then "get
draft-vanelburg-sipping-served-user-01.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html or
ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Send a message to:
	[email-masked].
In the body type:
	"FILE
/internet-drafts/draft-vanelburg-sipping-served-user-01.
txt".
	
NOTE:	The mail server at ietf.org can return the
document in
	MIME-encoded form by using the "mpack" utility.
To use this
	feature, insert the command "ENCODING mime"
before the "FILE"
	command.  To decode the response(s), you will
need "munpack" or
	a MIME-compliant mail reader.  Different
MIME-compliant mail readers
	exhibit different behavior, especially when
dealing with
	"multipart" MIME messages (i.e. documents which
have been split
	up into multiple messages), so check your local
documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant
mail reader implementation to automatically retrieve the
ASCII version of the Internet-Draft.