Subject: [Sipping] Tunneling of Q931 messages over SIP

From: "Jayesh Sangpal (jsangpal)" <[email-masked]>
Date: Wed, 13 Jun 2007 15:03:05 +0530

Hi experts,
I have a requirement where the 'ISDN Q931 messages' are to be tunneled
across SIP trunk.
RFC 3204 defines a MIME type explicitly for QSIG messages.
(application/qsig).
I have few doubts on that.
1)Is there any such standard for Q931 messages ?
2)As QSIG is a subtype of Q931, why RFC 3204 mentions only about QSIG
and not generically about Q931 messages ?

Thanks in Advance,
Jayesh

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Jesske, R" <[email-masked]>
Date: Thu, 14 Jun 2007 15:18:23 +0200

Question is what do you want to tunnel?
All Messages? Or only the needed? e.G HLC, LLC?

Best Regards

Roland

> -----Ursprüngliche Nachricht-----
> Von: Jayesh Sangpal (jsangpal) [mailto:[email-masked]] 
> Gesendet: Mittwoch, 13. Juni 2007 11:33
> An: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; 
> [email-masked]; [email-masked]; 
> Michael Hammer (mhammer); [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]
> Betreff: [BLISS] Tunneling of Q931 messages over SIP
> 
> 
> Hi experts,
> BLISS mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/bliss
>

---

From: "Jayesh Sangpal (jsangpal)" <[email-masked]>
Date: Thu, 14 Jun 2007 19:09:30 +0530

I want tunnel Complete Message and all the messages.

-----Original Message-----
From: Jesske, R [mailto:[email-masked]] 
Sent: Thursday, June 14, 2007 6:48 PM
To: Jayesh Sangpal (jsangpal); [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Michael Hammer (mhammer); [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: AW: [BLISS] Tunneling of Q931 messages over SIP

Best Regards

Roland

> An: [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked];
> [email-masked]; [email-masked]; Michael Hammer 
> (mhammer); [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 20 Jun 2007 22:11:57 +0100

Cc list trimmed to get it through list filter.
CC'ed to SIPPING but not BLISS.
#########################################

ISO and Ecma QSIG have been identical for many years. There was an early Ecma version that was not compatible, but that was obsoleted a long, long time ago. The IANA assignment of MIME type clearly states it is for the ISO/IEC version, and hence for the recent Ecma version too. When RFC 3204 was written, no need was seen for a means of identifying the old Ecma version.

Another difference between QSIG and Q.931 is the meaning of the Channel Identification information element, which in QSIG identifies logical channels, which do not necessarily correspond to physical timeslots and whose range is not constrained to the capacity of any single physical layer.

John 

> From: Martyn Davies [mailto:[email-masked]] 
> Sent: 20 June 2007 12:47
> To: DRAGE, Keith (Keith); Jayesh Sangpal (jsangpal)
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; Toleti Danayya Naidu (naidud); 
> Muthu ArulMozhi Perumal (mperumal); [email-masked]; 
> [email-masked]; [email-masked]; ROUSSEAU, 
> OLIVIER (OLIVIER); [email-masked]; [email-masked]; 
> [email-masked]; Michael Hammer (mhammer); 
> [email-masked]; Faisal Siyavudeen (fsiyavud); 
> [email-masked]; MOUROT, PATRICK (PATRICK); [email-masked]
> Subject: RE: [BLISS] Tunneling of Q931 messages over SIP
> 
> > The MIME type is there to tell you which protocol is meant 
> to be run.
> 
> That's true, but in practice it's often difficult to 
> enumerate all the possible variations in any case.  Already 
> this RFC is too ambiguous as at the very least it should use 
> 'version' or 'base' to allow you to specify whether it is ISO 
> or ECMA QSig.  This incompatibility of 'two QSigs' is a very 
> common problem for interconnecting PBXes.  In the same way, 
> you could use the version field to suggest that the protocol 
> is plain vanilla Q.931.
> 
> They've obviously made a more manful attempt in the RFC's 
> ISUP section, to enumerate sub-types of ISUP, but again in 
> practice it won't cover all the ISUPs that are out there.  
> The problem's just too big.
> 
> Regards, Martyn
> 
>  
> | Martyn Davies, Principal Consultant
> | Dialogic
> | Kings Chase, 107-123 King St, Maidenhead, SL6 1DP, UK
> | Tel:  +44 1628 641 790 x 210 
> | Cell: +44 7881 908 381 
> | Follow Me: +44 7031 911 586 
> | [email-masked]
> | blog: http://www.dialogic.com/drc
> | blog: http://voipsa.org/blog
>  
> Company Registration Number 2017909
> Registered in England and Wales
>  
> This e-mail is intended only for the named recipient(s) and 
> may contain information that is privileged, confidential 
> and/or exempt from disclosure under applicable law. No waiver 
> of privilege, confidence or otherwise is intended by virtue 
> of communication via the internet. Any unauthorized use, 
> dissemination or copying is strictly prohibited. If you have 
> received this e-mail in error, or are not named as a 
> recipient, please immediately notify the sender and destroy 
> all copies of this e-mail.
>  
>  
> 
> From: DRAGE, Keith (Keith) [mailto:[email-masked]] 
> Sent: Wednesday, June 20, 2007 11:54 AM
> To: Martyn Davies; Jayesh Sangpal (jsangpal)
> Cc: [email-masked]; [email-masked]; 
> Michael Hammer (mhammer); Toleti Danayya Naidu (naidud); 
> [email-masked]; Muthu ArulMozhi Perumal (mperumal); 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; MOUROT, PATRICK (PATRICK); 
> ROUSSEAU, OLIVIER (OLIVIER); [email-masked]; 
> Faisal Siyavudeen (fsiyavud); [email-masked]; 
> [email-masked]
> Subject: RE: [BLISS] Tunneling of Q931 messages over SIP
> 
> > doesn't need to know what the content is, as long as the two 
> > endpoints are running matching protocols.
> 
> And therein lies your problem.
> 
> The MIME type is there to tell you which protocol is meant to be run.
> 
> The key difference between the two protocols, is that QSIG 
> runs a state machine at both ends based on the user side 
> state machine in Q.931. The Q.931 protocol has different user 
> and network side state machines.
> 
> I suggest you also view the current thread on INFO usage in 
> the SIP WG list in regard to this part of the issue.
> 
> Regards
> 
> Keith 
> 
> > From: Martyn Davies [mailto:[email-masked]] 
> > Sent: Wednesday, June 20, 2007 11:44 AM
> > To: Jayesh Sangpal (jsangpal)
> > Cc: [email-masked]; DRAGE, Keith (Keith); 
> > [email-masked]; Michael Hammer (mhammer); 
> > Toleti Danayya Naidu (naidud); [email-masked]; 
> > Muthu ArulMozhi Perumal (mperumal); [email-masked]; 
> > [email-masked]; [email-masked]; 
> > [email-masked]; MOUROT, PATRICK (PATRICK); 
> > ROUSSEAU, OLIVIER (OLIVIER); [email-masked]; 
> > Faisal Siyavudeen (fsiyavud); [email-masked]; 
> > [email-masked]
> > Subject: RE: [BLISS] Tunneling of Q931 messages over SIP
> > 
> > 
> > As you said, QSig is a superset of Q931, so the distinction 
> > probably doesn't matter in this case.  In my direct 
> > experience of QSig, the only difference in practice from Q931 
> > is the large number of FACILITY messages containing Invoke 
> > commands, for example in Path Replacement sequences.
> > 
> > It looks from the RFC examples that the complete Q931/QSIG 
> > header is there embedded in any case, so the tunnel itself 
> > doesn't need to know what the content is, as long as the two 
> > endpoints are running matching protocols.
> > 
> > Regards, Martyn
> >  
> > | Martyn Davies, Principal Consultant
> > | Dialogic
> > | Kings Chase, 107-123 King St, Maidenhead, SL6 1DP, UK
> > | Tel:  +44 1628 641 790 x 210
> > | Cell: +44 7881 908 381
> > | Follow Me: +44 7031 911 586
> > | [email-masked]
> > | blog: http://www.dialogic.com/drc
> > | blog: http://voipsa.org/blog
> >  
> > Company Registration Number 2017909
> > Registered in England and Wales
> >  
> > This e-mail is intended only for the named recipient(s) and 
> > may contain information that is privileged, confidential 
> > and/or exempt from disclosure under applicable law. No waiver 
> > of privilege, confidence or otherwise is intended by virtue 
> > of communication via the internet. Any unauthorized use, 
> > dissemination or copying is strictly prohibited. If you have 
> > received this e-mail in error, or are not named as a 
> > recipient, please immediately notify the sender and destroy 
> > all copies of this e-mail.
> >  
> >  
> > From: Jayesh Sangpal (jsangpal) [mailto:[email-masked]]
> > Sent: Thursday, June 14, 2007 2:40 PM
> > To: Jesske, R; [email-masked]; [email-masked]; 
> > [email-masked]; [email-masked]; 
> > [email-masked]; Elwell, John
> > Cc: Muthu ArulMozhi Perumal (mperumal); Faisal Siyavudeen 
> > (fsiyavud); Toleti Danayya Naidu (naidud)
> > Subject: RE: [BLISS] Tunneling of Q931 messages over SIP
> > 
> > To: Jayesh Sangpal (jsangpal); [email-masked]; 
> > [email-masked]; [email-masked]; 
> > [email-masked]; [email-masked]; 
> > [email-masked]; 
> > Michael Hammer

---

From: "Martyn Davies" <[email-masked]>
Date: Wed, 20 Jun 2007 22:27:34 +0100

But what's in the field is another matter....

I could give you a case study only weeks old of ISO and ECMA implementations that are not identical and not compatible.

-----Original Message-----
From: Elwell, John [mailto:[email-masked]] 
Sent: Wednesday, June 20, 2007 10:12 PM
To: Martyn Davies; DRAGE, Keith (Keith); Jayesh Sangpal (jsangpal)
Cc: [email-masked]
Subject: RE: [BLISS] Tunneling of Q931 messages over SIP

John

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 20 Jun 2007 08:20:31 -0400

Keith,

Are you suggesting that any further variants of this sort *not* use 
INFO, and instead use some other mechanism?

	Paul

DRAGE, Keith (Keith) wrote:
> The key difference between the two protocols, is that QSIG runs a state machine at both ends based on the user side state machine in Q.931. The Q.931 protocol has different user and network side state machines.
> 
> I suggest you also view the current thread on INFO usage in the SIP WG list in regard to this part of the issue.
> 
> Regards
> 
> Keith 
>

---

From: "DRAGE, Keith \(Keith\)" <[email-masked]>
Date: Wed, 20 Jun 2007 18:57:53 +0200

No,

Merely pointing out that DSS1 (Q.931) and QSIG are definitely not the same protocol if you need to run the state machine, and that the limitations of identifying the usage of INFO are being discussed on the SIP list.

Regards

Keith

> From: Paul Kyzivat [mailto:[email-masked]] 
> Sent: Wednesday, June 20, 2007 1:21 PM
> To: DRAGE, Keith (Keith)
> Cc: Martyn Davies; Jayesh Sangpal (jsangpal); 
> [email-masked]; [email-masked]; 
> Subject: Re: [BLISS] Tunneling of Q931 messages over SIP
> 
> Keith,
> 
> Are you suggesting that any further variants of this sort 
> *not* use INFO, and instead use some other mechanism?
> 
> 	Paul
> 
> >> [email-masked]; Michael Hammer (mhammer); Toleti 
> >> Danayya Naidu (naidud); [email-masked]; Muthu ArulMozhi 
> >> Perumal (mperumal); [email-masked]; 
> [email-masked]; 
> >> [email-masked]; [email-masked]; MOUROT, 
> >> PATRICK (PATRICK); ROUSSEAU, OLIVIER (OLIVIER); 
> >> [email-masked]; [email-masked]
> >> As you said, QSig is a superset of Q931, so the 
> distinction probably 
> >> doesn't matter in this case.  In my direct experience of QSig, the 
> >> only difference in practice from Q931 is the large number 
> of FACILITY 
> >> messages containing Invoke commands, for example in Path 
> Replacement 
> >> sequences.
> >>
> header is 
> >> there embedded in any case, so the tunnel itself doesn't 
> need to know 
> >> what the content is, as long as the two endpoints are running 
> >> matching protocols.
> >>
> >> Regards, Martyn
> >>  
> >> | Martyn Davies, Principal Consultant Dialogic Kings 
> Chase, 107-123 
> >> | King St, Maidenhead, SL6 1DP, UK
> >> This e-mail is intended only for the named recipient(s) and may 
> >> contain information that is privileged, confidential and/or exempt 
> >> from disclosure under applicable law. No waiver of privilege, 
> >> confidence or otherwise is intended by virtue of communication via 
> >> the internet. Any unauthorized use, dissemination or copying is 
> >> strictly prohibited. If you have received this e-mail in error, or 
> >> are not named as a recipient, please immediately notify the sender 
> >> and destroy all copies of this e-mail.
> >>  
> >>  
> >> [email-masked]; [email-masked]; 
> >> [email-masked]; 
> >> To: Jayesh Sangpal (jsangpal); [email-masked]; [email-masked]; 
> >> [email-masked]; [email-masked];