Subject: [Sipping] Call Completion indication

From: "Huelsemann, Martin" <[email-masked]>
Date: Tue, 5 Jun 2007 16:26:18 +0200

Hi all,

one requirement for the call-completion service where the solution is still unclear to me is the indication that a certain call is a call-completion call. This would be some kind of marking the call as call-completion call, because when there are call-completion queue entries processed at the callee (a recall notification has been sent to the caller), only those special marked calls should be accepted. 
This call-completion indication of course needn't be mandatory, but it would be at least a good optional feature of a call-completion service, because when the CCBS user has received a notification that he can start the CCBS call, it should be avoided that he ends up in busy again because another user has started a normal call to the callee in the meantime.

As this is a matter of gaining prioritized access to resources, the usage of RFC 4412 (Resource-Priority with a new namespace) could be possible. Another suggestion is to use a mechanism similar to a token provided as a user-part parameter that indicates the incoming call is for completion and returns a token provided to the device at head of the queue.

Any other suggestions or comments?

Regards, Martin

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 06 Jun 2007 19:29:44 -0400

Such an indication isn't useful unless you can prevent it from being 
used in an abusive way. Do you have in mind a way to accomplish that?

	Paul