Subject: [Sipping] comments on draft-ren-sipping-replace-instant-message-00.txt

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 09 Jul 2007 17:23:00 -0400

Firstly, I'd like to see a little more content on requirements here. 
This draft has about two sentences of actual content. I think more can 
be said here.

In particular, I think the main question is around whether this is 
really useful for instant messages. I personally have found this useless 
in email since it appears to only work for outlook. Is there a 
standardized mechanism in IETF for message recall?

I think the draft needs to discuss what the desired operations are on 
the recipient side (per Paul's comments). It'd be good to also talk 
about how this is used in sms or mms. I'm not familiar with how it works 
there; my phone doesn't allow me to recall SMS messages for example.

-Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Linyi Tian <[email-masked]>
Date: Tue, 10 Jul 2007 11:24:26 +0800

Hi, 
Thanks very much for your comments. Sure we will put more content in future versions. We are very happy to discuss more about requirements here. 

For email supersedes please refer to  http://tools.ietf.org/html/rfc4021#section-2.1.46

Below is the description from SMS specification defined by 3GPP. It gives the information about Replace/Recall (delete) mechanism in SMS. There is new work in 3GPP named "SMS-IM interworking". I think the existing features should be interoperable or remain as many as possible. I hope this helpful. 

3GPP TS 23.040 V6.7.0 (2006-03)
Technical realization of the Short Message Service (SMS)

7.1	MS capabilities
The MS, when equipped for SMS, should be capable of:
-	notifying the SC when a short message is intended to replace a short message the MS has previously submitted to the same destination address.
9.2.3.9	TP-Protocol-Identifier (TP-PID)
The Replace Short Message feature is optional for the ME and the (U)SIM but if implemented it shall be performed as described here.
For MT short messages, on receipt of a short message from the SC, the MS shall check to see if the associated Protocol Identifier contains a Replace Short Message Type code.
If such a code is present, then the MS shall check the originating address and replace any existing stored message having the same Protocol Identifier code and originating address with the new short message and other parameter values. If there is no message to be replaced, the MS shall store the message in the normal way. The MS may also check the SC address as well as the Originating Address. However, in a network which has multiple SCs, it is possible for a Replace Message type for a SM to be sent via different SCs and so it is recommended that the SC address should not be checked by the MS unless the application specifically requires such a check.
If a Replace Short Message Type code is not present then the MS shall store the message in the normal way.

9.2.3.19	TP-Command-Type (TP-CT)
The TP-Command-Type is an 8-bit field specifying the type of operation that the SC is to perform. It has the following values:
00000010	Delete previously submitted Short Message	0
In the case where a TP-Command is to Delete a previously submitted short message, the SC shall send a Status Report indicating that the SM has been deleted if the original Submit SM request requested a status Report.

BR, 
Linyi

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]] 
Sent: Tuesday, July 10, 2007 5:23 AM
To: IETF Sipping List
Subject: [Sipping] comments on draft-ren-sipping-replace-instant-message-00.txt

-Jonathan R.