Subject: [Sipping] Comments on draft-vakil-sipping-Notify-pause-01

From: Paul Kyzivat <[email-masked]>
Date: Sat, 21 Jul 2007 23:20:44 -0400

I guess this hasn't changed since I was last in a conversation about it. 
But I just took a peek again to refresh my memory.

I think it is in good shape. I did notice one possible little improvement:

Suppose that a subscription is in effect (expires != 0) and notify=on.

Now what happens if a refresh subscription is sent with notify=once?

I *think* as currently written that there will be a NOTIFY and then the 
state will be notify=on. But I think it would be more useful if in this 
case the state was left as notify=off. This provides a way to get the 
latest state and then no updates. That isn't otherwise possible.

So what I am suggesting is that a refresh with notify=once should always 
leave the state as notify=off regardless of what the prior state was.

	Thanks,
	Paul

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Mohammad Vakil <[email-masked]>
Date: Mon, 23 Jul 2007 11:44:17 -0700

Thanks Paul. Yes, it hasn't changed since then. I'll update it after this IETF meeting.

I agree with your suggestion here. I just responded to Adam in a different thread, notify=once in the initial subscription is also in line with your suggestion, which would only create the first notify and then immediately pause the subscription.

-Mohammad

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]]
Sent: Saturday, July 21, 2007 8:21 PM
To: sipping
Subject: [Sipping] Comments on draft-vakil-sipping-Notify-pause-01

        Thanks,
        Paul