Subject: [Sipping] New I-D on 'sip trunks'

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 15 Feb 2008 15:45:52 -0500

I just posted a new I-D that tries to define a term that, though in 
common usage, isn't really defined at all in our documents - SIP trunk. 
It also proposes a mechanism to identify SIP trunks, using Route 
headers. In this way, it ties heavily into the UA loose route discussion.

See:
http://www.ietf.org/internet-drafts/draft-rosenberg-sipping-siptrunk-00.txt

Thanks,
-Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.                   499 Thornall St.
Cisco Fellow                                   Edison, NJ 08837
Cisco, Voice Technology Group
[email-masked]
http://www.jdrosen.net                         PHONE: (408) 902-3084
http://www.cisco.com
_______________________________________________
Sipping mailing list  http://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Richard Shockey" <[email-masked]>
Date: Fri, 15 Feb 2008 16:16:27 -0500

Ok what does this mean ..

PSTN Interconnect Trunk:  This is a SIP trunk that would be used by
      enterprises connecting to a service provider.  The trunk utilizes
      mutual TLS authentication to ascertain the identity of the
      requesting enterprise.  

"Requests are accepted only if the resulting identity matches a
pre-provisioned enterprise user; all others cause immediate closure of the
TLS connection."

How do you define identity here .. the identity of the enterprise so you can
use P-Asserted Identity to define the user to the SP or what? What is the
trust model you are asserting here in the definition?

>  -----Original Message-----
>  From: [email-masked] [mailto:[email-masked]] On
>  Behalf Of Jonathan Rosenberg
>  Sent: Friday, February 15, 2008 3:46 PM
>  To: IETF Sipping List
>  Subject: [Sipping] New I-D on 'sip trunks'
>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 15 Feb 2008 19:51:11 -0500

In this case, its talking about the identity of the TLS cert holder on 
the other side. So for example if enterprise example.com connects to a 
service provider but is not signed up for service, the connection is 
closed once the TLS exchange completes.

This text is just an example.

-Jonathan R.

---

From: Hadriel Kaplan <[email-masked]>
Date: Sun, 17 Feb 2008 20:16:24 -0500

Howdy,
Regarding section 2.1, you define 4 kinds of SIP Trunks.  What is the basis for this definition?  Specifically, what is the difference between a "PSTN Trunk" and a "Filtering Trunk"?  Why is one over TCP and one over MTLS?  Why does one have a whitelist of headers and one not?  Etc.  What do their definitions imply?

Also, isn't this more of a SIPPING thing than SIP? (or maybe even SIP Forum?)

Lastly, and I don't mean this in a negative way at all nor to be flippant, but what about this is Best *Common* Practice?  Maybe it's not my understanding of BCPs, but don't they represent something that is at least not uncommon?  (this has always confused me because different WG's in IETF seem to handle the concept of BCPs differently in this regard)

-hadriel

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Jonathan Rosenberg

---

From: Hadriel Kaplan <[email-masked]>
Date: Sun, 17 Feb 2008 20:21:05 -0500

Huh, ignore that question about SIPPING - apparently it already is.  I just wasn't. :)
-hadriel

> Of Hadriel Kaplan
> Sent: Sunday, February 17, 2008 8:16 PM
> To: Jonathan Rosenberg; IETF Sipping List
> Subject: Re: [Sipping] New I-D on 'sip trunks'
>
> Howdy,
> Regarding section 2.1, you define 4 kinds of SIP Trunks.  What is the
> basis for this definition?  Specifically, what is the difference between a
> "PSTN Trunk" and a "Filtering Trunk"?  Why is one over TCP and one over
> MTLS?  Why does one have a whitelist of headers and one not?  Etc.  What
> do their definitions imply?
>
> Lastly, and I don't mean this in a negative way at all nor to be flippant,
> but what about this is Best *Common* Practice?  Maybe it's not my
> understanding of BCPs, but don't they represent something that is at least
> not uncommon?  (this has always confused me because different WG's in IETF
> seem to handle the concept of BCPs differently in this regard)
>
> -hadriel
>
>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sun, 17 Feb 2008 22:07:59 -0500

inline:

Hadriel Kaplan wrote:
> Howdy, Regarding section 2.1, you define 4 kinds of SIP Trunks.  What
> is the basis for this definition?  Specifically, what is the
> difference between a "PSTN Trunk" and a "Filtering Trunk"?  Why is
> one over TCP and one over MTLS?  Why does one have a whitelist of
> headers and one not?  Etc.  What do their definitions imply?

This section is apparently confusing. THese are just examples actually, 
not formal definitions of these types. Just meant to convey the idea of 
the kinds of things one could put in the contract that defines the sip 
trunk.

> Lastly, and I don't mean this in a negative way at all nor to be
> flippant, but what about this is Best *Common* Practice?  Maybe it's
> not my understanding of BCPs, but don't they represent something that
> is at least not uncommon?  (this has always confused me because
> different WG's in IETF seem to handle the concept of BCPs differently
> in this regard)

Well there is some implementation of this at least; how common I don't 
know. I put BCP in there, just because it makes a recommendation on 
naming conventions, and typically that kind of thing, I think of as a BCP.

-Jonathan R.