Subject: [Sipping] can update be used in Figure 4 in draft-ietf-sipping-sip-offeranswer-06

From: "Rockson Li (zhengyli)" <[email-masked]>
Date: Tue, 26 Feb 2008 15:25:32 +0800

In Figure 4 of draft-ietf-sipping-sip-offeranswer-06
 
UPDATE is used to send new offer from Callee A.
 
However, I  wonder if it's valid to be used here? since as per RFC3311
sec5.1
 
and for the callee:
 
      o  If the UPDATE is being sent before the completion of the INVITE
         transaction, and the initial INVITE contained an offer, the
         UPDATE cannot be sent with an offer unless the callee has
         generated an answer in a reliable provisional response,
<NOTE>has
         received a PRACK for that reliable provisional response</NOTE>,
has
         not received any requests (PRACK or UPDATE) with offers that it
         has not answered, and has not sent any UPDATE requests
         containing offers that have not been answered.
 
Any comments?

Regards,
Rockson Li

Cisco R&D Center, Shanghai, PRC

_______________________________________________
Sipping mailing list  http://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "孙永光" <[email-masked]>
Date: Thu, 28 Feb 2008 10:13:07 +0800

Hi Rockson Li

Yes ,you're right

 but  Figure 4 of draft-ietf-sipping-sip-offeranswer-06 is a example of
*Exceptional Case Handling *

Thanks
Sun Yong-Guang

Infinite Shanghai, PRC

2008/2/26, Rockson Li (zhengyli) <[email-masked]>:
>          generated an answer in a reliable provisional response, <NOTE>has
Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping

---

From: "Rockson Li (zhengyli)" <[email-masked]>
Date: Thu, 28 Feb 2008 10:26:43 +0800

my understanding of "Exception" is original legal action producing unexpected result.
There would be countless cases if the original action is illegal.
Looks this explanation does not make sense.
 
Regards,
-Rockson
________________________________

From: 孙永光 [mailto:[email-masked]] 
Sent: Thursday, February 28, 2008 10:13 AM
To: Rockson Li (zhengyli)
Cc: [email-masked]
Subject: Re: [Sipping] can update be used in Figure 4 in draft-ietf-sipping-sip-offeranswer-06

Hi Rockson Li
 
Yes ,you're right

Thanks
Sun Yong-Guang
 
Infinite Shanghai, PRC

 

	 
	However, I  wonder if it's valid to be used here? since as per RFC3311 sec5.1
	 
	and for the callee:
	 
	         received a PRACK for that reliable provisional response</NOTE>, has
	 
	Any comments?

	Regards,
	Rockson Li