Subject: [Sipping] hold against 3264 in draft-ietf-sipping-sip-offeranswer-06 ?

From: "Rockson Li (zhengyli)" <[email-masked]>
Date: Thu, 28 Feb 2008 11:38:24 +0800

Hi all,
 
one question on sec 5.3. Hold and Resume of media
 
"If UA2 has previously been "placed on hold" by UA1, via receipt of
  "a=sendonly", then it may initiate its own hold by sending a new
  offer containing "a=sendonly" to UA1."
 
From RFC3264 sec 6.1 Unicast Streams
 
  If a stream is offered as sendonly, the corresponding stream MUST be
   marked as recvonly or inactive in the answer.
 
so UA2's stream is either recvonly or inactive now.
 
And From RFC3264 sec 8.4 Putting a Unicast Media Stream on Hold
 
   If the stream to be placed on hold was previously a recvonly media
stream,
   it is placed on hold by marking it inactive.
 
So RFC3264 says it only could be inactive, why draft above says it may
hold with a=sendonly?
 
Thanks

Regards,
Rockson Li

Cisco R&D Center, Shanghai, PRC

_______________________________________________
Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 28 Feb 2008 12:12:40 -0500

Rockson Li (zhengyli) wrote:
> And >From RFC3264 sec 8.4 Putting a Unicast Media Stream on Hold
>  

The sentence you reference in 8.4 is non-normative, and is wrong or 
confusing depending on how you read it. If you read the "was previously 
a recvonly media stream" as being that way because the other end had 
previously offered sendonly, then it contradicts the next paragraph. 
(Its different if the stream is inherently recvonly because of the 
capabilities or state of the local endpoint.)

Basing your offer, in part, on what you *think* the other party wants 
leads to all sorts of difficulty. And it doesn't provide any benefit. 
Specifically it leads to a "stuck on hold" situation once both sides 
have initiated a hold.

	Paul