Subject: Re: [Sipping] Publish a different status for different contacts

From: <[email-masked]>
Date: Mon, 30 Jun 2008 17:57:48 +0530

Hi,

	The RPID <class> element does not define any xml schema which
can be used to indicate different presence information for different
watchers. Could you please let us know how if we are missing something?

Regards,
-Vasanth

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Qian Sun
Sent: Saturday, June 28, 2008 2:15 PM
To: Veechi Jha (WT01 - MCE-Mobile Devices)
Cc: [email-masked]
Subject: Re: [Sipping] Publish a different status for different contacts

Hi, Veechi

The <class> element could be used to implement this scenario.

Qian
________________________________________
From: [email-masked] [mailto:[email-masked]] On
Behalf Of [email-masked]
Sent: Thursday, June 26, 2008 11:54 PM
To: [email-masked]; [email-masked]
Subject: Re: [Sipping] Publish a different status for different contacts

Right.All the documents i saw talk of only this context.i want to know
how I can show my status to be different for different watchers...I need
to implement this scenario...where the status of the same presentity
will be different for different watchers.
 
Veechi Jha
Project Engineer
Wipro Technologies
Email:[email-masked]
Mob:+919916896764

_______________________________________________
Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP Use
[email-masked] for questions on current sip Use
[email-masked] for new developments of core SIP
_______________________________________________
Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Qian Sun <[email-masked]>
Date: Tue, 01 Jul 2008 10:13:59 +0800

Hi,

For example, the presence source could publish:
<presence>
  <tuple>
     <status>
       <basic>open</basic>
     </status>
     <class>A</class>
  </tuple>
</presence>

And set the presence rules like:
<transformations>
   <provide_services>
     <class>A</class>
   </provide_services>
</transformations>

Qian

> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, June 30, 2008 8:28 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: [Sipping] Publish a different status for different contacts
> 
> Hi,
>