Subject: [Sipping] Offer/answer LS: How to document it

From: "Christer Holmberg" <[email-masked]>
Date: Wed, 6 Aug 2008 10:13:10 +0200

Hi,

Now when we agreed on which alternative to go for, we need to decided
how to document it.

Is it too late to get it into draft-ietf-sipping-sip-offeranswer, where
it is still listed as an open issue (in addtion we of course also needs
to get it into normative text)?

Regards,

Christer
_______________________________________________
Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 06 Aug 2008 08:13:19 -0400

I think it does make sense to make yet another rev to the o/a draft to 
close this issue in it.

But we also must find some way to make the changes normatively.

	Thanks,
	Paul

Christer Holmberg wrote:
> ------------------------------------------------------------------------
>

---

From: "Brett Tate" <[email-masked]>
Date: Thu, 7 Aug 2008 13:53:04 -0400

> Is it too late to get it into draft-ietf-sipping-sip-offeranswer, 
> where it is still listed as an open issue (in addtion we of 
> course also needs to get it into normative text)?

Draft-ietf-sipping-sip-offeranswer currently has several open issues.
If there are to be normative updates to the SIP RFCs, it should likely
occur within the SIP WG.  Additionally, I'd prefer all the open issues
mentioned within draft-ietf-sipping-sip-offeranswer be addressed at the
same time.  I have no preference between 1) allowing
draft-ietf-sipping-sip-offeranswer to proceed with open issues or 2)
moving the draft to the SIP working group so the open issues can be
resolved.
_______________________________________________
Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Christer Holmberg" <[email-masked]>
Date: Thu, 7 Aug 2008 22:01:54 +0200

Hi,

I don't think we need to move the offer/answer draft to the SIP WG.

The purpose of the draft is simply to clarify, not to specify protocol procedures. That is why I said that even if we document the decission regarding the re-INVITE fallback issue in the offer/answer draft, in addition we still need to also document it in some normative SIP document.

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 07 Aug 2008 16:13:10 -0400

I agree that the goal is to clarify rather than fix. As such it probably 
doesn't need to move.

But the clarification would be better if it didn't have open issues.

One solution is to simply hold this as a draft pending the fixes, and 
then rev it to reflect the fixes before progressing it.

OR, we could simply let it progress with the open issues.

Much as I would like to see it done, I am leaning toward holding it.

	Thanks,
	Paul

---

From: "Christer Holmberg" <[email-masked]>
Date: Thu, 7 Aug 2008 22:22:16 +0200

Hi,

>Much as I would like to see it done, I am leaning toward holding it.

I think I would agree. A clarification document with open issues is a little strange :)

Because, apart from the remaining open issues, the draft is very stable, and people can use it.

The main open issue still remaining is the one related to how-to-reject-offers-in-PRACK. There are a number of different solution proposals, each with pros and cons, and I think we will eventually just have to pick one. Again, from an interop perspective it's better to know how things shall work, and take the consequences based on that, than having no idea on how things should work - or having many different opinions on how things should work...

I've started to put together a draft regarding the PRACK issue. The intention is not to produce an RFC, but to have somewhere to document the different alternatives etc during the work on finding a solution.

Regards,

Christer

	Thanks,
	Paul

---

From: Takuya Sawada <[email-masked]>
Date: Fri, 8 Aug 2008 20:26:14 +0900

Hi,

I think I would also agree to hold it to reflect the fixes.

Regards,
Takuya

> > -----Alkuper臺nen viesti-----
> > L臧ett臻・ Brett Tate [mailto:[email-masked]]
> > L臧etetty: to 7.8.2008 19:53

--------
Takuya Sawada
KDDI Corporation (KDDI)
Garden Air Tower, 3-10-10, Iidabashi, 
Chiyoda-ku, Tokyo 102-8460, Japan
Tel: +81-3-6678-2997
Fax: +81-3-6678-0286
[email-masked]

------------------------------------------------------------------
注意：この電子メールには、KDDI株式会社の機密情報が含まれている
      場合が有ります。正式なメール受信者でない場合、メール複製、
　　　再配信または情報の使用を固く禁じております。
      エラー、手違い等でこのメールを受け取られましたら、お手数を
　　　おかけ致しますが、削除を行い配信者に連絡をお願い致します。
NOTE: This electronic mail message may contain confidential and
　　　privileged information from KDDI Corporation. If you are
　　　not the intended recipient, any disclosure, photocopying,
      distribution or use of the contents of the received
      information is prohibited. If you have received this e-mail
      in error, please notify the sender immediately and
    　permanently delete this message and all related copies.
-------------------------------------------------------------------