Subject: [Sipping] FW: [Sip-implementors] Replece question on RFC5057

From: "Rockson Li (zhengyli)" <[email-masked]>
Date: Wed, 6 Aug 2008 09:52:04 +0800

Try this list....

-Rockson
-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of
Rockson Li (zhengyli)
Sent: Tuesday, August 05, 2008 8:32 PM
To: [email-masked]
Subject: [Sip-implementors] Replece question on RFC5057

Hi guys,
 
On RFC5057 sec 6.
 
Carol accepts Alice's invitation to replace her dialog (invite usage)
with Bob ...
 Bob then ends his invite usages with both Alice and Carol using BYEs.
 
however, I don't see Carol send BYE to terminate the dialog(invite
usage) with Bob in Figure 5.
 
And if Carol sent BYE to Bob, Bob would not send BYE to Carol himself in
Figure 5
 
Regards,
-Rockson
_______________________________________________
Sip-implementors mailing list
[email-masked]
https://lists.cs.columbia.edu/cucslists/listinfo/sip-implementors
_______________________________________________
Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Ian Elz" <[email-masked]>
Date: Wed, 6 Aug 2008 11:33:00 +0200

Rockson,

I had enough comments on this RFC when it was a draft before the raising
to RFC but I did not see the problem with the sequence as shown in
Figure 5 of RFC5057.

The sequence does not show the Refer-to: Carol?Replaces=xxx but the
message sequence below, F5, does indicate that the REFER and resulting
INVITE, F6, uses the Replaces header (RFC3891).

Based upon RFC3891 Carol should send a BYE to Bob when the INVITE from
Alice has been accepted.

Remember however that this RFC is only 'Informational' and Figure 5 is
only an example to illustrate the usage of separate dialogs rather than
sending the REFER in the same dialog as the INVITE. I would always refer
to the Standards Track RFCs for normative behavior.

If you are looking at an implementation based upon the principles
proposed in RFC5057 you should remember that there is no standardized
routing behavior when any of the dialogs when the dialogs have the
call-id and or tags (to and from) are mapped by a B2BUA, e.g. a session
border controller or application server. Mapping of any of these values
has an impact on the usage of Replaces, Target-dialog and Join headers. 

An attempt was made to specify some best practice in this area in
draft-marjou-sipping-b2bua-01.txt but the sipping wg decided that this
work was not suitable for consideration as part of the wg charter.

Ian Elz

System Manager
DUCI LDC UK
(Lucid Duck)

Office: + 44 24 764 35256
gsm: +44 7801723668
[email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Rockson Li (zhengyli)
Sent: 06 August 2008 02:52
To: sipping
Subject: [Sipping] FW: [Sip-implementors] Replece question on RFC5057

Try this list....

-Rockson
-----Original Message-----

Hi guys,
 
On RFC5057 sec 6.

 
 
Regards,
-Rockson