Subject: [Sipping] Encrypted SDP body

From: Rocío Collado <[email-masked]>
Date: Fri, 22 Aug 2008 12:28:08 +0200

Hi, all!

            I wonder, in case I get a SIP message that is carrying an
encrypted body, if there is any way to know that those encrypted contents
are an encrypted SDP body, I mean, without the need of deciphering it. Maybe
some specific "Content-Type" value? Some parameter within some header? I've
found in the literature that you may find things such as

Content-Type: application/pkcs7-mime;
smime-type=enveloped-data;name=smime.p7m
Content-Disposition: attachment; filename=smime.p7m
           handling=required

which is a sort or generic encryption, isn't it? Your encrypted body might
be whatever, not necessarily an application/sdp content type, there is no
clue in these headers that lets you guess what the encrypted contents are. I
suppose this makes sense, since, if you want to encrypt something, you
really want to prevent anyone from finding out what it is. But, just in case
there is some artifact that "gives clues", that's why I'm asking…

           Thank you very much for your help.         

 

Rocío Collado Collado

eXperience Ingeniería y Servicios - Boecillo

Valladolid (SPAIN)

Tlf.:     +34 983 54 98 48

Móvil: +34 659 74 57 91

 <mailto:[email-masked]> [email-masked]

_______________________________________________
Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Attila Sipos" <[email-masked]>
Date: Fri, 22 Aug 2008 13:56:34 +0100

sorry again.
you were asking how to know what the content type is BEFORE encryption.
 
There is no way to know.
Not only is the content hidden but also the content-type.
Unfortunately this doesn't help you.
 
May I ask why you need to know?
Are you doing a B2BUA or SBC?
 
Regards,
Attila

________________________________

From: Attila Sipos 
Sent: 22 August 2008 13:53
To: 'Rocío Collado'
Cc: [email-masked]
Subject: RE: [Sipping] Encrypted SDP body

whoops!!
didn't read it very well, did I?
 
Yes, you can encrypt with any kind of body not just SDP.
 
It's just an envelope (smime-type=enveloped-data) - what you put inside the
envelope is up to you.
 
See the envelope on page 206 has Content-Type: application/sdp
but you can put whatever Content-Type you want...
 
        Content-Type: application/pkcs7-mime; smime-type=enveloped-data;
             name=smime.p7m
        Content-Disposition: attachment; filename=smime.p7m
           handling=required

      *******************************************************
      * Content-Type: application/sdp                       *
      *                                                     *
      * v=0                                                 *
      * o=alice 53655765 2353687637 IN IP4 pc33.atlanta.com *
      * s=-                                                 *
      * t=0 0                                               *
      * c=IN IP4 pc33.atlanta.com                           *
      * m=audio 3456 RTP/AVP 0 1 3 99                       *
      * a=rtpmap:0 PCMU/8000                                *
      *******************************************************

Regards,

Attila

________________________________

From: Rocío Collado [mailto:[email-masked]] 
Sent: 22 August 2008 13:19
To: Attila Sipos
Subject: RE: [Sipping] Encrypted SDP body

Thank you, but that's what I found as well (I wrote it in my first e-mail). Do you think application/pkcs7-mime is specific to encrypt only SDP bodies, or it can be used to encrypt also other kinds of bodies?

Thanks again

Rocío Collado Collado

Tlf.:     983 54 98 48

Móvil: 659 74 57 91

[email-masked] <mailto:[email-masked]> 

De: Attila Sipos [mailto:[email-masked]] 
Enviado el: viernes, 22 de agosto de 2008 14:02
Para: Rocío Collado
Asunto: RE: [Sipping] Encrypted SDP body

I'm not an expert on this but one example is:

        Content-Type: application/pkcs7-mime; smime-type=enveloped-data;
             name=smime.p7m

see page 206 of rfc 3261

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of Rocío Collado
Sent: 22 August 2008 11:28
To: [email-masked]
Subject: [Sipping] Encrypted SDP body

Hi, all!

            I wonder, in case I get a SIP message that is carrying an encrypted body, if there is any way to know that those encrypted contents are an encrypted SDP body, I mean, without the need of deciphering it. Maybe some specific "Content-Type" value? Some parameter within some header? I've found in the literature that you may find things such as

Content-Type: application/pkcs7-mime; smime-type=enveloped-data;name=smime.p7m
Content-Disposition: attachment; filename=smime.p7m
           handling=required

which is a sort or generic encryption, isn't it? Your encrypted body might be whatever, not necessarily an application/sdp content type, there is no clue in these headers that lets you guess what the encrypted contents are. I suppose this makes sense, since, if you want to encrypt something, you really want to prevent anyone from finding out what it is. But, just in case there is some artifact that "gives clues", that's why I'm asking...

Rocío Collado Collado

Valladolid (SPAIN)

Tlf.:     +34 983 54 98 48

Móvil: +34 659 74 57 91

[email-masked]

.

---

From: "Attila Sipos" <[email-masked]>
Date: Fri, 22 Aug 2008 13:52:50 +0100

whoops!!

 

Regards,

Attila

Thanks again

Rocío Collado Collado

Tlf.:     983 54 98 48

Móvil: 659 74 57 91

see page 206 of rfc 3261

Hi, all!

Rocío Collado Collado

Valladolid (SPAIN)

Tlf.:     +34 983 54 98 48

Móvil: +34 659 74 57 91

.