Subject: [siprec] WGLC comments on siprec-req-06 - AndyH

From: "Hutton, Andrew" <[email-masked]>
Date: Mon, 17 Jan 2011 18:28:43 +0100

A few WGLC comments on the draft.

1. Abstract: "Recording is typically done by". Maybe could replace "done" with "achieved" or "perfomed".

2. Definitions, 2nd Para": 
"The SRC itself or another entity working on its behalf (such as a SIP Application Server) may act as the source of the recording metadata."
I believe it is the SRC which is always the source of the metadata. However of course the SRC could be decomposed in various ways but it is still a component of the SRC which is the source of metadata. If an SRC receives information from somewhere else which it uses as metadata then that is also out of scope.

3. Section 4, Use Case 1: 
"Use Case 1: Full-time Recording: One (or more, in the case of
   redundant recording) Recording Session for each Communication
   Session."
There is no other reference to "redundant recording" in the document I think we should therefore remove this statement. I think we agreed that this was just an implementation option and did not need to be a requirement

4. Section 5, Req 10.
"REQ-010 The mechanism MUST support the ability to deliver to the
   SRS multiple media streams for a given CS."
Does this refer to the case of multiple media types (E.g. Voice, Video etc.) or does it mean multiple media streams of the same type (i.e. one per participant)?  I think we might need to explicitly state a requirement for unmixed audio streams from different parties.

Regards
Andy

---

From: Leon Portman <[email-masked]>
Date: Tue, 18 Jan 2011 08:52:40 +0200

Andy, Hi

Thank you for the comments
Please see below

Leob

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hutton, Andrew
Sent: Monday, January 17, 2011 7:29 PM
To: [email-masked]
Subject: [siprec] WGLC comments on siprec-req-06 - AndyH

[leon] don't have any strong opinion about it

[leon] I don't think that we should limit scope in such way. Why do we care if SRC received metadata from some other entity, like CTI server for backward compatibility case?
 
[leon] May be "duplicate" will be a better term? It is just an example, and not actual requirement

4. Section 5, Req 10.
"REQ-010 The mechanism MUST support the ability to deliver to the
   SRS multiple media streams for a given CS."
Does this refer to the case of multiple media types (E.g. Voice, Video etc.) or does it mean multiple media streams of the same type (i.e. one per participant)?  I think we might need to explicitly state a requirement for unmixed audio streams from different parties.
[leon] Yes, it means actually both. It is obvious for different types and not so obvious for unmixed streams

Regards
Andy

_______________________________________________
siprec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/siprec

---

From: "Hutton, Andrew" <[email-masked]>
Date: Thu, 20 Jan 2011 14:35:07 +0100

See my responses to Leon's comments below included suggested text for an new multiple media stream requirement.

Regards
Andy

> From: Leon Portman [mailto:[email-masked]] 
> Sent: 18 January 2011 06:53
> To: Hutton, Andrew; [email-masked]
> Subject: RE: WGLC comments on siprec-req-06 - AndyH
> 
> Andy, Hi
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Hutton, Andrew
> 1. Abstract: "Recording is typically done by". Maybe could 
> replace "done" with "achieved" or "perfomed".
> 
> "The SRC itself or another entity working on its behalf (such 
> as a SIP Application Server) may act as the source of the 
> recording metadata."
> I believe it is the SRC which is always the source of the 
> metadata. However of course the SRC could be decomposed in 
> various ways but it is still a component of the SRC which is 
> the source of metadata. If an SRC receives information from 
> somewhere else which it uses as metadata then that is also 
> out of scope.
> 
> [leon] I don't think that we should limit scope in such way. 
> Why do we care if SRC received metadata from some other 
> entity, like CTI server for backward compatibility case?

[Andy H] - We don't care how the SRC receives the metadata  however for the purposes of SIPREC we assume that the SRC is the only entity that sends metadata to the SRS. The current text could be interpreted as indicating that something other than the SRC is able to send metadata to the SRS which is I believe incorrect.

> There is no other reference to "redundant recording" in the 
> document I think we should therefore remove this statement. I 
> think we agreed that this was just an implementation option 
> and did not need to be a requirement
[Andy H] My preference would be to remove statements all statements on "Redundant" or "Duplicate" recording.

> Does this refer to the case of multiple media types (E.g. 
> Voice, Video etc.) or does it mean multiple media streams of 
> the same type (i.e. one per participant)?  I think we might 
> need to explicitly state a requirement for unmixed audio 
> streams from different parties.
> [leon] Yes, it means actually both. It is obvious for 
> different types and not so obvious for unmixed streams
> 
[Andy H] - Agreed so we need a REQ-XX which might state "The mechanism MUST support the ability to deliver to the SRS multiple media streams of the same media type (e.g. audio, video). For example in the case of delivering unmixed audio for each participant in the CS".

---

From: Leon Portman <[email-masked]>
Date: Mon, 24 Jan 2011 12:27:13 +0200

I am ok with that

Leon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hutton, Andrew
Sent: Thursday, January 20, 2011 3:35 PM
To: Leon Portman; [email-masked]
Subject: Re: [siprec] WGLC comments on siprec-req-06 - AndyH

Regards
Andy

> "The SRC itself or another entity working on its behalf (such as a SIP 
> Application Server) may act as the source of the recording metadata."
> I believe it is the SRC which is always the source of the metadata. 
> However of course the SRC could be decomposed in various ways but it 
> is still a component of the SRC which is the source of metadata. If an 
> SRC receives information from somewhere else which it uses as metadata 
> then that is also out of scope.
> 
> Why do we care if SRC received metadata from some other entity, like 
> CTI server for backward compatibility case?

> There is no other reference to "redundant recording" in the document I 
> think we should therefore remove this statement. I think we agreed 
> that this was just an implementation option and did not need to be a 
> requirement [leon] May be "duplicate" will be a better term? It is 
> just an example, and not actual requirement
> 

> Voice, Video etc.) or does it mean multiple media streams of the same 
> type (i.e. one per participant)?  I think we might need to explicitly 
> state a requirement for unmixed audio streams from different parties.