Subject: Re: [siprec] Use of INFO for siprec metadata

From: "Henry Lum" <[email-masked]>
Date: Mon, 24 Jan 2011 07:31:52 -0800

Hi Paul,

If we have an RS that only wants to send metadata without recorded
media, INFO can also be useful for this case without resorting to
UPDATE. 

With UPDATE or content in INVITE/PRACK, what can we do if we want a
mechanism to report errors in metadata from the SRS to the SRC? 

Let's bring this into the mailing list.

Henry

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: Monday, January 24, 2011 9:02 AM
> To: Parthasarathi R (partr)
> Cc: Henry Lum; Elwell, John; Ram Mohan R (rmohanr); Ken Rehor
(krehor);
> Leon Portman
> Subject: Use of INFO for siprec metadata
> 
> I question the value of using INFO for metadata. My reasoning is as
> follows:
> 
> - there is need to transmit metadata in conjunction with
>    media stream creation/change.
> 
> - the media stream creation/change happens as a result of o/a.
> 
> - the o/a happens in INVITE/UPDATE/PRACK and their responses.
> 
> - therefore there is a need to transmit metadata with those messages.
> 
> - in those cases where there is need to transmit metadata even
>    though there is no media stream change, it could be sent in an
>    UPDATE (since there will be mechanism to use UPDATE.)
> 
> The alternative would be to restrict metadata to INFO messages. But
> then
> the metadata about a media stream creation/change would have to follow
> the message that did the media change, so there would be a delay in
> understanding what it was about. And a need to cross reference between
> the two messages. That seems at best inconvenient.
> 
> 	Thanks,
> 	Paul
> 

-------------------------------------------------------------------------------------------------------------------
CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain confidential and proprietary information of Alcatel-Lucent and/or its affiliated entities. Access by the intended recipient only is authorized. Any liability arising from any party acting, or refraining from acting, on any information contained in this e-mail is hereby excluded. If you are not the intended recipient, please notify the sender immediately, destroy the original transmission and its attachments and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Copyright in this e-mail and any attachments belongs to Alcatel-Lucent and/or its affiliated entities.

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 24 Jan 2011 10:45:58 -0500

> Let's bring this into the mailing list.

Assuming we have a mechanism to use UPDATE to send metadata, then that 
will work even if the UPDATE does not include and o/a. Of course INFO 
would also work. It just seems an unnecessary complication to pull in 
the info package mechanism.

(If we didn't ever need to send metadata with messages carrying o/a then 
I would *prefer* to use INFO.)

	Thanks,
	Paul