Subject: [siprec] Application Data in the metadata model

From: "Elwell, John" <[email-masked]>
Date: Thu, 20 Jan 2011 09:17:43 +0100

Ram,

This has probably been discussed before, but why is Application Data a separate object class, as opposed to being attributes of the various other object classes. In particular, I find the cardinalities of Application Data's associations with other classes hard to understand. Why would an Application Data object be associated with a single RS, a single CSG, a single CS, a single Participant, and a single Media Stream all at the same time? Or I am interpreting the figure wrong?

John (as individual)

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Thu, 20 Jan 2011 16:51:05 +0530

Hi John,
Thanks for the review
Please see inline

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Elwell, John
> Sent: Thursday, January 20, 2011 1:48 PM
> To: [email-masked]
> Subject: [siprec] Application Data in the metadata model
> 
> Ram,
> 
> This has probably been discussed before, but why is Application Data a
> separate object class, as opposed to being attributes of the various
> other object classes.

App Data is for vendor specific data that may be sent for session. So I
doubt if that can be as attributes inside a block.

In particular, I find the cardinalities of
> Application Data's associations with other classes hard to understand.
> Why would an Application Data object be associated with a single RS, a
> single CSG, a single CS, a single Participant, and a single Media
> Stream all at the same time? Or I am interpreting the figure wrong?

I intend to say that there are different instances of App Data, and a
given instance of App Data has be associated to only one block.
I will add some text in the draft to reflect the same.
As of now, there can be Zero (there may be elements for which we don't
need App Data at all) or more instances of App Data for each of the
metadata element blocks(in most cases one should be enough) and a given
instance of App Data MUST be associated with only one block. 

Thanks,
Ram

> 
> John (as individual)
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 20 Jan 2011 14:58:14 +0100

> From: Ram Mohan R (rmohanr) [mailto:[email-masked]] 
> Sent: 20 January 2011 11:21
> To: Elwell, John; [email-masked]
> Subject: RE: [siprec] Application Data in the metadata model
> 
> Hi John,
> Thanks for the review
> Please see inline
> 
[JRE] It still strikes me as a property of other objects. For example, a participant can have application data that says something about the participant, e.g., adds to the description of the participant. But that application data doesn't have associations with any other objects. So I am not convinced, but I can accept whatever consensus others may reach.

> instance of App Data MUST be associated with only one block. 
[JRE] Yes, I understand this, but I don't know how to model it. I am sure there must be a formal way.

John

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 20 Jan 2011 09:21:30 -0500

IMO appdata is just a way to talk about an extensibility hook for each 
defined object.

We have been having a private conversation about how to encode this in 
xml. I'm no xml expert, but I was thinking that each object simply end 
up with a sequence of ANY to cover the appdata. An alternative view is 
that we define an appdata xml entity that contains a sequence of ANY. 
I'm going to defer to an xml expert for the best way to encode such stuff.

	Thanks,
	Paul