Subject: [siprec] What happened to the 'recorded' feature tag?

From: "Elwell, John" <[email-masked]>
Date: Thu, 20 Jan 2011 09:26:18 +0100

Draft-johnston-siprec-cc-rec specified 3 media feature tags. Two of them, 'src' and 'srs', have been moved to draft-portman-siprec-protocol, as part of the merger of the two drafts. The third one, 'recorded', for use on the CS, has been dropped. I recognise this is not part of the "SIPREC protocol" between SRC and SRS, but nevertheless it seems to be a solution to one of the SIPREC requirements. What are the intentions of the draft authors?

John

---

From: "Henry Lum" <[email-masked]>
Date: Thu, 20 Jan 2011 01:07:46 -0800

The intention for this draft is to include any extensions to address
recording-aware endpoints for the following requirements:

REQ-15, 016, 017, 018

These requirements are currently not addressed in the protocol draft.

Henry

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Elwell, John
> Sent: Thursday, January 20, 2011 3:26 AM
> To: [email-masked]
> Subject: [siprec] What happened to the 'recorded' feature tag?
> 
> Draft-johnston-siprec-cc-rec specified 3 media feature tags. Two of
> them, 'src' and 'srs', have been moved to draft-portman-siprec-
> protocol, as part of the merger of the two drafts. The third one,
> 'recorded', for use on the CS, has been dropped. I recognise this is
> not part of the "SIPREC protocol" between SRC and SRS, but
nevertheless
> it seems to be a solution to one of the SIPREC requirements. What are
> the intentions of the draft authors?
> 
> John
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec

-------------------------------------------------------------------------------------------------------------------
CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain confidential and proprietary information of Alcatel-Lucent and/or its affiliated entities. Access by the intended recipient only is authorized. Any liability arising from any party acting, or refraining from acting, on any information contained in this e-mail is hereby excluded. If you are not the intended recipient, please notify the sender immediately, destroy the original transmission and its attachments and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Copyright in this e-mail and any attachments belongs to Alcatel-Lucent and/or its affiliated entities.

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 20 Jan 2011 10:32:53 +0100

Henry,

Thanks for the clarification. The particular requirement I picked on (REQ-018) is indeed not the only requirement still to be addressed. If the intention is to cover these remaining requirements in the protocol draft, we should perhaps get these in before considering adoption as a WG draft.

John 

> From: Henry Lum [mailto:[email-masked]] 
> Sent: 20 January 2011 09:08
> To: Elwell, John; [email-masked]
> Subject: RE: [siprec] What happened to the 'recorded' feature tag?
> 
> --------------------------------------------------------------
> -----------------------------------------------------
> CONFIDENTIALITY NOTICE: This e-mail and any files attached 
> may contain confidential and proprietary information of 
> Alcatel-Lucent and/or its affiliated entities. Access by the 
> intended recipient only is authorized. Any liability arising 
> from any party acting, or refraining from acting, on any 
> information contained in this e-mail is hereby excluded. If 
> you are not the intended recipient, please notify the sender 
> immediately, destroy the original transmission and its 
> attachments and do not disclose the contents to any other 
> person, use it for any purpose, or store or copy the 
> information in any medium. Copyright in this e-mail and any 
> attachments belongs to Alcatel-Lucent and/or its affiliated entities.
> 					
>

---

From: "Hutton, Andrew" <[email-masked]>
Date: Thu, 20 Jan 2011 15:22:35 +0100

Hi All,

Hi all with regard to the 'recorded' feature tag them I don't know why this was not copied to the new draft I think it should have been. Alan can you please comment on that.

We did update the scope in the 02 draft to make it clear that the protocol specified also impacted the CS and this was I think because of the 'recorded' feature tag.

I suggest we put it back in at the next update.

Regards
Andy

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Elwell, John
> Sent: 20 January 2011 09:33
> To: Henry Lum; [email-masked]
> Subject: Re: [siprec] What happened to the 'recorded' feature tag?
> 
> Henry,
> 
> Thanks for the clarification. The particular requirement I 
> picked on (REQ-018) is indeed not the only requirement still 
> to be addressed. If the intention is to cover these remaining 
> requirements in the protocol draft, we should perhaps get 
> these in before considering adoption as a WG draft.
> 
> John 
>

---

From: Alan Johnston <[email-masked]>
Date: Thu, 20 Jan 2011 09:09:30 -0600

I thought the consensus of the group was that the notification requirements
were to be met by notifications in the media path.

The fatal flaw with the feature tag approach was that it was not backwards
compatible - an RFC 3261 UA would not render or display this information to
the user, and hence some other notification would be needed.

We can certainly add it back in if the working group thinks it is useful.

- Alan -

On Thu, Jan 20, 2011 at 8:22 AM, Hutton, Andrew <
[email-masked]> wrote:

> Hi All,
>
> Hi all with regard to the 'recorded' feature tag them I don't know why this
> was not copied to the new draft I think it should have been. Alan can you
> please comment on that.
>
> We did update the scope in the 02 draft to make it clear that the protocol
> specified also impacted the CS and this was I think because of the
> 'recorded' feature tag.
>

---

From: "Hutton, Andrew" <[email-masked]>
Date: Thu, 20 Jan 2011 17:13:27 +0100

My thinking has always been that we should include a recorded indication in the CS and I think the charter actually refers to this.

Obviously this might need to be backed up with an indication in the media path but I don't see that as a reason for not including the information in SIP.

Regards
Andy

________________________________
From: Alan Johnston [mailto:[email-masked]]
Sent: 20 January 2011 15:10
To: Hutton, Andrew
Cc: Elwell, John; Henry Lum; [email-masked]
Subject: Re: [siprec] What happened to the 'recorded' feature tag?

I thought the consensus of the group was that the notification requirements were to be met by notifications in the media path.

The fatal flaw with the feature tag approach was that it was not backwards compatible - an RFC 3261 UA would not render or display this information to the user, and hence some other notification would be needed.

- Alan -

On Thu, Jan 20, 2011 at 8:22 AM, Hutton, Andrew <[email-masked]<mailto:[email-masked]>> wrote:
Hi All,

Regards
Andy

> From: [email-masked]<mailto:[email-masked]>
> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Elwell, John
> To: Henry Lum; [email-masked]<mailto:[email-masked]>
> > From: Henry Lum [mailto:[email-masked]<mailto:[email-masked]>]
> > To: Elwell, John; [email-masked]<mailto:[email-masked]>
> > > From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On
> > > Behalf Of Elwell, John
> > > To: [email-masked]<mailto:[email-masked]>
> > > [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>