Subject: [siprec] Recording awareness indication

From: "Elwell, John" <[email-masked]>
Date: Wed, 6 Apr 2011 16:55:12 +0200

There was an inconclusive discussion in Prague on the recording awareness signalling indication in draft-portman-siprec-protocol (slide 6 / section 6.1 of draft). If I understand correctly, it indicates that a UA involved in the CS supports the SIPREC extensions relevant to the CS. In particular, it indicates that the UA would be able to understand SIP/SDP recording indications (slide 7 / section 6.2 of draft). It seems the recording awareness indication means that the SRC can rely on the recording indications in SIP/SDP to advise the user that recording is in progress, thereby avoiding the need for the SRC to provide suitable indications through non-SIP means (e.g., in-band audio announcements).

Please continue this discussion.

John (as chair)

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 6 Apr 2011 17:08:07 +0200

My own thoughts on this are that the SIP/SDP indication that recording is in progress, even if sent to a UA known to be recording-aware, should not be used as a substitute for other non-SIP/SDP means of notification that might otherwise be needed (e.g., an in-band audio announcement). I think recording indicators should be used to complement other means. For example, an in-band audio announcement would be able to reach all users (although might be problematic for hearing-impaired users or for users speaking a different language). Despite such limitations, an in-band announcement is often sufficient to satisfy legal requirements. On the other hand, a SIP/SDP indication that recording is in progress could be rendered in different ways and in different languages at the user interface of a recording-aware UA.

For this reason, I don't see a need for the recording-aware indication in SIP/SDP. Recording indications can be sent without knowing whether they will be understood by the receiving UA - if they are understood the user might get an enhanced indication - if not they will be discarded and the user will get only the basic (non-SIP/SDP) indication.

John (as individual)

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Elwell, John
> Sent: 06 April 2011 15:55
> To: [email-masked]
> Subject: [siprec] Recording awareness indication
> 
> There was an inconclusive discussion in Prague on the 
> recording awareness signalling indication in 
> draft-portman-siprec-protocol (slide 6 / section 6.1 of 
> draft). If I understand correctly, it indicates that a UA 
> involved in the CS supports the SIPREC extensions relevant to 
> the CS. In particular, it indicates that the UA would be able 
> to understand SIP/SDP recording indications (slide 7 / 
> section 6.2 of draft). It seems the recording awareness 
> indication means that the SRC can rely on the recording 
> indications in SIP/SDP to advise the user that recording is 
> in progress, thereby avoiding the need for the SRC to provide 
> suitable indications through non-SIP means (e.g., in-band 
> audio announcements).
> 
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>

---

From: "Henry Lum" <[email-masked]>
Date: Wed, 6 Apr 2011 08:23:18 -0700

If the awareness is not revealed to the SRC, then this means that the
SRC will have to assume that it will deliver both the basic
(non-SIP/SDP) indication as well as the enhanced indication (in SIP/SDP)
to ensure it meets any legal requirements. This may sound redundant to
me to render both indications at the same time, however, the
requirements REQ-018 and REQ-019 does not preclude both types of
indication to be used together. 

Henry

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Elwell, John
> Sent: Wednesday, April 06, 2011 11:08 AM
> To: Elwell, John; [email-masked]
> Subject: Re: [siprec] Recording awareness indication
> 
> My own thoughts on this are that the SIP/SDP indication that recording
> is in progress, even if sent to a UA known to be recording-aware,
> should not be used as a substitute for other non-SIP/SDP means of
> notification that might otherwise be needed (e.g., an in-band audio
> announcement). I think recording indicators should be used to
> complement other means. For example, an in-band audio announcement
> would be able to reach all users (although might be problematic for
> hearing-impaired users or for users speaking a different language).
> Despite such limitations, an in-band announcement is often sufficient
> to satisfy legal requirements. On the other hand, a SIP/SDP indication
> that recording is in progress could be rendered in different ways and
> in different languages at the user interface of a recording-aware UA.
> 
> For this reason, I don't see a need for the recording-aware indication
> in SIP/SDP. Recording indications can be sent without knowing whether
> they will be understood by the receiving UA - if they are understood
> the user might get an enhanced indication - if not they will be
> discarded and the user will get only the basic (non-SIP/SDP)
> indication.
> 
> John (as individual)
> 
> 

-------------------------------------------------------------------------------------------------------------------
CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain confidential and proprietary information of Alcatel-Lucent and/or its affiliated entities. Access by the intended recipient only is authorized. Any liability arising from any party acting, or refraining from acting, on any information contained in this e-mail is hereby excluded. If you are not the intended recipient, please notify the sender immediately, destroy the original transmission and its attachments and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Copyright in this e-mail and any attachments belongs to Alcatel-Lucent and/or its affiliated entities.

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 06 Apr 2011 15:14:24 -0400

I liked this concept of an overt "opt-out" of the in-band indication.
ISTM that if the UA has a "better" way of doing the indication it may 
not want the default mechanism. (E.g. The UA may want to apply its own 
in-band indication. But that won't work well if a different one has 
already been applied.)

If we can agree on the *concept* of opt-out, then we can determine the 
exact form as a subsequent step.

I suppose some SRCs may feel they are obliged to do their own indication 
even if a participant desires to opt-out, and we ought to allow that 
too. In that case there should probably be some indication that the 
opt-out has been ignored, so that the UA can behave accordingly.

	Thanks,
	Paul

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 7 Apr 2011 12:44:39 -0700

I agree with Paul. I would hate to force the addition of an audible beep
or a red dot to all participants when a less intrusive mechanism is
supported.

Cheers,
Charles 

> From: [email-masked] [mailto:[email-masked]] On
Behalf Of Paul Kyzivat (pkyzivat)
> Sent: Wednesday, April 06, 2011 12:14 PM
> To: [email-masked]
> > My own thoughts on this are that the SIP/SDP indication that
recording is in progress, even if sent
> to a UA known to be recording-aware, should not be used as a
substitute for other non-SIP/SDP means of
> notification that might otherwise be needed (e.g., an in-band audio
announcement). I think recording
> indicators should be used to complement other means. For example, an
in-band audio announcement would
> be able to reach all users (although might be problematic for
hearing-impaired users or for users
> speaking a different language). Despite such limitations, an in-band
announcement is often sufficient
> to satisfy legal requirements. On the other hand, a SIP/SDP indication
that recording is in progress
> could be rendered in different ways and in different languages at the
user interface of a recording-
> aware UA.
> >
> > For this reason, I don't see a need for the recording-aware
indication in SIP/SDP. Recording
> indications can be sent without knowing whether they will be
understood by the receiving UA - if they
> are understood the user might get an enhanced indication - if not they
will be discarded and the user
> will get only the basic (non-SIP/SDP) indication.
> >
> > John (as individual)
> >
> >

---

From: "Henry Lum" <[email-masked]>
Date: Fri, 8 Apr 2011 07:46:55 -0700

Currently in the draft we propose to use an SDP attribute to declare the
awareness. I saw comments that this should be changed to a feature tag
instead. I am okay either way; are there arguments against using a
feature tag?

Regards,
Henry

> Behalf Of Charles Eckel (eckelcu)
> Sent: Thursday, April 07, 2011 3:45 PM
> To: Paul Kyzivat (pkyzivat); [email-masked]

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 11 Apr 2011 09:39:26 -0400

> instead. I am okay either way; are there arguments against using a

IIUC the main argument has been to use SDP attributes to indicate that 
recording is being done. And there it *is* important for it to be in SDP 
so it can be indicated on a per-media basis.

For the awareness indicator its not so clear cut. Certainly we could 
define awareness so that it applies to all media, and then it *could* be 
in the SIP rather than the SDP. It then comes down to taste - for 
consistency it might be preferable to indicate it in SDP. I don't have a 
strong preference one way or the other.

	Thanks,
	Paul

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 11 Apr 2011 08:32:50 -0700

My thinking on this is that recording awareness indication may be useful
to indicate an ability to request and/or provide recording. As such, I
may place a call and see in the response that I have the ability to
request this call, or not. I also thought this indication may be useful
to help a SRC determine how best to indicate to a UA that its media is
being recorded. In both case, but especially in the former, the
indication is not tied to the media, so I think it makes more sense to
signal it as a feature tag than as an SDP attribute. 

Cheers,
Charles

> From: Paul Kyzivat (pkyzivat)
> Sent: Monday, April 11, 2011 6:39 AM
> To: Henry Lum
> Cc: Charles Eckel (eckelcu); [email-masked]
------------------------------------------------------------------------
----------------------------
> ---------------
> > CONFIDENTIALITY NOTICE: This e-mail and any files attached may
contain confidential and proprietary
> information of Alcatel-Lucent and/or its affiliated entities. Access
by the intended recipient only is
> authorized. Any liability arising from any party acting, or refraining
from acting, on any information
> contained in this e-mail is hereby excluded. If you are not the
intended recipient, please notify the
> sender immediately, destroy the original transmission and its
attachments and do not disclose the
> contents to any other person, use it for any purpose, or store or copy
the information in any medium.
> Copyright in this e-mail and any attachments belongs to Alcatel-Lucent
and/or its affiliated entities.

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 12 Apr 2011 08:28:39 +0200

I am curious why a media feature tag is being considered, rather than an option tag (in the Supported header field).

John 

> [mailto:[email-masked]] On Behalf Of Charles Eckel (eckelcu)
> Sent: 11 April 2011 16:33
> To: Paul Kyzivat (pkyzivat); Henry Lum
> Cc: [email-masked]
> > > Currently in the draft we propose to use an SDP attribute 
> to declare
> the
> > define awareness so that it applies to all media, and then 
> it *could*
> be
> > consistency it might be preferable to indicate it in SDP. I 
> don't have
> a
> > >> I agree with Paul. I would hate to force the addition of 
> an audible
> > >> beep
> [mailto:[email-masked]] On
> > >>> ISTM that if the UA has a "better" way of doing the 
> indication it
> > > may
> > >>> not want the default mechanism. (E.g. The UA may want 
> to apply its
> > >> own
> > >>> If we can agree on the *concept* of opt-out, then we 
> can determine
> > >> the
> > >>> indicators should be used to complement other means. 
> For example,
> an
> > >>> could be rendered in different ways and in different 
> languages at
> > > the
> > >>> are understood the user might get an enhanced 
> indication - if not
> > >> they

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 12 Apr 2011 07:47:00 -0700

I was actually thinking of an options tag in a supported header field as
well, though I now realize the term feature tag means something else. I
am not all that familiar with media feature tags, so I possibly could be
convinced to go either way.

Cheers,
Charles 

> From: Elwell, John [mailto:[email-masked]]
> Sent: Monday, April 11, 2011 11:29 PM
> To: Charles Eckel (eckelcu); Paul Kyzivat (pkyzivat); Henry Lum
> Cc: [email-masked]
> Subject: RE: [siprec] Recording awareness indication
> 
> I am curious why a media feature tag is being considered, rather than
an option tag (in the Supported
> header field).
> > > > awareness. I saw comments that this should be changed to a
feature
> > tag
> > > recording is being done. And there it *is* important for it to be
in
> > SDP
> > > >>> in-band indication. But that won't work well if a different
one
> > has
> > > >>> even if a participant desires to opt-out, and we ought to
allow
> > that
> > > >>> too. In that case there should probably be some indication
that