Subject: [siprec] Question on the scope

From: Roy <[email-masked]>
Date: Tue, 12 Apr 2011 14:28:57 +0800

Hello

I find this work group during Prague meeting. The work here is quite
interesting although I have some questions as below:

All through the architecture and requirement document, we are talking about
recording a media session between two UA. 

However, there is also use cases that a UA1 requests a recording server
(SRS) to record a media content in media server (UA2) while there is not any
direct media session between UA1 and media server. Following is a general
architecture.

                                                  +-----------+

                          (Recording Session)     |           |

                             +-------SIP--------->| Recording |

                             |                    |  Server   |

                             |   +---MetaData---->|           |

                             |   |                +-----------+

                             |   |                     ^

                             |   |                     |

                             |   |                    RTP

                             V   V            unicast or multicast

                        +------------------+           |

                        |      B2BUA       |           |

     +--------+         | Service Control  |         +---------+

     |        |<- SIP ->|   Function       |<- SIP ->|         |

     |  UA-A  |         +------------------+         |  Media  |

     |        |                                      |  Server |

     +--------+                                      +---------+

This case is very common in IPTV industry, known as Network Personal Video
Record (NPVR). I feel this is very similar with the work here.

Does current document cover this use case already or did you discussed
similar case ever?

Many thanks and best regards,

Roy

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 12 Apr 2011 09:14:26 +0200

Roy,

I am not sure I understand your use case correctly, but it seems some content from inside a media server is being recorded, as opposed to recording content that is transported between two or more users as part of a communication session. I believe that is outside the scope of the working group. See the charter and draft-ietf-siprec-req (requirements). Our work is concerned with recording a session, so content that is held internally to a media server, as opposed to being transported as part of a session is out of scope.

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Roy
> Sent: 12 April 2011 07:29
> To: [email-masked]
> Subject: [siprec] Question on the scope
> 
> Hello
> 
>  
> 
> I find this work group during Prague meeting. The work here 
> is quite interesting although I have some questions as below:
> 
>  
> 
> All through the architecture and requirement document, we are 
> talking about recording a media session between two UA. 
> 
> However, there is also use cases that a UA1 requests a 
> recording server (SRS) to record a media content in media 
> server (UA2) while there is not any direct media session 
> between UA1 and media server. Following is a general architecture.
> 
>                                                   +-----------+
> 
>                           (Recording Session)     |           |
> 
>                              ; +----- ding |
> 
>                              |                    |  Server   |
> 
>                              |   +---MetaData---->|           |
> 
>                            &n |                +-----------+
> 
>                              |   |                     ^
> 
>                              |   |                     |
> 
>      &n sp;                    |   |                    RTP
> 
>                              V   V            unicast or multicast
> 
>                         +------------------+           |
> 
> nbsp;                   |      B2BUA       |           |
> 
>      |  UA-A  |         +--------- -------- ;     |  Media  |
> 
>      |        |                                      |  Server |
> 
>      +--------+                                      +---------+
> 
>  
> 
> This case is very common in IPTV industry, known as Network 
> Personal Vide o Record ery similar with the work here.
> 
> Does current document cover this use case already or did you 
> discussed similar case ever?
> 
>  
>

---

From: "Hutton, Andrew" <[email-masked]>
Date: Tue, 12 Apr 2011 11:36:59 +0200

Hi Roy,

Your diagram shows a SIP session from UA-A to the B2BUA and between the B2BUA and the Media Server. I assume this is logically a session between the UA-A and the Media Server with the B2BUA in the middle. 

Does this session convey any media between UA-A and the Media Server and if so what is the relationship between this and the media sent to the recording server?

What is the SIP Session used for at UA-A?

Regards
Andy

> [mailto:[email-masked]] On Behalf Of Elwell, John
> Sent: 12 April 2011 08:14
> To: Roy; [email-masked]
> Subject: Re: [siprec] Question on the scope
> 
> Roy,
> 
> I am not sure I understand your use case correctly, but it 
> seems some content from inside a media server is being 
> recorded, as opposed to recording content that is transported 
> between two or more users as part of a communication session. 
> I believe that is outside the scope of the working group. See 
> the charter and draft-ietf-siprec-req (requirements). Our 
> work is concerned with recording a session, so content that 
> is held internally to a media server, as opposed to being 
> transported as part of a session is out of scope.
> 
> John
> 
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>

---

From: Roy <[email-masked]>
Date: Wed, 13 Apr 2011 10:09:30 +0800

Hi Andy,

The session between UA-A and the Media Server does not convey any media.
This SIP session mainly tells the B2BUA what to be recorded.

As background, to watch a IPTV program, the UA-A initiates a SIP session to
setup a media session between UA-A and Media Server. The media session could
be a unicast or multicast session.
While in the NPVR case, the user (with UA-A) may not be able to watch the
live program, and want to record and watch the program at a later time. 
Therefore, when initiates the recording session, the UA-A will only tells
what to record, without any media conveying. 

Hope this clarifies!

Best regards,
Roy

-----邮件原件-----
发件人: Hutton, Andrew [mailto:[email-masked]] 
发送时间: 2011年4月12日 17:37
收件人: Elwell, John; Roy; [email-masked]
主题: RE: [siprec] Question on the scope

Hi Roy,

Your diagram shows a SIP session from UA-A to the B2BUA and between the
B2BUA and the Media Server. I assume this is logically a session between the
UA-A and the Media Server with the B2BUA in the middle. 

Does this session convey any media between UA-A and the Media Server and if
so what is the relationship between this and the media sent to the recording
server?

Regards
Andy

---

From: "Hutton, Andrew" <[email-masked]>
Date: Wed, 13 Apr 2011 12:04:17 +0200

Hi Roy,

So what protocol is used to tell the B2BUA what is to be recorded is this something that is conveyed in a SIP body or something else and is it standardized ?

It sounds like this is not within scope of the IETF SIPREC group but I would like to understand the mechanism used.

Regards
Andy

> From: Roy [mailto:[email-masked]] 
> Sent: 13 April 2011 03:09
> To: Hutton, Andrew; Elwell, John; [email-masked]

---

From: Roy <[email-masked]>
Date: Thu, 14 Apr 2011 17:27:09 +0800

Hi Andy,

SIP MESSAGE (from UA-A to the B2BUA) is used to convey the request, the
request-URI tells this is a NPVR request, while in the SIP body, an XML
document tells the program to be recorded, as well as time period, etc
SIP INVITE (from B2BUA to recording server) is used to initiate the media
session between media server and recording server.
We(I as one of the contributors) defined this due to lake of other
standardized way.
Similar mechanisms are used in the following specifications:
	ETSI TS 183063 v3.4.5, 
	3GPP TS 26.237 v10.1.0, 
	OIPF R2 Volume 4 - Protocol

After reading the ARCH and REQ document more, I realize that the NPVR case
can be divided into two sub cases:
sub case 1:
	A user is watching a program (initiated by a SIP session), and at
meaning time want to record the program for any reason. Then this is in
scope of SIPREC.
	Note: The abovementioned specifications take the watching and
recording as two separated procedure.
Sub case 2:
	A user want to record a future program or a program which is not
what he is watching. 
	This case is out scope of SIPREC. But if we relax our restrictions a
little bit, this case can also be covered easily.

What do you think?

Best regards, Roy

-----邮件原件-----
发件人: Hutton, Andrew [mailto:[email-masked]] 
发送时间: 2011年4月13日 18:04
收件人: Roy; Elwell, John; [email-masked]
主题: RE: [siprec] Question on the scope

Hi Roy,

So what protocol is used to tell the B2BUA what is to be recorded is this
something that is conveyed in a SIP body or something else and is it
standardized ?

It sounds like this is not within scope of the IETF SIPREC group but I would
like to understand the mechanism used.

Regards
Andy

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 14 Apr 2011 11:57:50 +0200

Roy,

The scope of SIPREC is to record a communication session between a number of parties. The simplest case is between two parties, A and B, and media that flows between A and B is captured by the SRC and passed to the SRS.

You identify two sub-cases: (a) watching (and simultaneously recording) and (b) recording only (for future playback).

For case (a), I assume the media (TV audio and video) flow from B (the media server) to A, so any entity that has access to that media (e.g., the B2BUA) can act as an SRC and send the media simultaneously to the SRS. This is normal SIPREC. Media sent to the SRS is a copy of media exchanged between B and A.

For case (b), it seems media is sent only from B to the recording server, and not simultaneously to A - correct? So it seems that the recording device is a media device acting on behalf of A for that communication session. There are various approaches possible for establishing that communication session, e.g., A's SDP for the video medium could contain the IP address/port of the recording device. This is all a matter of how the communication session is established, and that is outside the scope of SIPREC. Since we are not copying media exchanged during a communication session to an SRS, it really does seem to be outside the scope of SIPREC.

Of course, I may have misunderstood your requirement.

John

> Sent: 14 April 2011 10:27
> > > >                              V   V            unicast 
> or multicast