Subject: [siprec] metadata model and persisent recording

From: Leon Portman <[email-masked]>
Date: Mon, 11 Apr 2011 16:24:25 +0300

Partha Hi

I think we are missing in the metadata model support for persistent recording mode, where RS INVITE may be  sent from SRC to SRC with participant info but without any communication session or group. For example where RS will be established when somebody logins to the phone.

Regards

Leon

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Mon, 11 Apr 2011 19:09:33 +0530

The current model (-04) insists on CSG has directly relationship with
participant in case CS is not associated with participant. Moving
forward, CSG will be optional metadata block whereas RS has direct
relationship with participant in case CS is not associated with
participant.
 
Good timing from the discussion perspective as the same issue which I'm
explaining with conference recording by user usecase in the another mail
thread "Partial updates and identifiers" wherein RS is related directly
with participant without CS & CSG. 
 
I wish that we will track this issue as part of "Partial updates and
identifiers" mail thread.
 
Thanks
Partha
________________________________

From: Leon Portman [mailto:[email-masked]] 
Sent: Monday, April 11, 2011 6:54 PM
To: [email-masked]; Parthasarathi R (partr)
Subject: [siprec] metadata model and persisent recording

Partha Hi

I think we are missing in the metadata model support for persistent
recording mode, where RS INVITE may be  sent from SRC to SRC with
participant info but without any communication session or group. For
example where RS will be established when somebody logins to the phone.

Regards

Leon

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 11 Apr 2011 11:28:44 -0400

Leon,

Is it important that a persistent RS identify a participant when there 
is no CS? Isn't it sufficient to identify the participant at the time 
the CS is reported?

	Thanks,
	Paul

On 4/11/2011 9:24 AM, Leon Portman wrote:
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec

---

From: Leon Portman <[email-masked]>
Date: Mon, 11 Apr 2011 18:36:50 +0300

Actually yes, because it is common for persistent session that SRS channel are predefined per DN (participant)

Leon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: Monday, April 11, 2011 6:29 PM
To: [email-masked]
Subject: Re: [siprec] metadata model and persisent recording

Leon,

Is it important that a persistent RS identify a participant when there is no CS? Isn't it sufficient to identify the participant at the time the CS is reported?

	Thanks,
	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 11 Apr 2011 11:56:35 -0400

> Actually yes, because it is common for persistent session that SRS channel are predefined per DN (participant)

That seems to require a model change. We then have a participant that is 
not participating in anything.

Or are you saying that there is a media stream involving this 
participant, even if it is inactive or silent? And even though there is 
no CS containing that MS.

	Thanks,
	Paul

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Mon, 11 Apr 2011 21:39:34 +0530

Leon,

I have a question here:-
I understand that end points setup a persistent session (SIP dialog)
with SRS even before CS is present. 
Why do we need to report metadata at a point even when there is no CS ?
Doing this will end up in changing the meaning of metadata itself which
currently is defined as [Taken from requirement doc].
Metadata: Information that describes recorded media and the CS to
   which they relate. 

If we are to consider the below case we should change metadata
definition as now we can have a participant info reported in metadata
who is not doing anything.

Regards,
Ram

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Paul Kyzivat (pkyzivat)
> Sent: Monday, April 11, 2011 9:27 PM
> To: Leon Portman
> Cc: [email-masked]
> > Actually yes, because it is common for persistent session that SRS
> channel are predefined per DN (participant)
> 
> > Is it important that a persistent RS identify a participant when
> there is no CS? Isn't it sufficient to identify the participant at the
> time the CS is reported?
> >
> > 	Thanks,
> > 	Paul
> >

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 11 Apr 2011 18:52:05 +0200

Perhaps this is an attribute of the RS metadata object (let's call it the "target" attribute, i.e., the target of recording) rather than a participant. When a CS starts, one of the participant objects associated with the CS will happen to match the target.

John (as individual)

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Leon Portman
> Sent: 11 April 2011 16:37
> To: Paul Kyzivat; [email-masked]
> Actually yes, because it is common for persistent session 
> that SRS channel are predefined per DN (participant)
> 
> Leon
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Paul Kyzivat
> Is it important that a persistent RS identify a participant 
> when there is no CS? Isn't it sufficient to identify the 
> participant at the time the CS is reported?
> 
> 	Thanks,
> 	Paul
>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 11 Apr 2011 16:02:20 -0700

If I understand correctly, this is the case in which the URL is:
1) dialed to add a recorder to a conference
or
2) a recorder dials into a conference using a given URL as its caller ID
In either case, I see the URL as being a property of the recorder, not a
participant. I support if the record injects media into the conference,
then it could be a participant as well. Is this the reason for having
URL presented both as a participant and as the "target" of the RS?

Thanks,
Charles

> From: [email-masked] [mailto:[email-masked]] On
Behalf Of Elwell, John
> Sent: Monday, April 11, 2011 9:52 AM
> To: Leon Portman; Paul Kyzivat (pkyzivat); [email-masked]
> Perhaps this is an attribute of the RS metadata object (let's call it
the "target" attribute, i.e.,
> the target of recording) rather than a participant. When a CS starts,
one of the participant objects
> associated with the CS will happen to match the target.
> 
> John (as individual)
> 
>

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 12 Apr 2011 09:02:05 +0200

No, I don't think what you describe is the same as the persistent recording session that Leon was talking about. I think a persistent recording session is where there is a permanent recording session between user X (e.g., a contact centre agent) and the SRS, such that whenever user X is involved in a CS, that CS gets recorded using that RS. At other times the RS is idle, but still exists. Leon wanted to make sure that the identify of X is always part of the metadata (i.e., it doesn't disappear during times when X is not involved in a CS), and the way he wanted to achieve that was by considering X as a Participant, even when there is no CS. My alternative proposal is to make X an attribute of the RS object in the metadata.

John

> From: Charles Eckel (eckelcu) [mailto:[email-masked]] 
> Sent: 12 April 2011 00:02
> To: Elwell, John; Leon Portman; Paul Kyzivat (pkyzivat); 
> [email-masked]
> Subject: RE: [siprec] metadata model and persisent recording
>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 12 Apr 2011 08:50:07 -0400

> No, I don't think what you describe is the same as the persistent recording session that Leon was talking about. I think a persistent recording session is where there is a permanent recording sessi…

ISTM this is a distinction without a difference, *unless* the RS may 
actually be receiving/recording media from the one UA even when there is 
no CS. (IOW, it is a tap on the agent's phone all the time.)

	Thanks,
	Paul