Subject: [siprec] Summary of the changes of draft-ietf-siprec-req-10 - last call

From: Leon Portman <[email-masked]>
Date: Wed, 27 Apr 2011 16:30:23 +0300

Hello

Please see below summary of the changes for  updated version of the requirements document.

Main changes:

1.       Updated REQ-022, 023, 024 (all other numbers are ++, original 22 and 23 removed), thanks to Muthu and John for the text

a.       REQ-022: The mechanism MUST provide means for facilitating synchronization of the recorded media streams and metadata.

b.      REQ-023: The mechanism MUST provide means for facilitating synchronization among the recorded media streams.

c.       REQ-024: The mechanism MUST provide means for relating recordings to wall clock time.

2. Use Case 8 - nit pick, thanks to Muthu (me -> may be)

a."In cases where calls inside or between branches must be recorded, a centralized recording system in data centers together with telephony infrastructure (e.g. PBX) may be deployed."

                3. Proposed additional paragraph in the security section from the security review (not in the text yet, pending WG approval):

"Integrity and correctness of the recorded sessions is not ensured by cryptographic means to ensure that the CS has not been tampered with. This would have to be done by organizational and technical controls that prevent tampering with CS participants and SRC."

Regards

Leon

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 27 Apr 2011 18:54:02 +0200

> -----Original Message-----
> From: Leon Portman [mailto:[email-masked]] 
> Sent: 27 April 2011 14:30
> To: [email-masked]; Ken Rehor (krehor) ([email-masked]); 
> Elwell, John
> Subject: [siprec] Summary of the changes of 
> draft-ietf-siprec-req-10 - last call
> 
> Hello
> 
>  
> 
> 1.       Updated REQ-022, 023, 024 (all other numbers are ++, 
> original 22 and 23 removed), thanks to Muthu and John for the text
> 
> a.       REQ-022: The mechanism MUST provide means for 
> facilitating synchronization of the recorded media streams 
> and metadata.
> 
> b.      REQ-023: The mechanism MUST provide means for 
> facilitating synchronization among the recorded media streams.
> 
> a."In cases where calls inside or between branches must be 
> recorded, a centralized recording system in data centers 
> together with telephony infrastructure (e.g. PBX) may be deployed."
> 
>                 3. Proposed additional paragraph in the 
> security section from the security review (not in the text 
> yet, pending WG approval):
> 
> "Integrity and correctness of the recorded sessions is not 
> ensured by cryptographic means to ensure that the CS has not 
> been tampered with. This would have to be done by 
> organizational and technical controls that prevent tampering 
> with CS participants and SRC."

I have tried to reword to make it clearer (e.g., to get rid of the double use of "ensure"):
"A malicious or corrupt SRC can tamper with media and metadata relating to a CS before sending to an SRC. Also CS media and signalling can be tampered with in the network prior to reaching an SRC, unless proper means are provided to ensure integrity protection during transmission. Means for ensuring the integrity and correctness of media and metadata emitted by an SRC are outside the scope of this work. Other organizational and technical controls will need to be used to prevent tampering."

I would suggest you run this by the Security Area reviewer to ensure he is happy.

John

---

From: Leon Portman <[email-masked]>
Date: Wed, 27 Apr 2011 20:47:23 +0300

John, hi

Thank you very much. I think there two places were you meant to use SRS instead of SRC:

"A malicious or corrupt SRC can tamper with media and metadata relating to a CS before sending to an SRS. Also CS media and signaling can be tampered with in the network prior to reaching an SRS, unless proper means are provided to ensure integrity protection during transmission. Means for ensuring the integrity and correctness of media and metadata emitted by an SRC are outside the scope of this work. Other organizational and technical controls will need to be used to prevent tampering."

Leon

-----Original Message-----
From: Elwell, John [mailto:[email-masked]]
Sent: Wednesday, April 27, 2011 7:54 PM
To: Leon Portman; [email-masked]; Ken Rehor (krehor) ([email-masked])
Subject: RE: [siprec] Summary of the changes of draft-ietf-siprec-req-10 - last call

> Please see below summary of the changes for  updated version

> of the requirements document.

> c.       REQ-024: The mechanism MUST provide means for

> relating recordings to wall clock time.

John

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 27 Apr 2011 20:04:39 +0200

Oops. In fact, only the first place was wrong. To clarify the other one, I extended the second sentence with the words "on the CS". The text should be:

"A malicious or corrupt SRC can tamper with media and metadata relating to a CS before sending to an SRS. Also CS media and signalling can be tampered with in the network prior to reaching an SRC, unless proper means are provided to ensure integrity protection during transmission on the CS. Means for ensuring the integrity and correctness of media and metadata emitted by an SRC are outside the scope of this work. Other organizational and technical controls will need to be used to prevent tampering."

John 

> Sent: 27 April 2011 18:47
> To: Elwell, John; [email-masked]; Ken Rehor (krehor) 
> ([email-masked])
> "A malicious or corrupt SRC can tamper with media and 
> metadata relating to a CS before sending to an SRS. Also CS 
> media and signaling can be tampered with in the network prior 
> to reaching an SRS, unless proper means are provided to 
> ensure integrity protection during transmission. Means for 
> ensuring the integrity and correctness of media and metadata 
> emitted by an SRC are outside the scope of this work. Other 
> organizational and technical controls will need to be used to 
> prevent tampering."
> 
>  
> 
> Leon
> 
>  
> 
> "A malicious or corrupt SRC can tamper with media and 
> metadata relating to a CS before sending to an SRC. Also CS 
> media and signalling can be tampered with in the network 
> prior to reaching an SRC, unless proper means are provided to 
> ensure integrity protection during transmission. Means for 
> ensuring the integrity and correctness of media and metadata 
> emitted by an SRC are outside the scope of this work. Other 
> organizational and technical controls will need to be used to 
> prevent tampering."
> 
>  
>

---

From: Leon Portman <[email-masked]>
Date: Wed, 27 Apr 2011 22:23:24 +0300

Thank you very much.
Sending it to Tobias

Leon

-----Original Message-----
From: Elwell, John [mailto:[email-masked]] 
Sent: Wednesday, April 27, 2011 9:05 PM
To: Leon Portman; [email-masked]; Ken Rehor (krehor) ([email-masked])
Subject: RE: [siprec] Summary of the changes of draft-ietf-siprec-req-10 - last call

John 

> "A malicious or corrupt SRC can tamper with media and metadata 
> relating to a CS before sending to an SRS. Also CS media and signaling 
> can be tampered with in the network prior to reaching an SRS, unless 
> proper means are provided to ensure integrity protection during 
> transmission. Means for ensuring the integrity and correctness of 
> media and metadata emitted by an SRC are outside the scope of this 
> work. Other organizational and technical controls will need to be used 
> to prevent tampering."
> 
>  
> 
> Leon
> 
>  
> 
> "A malicious or corrupt SRC can tamper with media and metadata 
> relating to a CS before sending to an SRC. Also CS media and 
> signalling can be tampered with in the network prior to reaching an 
> SRC, unless proper means are provided to ensure integrity protection 
> during transmission. Means for ensuring the integrity and correctness 
> of media and metadata emitted by an SRC are outside the scope of this 
> work. Other organizational and technical controls will need to be used 
> to prevent tampering."
> 
>  
>