Subject: Re: [siprec] Schema errors

From: "Elwell, John" <[email-masked]>
Date: Fri, 9 Sep 2011 14:47:43 +0200

> -----Original Message-----
> From: Elwell, John 
> Sent: 09 September 2011 08:15
> To: [email-masked]
> Cc: Winter, Johannes
> Subject: Schema errors
> 
> The schema in -04 is not valid.  I am informed by a colleague 
> that some corrections along the following lines are needed:
> 
> 1. There is a missing </xs:schema> end tag.
> 
> 2. There is a redundant </xs:simpleType> towards the end.
[JRE] I meant to say it is in the wrong place. Following:
<xs:simpleType name="urnuuid">
there are two identical end tags - one of them should be moved before this start tag.

> 
> 3. Target namespace uses a prefix (tns), but the prefix is 
> missed in the type-definitions:
> 	xmlns:tns="urn:ietf:params:xml:ns:recording"
> But, for example:
> 	<xs:element name="datamode" type="dataMode"
> 
> This could be solved by, for example:
> 	<xs:element name="datamode" type="tns:dataMode"
> 
> Or alternatively make the target namespace the default namespace:
> 	xmlns="urn:ietf:params:xml:ns:recording"
> 
> John (as individual)
> 
> John Elwell
> Tel: +44 1908 817801 (office and mobile)
> Email: [email-masked]
> http://www.siemens-enterprise.com/uk/
> 
> Siemens Enterprise Communications Limited.
> Registered office: Brickhill Street, Willen Lake, Milton 
> Keynes, MK15 0DJ.
> Registered No: 5903714, England.
> 
> Siemens Enterprise Communications Limited is a Trademark 
> Licensee of Siemens AG.
>

---

From: "Ravindran Parthasarathi" <[email-masked]>
Date: Tue, 13 Sep 2011 22:55:57 +0530

John,

Thanks for the comments. Please read inline.

Thanks
Partha

>From: [email-masked] [mailto:[email-masked]] On
Behalf
>Of Elwell, John
>Sent: Friday, September 09, 2011 6:18 PM
>To: [email-masked]
>Subject: Re: [siprec] Schema errors
>
>
>
>
<partha> Agreed for the two of above comments and the fix will be 
incorporated in next revision </partha>
>> 	xmlns="urn:ietf:params:xml:ns:recording"
<partha> The intention is to use without a prefix, so I'll update xmlns 
as you proposed as xmlns="urn:ietf:params:xml:ns:recording" </partha>
>_______________________________________________
>siprec mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/siprec