Subject: [siprec] Metadata and UML

From: "Elwell, John" <[email-masked]>
Date: Tue, 6 Sep 2011 21:28:00 +0200

Looking at metadata-04, it strikes me there is a lot of work to do in order to get this into a shape where it is ready for WGLC. There is an ongoing thread on how to model attributes of associations (ticket #72), and this has triggered the thought that perhaps we don't need to show a formal UML model in the final deliverable. The stuff that will be implemented is the XML, and we need enough description surrounding the various XML elements to make it clear what they represent and how they should be used. Is UML the right tool for this, or can we achieve it much more briefly, and more easily understandable, just by prose descriptions around the XML elements?

I am not aware of precedents where UML has been used in IETF. A search for UML on the tracker yields nothing. Protocols such as SIMPLE and XMPP that make extensive use of XML do not use UML for modelling.

UML was fine for our initial discussions on the topic, and it has helped get us to a common understanding on which we could develop the XML. But I am not sure it is the most appropriate way of documenting the results.

Thoughts?

John

John Elwell
Tel: +44 1908 817801 (office and mobile)
Email: [email-masked]
http://www.siemens-enterprise.com/uk/

Siemens Enterprise Communications Limited.
Registered office: Brickhill Street, Willen Lake, Milton Keynes, MK15 0DJ.
Registered No: 5903714, England.

Siemens Enterprise Communications Limited is a Trademark Licensee of Siemens AG.

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 06 Sep 2011 19:22:39 -0400

I don't feel strongly whether the UML appears in the final standard docs 
or not.

As I stated earlier, the real value of UML, IMO, is that it can 
concisely display the big picture, in a way that XML cannot. For those 
of use that have been through all that, the UML is most likely 
unnecessary. But it may still be valuable for new readers of the spec.

	Thanks,
	Paul

On 9/6/11 3:28 PM, Elwell, John wrote:
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Wed, 7 Sep 2011 09:21:30 +0530

I tend to agree with Paul here. 

IMO we can leave the UML as it is in the doc as it is valuable and shows
pictorial representation of metadata and easy for someone new to
visualize. 

Regards,
Ram

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Paul Kyzivat
> Sent: Wednesday, September 07, 2011 4:53 AM
> To: [email-masked]
> Subject: Re: [siprec] Metadata and UML
> 
> > Looking at metadata-04, it strikes me there is a lot of work to do
in
> order to get this into a shape where it is ready for WGLC. There is an
> ongoing thread on how to model attributes of associations (ticket
#72),
> and this has triggered the thought that perhaps we don't need to show
a
> formal UML model in the final deliverable. The stuff that will be
> implemented is the XML, and we need enough description surrounding the
> various XML elements to make it clear what they represent and how they
> should be used. Is UML the right tool for this, or can we achieve it
> much more briefly, and more easily understandable, just by prose
> descriptions around the XML elements?
> >
> > I am not aware of precedents where UML has been used in IETF. A
> search for UML on the tracker yields nothing. Protocols such as SIMPLE
> and XMPP that make extensive use of XML do not use UML for modelling.
> >
> > UML was fine for our initial discussions on the topic, and it has
> helped get us to a common understanding on which we could develop the
> XML. But I am not sure it is the most appropriate way of documenting
> the results.
> >
> > Thoughts?
> >
> > John
> >
> >
> > John Elwell
> > Registered office: Brickhill Street, Willen Lake, Milton Keynes,
MK15
> 0DJ.

---

From: "Ravindran Parthasarathi" <[email-masked]>
Date: Wed, 7 Sep 2011 11:16:27 +0530

John & Ram,

As Paul mentioned, UML was chosen to illustrate how the metadata is
organized which is not possible to visualize by looking at XML example
and XML schema. 

I agree with you that UML diagram in metadata draft may be tough to read
or misinterpreted in case reader is unaware of UML terminology. Whether
it is fine to provide the related UML definition like association,
composition in the definition section with diagram notation for making
the document as a self contained document.

Thanks
Partha

>From: [email-masked] [mailto:[email-masked]] On
Behalf
>Of Ram Mohan R (rmohanr)
>Sent: Wednesday, September 07, 2011 9:22 AM
>To: Paul Kyzivat; [email-masked]
>> > Siemens Enterprise Communications Limited is a Trademark Licensee
of
>> Siemens AG.

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 7 Sep 2011 11:06:16 +0200

One of the problems I have is that the UML does NOT really represent what is in the XML. Or putting it another way, there is not a 1:1 relationship between an XML element and a UML object in all cases. I will submit separately on that topic.

John (as individual)

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Ravindran Parthasarathi
> Sent: 07 September 2011 06:46
> To: Ram Mohan R (rmohanr); Paul Kyzivat; [email-masked]

---

From: <[email-masked]>
Date: Wed, 7 Sep 2011 11:30:30 +0100

As someone who only started following siprec recently, I personally have not found the UML to be very helpfull, in fact at present it adds confusion, because as you say, the UML and XML may not agree. 

In terms of implementing, its always going to be the XML schema that is the definitive reference, and I think having sufficient description of the XML elements/attributes will make the UML redundant.

Rgds
John Stafford | Solution Architect 1 | BT Global Services 
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Elwell, John [[email-masked]]
Sent: 07 September 2011 10:06
To: Ravindran Parthasarathi; Ram Mohan R (rmohanr); Paul Kyzivat; [email-masked]
Subject: Re: [siprec] Metadata and UML

John (as individual)

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 07 Sep 2011 10:46:39 -0400

> One of the problems I have is that the UML does NOT really represent what is in the XML. Or putting it another way, there is not a 1:1 relationship between an XML element and a UML object in all ca…

As we work on one thing or another its understandable that these can 
drift apart. But by the time we are done, if we keep both then they 
should be consistent.

	Thanks,
	Paul

>> John&  Ram,

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 7 Sep 2011 08:51:20 -0700

I find it useful. We just need to make sure we keep things consistent to
avoid confusion. I suggest that the text is normative and the UML non
normative.

Cheers,
Charles

> From: [email-masked] [mailto:[email-masked]] On
Behalf Of Ram Mohan R (rmohanr)
> Sent: Tuesday, September 06, 2011 8:52 PM
of

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Wed, 7 Sep 2011 21:29:03 +0530

Charles,

In Ver-04 of the metadata draft, I have removed most of normative text
of UML and made it to simple text. If you happen to spot any instance
where normative language is still used, please let me know. I will take
care of it in the next revision.

Regards,
Ram

> From: Charles Eckel (eckelcu)
> Sent: Wednesday, September 07, 2011 9:21 PM
> Subject: RE: [siprec] Metadata and UML
> 
> I find it useful. We just need to make sure we keep things consistent
> to avoid confusion. I suggest that the text is normative and the UML
> non normative.
> 
> Cheers,
> Charles
> 
> 
> > > I don't feel strongly whether the UML appears in the final
standard
> > > docs
> > > order to get this into a shape where it is ready for WGLC. There
is
> an

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 8 Sep 2011 15:48:51 +0200

> [mailto:[email-masked]] On Behalf Of Charles Eckel (eckelcu)
> Sent: 07 September 2011 16:51
[JRE] Yes, that is the way we are heading anyway - it is just a question of whether UML is the most effective way of documenting the informative stuff.

John

> > > I don't feel strongly whether the UML appears in the 
> final standard
> > > docs
> > > or not.
> > >
> > > order to get this into a shape where it is ready for 
> WGLC. There is
> an

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 08 Sep 2011 12:49:11 -0400

> [JRE] Yes, that is the way we are heading anyway - it is just a question of whether UML is the most effective way of documenting the informative stuff.

The XML only documents the deltas that are being applied to build the 
complete metadata respository. It is probably impossible to derive the 
model for the complete repository from just the XML schema. So if we 
want to abandon the UML then we will need to construct a new 
representation for the complete repository. It *could* be done in XML. 
But that will make things harder to read without some overview of it, 
which is what the UML provides.

	Thanks,
	Paul