Subject: [siprec] Question on XML stream mode

From: "Elwell, John" <[email-masked]>
Date: Tue, 6 Sep 2011 17:59:47 +0200

Within the <stream/> element there is an optional <mode/> element of type streamMode, indicating either mixed or separate. Why is this needed? Clearly if more than one participant is contributing to a single stream (<send/> elements) the stream must be mixed, otherwise it must be unmixed.

John (as individual)

John Elwell
Tel: +44 1908 817801 (office and mobile)
Email: [email-masked]
http://www.siemens-enterprise.com/uk/

Siemens Enterprise Communications Limited.
Registered office: Brickhill Street, Willen Lake, Milton Keynes, MK15 0DJ.
Registered No: 5903714, England.

Siemens Enterprise Communications Limited is a Trademark Licensee of Siemens AG.

---

From: "Ravindran Parthasarathi" <[email-masked]>
Date: Tue, 6 Sep 2011 22:50:15 +0530

John,

I agree that it is possible to deduce stream mode by the count of the
participants. In case there is no objection, we will remove this
attribute from stream in the next revision.

Thanks
Partha

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On
Behalf
>Of Elwell, John
>Sent: Tuesday, September 06, 2011 9:30 PM
>To: [email-masked]
>Subject: [siprec] Question on XML stream mode
>
>Within the <stream/> element there is an optional <mode/> element of
>type streamMode, indicating either mixed or separate. Why is this
>needed? Clearly if more than one participant is contributing to a
single
>stream (<send/> elements) the stream must be mixed, otherwise it must
be
>unmixed.
>_______________________________________________
>siprec mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/siprec