Subject: [siprec] Deletion of <stream/> element

From: "Elwell, John" <[email-masked]>
Date: Wed, 7 Sep 2011 11:06:28 +0200

I understand that we have an issue about start/stop or associate/dissociate times for <send/> and <receive/> elements. Notwithstanding that, I notice that, in the absence of a dissociate time for a <stream/> element, we apparently have no way of indicating deletion or a <stream/> element in a metadata partial update. How is this to be achieved?

John

John Elwell
Tel: +44 1908 817801 (office and mobile)
Email: [email-masked]
http://www.siemens-enterprise.com/uk/

Siemens Enterprise Communications Limited.
Registered office: Brickhill Street, Willen Lake, Milton Keynes, MK15 0DJ.
Registered No: 5903714, England.

Siemens Enterprise Communications Limited is a Trademark Licensee of Siemens AG.

---

From: "Ravindran Parthasarathi" <[email-masked]>
Date: Tue, 13 Sep 2011 23:32:40 +0530

John,

While discussing about removing associate-time/disassociate-time
attribute open item from stream element, the proposal is to use metadata
SDP attributes to indicates the termination of the specific stream
element like m-line with port-0 or direction attribute set as inactive.
In case you wish to discuss again, let us discuss it.

Thanks
Partha 

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On
Behalf
>Of Elwell, John
>Sent: Wednesday, September 07, 2011 2:36 PM
>To: [email-masked]
>Subject: [siprec] Deletion of <stream/> element
>
>I understand that we have an issue about start/stop or
>associate/dissociate times for <send/> and <receive/> elements.
>Notwithstanding that, I notice that, in the absence of a dissociate
time
>for a <stream/> element, we apparently have no way of indicating
>deletion or a <stream/> element in a metadata partial update. How is
>this to be achieved?
>
>John
>
>John Elwell
>_______________________________________________
>siprec mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/siprec

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 15 Sep 2011 17:16:03 +0200

Partha,

I don't think this solution makes sense in the context of the recent consensus to keep the <stream/> element, rather than relying on the SDP media description. That decision seemed to be made on the basis that there are corner cases that mean that a <stream/> element (and the corresponding media stream object in the model) do not always have a 1:1 relationship with an SDP media description.

Therefore using the disabling of a media description in SDP as an indication of deletion of a <stream/> object seems inconsistent with that earlier decision.

John (as individual)

> From: Ravindran Parthasarathi [mailto:[email-masked]] 
> Sent: 13 September 2011 19:03
> To: Elwell, John; [email-masked]
> Subject: RE: [siprec] Deletion of <stream/> element
> 
> John,
>

---

From: "Ravindran Parthasarathi" <[email-masked]>
Date: Fri, 16 Sep 2011 03:20:53 +0530

Hi John,

I'm fine with the addition of association-time/disassociation-time
element for stream.

Thanks
Partha

>From: Elwell, John [mailto:[email-masked]]
>Sent: Thursday, September 15, 2011 8:46 PM
>To: Ravindran Parthasarathi; [email-masked]
>I don't think this solution makes sense in the context of the recent
>consensus to keep the <stream/> element, rather than relying on the SDP
>media description. That decision seemed to be made on the basis that
>there are corner cases that mean that a <stream/> element (and the
>corresponding media stream object in the model) do not always have a
1:1
>relationship with an SDP media description.
>
>Therefore using the disabling of a media description in SDP as an
>indication of deletion of a <stream/> object seems inconsistent with
>that earlier decision.
>
>John (as individual)
>
>
>> >Registered office: Brickhill Street, Willen Lake, Milton Keynes,
MK15
>> >0DJ.

---

From: Leon Portman <[email-masked]>
Date: Sun, 18 Sep 2011 14:45:35 +0300

+1 

Leon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ravindran Parthasarathi
Sent: Friday, September 16, 2011 12:51 AM
To: Elwell, John; [email-masked]
Subject: Re: [siprec] Deletion of <stream/> element

Hi John,

Thanks
Partha

1:1
>> attribute open item from stream element, the proposal is to use 
>> metadata SDP attributes to indicates the termination of the specific 
>> stream element like m-line with port-0 or direction attribute set as 
>> inactive.
MK15

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Mon, 19 Sep 2011 15:47:06 +0530

I am also fine to add associate/disassociate time.

IMO we need some discussion on what it means. Here is what I have in my
mind - 

associate-time -  the time a participant starts contributing to a stream
and 
disassociate-time -  the time a participant stops contributing.

Should associate/disassociate( or rather participant participation in a
MS ) be an attribute of association of participant to MS ?   
This gives the flexibility as for a given stream (mapped to an m-line in
RS) to have multiple associate/disassociate time from each participant
who contributes to that stream (mixed stream case).
In case of non mixed stream it is straightforward as there will be only
associate/disassociate-time from one participant who contributed to that
stream.

Regards,
Ram

> Behalf Of Leon Portman
> Sent: Sunday, September 18, 2011 5:16 PM
> To: Ravindran Parthasarathi; Elwell, John; [email-masked]
> Behalf Of Ravindran Parthasarathi
> >> >Siemens Enterprise Communications Limited is a Trademark Licensee
> of
> >> >Siemens AG.

---

From: Leon Portman <[email-masked]>
Date: Mon, 19 Sep 2011 15:48:25 +0300

I am ok with the suggestion

Leon

-----Original Message-----
From: Ram Mohan R (rmohanr) [mailto:[email-masked]] 
Sent: Monday, September 19, 2011 1:17 PM
To: Leon Portman; Ravindran Parthasarathi; Elwell, John; [email-masked]
Subject: RE: [siprec] Deletion of <stream/> element

IMO we need some discussion on what it means. Here is what I have in my mind - 

associate-time -  the time a participant starts contributing to a stream and disassociate-time -  the time a participant stops contributing.

Should associate/disassociate( or rather participant participation in a
MS ) be an attribute of association of participant to MS ?   
This gives the flexibility as for a given stream (mapped to an m-line in
RS) to have multiple associate/disassociate time from each participant who contributes to that stream (mixed stream case).
In case of non mixed stream it is straightforward as there will be only associate/disassociate-time from one participant who contributed to that stream.

Regards,
Ram