Subject: [siprec] XML representation of element containing name and/or address of a participant

From: <[email-masked]>
Date: Tue, 20 Sep 2011 11:47:56 +0100

In the interim meeting discussion I thought the request was to allow multiple names to be associated with an AOR, if so then that excludes John's suggestion of using SIP displayname-Address format, as that would only allow one name per AOR.

I think it would be usefull to allow multiple names, as then when searching for a CS to replay any of the names could be used.

It should be optional whether the SRC includes details of where the name came from, eg was it P-Asserted-Identity etc.

I'm not sure there is a direct AOR-name relationship, a participant could have multiple AOR's but wouldn't his names apply to all his AOR's ?

John Stafford | Solution Architect 1 | BT Global Services

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 20 Sep 2011 10:07:37 -0400

On 9/20/11 6:47 AM, [email-masked] wrote:
> In the interim meeting discussion Ithought the request was to allow
> multiple names to be associated with an AOR, if so then that excludes
> John's suggestion of using SIP displayname-Address format, as that would
> only allow one name per AOR.
> I think it would be usefull to allow multiple names, as then when
> searching for a CS to replay any of the names could be used.
> It should be optional whether the SRC includes details of where the name
> came from, eg was it P-Asserted-Identity etc.
> I'm not sure there is a direct AOR-name relationship, a participant
> could have multiple AOR's but wouldn't his names apply to all his AOR's ?

The request, originated by me in Quebec, was to allow a Participant that 
has multiple AORs to also be able to have a name for each AOR. Not 
multiple names for a single AOR.

With sip signaling, names are associated with particular URIs that come 
with various headers - e.g. To, From, P-Asserted-Identity. The 
particular precedence of names is undefined. E.g. if you have:

	...
	From: Alice Smith <sip:[email-masked]>
	P-Asserted-Identity: John Smith <sip:[email-masked]>
	P-Asserted-Identity: John Smith <tel:+12125551234>

Then it is unclear which name is most relevant, or which URI is most 
relevant. It must be decided by policy. For purposes of siprec, that 
policy could be decided by the SRC - by only reporting the name/aor 
considers relevant. Or, the SRC could supply them all, and leave the 
policy decisions to the SRS.

	Thanks,
	Paul

> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Fri, 23 Sep 2011 11:36:58 +0530

Inline

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Paul Kyzivat
> Sent: Tuesday, September 20, 2011 7:38 PM
> To: [email-masked]
> Subject: Re: [siprec] XML representation of element containing name
> and/or address of a participant
> 

I think there was a general agreement during IETF 81 to allow multiple
identifiers(Name/AoR pairs) in the metadata from SRC to SRS. However
there were some discussions on how to handle privacy issues ( e.g. if a
P-A-I is marked as private how to handle the same) and which identifier
( if SRC receives several) to indicate to SRS. IMO this can be a policy
at SRC

Below is one simple mechanism to encode identifier in metadata.

<nameID>
   <aor>sip:[email-masked]</aor>
   <name xml:lang="it">Alice Smith</name>
</nameID>

This new elemen <nameID> can be present in a participant element and
there may be several instances of the same ( one for each name/AoR pair
which the SRC wishes to indicate to SRS).

Thoughts / comments ?

Regards,
Ram