Subject: [siprec] Setting Up Persistent Recording Session before any Calls

From: <[email-masked]>
Date: Fri, 23 Sep 2011 18:46:53 +0100

I'm trying to work out how we would setup multiple RS sessions before there are any CS's to record on those sessions.
We would want to setup several RS's with a single INVITE.

So the INVITE to setup the persistent streams would have multiple m= lines in the SDP, for multiple RS's
but what about the metadata ?

Suppose there were 2 persistent RS RTP streams being setup, all the meta data could have in it is two empty RS's:

    <recording xmlns='urn:ietf:params:xml:ns:recording'>
        <dataMode>complete</dataMode>
   </recording>
     <recording xmlns='urn:ietf:params:xml:ns:recording'>
        <dataMode>complete</dataMode>
   </recording>

There doesn't seem to be any point including this meta data in the INVITE.

The protocol spec doesnt seem to exclude sending no metadata it as it says
  "The SRC may   provide an initial metadata snapshot about recorded media streams in
   the initial INVITE content in the recording session"

But theres no statement to say an INVITE without meta data means there are no CS's.
So is it valid to send an INVITE to SRS that doesnt contain metadata ?

Also it seems a bit strange that there's no reference in the RS to the associated RTP streams label.
That means that if extension meta data isprovided in a RS about a stream,
then the SRS wouldn't know what RTP stream it referred to,
until a CS occurred with a MS referencing the RTP streams label.

Rgds
John Stafford | Solution Architect 1 | BT Global Services

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 23 Sep 2011 13:42:40 -0700

Hi John,

Please see inline.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf Of [email-masked]
> Sent: Friday, September 23, 2011 10:47 AM
> To: [email-masked]
> Subject: [siprec] Setting Up Persistent Recording Session before any
Calls
> 
> 
> I'm trying to work out how we would setup multiple RS sessions before
there are any CS's to record on
> those sessions.

I have been assuming one INVITE per RS.

> So the INVITE to setup the persistent streams would have multiple m=
lines in the SDP, for multiple
> RS's
> Suppose there were 2 persistent RS RTP streams being setup, all the
meta data could have in it is two
> empty RS's:

I think so.

> until a CS occurred with a MS referencing the RTP streams label.

An SRC might want to negotiate one of more media streams within the RS
such that those media streams as up and ready once there is media from a
CS to record. At that time, in addition to sending the media, the SRC
would send the associated metadata. That is the model I am envisioning.
It is not the only model.

Cheers,
Charles

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 26 Sep 2011 11:05:47 +0200

John, 

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: 23 September 2011 18:47
> To: [email-masked]
> Subject: [siprec] Setting Up Persistent Recording Session 
> before any Calls
> 
>  
> I'm trying to work out how we would setup multiple RS 
> sessions before there are any CS's to record on those sessions. 
[JRE] I think we would call it a single RS, although that single RS might support the recording of multiple CSs and might have multiple RTP sessions for recording multiple streams.

>  
> So the INVITE to setup the persistent streams would have 
> multiple m= lines in the SDP, for multiple RS's
[JRE] Multiple m-lines for multiple RTP sessions, which are established in order that they can be used for delivering media streams of recorded communication sessions, as and when these arise.

>  
> Suppose there were 2 persistent RS RTP streams being setup, 
> all the meta data could have in it is two empty RS's:
>  
[JRE] This is not in compliance with the XML schema, which permits only a single <recording/> element. So there should only be one such element.

> So is it valid to send an INVITE to SRS that doesnt contain metadata ?
[JRE] I would say it is valid to omit the metadata, but equally valid to send metadata with an empty <recording/> element.

> until a CS occurred with a MS referencing the RTP streams label.
[JRE] The <stream/> element references the RTP stream's label. When a CS starts up, the metadata will be updated to show a <session/> element together with a number of <participant/> and <stream/> elements. Each <stream/> element would reference an RTP session label, meaning that that particular RTP session is being used for conveying that stream. When the session finishes, or the stream finishes, the RTP session still exists (unless it is disabled) but no longer conveys recordable information.

John (as individual)

---

From: <[email-masked]>
Date: Mon, 26 Sep 2011 11:03:47 +0100

Charles

Thanks for the clarification, you are right it would be a single RS.

I meant setup a single persistent RS with multiple streams, that could subsequently be used to simultaneously record multiple CS's.
The CS's could be one per media stream, or there could be several CS's mixed into each of the streams.

That does then appear to be covered by current protocal and metadata docs..

Rgds
John Stafford | Solution Architect 1 | BT Global Services 
________________________________________
From: Charles Eckel (eckelcu) [[email-masked]]
Sent: 23 September 2011 21:42
To: Stafford,J,John,JRJ3X C; [email-masked]
Subject: RE: [siprec] Setting Up Persistent Recording Session before any Calls

Hi John,

Please see inline.

Calls

I think so.

Cheers,
Charles