Subject: [siprec] FW: #75: How to represent recording callee capabilities in metadata XML ?

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Thu, 15 Sep 2011 22:10:05 +0530

Can we get some input on this ?

In the last discussion on this topic, Paul had proposed a mechanism for representing capabilities in XML  and Alan pointed to the example in RFC 4235. Here is the last discussion on this http://www.ietf.org/mail-archive/web/siprec/current/msg02308.html

Should we follow the approach/representation as given in RFC 4235 ?

Regards,
Ram

-----Original Message-----
From: siprec issue tracker [mailto:[email-masked]] 
Sent: Friday, September 02, 2011 12:07 PM
To: Ram Mohan R (rmohanr)
Cc: [email-masked]
Subject: [siprec] #75: How to represent recording callee capabilities in metadata XML ?

#75: How to represent recording callee capabilities in metadata XML ?

 There was some discussions on this at http://www.ietf.org/mail-
 archive/web/siprec/current/msg02316.html

 However no concrete conclusion was reached on this.
 Further during IETF 81 there was an agreement that capabilities of
 participants are actually attributes of association of participant to a
 session.This is because a participant in two sessions can have different
 capabilities depending on its role in the session.

-- 
--------------------------------+-------------------------------------------
 Reporter:  rmohanr@…           |       Owner:  rmohanr@…        
     Type:  enhancement         |      Status:  new              
 Priority:  minor               |   Milestone:                   
Component:  metadata            |     Version:                   
 Severity:  Active WG Document  |    Keywords:                   
--------------------------------+-------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/75>
siprec <http://tools.ietf.org/siprec/>

---

From: Leon Portman <[email-masked]>
Date: Thu, 15 Sep 2011 19:51:24 +0300

I am ok with such representation. However it is important to satisfy below comment that participant capabilities are per session.

Leon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ram Mohan R (rmohanr)
Sent: Thursday, September 15, 2011 7:40 PM
To: [email-masked]; Paul Kyzivat
Subject: [siprec] FW: #75: How to represent recording callee capabilities in metadata XML ?

Regards,
Ram

-----Original Message-----
From: siprec issue tracker [mailto:[email-masked]]
Sent: Friday, September 02, 2011 12:07 PM
To: Ram Mohan R (rmohanr)
Cc: [email-masked]
Subject: [siprec] #75: How to represent recording callee capabilities in metadata XML ?

 There was some discussions on this at http://www.ietf.org/mail-  archive/web/siprec/current/msg02316.html

 However no concrete conclusion was reached on this.
 Further during IETF 81 there was an agreement that capabilities of  participants are actually attributes of association of participant to a  session.This is because a participant in two sessions can have different  capabilities depending on its role in the session.

-- 
--------------------------------+---------------------------------------
--------------------------------+----
 Reporter:  rmohanr@…           |       Owner:  rmohanr@…        
     Type:  enhancement         |      Status:  new              
 Priority:  minor               |   Milestone:                   
Component:  metadata            |     Version:                   
 Severity:  Active WG Document  |    Keywords:                   
--------------------------------+---------------------------------------
--------------------------------+----

_______________________________________________
siprec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/siprec

---

From: "Ravindran Parthasarathi" <[email-masked]>
Date: Fri, 16 Sep 2011 04:42:27 +0530

Hi Ram,

I remember that Paul requested to raise the bug (errata) in RFC 4235 because of the syntax restriction. In case the syntax restriction is removed by new grammar, XML will take new form. Paul may able to comment on the approach for the element.

Hi Leon,

I agree with your comment.

Thanks
Partha

>From: [email-masked] [mailto:[email-masked]] On Behalf
>Of Leon Portman
>Sent: Thursday, September 15, 2011 10:21 PM
>To: Ram Mohan R (rmohanr); [email-masked]; Paul Kyzivat
>Subject: Re: [siprec] FW: #75: How to represent recording callee
>capabilities in metadata XML ?
>
>I am ok with such representation. However it is important to satisfy
>below comment that participant capabilities are per session.
>
>Leon
>
>In the last discussion on this topic, Paul had proposed a mechanism for
>representing capabilities in XML  and Alan pointed to the example in RFC
>4235. Here is the last discussion on this http://www.ietf.org/mail-
>archive/web/siprec/current/msg02308.html
>

---

From: "Elwell, John" <[email-masked]>
Date: Fri, 16 Sep 2011 18:37:26 +0200

It was a ticket against the requirements document, so clearly it can be closed now.

John 

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Leon Portman
> Sent: 15 September 2011 17:51
> Subject: Re: [siprec] FW: #75: How to represent recording 
> callee capabilities in metadata XML ?
> 
> I am ok with such representation. However it is important to 
> satisfy below comment that participant capabilities are per session.
> 
> Leon
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Ram Mohan R (rmohanr)
> In the last discussion on this topic, Paul had proposed a 
> mechanism for representing capabilities in XML  and Alan 
> pointed to the example in RFC 4235. Here is the last 
> discussion on this 
> http://www.ietf.org/mail-archive/web/siprec/current/msg02308.html
> 
>  There was some discussions on this at 
> http://www.ietf.org/mail-  archive/web/siprec/current/msg02316.html
> 
>  Further during IETF 81 there was an agreement that 
> capabilities of  participants are actually attributes of 
> association of participant to a  session.This is because a 
> participant in two sessions can have different  capabilities 
> depending on its role in the session.
> 
> -- 
>  Reporter:  rmohanr@...           |       Owner:  rmohanr@...

---

From: Leon Portman <[email-masked]>
Date: Mon, 19 Sep 2011 09:36:04 +0300

John, Thank you.

I am having troubles to get into issues management system. Anybody else?

Leon

-----Original Message-----
From: Elwell, John [mailto:[email-masked]] 
Sent: Friday, September 16, 2011 7:37 PM
To: Leon Portman; Ram Mohan R (rmohanr); [email-masked]; Paul Kyzivat
Subject: RE: [siprec] FW: #75: How to represent recording callee capabilities in metadata XML ?

John 

> In the last discussion on this topic, Paul had proposed a mechanism 
> for representing capabilities in XML  and Alan pointed to the example 
> in RFC 4235. Here is the last discussion on this 
> participants are actually attributes of association of participant to 
> a  session.This is because a participant in two sessions can have 
> different  capabilities depending on its role in the session.
> 
> --

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 19 Sep 2011 10:50:26 +0200

My response below was sent on the wrong thread - please disregard. I too am having trouble with the Wiki - I have informed Henrik.

John 

> From: Leon Portman [mailto:[email-masked]] 
> Sent: 19 September 2011 07:36
> To: Elwell, John; Ram Mohan R (rmohanr); [email-masked]; Paul Kyzivat
> > Subject: [siprec] #75: How to represent recording callee 
> capabilities 
> > in metadata XML ?
> > 
> capabilities of