Subject: [siprec] Partial Metadata Update

From: Ofir Roth <[email-masked]>
Date: Thu, 6 Oct 2011 10:01:50 +0200

Hello,

What are the guidelines for partial metadata update sent from SRC to SRS in respect to the elements included (sessions, participants etc.)?
Is it acceptable to assume that all related elements will be included in the partial update as opposed to sending just the pointers (e.g. only stream with no relative participant)?

Thanks,
Ofir.

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 06 Oct 2011 12:31:30 -0400

On 10/6/11 4:01 AM, Ofir Roth wrote:
> Hello,
>
> What are the guidelines for partial metadata update sent from SRC to SRS
> in respect to the elements included (sessions, participants etc.)?
>
> Is it acceptable to assume that all related elements will be included in
> the partial update as opposed to sending just the pointers (e.g. only
> stream with no relative participant)?

The expectation is that a partial update will include only those 
elements that have changed.

A major reason for having "pointers" (IDs) is so that a new reference to 
a preexisting element can be sent without resending the preexisting element.

	Thanks,
	Paul

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Wed, 12 Oct 2011 11:50:05 +0530

Ofir,

As Paul mentioned only those elements that are changed will be sent in
the partial update.
There are some basic examples of partial update given in ver -04 of the
draft.
Please look at them for reference.

Thanks,
Ram

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Paul Kyzivat
> Sent: Thursday, October 06, 2011 10:02 PM
> To: [email-masked]
> Subject: Re: [siprec] Partial Metadata Update
> 
> > Is it acceptable to assume that all related elements will be
included
> in
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec