Subject: Re: [siprec] Metadata-04 - comments on section 4

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Wed, 12 Oct 2011 18:55:10 +0530

Hi John,

Thanks for your comments. Please see inline for my responses.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Elwell, John
> Sent: Monday, September 26, 2011 2:53 PM
> To: [email-masked]
> Subject: [siprec] Metadata-04 - comments on section 4
> 
> (as individual)
> 
> 1. "The Metadata model is a class diagram in Unified Modelling
>    Language(UML). The model is a structure diagram that describes the
>    structure of a recording's Metadata by showing the classes, their
>    attributes, and the relationships among the classes."
> The two sentences seem to be in conflict - is it a class diagram or a
> structure diagram?

I will change it to  class diagram to make it uniform.

> Also, I believe the class diagram represents the structure of metadata
> in general, not the structure of metadata for a particular recording.

Agreed.

> 
> 2. "Session Recording Client (SRC) MAY initiate the
>    Recording Session."
> This sounds like protocol to me. We should not have normative
> statements about initiating an RS in a section describing the metadata
> model.

I will remove this statement from the document.

> 
> 3. "Here, Recording Session is a completely
>    independent from the Communication Session that is being recorded
at
>    both the SIP dialog level and at the session level."
> We should import definitions of CS and RS, and we should not need to
> explain the difference in this section.

Ok. I have given reference to architecture document that has
definitions. So I will remove this statement.

> 
> 4. "The metadata
>    MUST be conveyed from SRC to SRS."
> This too sounds like protocol.

I don't think this is related to protocol. This tells from where to
where the metadata has to be conveyed. I don't see any problems in
having this. 

> 
> 5. "For example, if the call is transferred from
>    one participant to another, then the SRC conveys the changes in the
>    model ( In this instance change of participant and the properties
of
>    the new media stream) to the SRS."
> This is probably a bad example. Although call transfer could be
> modelled as a change of participant in a CS, it could also be modelled
> as a change of CS (where one of the Participants is common). Can we
> pick an example where there is less scope for doing things differently
> (e.g., a Participant joins a conference)?

I agree that call transfer can be modeled as a change in participant or
even a change in CS depending on type of transfer(INVITE based or
REFER). I will try to give some other example.

> 
> 6. "Some of the metadata is not required to be conveyed explicitly
from
>    the SRC to the SRS, if it can be obtained contextually by the SRS.
>    For instance, the timing of RS object changes(like Start / Stop
> time)
>    may not be explicitly conveyed from the SRC to the SRS (The Date
>    header in RS dialog SIP message provides the timing, but it is
>    optional).  In such cases the time a change occurred may be assumed
>    to be the same as the time when notification of the change is
>    received by the SRS.  This is not true in cases where SRS requests
a
>    snapshot of metadata from SRC."
> The first sentence seems OK, but I worry about the example that
> follows. It is getting into protocol, and the final sentence is
> certainly protocol. Perhaps all that is needed is to cite SIP/SDP as
an
> example, e.g.:
> "Some of the metadata is not required to be conveyed explicitly from
>    the SRC to the SRS, if it can be obtained contextually by the SRS
> (e.g., from SIP or SDP signalling)."

I will replace the above text with this text.

Thanks,
Ram

> Even that is perhaps not relevant for section 4 - and I see section 5,
> which might be more appropriate, already has something similar.
> 
> John
> 
> 
> John Elwell
> Tel: +44 1908 817801 (office and mobile)
> Email: [email-masked]
> http://www.siemens-enterprise.com/uk/
> 
> Siemens Enterprise Communications Limited.
> Registered office: Brickhill Street, Willen Lake, Milton Keynes, MK15
> 0DJ.
> Registered No: 5903714, England.
> 
> Siemens Enterprise Communications Limited is a Trademark Licensee of
> Siemens AG.
> 
> 
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec

---

From: "John Elwell" <[email-masked]>
Date: Thu, 27 Oct 2011 09:51:52 +0100

Ram,

Thanks for your reponses, and sorry about the delay on my part. I disagree 

> where the metadata has to be conveyed. I don't see any problems in
[JRE] I would have not problem with an informative statement, but if we use 
MUST we need to say how an SRC would comply with this MUST, which to me gets 
into the realm of protocol. I would be happy with "The metadata is conveyed 
from SRC to SRS".

John

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Thu, 27 Oct 2011 14:23:54 +0530

Hi John,

I agree with you. I will make it an informative statement.

Regards,
Ram

> From: John Elwell [mailto:[email-masked]]
> Sent: Thursday, October 27, 2011 2:22 PM
> To: Ram Mohan R (rmohanr); [email-masked]
> Subject: Re: [siprec] Metadata-04 - comments on section 4
> 
> Ram,
> 
> [JRE] I would have not problem with an informative statement, but if
we
> use
> MUST we need to say how an SRC would comply with this MUST, which to
me
> gets