Subject: Re: [siprec] Start & stop time for CS [was RE: IETF 82 Minutes.]

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Mon, 16 Jan 2012 21:51:17 +0530

Hi Leon,

Please see inline

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Ravindran, Parthasarathi
> Sent: Wednesday, January 11, 2012 10:39 PM
> To: Leon Portman; [email-masked]
> Subject: Re: [siprec] Start & stop time for CS [was RE: IETF 82
> Minutes.]
> 
> Leon,
> 
> In case media level, it is possible to find the start/stop time using
> participantstream association or SDP attribute change for a specific
> stream. In case of participant to CS, association & disassociation
> attribute helps to identify how long participant is associated with CS
> during the recording.
> 
> Please read inline for more comments.
> 
> Thanks
> Partha
> 
> From: Leon Portman [mailto:[email-masked]]
> Sent: Tuesday, January 10, 2012 8:16 PM
> To: Ravindran, Parthasarathi; [email-masked]
> Subject: RE: Start & stop time for CS [was RE: IETF 82 Minutes.]
> 
> First couple of comments:
> 1. We need it also on the media level - for example when video or text
> sharing started/ended and not only complete CS 

I suppose you are asking for the times a media stream started / ended. The information on when a video/text/audio has started can be known at a participant level in the current model. In other words the participantStreamAssoc element has associate/dis-associate time which represents the times a participant starts/stops contributing to a stream. IMO this is sufficient.
What that does not cover is if you have a stream for which there are no associated participants and still want to track start/stop. My question is - Is there a need to know start/stop time for a stream for which there are no associated participants ? Any use-case you have in mind for such a thing ?

> 2. Same for participants - joining/leaving CS

The information on when a participant joins/leaves session is included in participantCSAssociation element.
Associate-time - associate-time is calculated by SRC as the time it sees a participant is associated to CS
Disassociate-time- Disassociate-time is calculated by SRC as the time it see a participant disassociate from a CS.

> 
> For the scenarios where RS covers on part of CS - like record on
> demand, how SRS will know when CS have started?

I agree this could be one use-case where we need CS start time. As partha mentioned for cases where SRC has knowledge of the CS start-time it can convey the same. The challenge I see is CS is a logical and may comprises of several SIP dialogs. In such cases what does start/stop means ? 

Regards,
Ram

> <partha> SRC has to maintain the dialog history information like Call
> Detail records (CDR) then only, this requirement will be solved. This
> requirement is not required to be mandated in all SRC </partha>
> 
> It is import from compliance recording point of view to indicate that
> RS does not cover complete CS.
> <partha> Could you please provide the name of compliance which mandate
> CS start/stop time </partha>
> 
> Hope it helps
> 
> Leon
> 
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Ravindran, Parthasarathi
> Sent: Thursday, January 05, 2012 7:16 PM
> To: [email-masked]
> Subject: [siprec] Start & stop time for CS [was RE: IETF 82 Minutes.]
> 
> Hi all,
> 
> Associate/disassociate time helps to understand how long CS is
> associated with RS. Initial association time shall be considered  as
> start time and final disassociation time shall be considered as stop
> time. As we could not conclude this open item during IETF-82, I'm
> starting this mail thread for discussion.
> 
> I could not see any other strong reason for having start/stop time for
> CS apart from associate/disassociate time. Please provide usecase for
> including start/stop time attribute in CS.
> 
> In case we could not see the proper usecase, it is better to remove
> from metadata draft.
> 
> Thanks
> Partha

---

From: Leon Portman <[email-masked]>
Date: Tue, 17 Jan 2012 11:01:15 +0200

Ram Hi

I am ok with the below regarding media and participant times. 
Regarding local CS with multiple SIP sessions: it is depends on SRC logic - may be start of first SIP dialog?

Regards

Leon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ram Mohan R (rmohanr)
Sent: Monday, January 16, 2012 6:21 PM
To: [email-masked]
Subject: Re: [siprec] Start & stop time for CS [was RE: IETF 82 Minutes.]

Hi Leon,

Please see inline

Regards,
Ram

> In case we could not see the proper usecase, it is better to remove 
_______________________________________________
siprec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/siprec