Subject: [siprec] Drawings in siprec-architecture-03

From: "Feenstra, Friso" <[email-masked]>
Date: Sun, 15 Jan 2012 19:24:00 +0000

All,

I am visually oriented and as such always look first at pictures and after that study the text. On the drawings in siprec-architecture-03 I have the following remarks.

1.      In some drawings for the voice stream the abbreviation RTP is used, while for others the abbreviation RTP/RTCP is used. Is there a reason for this, if not I would recommend to standardize on RTP.

2.      In figure 3, it is suggested that the RTP/RTCP stream flows from SRC to SRS and vice versa. Other figures suggest that the stream only flows from SRC to SRS.

3.      In figure 4, it is suggested that the RTP stream flows from SRS to SRC and that the SIP session is only established from SRC to SRS (and not vice versa)

4.      In figure 5, I would recommend to draw lines for both SIP and RTP streams per dialog and indicate SIP for the top recording session connection.

Alternatives

Figure 1

                                              +-----------+
                          (Recording Session) |  Session  |
                             +------SIP------>| Recording |
                             |                |  Server   |
                             |  +---RTP------>|  (SRS)    |
                             |  |             +-----------+
                             V  |                   ^
                        +-------------+             |
                        |             |             |
                        |             |-- MetaData -+
                        |             |
                        |    B2BUA    |
                        |             |
                        |   Session   |
     +--------+         |  Recording  |         +---------+
     |        |<- SIP ->|   Client    |<- SIP ->|         |
     |  UA-A  |         |   (SRC)     |         |  UA-B   |
     |        |<- RTP ->|             |<- RTP ->|         |
     +--------+         |             |         +---------+
                        +-------------+
     |____________________________________________________|
                    (Communication Session)

Figure 2

          (Recording Session) +-----------+

         +----------SIP------>|           |

         |  +-------RTP------>|  Session  |

         |  |                 | Recording |

         |  |                 |  Server   |

         |  | +-- Metadata -->|   (SRS)   |

         |  | |               |           |

         |  | |               +-----------+

         |  | |

         |  | |

         |  | |

         |  | |

         V  | |  (Communication Session)

      +--+------+                     +---------+

      |         |<-------SIP--------->|         |

      |  UA-A   |                     |  UA-B   |

      |  (SRC)  |<-------RTP--------->|         |

      +---------+                     +---------+

Figure 3

                                     Session Recording Server (SRS)

                              +----------------------------------------+

                              |                                        |

          (Recording Session) |  +-----------+          +------------+ |

          +------------SIP----|->|           |          |            | |

          |                   |  | MediaCtrl |MEDIACTRL |   Media    | |

          |                   |  |Application|<-------->|   Server   | |

          |    +-----Metadata--->|  Server   |          |  (Recorder)| |

          |    |              |  |           |          |            | |

          |    |              |  +-----------+          +------------+ |

          |    |              |                              ^         |

          |    |              +------------------------------|---------+

          |    |  +-----------------RTP----------------------+

          |    |  |

          V    |  |

        +---+------+                          +---------+

        |          |<-------SIP-------------->|         |

        |   UA-A   | (Communication Session)  |  UA-B   |

        |   (SRC)  |<-------RTP-------------->|         |

        +----------+                          +---------+

Figure 4

                                                    +----------+

                 (Recording Session)                | Session  |

           +-----------SIP------------------------->|Recording |

           |                                        |  Server  |

           |                                        |   (SRS)  |

           V  UA-A Session Recording Client (SRC)   +----------+

    +----------------------------------------+         ^  ^

    |                                        |         |  |

    |  +-----------+          +------------+ |---RTP---+  |

    |  |           | Control  |            | |            |

    |  |    UA     | Protocol |   Media    | |---Metadata-+

    |  |Application|<-------->|  Server    | |              +---------+

    |  |  Server   |          |            | |              |         |

    |  |           |          |            | |<----SIP----->|  UA-B   |

    |  +-----------+          +------------+ |<----RTP----->|         |

    |                                        |              +---------+

    +----------------------------------------+

Figure 5

                                User 1

                            +-----------+

                            |           |

                            |           |

                            |Participant|

                            |     1     |

                            |           |

                            +-----------+

                               ^     ^

                               |     |

                     Dialog   RTP   SIP

                        1      |     |

       User 2                  V     V     Recording

    +-----------+           +-----------+  Session     *************

    |           |           |           |<---SIP------>*           *

    |           |<---SIP--->|           |----RTP 1 --->*           *

    |Participant|           | Focus/SRC |----RTP 2 --->*    SRS    *

    |     2     |<---RIP--->|           |----RTP 3 --->*           *

    |           |  Dialog   |           |--Metadata--->*           *

    +-----------+    2      +-----------+              *************

                               ^    ^

                               |    |

                     Dialog   RTP  SIP

                        3      |    |

                               V    V

                            +-----------+

                            |           |

                            |           |

                            |Participant|

                            |    3      |

                            |           |

                            +-----------+

                               User 3

Think green - keep it on the screen.

This e-mail and any attachment is for authorised use by the intended recipient(s) only. It may contain proprietary material, confidential information and/or be subject to legal privilege. It should not be copied, disclosed to, retained or used by, any other party. If you are not an intended recipient then please promptly delete this e-mail and any attachment and all copies and inform the sender. Thank you.

---

From: Leon Portman <[email-masked]>
Date: Mon, 16 Jan 2012 10:55:21 +0200

Friso Hello

Thank you very much for comments.

1.       Regarding showing RTP or RTP/RTCP in the figures. This was one of the recent changes in order to show best practice from MMUSIC to always support RTCP.
I think we should to show RTP/RTCP on every figures. Or is it enough only to mention it in the text?

2.       RTP/RTCP direction. This is very good point. RTP will be one direction (SRC to SRS) but RTCP is bi-directional. So if we will user RTP/RTCP as one label, line should be bi-directional as well. Any opinions?

3.       Figure 4 is mistake, I will fix it.

4.       Figure 5, I agree as well.

Thank you for the figure  proposals.

Any comments from the list?  Most important is to finalize RTP or RTP/RTPC labels in the figures from my point of view.

Regards

Leon

From: [email-masked] [mailto:[email-masked]] On Behalf Of Feenstra, Friso
Sent: Sunday, January 15, 2012 9:24 PM
To: [email-masked]
Subject: [siprec] Drawings in siprec-architecture-03

All,

Alternatives

Figure 1

                                              +-----------+

Figure 2

         +----------SIP------>|           |

         |  |                 | Recording |

         |  |                 |  Server   |

         |  | |               |           |

         |  | |               +-----------+

         |  | |

         |  | |

         |  | |

         |  | |

      +--+------+                     +---------+

      |  UA-A   |                     |  UA-B   |

      +---------+                     +---------+

Figure 3

                              |                                        |

          |    |              |  |           |          |            | |

          |    |              |                              ^         |

          |    |  |

          V    |  |

        +---+------+                          +---------+

        +----------+                          +---------+

Figure 4

                                                    +----------+

           |                                        |  Server  |

           |                                        |   (SRS)  |

    |                                        |         |  |

    |  |           | Control  |            | |            |

    |  |  Server   |          |            | |              |         |

    |                                        |              +---------+

Figure 5

                                User 1

                            +-----------+

                            |           |

                            |           |

                            |Participant|

                            |     1     |

                            |           |

                            +-----------+

                               ^     ^

                               |     |

                     Dialog   RTP   SIP

                        1      |     |

       User 2                  V     V     Recording

    |           |           |           |<---SIP------>*           *

                               ^    ^

                               |    |

                     Dialog   RTP  SIP

                        3      |    |

                               V    V

                            +-----------+

                            |           |

                            |           |

                            |Participant|

                            |    3      |

                            |           |

                            +-----------+

                               User 3

Think green - keep it on the screen. This e-mail and any attachment is for authorised use by the intended recipient(s) only. It may contain proprietary material, confidential information and/or be subject to legal privilege. It should not be copied, disclosed to, retained or used by, any other party. If you are not an intended recipient then please promptly delete this e-mail and any attachment and all copies and inform the sender. Thank you.

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Mon, 16 Jan 2012 21:28:31 +0530

Hi Leon, 

Please see inline

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Leon Portman
> Sent: Monday, January 16, 2012 2:25 PM
> To: Feenstra, Friso; [email-masked]
> Subject: Re: [siprec] Drawings in siprec-architecture-03
> 
> Friso Hello
> 
> 1. Regarding showing RTP or RTP/RTCP in the figures. This was one of
> the recent changes in order to show best practice from MMUSIC to always
> support RTCP.

I don't see any issues in showing RTP/RTCP in the figures. Where ever possible SRC can record RTCP
> 
> 2. RTP/RTCP direction. This is very good point. RTP will be one
> direction (SRC to SRS) but RTCP is bi-directional. So if we will user
> RTP/RTCP as one label, line should be bi-directional as well. Any
> opinions?

Yes. Make sense. RTCP should be bi-directional.

Regards,
Ram

> Any comments from the list?  Most important is to finalize RTP or
> RTP/RTPC labels in the figures from my point of view.
> 
> Regards
> 
> Leon
> 
> 
> 
> 
> I am visually oriented and as such always look first at pictures and
> after that study the text. On the drawings in siprec-architecture-03 I
> have the following remarks.
> 
> 1. In some drawings for the voice stream the abbreviation RTP is used,
> while for others the abbreviation RTP/RTCP is used. Is there a reason
> for this, if not I would recommend to standardize on RTP.
> 2. In figure 3, it is suggested that the RTP/RTCP stream flows from SRC
> to SRS and vice versa. Other figures suggest that the stream only flows
> from SRC to SRS.
> 3. In figure 4, it is suggested that the RTP stream flows from SRS to
> SRC and that the SIP session is only established from SRC to SRS (and
> not vice versa)
> 4. In figure 5, I would recommend to draw lines for both SIP and RTP
> streams per dialog and indicate SIP for the top recording session
> connection.
> 
> 
> Alternatives
> 
> Figure 1
> 
> 
>                                               +-----------+
>                               |
> |
>           |    |              |  |           |          |            |
> |
>           |    |              |                              ^
> |
> Think green - keep it on the screen. This e-mail and any attachment is
> for authorised use by the intended recipient(s) only. It may contain
> proprietary material, confidential information and/or be subject to
> legal privilege. It should not be copied, disclosed to, retained or
> used by, any other party. If you are not an intended recipient then
> please promptly delete this e-mail and any attachment and all copies
> and inform the sender. Thank you.