Subject: Re: [siprec] Proposal for minor changes to metadata to support mixed stream and duplicated stream recording.

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Wed, 9 May 2012 13:44:51 +0000

Hi John,

Sorry for the delay reply.  In the object model, there is unique-id and association related to the object. In case of XML representation, unique-id of the object is represented as XML attribute "id" and the association of the object is represented by second attribute .

While I discussing with XML experts, I understand that "id" has special meaning in XML and it should not be repeated. So, I'm proposing to have object name with id for both attributes and XML looks as follows:

      <stream stream_id="Axzg12XHdhjelfjhdldjf;34jn78=="
                    session_id="zzlafnvvjlCHllaHF6mn8kkSS==">
                    <label>99</label>
       </stream>
      <stream stream_id="Axzg12XHdhjelfjhdldjf;34jn78=="
                    session_id=" zSfPoSvdSDCmU3A3TRDxAw==">
                    <label>99</label>
       </stream>
      <stream stream_id="EiXGlc+4TruqqoDaNE76ag=="
                    session_id=" zzlafnvvjlCHllaHF6mn8kkSS==">
                    <label>100</label>
       </stream>
      <stream stream_id="EiXGlc+4TruqqoDaNE76ag=="
                    session_id="zSfPoSvdSDCmU3A3TRDxAw==">
                   <label>99</label>
       </stream>

Please let me know your opinion on the same.

Thanks
Partha

From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, March 29, 2012 2:35 PM
To: Ravindran, Parthasarathi; [email-masked]
Subject: RE: [siprec] Proposal for minor changes to metadata to support mixed stream and duplicated stream recording.

Partha,

  so you are saying there is no need to allow multiple labels on a stream element, as a stream elemet can be repeated in the metadata multiple times.

  I dont see how this matches the object model, a element with a unique id can surely on occur once in the matadata.

Rgds
John Stafford | Solution Architect 1 | BT Global Services | Tel:+44 (0)1932 773504   | E: [email-masked]<mailto:[email-masked]>  |  www.bt.com/globalservices<http://www.bt.com/globalservices>

________________________________
From: Ravindran, Parthasarathi [[email-masked]]
Sent: 28 March 2012 22:42
To: Stafford,J,John,JRJ3X C; [email-masked]<mailto:[email-masked]>
Subject: RE: [siprec] Proposal for minor changes to metadata to support mixed stream and duplicated stream recording.
John,

I'll explain how to form metadata XML element for your requirement:

"Siprec support for recording same CS stream in multiple m line streams of 1 RS:
   This is the converse of the above, I propose that multiple labels be allowed in a  stream element,
   the meaning would be that the stream is recorded in all of the referenced recording m-line streams."

Here,  There are two CS's,  2 m'line and 1 RS. For representing as per current XML schema is as follows,

      <stream id="Axzg12XHdhjelfjhdldjf;34jn78=="
                    session="zzlafnvvjlCHllaHF6mn8kkSS==">
                    <label>99</label>
       </stream>
      <stream id="Axzg12XHdhjelfjhdldjf;34jn78=="
                    session=" zSfPoSvdSDCmU3A3TRDxAw==">
                    <label>99</label>
       </stream>
      <stream id="EiXGlc+4TruqqoDaNE76ag=="
                    session=" zzlafnvvjlCHllaHF6mn8kkSS==">
                    <label>100</label>
       </stream>
      <stream id="EiXGlc+4TruqqoDaNE76ag=="
                    session="zSfPoSvdSDCmU3A3TRDxAw==">
                   <label>99</label>
       </stream>

Could you please explain the issue in the above approach.

Thanks
Partha

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Wednesday, March 28, 2012 8:19 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [siprec] Proposal for minor changes to metadata to support mixed stream and duplicated stream recording.

This is as follow up to the threads
   "How to specify in metadata that multiple CS's are being recorded in a single mixed RS m line stream"
   http://www.ietf.org/mail-archive/web/siprec/current/msg03126.html

   "How to specify in metadata that a participants stream is being recorded in multiple m line streams"
    http://www.ietf.org/mail-archive/web/siprec/current/msg03107.html

Siprec support for mixed stream recording:
   I propose multiple streams would use the same label,
   indicating that the streams are recorded in the same recording m-line stream.

Siprec support for recording same CS stream in multiple m line streams of 1 RS:
   This is the converse of the above, I propose that multiple labels be allowed in a  stream element,
   the meaning would be that the stream is recorded in all of the referenced recording m-line streams.

Implications for existing metadata specification:
   This does not change the existing metadata usage of streams and labels, it just adds more flexibility.
   The only changes required would be that
      1. stream's label element  maxoccurs="1" restriction would need to be removed
      2. there would  be a 1:n stream:label relationship not 1:1.
         I can't see anything in draft-ietf-siprec-metadata-06 that says there is a 1:1 relationship anyway.

Examples:
   Mixed Stream Recording:
      If we have a persistent RS with a single m-line, and a single CS being recorded via a mixed TX/RX stream,
     then the metadata will have a single <stream> element, which has a label referencing a RS m-line.

      Now if we add a 2nd CS to that RS, we will now have two <Stream> elements, one for each CS.
      If they are both being mixed onto the one RS m-line stream, both <stream> elements will have the same label, ie:

      <stream id="Axzg12XHdhjelfjhdldjf;34jn78=="
                    session="zzlafnvvjlCHllaHF6mn8kkSS==">
                    <label>99</label>
                </stream>
      <stream id="EiXGlc+4TruqqoDaNE76ag=="
                    session="zSfPoSvdSDCmU3A3TRDxAw==">
                    <label>99</label>
                </stream>

   Duplicate Stream Recording
      If we have a persistent RS with a single m-line, and a single CS being recorded via a mixed TX/RX stream,
      then the metadata will have a single <stream> element, which has a label referencing a RS m-line.

      If we have a a persistent RS with a two m-line's for duplicated recording, then
      the metadata will have a single <stream> element, which has a two labels referencing both the RS m-lines.

     <stream id="Axzg12XHdhjelfjhdldjf;34jn78=="
                    session="zzlafnvvjlCHllaHF6mn8kkSS==">
                    <label>99</label>
                    <label>100</label>
                </stream>

   Finally, we could have both the above scenarios together, where the mixed two CS recording is duplicated:

      <stream id="Axzg12XHdhjelfjhdldjf;34jn78=="
                    session="zzlafnvvjlCHllaHF6mn8kkSS==">
                    <label>99</label>
                    <label>100</label>
                </stream>
      <stream id="EiXGlc+4TruqqoDaNE76ag=="
                    session="zSfPoSvdSDCmU3A3TRDxAw==">
                   <label>99</label>
                    <label>100</label>
                </stream>

So why do I think siprec should support these changes ?

   Requirements for mixed stream recording:

      RFC6341 refers to mixed recording in use cases 3 and 11 and in REQ 9::

      In Use Case 3:
         In some cases, more than one concurrent Communication Session (on
         a single end-user apparatus, e.g., trading-floor turret) is mixed
         into one Recording Session:

                          |-------- CS 1 -------|
                             |-------- CS 2 -------|
                        |-------- CS 3 -------|

            RS  |----------- Recording Session --------------|
            t--->

      In Use case 11:
         In trading-floor environments, in order to minimize storage and
         recording system resources, it may be preferable to mix multiple
         concurrent calls (Communication Sessions) on different handsets/
         speakers on the same turret into a single recording session.

      REQ-009: The mechanism MUST support the ability for an SRC to
         deliver mixed audio streams from different parties of a given
         Communication Session to an SRS.

      To me this implies multiple CS's in one mixed recorder stream, since the requirement specifically
      says "mix", and "to minimise storage".

   Requirements for Duplicated stream recording:
      RFC6341 does not specifically mention duplicated recording
      But I don't think allowing it would complicate the metadata, and it will be down to the recorder
      implementation how it handles the duplicated CS recording.

Rgds
John Stafford | Solution Architect 1 | BT Global Services

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 09 May 2012 10:15:15 -0400

The new form reads nicely, but it is a bit verbose.
I'd be interested to hear more about why "id" is *special* in XML.

	Thanks,
	Paul

On 5/9/12 9:44 AM, Ravindran, Parthasarathi wrote:
> Hi John,
>
> Sorry for the delay reply. In the object model, there is unique-id and
> association related to the object. In case of XML representation,
> unique-id of the object is represented as XML attribute “id” and the
> association of the object is represented by second attribute .
>
> While I discussing with XML experts, I understand that “id” has special
> meaning in XML and it should not be repeated. So, I’m proposing to have
> object name with id for both attributes and XML looks as follows:
>
> session_id="zzlafnvvjlCHllaHF6mn8kkSS==”>
> <label>99</label>
> </stream>
>
> session_id=" zSfPoSvdSDCmU3A3TRDxAw==”>
> <label>99</label>
> </stream>
> *From:[email-masked] [mailto:[email-masked]]
> *Sent:* Thursday, March 29, 2012 2:35 PM
> *To:* Ravindran, Parthasarathi; [email-masked]
> *Subject:* RE: [siprec] Proposal for minor changes to metadata to
> support mixed stream and duplicated stream recording.
>
> Partha,
>
> so you are saying there is no need to allow multiple labels on a stream
> element, as a stream elemet can be repeated in the metadata multiple times.
>
> I dont see how this matches the object model, a element with a unique id
> can surely on occur once in the matadata.
>
> Rgds
>
> John Stafford | Solution Architect 1 | BT Global Services | Tel:+44
> <Tel:+44> (0)1932 773504 | E: [email-masked]
> <mailto:[email-masked]> | _www.bt.com/globalservices
> <http://www.bt.com/globalservices>_
>
> ------------------------------------------------------------------------
>
> *From:*Ravindran, Parthasarathi [[email-masked]]
> *Sent:* 28 March 2012 22:42
> *To:* Stafford,J,John,JRJ3X C; [email-masked] <mailto:[email-masked]>
> *Subject:* RE: [siprec] Proposal for minor changes to metadata to
> support mixed stream and duplicated stream recording.
>
> John,
>
> I’ll explain how to form metadata XML element for your requirement:
>
> “Siprec support for recording same CS stream in multiple m line streams
> of 1 RS:
> the meaning would be that the stream is recorded in all of the
> referenced recording m-line streams.”
>
> Here, There are two CS’s, 2 m’line and 1 RS. For representing as per
> current XML schema is as follows,
>
> session="zzlafnvvjlCHllaHF6mn8kkSS==”>
> <label>99</label>
> </stream>
>
> session=" zSfPoSvdSDCmU3A3TRDxAw==”>
> <label>99</label>
> </stream>
> *From:[email-masked] <mailto:[email-masked]>
> [mailto:[email-masked]] *On Behalf Of [email-masked]
> <mailto:[email-masked]>
> *Sent:* Wednesday, March 28, 2012 8:19 PM
> *To:* [email-masked] <mailto:[email-masked]>
> *Subject:* [siprec] Proposal for minor changes to metadata to support
> mixed stream and duplicated stream recording.
>
>
> “How to specify in metadata that multiple CS's are being recorded in a
> single mixed RS m line stream”
> “How to specify in metadata that a participants stream is being recorded
> in multiple m line streams”
> 1. stream’s label element maxoccurs=”1” restriction would need to be removed
> I can’t see anything in draft-ietf-siprec-metadata-06 that says there is
> a 1:1 relationship anyway.
>
>
>
>
> Examples:
> Mixed Stream Recording:
> If they are both being mixed onto the one RS m-line stream, both
> <stream> elements will have the same label, ie:
>
> session="zzlafnvvjlCHllaHF6mn8kkSS==”>
> <label>99</label>
> </stream>
> If we have a a persistent RS with a two m-line’s for duplicated
> recording, then
> session="zzlafnvvjlCHllaHF6mn8kkSS==”>
> <label>99</label>
> <label>100</label>
> </stream>
>
>
> session="zzlafnvvjlCHllaHF6mn8kkSS==”>
> <label>99</label>
> <label>100</label>
> </stream>
> To me this implies multiple CS’s in one mixed recorder stream, since the
> requirement specifically
>
> says ”mix”, and ”to minimise storage”.
>
>
>
> But I don’t think allowing it would complicate the metadata, and it will
> be down to the recorder
>
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec

---

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Thu, 10 May 2012 13:13:25 +0000

Paul,

XML:id attribute is mentioned in http://www.w3.org/TR/xml-id/ and each element in XML document has at most one single unique identifier "id".

Including Joe in this mail thread.

Thanks
Partha

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf
>Of Paul Kyzivat
>Sent: Wednesday, May 09, 2012 7:45 PM
>To: [email-masked]
>Subject: Re: [siprec] Proposal for minor changes to metadata to support
>> unique-id of the object is represented as XML attribute "id" and the
>> While I discussing with XML experts, I understand that "id" has
>> special meaning in XML and it should not be repeated. So, I'm
>> proposing to have object name with id for both attributes and XML
>looks as follows:
>>
>> session_id=" zSfPoSvdSDCmU3A3TRDxAw=="> <label>99</label> </stream>
>> session_id=" zzlafnvvjlCHllaHF6mn8kkSS=="> <label>100</label>
>> </stream>
>>
>> so you are saying there is no need to allow multiple labels on a
>> stream element, as a stream elemet can be repeated in the metadata
>multiple times.
>>
>> I dont see how this matches the object model, a element with a unique
>> id can surely on occur once in the matadata.
>>
>> Rgds
>>
>> This is the converse of the above, I propose that multiple labels be
>> allowed in a stream element, the meaning would be that the stream is
>> recorded in all of the referenced recording m-line streams."
>>
>> session=" zzlafnvvjlCHllaHF6mn8kkSS=="> <label>100</label> </stream>
>>
>> This is the converse of the above, I propose that multiple labels be
>> allowed in a stream element, the meaning would be that the stream is
>> recorded in all of the referenced recording m-line streams.
>>
>> The only changes required would be that 1. stream's label element
>> maxoccurs="1" restriction would need to be removed 2. there would be a
>> 1:n stream:label relationship not 1:1.
>> If we have a persistent RS with a single m-line, and a single CS being
>> recorded via a mixed TX/RX stream, then the metadata will have a
>> single <stream> element, which has a label referencing a RS m-line.
>>
>> If we have a persistent RS with a single m-line, and a single CS being
>> recorded via a mixed TX/RX stream, then the metadata will have a
>> single <stream> element, which has a label referencing a RS m-line.
>>
>> If we have a a persistent RS with a two m-line's for duplicated
>> recording, then the metadata will have a single <stream> element,
>> which has a two labels referencing both the RS m-lines.
>>
>> In some cases, more than one concurrent Communication Session (on a
>> single end-user apparatus, e.g., trading-floor turret) is mixed into
>> one Recording Session:
>>
>> |-------- CS 1 -------|
>> |-------- CS 2 -------|
>> |-------- CS 3 -------|
>>
>> REQ-009: The mechanism MUST support the ability for an SRC to deliver
>> mixed audio streams from different parties of a given Communication
>> Session to an SRS.
>>
>>
>> RFC6341 does not specifically mention duplicated recording But I don't
>> think allowing it would complicate the metadata, and it will be down
>> to the recorder
>>

---

From: Joe Hildebrand <[email-masked]>
Date: Thu, 10 May 2012 09:20:04 -0600

id is supposed to be unique across the entire document.  In some processing
software (such as CSS), id has special syntax that takes advantage of that
assumption.

On 5/10/12 7:13 AM, "Ravindran, Parthasarathi" <[email-masked]>
wrote:

> Paul,
> 
> XML:id attribute is mentioned in http://www.w3.org/TR/xml-id/ and each element
> in XML document has at most one single unique identifier "id".
> 

-- 
Joe Hildebrand

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 10 May 2012 16:02:37 -0400

> software (such as CSS), id has special syntax that takes advantage of that

OK, I'll take your word for it, since it sounds like otherwise it would 
take me down a rat hole that I would rather avoid.

	Thanks,
	Paul

> On 5/10/12 7:13 AM, "Ravindran, Parthasarathi"<[email-masked]>
> wrote:
>
>> Paul,
>>
>>>> *From:[email-masked]<mailto:[email-masked]>
>>>> *To:* [email-masked]<mailto:[email-masked]>
>>>> single<stream>  element, which has a label referencing a RS m-line.
>>>>
>>>> Now if we add a 2nd CS to that RS, we will now have two<Stream>
>>>> elements, one for each CS.
>>>> single<stream>  element, which has a label referencing a RS m-line.
>>>>
>>>> recording, then the metadata will have a single<stream>  element,

---

From: <[email-masked]>
Date: Mon, 14 May 2012 12:52:29 +0100

Partha, 

You are suggesting 
>>>> session_id="zSfPoSvdSDCmU3A3TRDxAw==">
I am confused, what is the example you show supposed to respresent ?

>>>> session="zzlafnvvjlCHllaHF6mn8kkSS==">

Rgds
John Stafford | Solution Architect 1 | BT Global Services | Tel:+44 (0)1932 773504   | E: [email-masked]  |  www.bt.com/globalservices
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Paul Kyzivat [[email-masked]]
Sent: 10 May 2012 21:02
To: Joe Hildebrand
Cc: [email-masked]
Subject: Re: [siprec] Proposal for minor changes to metadata to support mixed stream and duplicated stream recording.

        Thanks,
        Paul

---

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Mon, 14 May 2012 12:09:58 +0000

John,

My example is to show how to represent single stream in two CS and it is as follows:

In the above example, Axzg12XHdhjelfjhdldjf;34jn78== is the single stream id which is
Used by two CS namely zzlafnvvjlCHllaHF6mn8kkSS== & 
zSfPoSvdSDCmU3A3TRDxAw==. 

The trouble with multiple label in single stream is that the handling of 
participantstream association for each of the label individually within the single 
stream element.  

Duplicate stream recording has to have separate streams to distinguish the actual & 
duplicate stream.

Thanks
Partha

>Sent: Monday, May 14, 2012 5:22 PM
>To: Ravindran, Parthasarathi
>Cc: [email-masked]
>Subject: RE: [siprec] Proposal for minor changes to metadata to support
>To hark back to my original request, what is your objection to the
>following, as it seems simpler to me than what you are suggesting:
>
>>>>> If we have a persistent RS with a single m-line, and a single CS
>>>>> being recorded via a mixed TX/RX stream, then the metadata will
>>>>> have a single<stream>  element, which has a label referencing a RS
>m-line.
>
>>>>> Mixed Stream Recording:
>>>>>
>(0)1932 773504   | E: [email-masked]  |
>www.bt.com/globalservices
>> id is supposed to be unique across the entire document.  In some
>> processing software (such as CSS), id has special syntax that takes
>> advantage of that assumption.
>
>>> XML:id attribute is mentioned in http://www.w3.org/TR/xml-id/ and
>>> each element in XML document has at most one single unique identifier
>"id".
>>>
>>>> From: [email-masked] [mailto:[email-masked]] On
>>>> Behalf Of Paul Kyzivat
>>>> Subject: Re: [siprec] Proposal for minor changes to metadata to
>>>>> Sorry for the delay reply. In the object model, there is unique-id
>>>>> and association related to the object. In case of XML
>>>>> representation, unique-id of the object is represented as XML
>>>>> attribute "id" and the association of the object is represented by
>second attribute .
>>>>>
>>>>> session_id=" zSfPoSvdSDCmU3A3TRDxAw==">  <label>99</label>
>>>>> </stream> <stream stream_id="EiXGlc+4TruqqoDaNE76ag=="
>>>>> I dont see how this matches the object model, a element with a
>>>>> unique id can surely on occur once in the matadata.
>>>>>
>>>>> Rgds
>>>>>
>>>>> -------------------------------------------------------------------
>>>>> ---
>>>>> --
>>>>>
>>>>> This is the converse of the above, I propose that multiple labels
>>>>> be allowed in a stream element, the meaning would be that the
>>>>> stream is recorded in all of the referenced recording m-line
>streams."
>>>>>
>>>>> session=" zSfPoSvdSDCmU3A3TRDxAw=="> <label>99</label> </stream>
>>>>> [mailto:[email-masked]] *On Behalf Of
>>>>> [email-masked] <mailto:[email-masked]>
>>>>> *Subject:* [siprec] Proposal for minor changes to metadata to
>>>>> This is as follow up to the threads "How to specify in metadata
>>>>> that multiple CS's are being recorded in a single mixed RS m line
>>>>> stream"
>>>>> This is the converse of the above, I propose that multiple labels
>>>>> be allowed in a stream element, the meaning would be that the
>>>>> stream is recorded in all of the referenced recording m-line
>streams.
>>>>>
>>>>> maxoccurs="1" restriction would need to be removed 2. there would
>>>>> be a 1:n stream:label relationship not 1:1.
>>>>> If we have a persistent RS with a single m-line, and a single CS
>>>>> being recorded via a mixed TX/RX stream, then the metadata will
>>>>> have a single<stream>  element, which has a label referencing a RS
>m-line.
>>>>>
>>>>> If we have a persistent RS with a single m-line, and a single CS
>>>>> being recorded via a mixed TX/RX stream, then the metadata will
>>>>> have a single<stream>  element, which has a label referencing a RS
>m-line.
>>>>>
>>>>> single end-user apparatus, e.g., trading-floor turret) is mixed
>>>>> RFC6341 does not specifically mention duplicated recording But I
>>>>> don't think allowing it would complicate the metadata, and it will
>>>>> be down to the recorder
>>>>>

---

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Wed, 16 May 2012 07:30:12 +0000

Hi all,

In case there is no objection to the below proposal with explicit id instead of "id" usage till 23rd May (Next Wednesday), I think that it is better to incorporate in (-07) metadata draft as these changes helps for the progresses of the metadata draft. Please let me know your opinion on the same.

Thanks
Partha

>Of Ravindran, Parthasarathi
>Sent: Monday, May 14, 2012 5:40 PM
>To: [email-masked]
>Cc: [email-masked]
>In the above example, Axzg12XHdhjelfjhdldjf;34jn78== is the single
>stream id which is Used by two CS namely zzlafnvvjlCHllaHF6mn8kkSS== &
>participantstream association for each of the label individually within
>the single stream element.
>
>Duplicate stream recording has to have separate streams to distinguish
>the actual & duplicate stream.
>
>
>Thanks
>Partha
>
>>>>>> Finally, we could have both the above scenarios together, where
>the
>>>>>> mixed two CS recording is duplicated:
>>>>>>
>a

---

From: "Hutton, Andrew" <[email-masked]>
Date: Mon, 28 May 2012 14:15:43 +0000

Hi All,

I just want to make sure I understand the results of this discussion and whether we have consensus.

I am assuming we have consensus to move to using "stream_id" rather than "id" as this is what the XML experts are telling us is correct.

Mixed Stream Recording
=======================

For the mixed stream scenario in which streams from two CS's are mixed in to a single RS stream then the following seems to be what we have settled on.

Recoding same CS stream in multiple m line streams of 1 RS
==========================================================

I am not sure I have it right for this case but I think assuming the change to use "stream_id" and "session_id" would result in the following:

Do we have any issues with this?

Regards
Andy (SIPREC Co-Chair).

> Behalf Of Ravindran, Parthasarathi
> Sent: 16 May 2012 08:30
> To: Ravindran, Parthasarathi; [email-masked]
> Cc: [email-masked]
> In case there is no objection to the below proposal with explicit id
> instead of "id" usage till 23rd May (Next Wednesday), I think that it
> is better to incorporate in (-07) metadata draft as these changes helps
> for the progresses of the metadata draft. Please let me know your
> opinion on the same.
> 
> Thanks
> Partha
> 
> Behalf
> support
> >My example is to show how to represent single stream in two CS and it
> is
> >as follows:
> >
> support
> >>>>>> ----------------------------------------------------------------
> --
> >-
> >>>>>> ---
> >>>>>> --
> >>>>>>
> >>>>>> RFC6341 refers to mixed recording in use cases 3 and 11 and in
> REQ
> >>9::
> >>>>>>
> >>>>>> In Use Case 3:

---

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Mon, 28 May 2012 17:15:05 +0000

Andy,

Recording multiple m line in CS has to be represented as follows:

	<stream stream_id="Axzg12XHdhjelfjhdldjf;34jn78=="
		session_id="zzlafnvvjlCHllaHF6mn8kkSS==">
		<label>99</label>
	</stream>
      <stream stream_id=" EiXGlc+4TruqqoDaNE76ag=="
		session_id="zzlafnvvjlCHllaHF6mn8kkSS==">
           <label>100</label>
      </stream>

The reason for this approach in XML is due to the metadata model constraints and the exact details are as follows:

1) Mapping of each individual label (SDP "m" line) to single stream by which participantstream's attributes will explain about the stream correctly. Say video label attribute is added in the stream element during mid-dialog whereas the session is established with audio label & stream, here video label association time is different from audio label association time.
 
2) Partial update for each stream independently provide more flexibility. (Add & Remove stream without impacting any other stream).

In case of multiple label exists within single stream as shown in your mail, 

1) It is impossible to deduce the association and disassociation time of the individual label or SDP "m" line 
2) It is possible to have the wrong information like indicate one of the stream in "recv" association whereas other stream is in "send" association (Hypothetical scenario).

So, stream XML element has to have single label attribute within itself. 

Thanks
Partha
   
>From: Hutton, Andrew [mailto:[email-masked]]
>Sent: Monday, May 28, 2012 7:46 PM
>I am assuming we have consensus to move to using "stream_id" rather than
>"id" as this is what the XML experts are telling us is correct.
>
>Mixed Stream Recording
>=======================
>
>For the mixed stream scenario in which streams from two CS's are mixed
>in to a single RS stream then the following seems to be what we have
>settled on.
>
>I am not sure I have it right for this case but I think assuming the
>change to use "stream_id" and "session_id" would result in the
>following:
>
>> is better to incorporate in (-07) metadata draft as these changes
>> helps for the progresses of the metadata draft. Please let me know
>> your opinion on the same.
>>
>> Thanks
>> Partha
>>
>> >stream id which is Used by two CS namely zzlafnvvjlCHllaHF6mn8kkSS==
>> >& zSfPoSvdSDCmU3A3TRDxAw==.
>> >
>> >Duplicate stream recording has to have separate streams to
>> >distinguish the actual & duplicate stream.
>> >
>> >
>> >Thanks
>> >Partha
>> >
>> >>>>>> If we have a persistent RS with a single m-line, and a single
>> >>>>>> CS being recorded via a mixed TX/RX stream, then the metadata
>> >>>>>> will have a single<stream>  element, which has a label
>> >>>>>> referencing a
>> RS
>> >>m-line.
>> >>
>> >>>>>> Mixed Stream Recording:
>> >>>>>>
>> >>>>>> If they are both being mixed onto the one RS m-line stream,
>> >>>>>> both <stream>  elements will have the same label, ie:
>> >>>>>>
>> >>> processing software (such as CSS), id has special syntax that
>> >>> takes advantage of that assumption.
>> >>
>> >>>>> From: [email-masked] [mailto:[email-masked]]
>> >>>>> On Behalf Of Paul Kyzivat
>> >>>>>> Sorry for the delay reply. In the object model, there is
>> >>>>>> unique-
>> id
>> >>>>>> so you are saying there is no need to allow multiple labels on
>> >>>>>> a stream element, as a stream elemet can be repeated in the
>> metadata
>> >>>>> multiple times.
>> >>>>>>
>> >>>>>> session=" zSfPoSvdSDCmU3A3TRDxAw=="> <label>99</label>
>> >>>>>> </stream> <stream id="EiXGlc+4TruqqoDaNE76ag=="
>> >>>>>> If we have a persistent RS with a single m-line, and a single
>> >>>>>> CS being recorded via a mixed TX/RX stream, then the metadata
>> >>>>>> will have a single<stream>  element, which has a label
>> >>>>>> referencing a
>> RS
>> >>m-line.
>> >>>>>>
>> >>>>>> If they are both being mixed onto the one RS m-line stream,
>> >>>>>> both <stream>  elements will have the same label, ie:
>> >>>>>>
>> >>>>>> If we have a persistent RS with a single m-line, and a single
>> >>>>>> CS being recorded via a mixed TX/RX stream, then the metadata
>> >>>>>> will have a single<stream>  element, which has a label
>> >>>>>> referencing a
>> RS
>> >>m-line.
>> >>>>>>
>> >>>>>> recording system resources, it may be preferable to mix
>> >>>>>> multiple concurrent calls (Communication Sessions) on different
>> >>>>>> handsets/ speakers on the same turret into a single recording
>session.
>> >>>>>>
>> >>>>>> RFC6341 does not specifically mention duplicated recording But
>> >>>>>> I don't think allowing it would complicate the metadata, and it
>> will
>> >>>>>> be down to the recorder
>> >>>>>>

---

From: "Hutton, Andrew" <[email-masked]>
Date: Tue, 29 May 2012 09:57:01 +0000

Hi Partha,

Before looking at your reasons in more detail I want to check we are on the same page.

The case I think we are discussing is recoding the same CS stream (m-line) in multiple m line streams of one RS. (i.e. a single CS stream is duplicated in to multiple RS streams). Is this also your understanding ?

Regards
Andy

> From: Ravindran, Parthasarathi [mailto:[email-masked]]
> Sent: 28 May 2012 18:15
> To: Hutton, Andrew; [email-masked]
> Cc: [email-masked]
> The reason for this approach in XML is due to the metadata model
> constraints and the exact details are as follows:
> 
> 1) Mapping of each individual label (SDP "m" line) to single stream by
> which participantstream's attributes will explain about the stream
> correctly. Say video label attribute is added in the stream element
> during mid-dialog whereas the session is established with audio label &
> stream, here video label association time is different from audio label
> association time.
> 
> 2) Partial update for each stream independently provide more
> flexibility. (Add & Remove stream without impacting any other stream).
> 
> 2) It is possible to have the wrong information like indicate one of
> the stream in "recv" association whereas other stream is in "send"
> association (Hypothetical scenario).
> 
> >I just want to make sure I understand the results of this discussion
> and
> >whether we have consensus.
> >
> >> >The trouble with multiple label in single stream is that the
> handling
> >> of
> >> >>From: [email-masked] [[email-masked]] On Behalf
> Of
> >> >>Paul Kyzivat [[email-masked]]
> >> >>Sent: 10 May 2012 21:02
> >> >>To: Joe Hildebrand
> >> >>Cc: [email-masked]
> >> >>>>>> attribute "id" and the association of the object is
> represented
> >> by
> >> >>second attribute .
> >> >>>>>>
> >> >>>>>> *Subject:* RE: [siprec] Proposal for minor changes to
> metadata
> >> to
> >> >>>>>> -------------------------------------------------------------
> --
> >> >>>>>> -
> >> --
> >> >-
> >> >>>>>> ---
> >> >>>>>> --
> >> >>>>>>
> >> >>>>>> *Subject:* RE: [siprec] Proposal for minor changes to
> metadata
> >> to
> >> >>>>>> "Siprec support for recording same CS stream in multiple m
> line
> >> >>>>>> streams of 1 RS:
> >> >>>>>> "How to specify in metadata that a participants stream is
> being
> >> >>>>>> recorded in multiple m line streams"
> >> >>>>>> indicating that the streams are recorded in the same
> recording
> >> >>>>>> m-line stream.
> >> >>>>>>
> >> >>>>>> Siprec support for recording same CS stream in multiple m
> line
> >> >>>>>> streams of 1 RS:
> >> >>>>>> This does not change the existing metadata usage of streams
> and
> >> >>>>>> labels, it just adds more flexibility.
> >> >>>>>> I can't see anything in draft-ietf-siprec-metadata-06 that
> says
> >> >>>>>> there is a 1:1 relationship anyway.
> >> >>>>>>
> >> >>>>>>
> >> >>>>>>
> >> >>>>>>
> >> >>>>>> Examples:
> >> >>>>>> Mixed Stream Recording:
> >> >>>>>> To me this implies multiple CS's in one mixed recorder
> stream,
> >> >>>>>> since the requirement specifically
> >> >>>>>>
> But

---

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Wed, 30 May 2012 10:48:49 +0000

Hi Andy,

I think that we are in the same page. Duplication of single CS stream into multiple RS stream is one of the usecase mentioned in the below mail. Multiple label in "stream" element does not indicate the duplication of the CS stream automatically. Apart from this, There is a need of explicit grouping mechanism to say that two stream are duplicate of each other. 

Thanks
Partha

>Sent: Tuesday, May 29, 2012 3:27 PM
>The case I think we are discussing is recoding the same CS stream (m-
>line) in multiple m line streams of one RS. (i.e. a single CS stream is
>duplicated in to multiple RS streams). Is this also your understanding ?
>
>
>Regards
>Andy
>
>
>> Subject: RE: [siprec] Proposal for minor changes to metadata to
>> during mid-dialog whereas the session is established with audio label
>> & stream, here video label association time is different from audio
>> label association time.
>>
>> >For the mixed stream scenario in which streams from two CS's are
>> >mixed in to a single RS stream then the following seems to be what we
>> >have settled on.
>> >
>> >> In case there is no objection to the below proposal with explicit
>> >> id instead of "id" usage till 23rd May (Next Wednesday), I think
>> >> that
>> it
>> >> >>>>>> <label>100</label> </stream>
>> >> >>>>>>
>> >> >>I am confused, what is the example you show supposed to
>> >> >>respresent
>> ?
>> >> >>
>> >> >>
>> >> >>To hark back to my original request, what is your objection to
>> >> >>the following, as it seems simpler to me than what you are
>suggesting:
>> >> >>
>> >> >>>>>> If we have a persistent RS with a single m-line, and a
>> >> >>>>>> single CS being recorded via a mixed TX/RX stream, then the
>> >> >>>>>> metadata will have a single<stream>  element, which has a
>> >> >>>>>> label referencing a
>> >> RS
>> >> >>m-line.
>> >> >>
>> >> >>>>>> Mixed Stream Recording:
>> >> >>>>>>
>> >> >>> id is supposed to be unique across the entire document.  In
>> >> >>> some processing software (such as CSS), id has special syntax
>> >> >>> that takes advantage of that assumption.
>> >> >>
>> >> >>>>> From: [email-masked]
>> >> >>>>> [mailto:[email-masked]] On Behalf Of Paul Kyzivat
>> >> >>>>>> representation, unique-id of the object is represented as
>> >> >>>>>> XML attribute "id" and the association of the object is
>> represented
>> >> by
>> >> >>second attribute .
>> >> >>>>>>
>> >> >>>>>> special meaning in XML and it should not be repeated. So,
>> >> >>>>>> I'm proposing to have object name with id for both
>> >> >>>>>> attributes and
>> >> XML
>> >> >>>>> looks as follows:
>> >> >>>>>>
>> >> >>>>>> be allowed in a stream element, the meaning would be that
>> >> >>>>>> the stream is recorded in all of the referenced recording
>> >> >>>>>> m-line
>> >> >>streams."
>> >> >>>>>>
>> >> >>>>>> Here, There are two CS's, 2 m'line and 1 RS. For
>> >> >>>>>> representing as per current XML schema is as follows,
>> >> >>>>>>
>> >> >>>>>> *Subject:* [siprec] Proposal for minor changes to metadata
>> >> >>>>>> to support mixed stream and duplicated stream recording.
>> >> >>>>>>
>> >> >>>>>>
>> >> >>>>>> be allowed in a stream element, the meaning would be that
>> >> >>>>>> the stream is recorded in all of the referenced recording
>> >> >>>>>> m-line
>> >> >>streams.
>> >> >>>>>>
>> >> >>>>>> If we have a persistent RS with a single m-line, and a
>> >> >>>>>> single CS being recorded via a mixed TX/RX stream, then the
>> >> >>>>>> metadata will have a single<stream>  element, which has a
>> >> >>>>>> label referencing a
>> >> RS
>> >> >>m-line.
>> >> >>>>>>
>> >> >>>>>> If we have a persistent RS with a single m-line, and a
>> >> >>>>>> single CS being recorded via a mixed TX/RX stream, then the
>> >> >>>>>> metadata will have a single<stream>  element, which has a
>> >> >>>>>> label referencing a
>> >> RS
>> >> >>m-line.
>> >> >>>>>>
>> >> >>>>>> In some cases, more than one concurrent Communication
>> >> >>>>>> Session
>> >> (on
>> >> >a
>> >> >>>>>> REQ-009: The mechanism MUST support the ability for an SRC
>> >> >>>>>> to deliver mixed audio streams from different parties of a
>> >> >>>>>> given Communication Session to an SRS.
>> >> >>>>>>
>> >> >>>>>>

---

From: "Hutton, Andrew" <[email-masked]>
Date: Wed, 30 May 2012 12:07:07 +0000

Hi Partha,

Ok so why in your example do the two streams contain different stream_id's if they both are referring to the same stream within the CS?

Regards
Andy

> Sent: 30 May 2012 11:49
> I think that we are in the same page. Duplication of single CS stream
> into multiple RS stream is one of the usecase mentioned in the below
> mail. Multiple label in "stream" element does not indicate the
> duplication of the CS stream automatically. Apart from this, There is a
> need of explicit grouping mechanism to say that two stream are
> duplicate of each other.
> 
> Thanks
> Partha
> 
> >Before looking at your reasons in more detail I want to check we are
> on
> >the same page.
> >
> >> In case of multiple label exists within single stream as shown in
> your
> >> mail,
> >>
> >> 1) It is impossible to deduce the association and disassociation
> time
> >> of the individual label or SDP "m" line
> On
> >> >> >My example is to show how to represent single stream in two CS
> and
> >> it
> >> >> is
> >> >> >as follows:
> >> >> >
> >> >> >>OK, I'll take your word for it, since it sounds like otherwise
> it
> >> >> would
> >> >> >>>> XML:id attribute is mentioned in http://www.w3.org/TR/xml-
> id/
> >> and
> >> >> >>>>> Subject: Re: [siprec] Proposal for minor changes to
> metadata
> >> to
> >> >> >>>>> I'd be interested to hear more about why "id" is *special*
> in
> >> >> XML.
> >> >> >>>>>
> >> >> >>>>> Thanks,
> >> >> >>>>> Paul
> >> >> >>>>>
> >> >> >>>>>> While I discussing with XML experts, I understand that
> "id"
> >> has
> >> >> >>>>>> so you are saying there is no need to allow multiple
> labels
> >> on
> >> >> >>>>>> I dont see how this matches the object model, a element
> with
> >> a
> |
> >> >> >Tel:+44
> >> >> >>>>>> ----------------------------------------------------------
> --
> >> >> >>>>>> -
> >> --
> >> >> >>>>>> -
> >> >> --
> >> >> >-
> >> >> >>>>>> ---
> >> >> >>>>>> --
> >> >> >>>>>>
> >> >> >>>>>> that multiple CS's are being recorded in a single mixed RS
> m
> >> >> line
> >> >> >>>>>> stream"
> >> >> >>>>>> maxoccurs="1" restriction would need to be removed 2.
> there
> >> >> would
> >> >> >>>>>> RFC6341 refers to mixed recording in use cases 3 and 11
> and
> >> in
> >> >> REQ
> >> >> >>9::
> >> >> >>>>>>
> >> >> >>>>>> In Use Case 3:
> >> >> >>>>>> In trading-floor environments, in order to minimize
> storage
> >> and
> >> >> >>>>>> I don't think allowing it would complicate the metadata,
> and
> >> it
> >> >> will
> >> >> >>>>>> be down to the recorder
> >> >> >>>>>>