Subject: [siprec] Does siprec support recording of MSRP sessions?

From: Michael Smith <[email-masked]>
Date: Fri, 19 Apr 2013 21:32:22 +0000

NENA is planning an interoperability testing event in the fall that will include testing of siprec recording. We may have MSRP sessions that we want to record. Is there any reason we couldn't use the siprec protocol to record these? If so, what would the issue(s) be?

Michael Smith
NENA ICE 8 Planning Committee chair

---

From: "Parthasarathi R" <[email-masked]>
Date: Mon, 22 Apr 2013 00:09:29 +0530

Michael,

SIP recording mechanism works for any media type as long as media is
negotiated between SRC & SRS. As MSRP is negotiated using SDP offer/answer,
the SIPREC framework supports. The separate metadata Stream element will be
created for MSRP "m" line.  

MSRP communication occurs between SRC and SRS which has all the information
about CS MSRP communication. I'm not very sure about MSRP message side
effects if any. There is a need of more discussion like whether SRC shall
act like MSRP relay.

Thanks

Partha 

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Michael Smith
Sent: Saturday, April 20, 2013 3:02 AM
To: [email-masked]
Subject: [siprec] Does siprec support recording of MSRP sessions?

NENA is planning an interoperability testing event in the fall that will
include testing of siprec recording. We may have MSRP sessions that we want
to record. Is there any reason we couldn't use the siprec protocol to record
these? If so, what would the issue(s) be?

Michael Smith

---

From: "Hutton, Andrew" <[email-masked]>
Date: Mon, 22 Apr 2013 08:57:46 +0000

Hi,

Although I can see that it might not be hard to add MSRP to SIPREC the current SIPREC work relates only to RTP based media as stated in the requirements http://tools.ietf.org/html/rfc6341.

There has been so far no real discussion on how MSRP recording would work within the contact of SIPREC so I agree that more discussion would be needed as to whether MSRP is within scope of the current SIPREC work and if so on the technical details and how to document a solution.

Regards
Andy

From: [email-masked] [mailto:[email-masked]] On Behalf Of Parthasarathi R
Sent: 21 April 2013 19:39
To: 'Michael Smith'; [email-masked]
Subject: Re: [siprec] Does siprec support recording of MSRP sessions?

Michael,

SIP recording mechanism works for any media type as long as media is negotiated between SRC & SRS. As MSRP is negotiated using SDP offer/answer, the SIPREC framework supports. The separate metadata Stream element will be created for MSRP "m" line.

MSRP communication occurs between SRC and SRS which has all the information about CS MSRP communication. I'm not very sure about MSRP message side effects if any. There is a need of more discussion like whether SRC shall act like MSRP relay.

Thanks
Partha

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Michael Smith
Sent: Saturday, April 20, 2013 3:02 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [siprec] Does siprec support recording of MSRP sessions?

Michael Smith

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 22 Apr 2013 10:50:00 -0400

Andrew beat me to it - I was about to say the same:
By analogy it is pretty easy to see how to handle msrp with siprec, but 
the existing specs don't really include it in scope. Were we to start 
trying to formally extend siprec to include that, issues would likely 
arise where there are alternative ways of handling things so that some 
decisions and clarifications would be required to ensure interoperable 
implementations.

I think it would be reasonable for implementations to experiment with 
this. Just understand that such experimentation is proprietary until we 
actually do the work to incorporate it.

	Thanks,
	Paul

On 4/22/13 4:57 AM, Hutton, Andrew wrote:
> Hi,
>
> Although I can see that it might not be hard to add MSRP to SIPREC the
> current SIPREC work relates only to RTP based media as stated in the
> requirements http://tools.ietf.org/html/rfc6341.
>
> There has been so far no real discussion on how MSRP recording would
> work within the contact of SIPREC so I agree that more discussion would
> be needed as to whether MSRP is within scope of the current SIPREC work
> and if so on the technical details and how to document a solution.
>
> Regards
>
> Andy
>
> *From:[email-masked] [mailto:[email-masked]] *On
> Behalf Of *Parthasarathi R
> *Sent:* 21 April 2013 19:39
> *To:* 'Michael Smith'; [email-masked]
> *Subject:* Re: [siprec] Does siprec support recording of MSRP sessions?
>
> Michael,
>
> negotiated between SRC & SRS. As MSRP is negotiated using SDP
> offer/answer, the SIPREC framework supports. The separate metadata
> Stream element will be created for MSRP “m” line.
>
> MSRP communication occurs between SRC and SRS which has all the
> information about CS MSRP communication. I’m not very sure about MSRP
> message side effects if any. There is a need of more discussion like
> whether SRC shall act like MSRP relay.
>
> Thanks
>
> Partha
>
> *From:[email-masked] <mailto:[email-masked]>
> [mailto:[email-masked]] *On Behalf Of *Michael Smith
> *Sent:* Saturday, April 20, 2013 3:02 AM
> *To:* [email-masked] <mailto:[email-masked]>
> *Subject:* [siprec] Does siprec support recording of MSRP sessions?
>
> include testing of siprec recording. We may have MSRP sessions that we
> want to record. Is there any reason we couldn’t use the siprec protocol
> to record these? If so, what would the issue(s) be?
>
> Michael Smith
>
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>

---

From: Henry Lum <[email-masked]>
Date: Tue, 23 Apr 2013 14:54:50 +0000

I was going to say the same thing too. When RFC6341 was drafted this was purposely left out of scope so that we can focus on RTP media at this point. It looks like there needs to be an additional draft on top of the protocol draft to explain additional details for handling MSRP.

Similar to MSRP, there is MRCPv2 and mediactrl that negotiates a separate channel using SDP. The difference is that they are control channels, and I wonder whether SIPREC can apply to control channels.

Regards,
Henry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: April-22-13 10:50 AM
To: [email-masked]
Subject: Re: [siprec] Does siprec support recording of MSRP sessions?

	Thanks,
	Paul

On 4/22/13 4:57 AM, Hutton, Andrew wrote:
> Stream element will be created for MSRP "m" line.
>
> information about CS MSRP communication. I'm not very sure about MSRP
> want to record. Is there any reason we couldn't use the siprec protocol