Subject: [siprec] Proposal for follow-on siprec work

From: Paul Kyzivat <[email-masked]>
Date: Thu, 16 May 2013 15:55:46 -0400

siprec'ers:

I hope I'm not getting ahead of myself, but I *think* we are almost done 
with the current round of siprec work. While we need to finish it, I 
also think we need to be thinking about "what next".

Michael Yan and I have just posted a new draft proposing some new siprec 
functionality that we would like to see. We are looking to assess the 
interest in this.

The draft is intentionally somewhat vague, reflecting its preliminary 
status. We want to refine it based on interest from the community. I can 
imagine refining it in two ways:

- deepening it with more detail about the functionality mentioned
- broadening it with additional functionality that others feel is
   currently lacking from siprec.

I'm posting this message to siprec, where I know there is a built-in 
community of interest. But IIUC the actual process for adopting new work 
of this sort will be to go back through dispatch. So I'll probably also 
be posting a similar message to the dispatch mailing list.

Please, we want to hear from you!

	Thanks,
	Paul

-------- Original Message --------
Subject: New Version Notification for 
draft-kyzivat-siprec-webconf-use-case-00.txt
Date: Thu, 16 May 2013 12:41:28 -0700
From: [email-masked]
To: Paul H. Kyzivat <[email-masked]>,        Michael Yan 
<[email-masked]>,        Paul Kyzivat <[email-masked]>

A new version of I-D, draft-kyzivat-siprec-webconf-use-case-00.txt
has been successfully submitted by Paul H. Kyzivat and posted to the
IETF repository.

Filename:	 draft-kyzivat-siprec-webconf-use-case
Revision:	 00
Title:		 Web Conference Recording Use Case
Creation date:	 2013-05-16
Group:		 Individual Submission
Number of pages: 6
URL: 
http://www.ietf.org/internet-drafts/draft-kyzivat-siprec-webconf-use-case-00.txt
Status: 
http://datatracker.ietf.org/doc/draft-kyzivat-siprec-webconf-use-case
Htmlized: 
http://tools.ietf.org/html/draft-kyzivat-siprec-webconf-use-case-00

Abstract:
    The current work of SIPREC will soon finish.  As its charter defined,
    SIPREC has covered industries like financial trading floors, contact
    center and emergency service bureaus.  But when talking about
    products or solutions like data or web conferencing, SIPREC is
    insufficient to record all aspects of calls with different
    interactive media channels.  This draft tries to show a use case for
    web conference recording and show how it can work well under SIPREC
    mechanism.

The IETF Secretariat

---

From: Guy Churchouse <[email-masked]>
Date: Thu, 16 May 2013 13:25:20 -0700

I very much support continuing with web conferencing recording as
outlined.

Guy

Guy Churchouse, ENP, SSCA (SIP Certified)
Book of the Month: Surfaces and Essences: Analogy as the Fuel and Fire of
Thinking By: Douglas Hofstadter & Emmanuel Sander
Executive Vice President
REVCORD Revolutionizing Voice Recording
10575 Katy Freeway, Suite 470
Houston, Texas  77024
281-404-7040  Main
281-404-5323  Fax
866-559-2188  Toll
Mobile 714-316-4952
gchurchouse.revcord Skype

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Paul Kyzivat
Sent: Thursday, May 16, 2013 12:56 PM
To: [email-masked]
Subject: [siprec] Proposal for follow-on siprec work

siprec'ers:

I hope I'm not getting ahead of myself, but I *think* we are almost done
with the current round of siprec work. While we need to finish it, I also
think we need to be thinking about "what next".

I'm posting this message to siprec, where I know there is a built-in
community of interest. But IIUC the actual process for adopting new work
of this sort will be to go back through dispatch. So I'll probably also be
posting a similar message to the dispatch mailing list.

	Thanks,
	Paul

-------- Original Message --------

http://www.ietf.org/internet-drafts/draft-kyzivat-siprec-webconf-use-case-
00.txt

Abstract:

The IETF Secretariat

_______________________________________________
siprec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/siprec

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 16 May 2013 16:45:50 -0400

> I very much support continuing with web conferencing recording as

Thanks Guy!

We would appreciate any suggestions you have toward refining what we 
have written.

	Thanks,
	Paul

---

From: Brian Rosen <[email-masked]>
Date: Thu, 16 May 2013 16:51:39 -0400

In addition to this work, we need to extend for recording MSRP.  I'll probably contribute to a draft on that.

Brian

On May 16, 2013, at 4:45 PM, Paul Kyzivat <[email-masked]> wrote:

> We would appreciate any suggestions you have toward refining what we have written.
> 
> 	Thanks,
> 	Paul
> 
>> Guy
>>

---

From: Michael Smith <[email-masked]>
Date: Thu, 16 May 2013 20:58:39 +0000

+1 on recording MSRP - and support for associated metadata.

Michael Smith
Chief Technologist
Ph: 606.877.2788 | Mobile: 606.231.0243 

DSS Corporation / Equature
18311   W. Ten Mile Road, Suite 200
Southfield, MI - 48075
Tel: 1-888.305.3428
Fax: 1-248.569.6567
www.dss-corp.com
www.dispatchimprovement.com

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Brian Rosen
Sent: Thursday, May 16, 2013 4:52 PM
To: Paul Kyzivat
Cc: [email-masked]
Subject: Re: [siprec] Proposal for follow-on siprec work

Brian

On May 16, 2013, at 4:45 PM, Paul Kyzivat <[email-masked]> wrote:

>> Guy Churchouse, ENP, SSCA (SIP Certified) Book of the Month: Surfaces 
>> and Essences: Analogy as the Fuel and Fire of Thinking By: Douglas 
>> Hofstadter & Emmanuel Sander Executive Vice President REVCORD 
>> Revolutionizing Voice Recording
>> From: [email-masked] [mailto:[email-masked]] On 
>> Behalf Of Paul Kyzivat
>> I hope I'm not getting ahead of myself, but I *think* we are almost 
>> done with the current round of siprec work. While we need to finish 
>> it, I also think we need to be thinking about "what next".
>> 
>> Michael Yan and I have just posted a new draft proposing some new 
>> siprec functionality that we would like to see. We are looking to 
>> assess the interest in this.
>> 
>> status. We want to refine it based on interest from the community. I 
>> can imagine refining it in two ways:
>> 
>> community of interest. But IIUC the actual process for adopting new 
>> work of this sort will be to go back through dispatch. So I'll 
>> probably also be posting a similar message to the dispatch mailing list.
>>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 16 May 2013 16:59:45 -0400

> In addition to this work, we need to extend for recording MSRP.  I'll probably contribute to a draft on that.

This is one of the things included!

	Thanks,
	Paul

---

From: "Dave Higton" <[email-masked]>
Date: Fri, 17 May 2013 10:38:09 +0100

Excellent news, because it's +1 from NICE too.

Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: 16 May 2013 22:00
To: Brian Rosen
Cc: [email-masked]
Subject: Re: [siprec] Proposal for follow-on siprec work

	Thanks,
	Paul

NICE Systems UK Limited ("NICE") is registered in England under company number, 3403044. The registered office of NICE is at Tollbar Way, Hedge End, Southampton, Hampshire SO30 2ZP.

Confidentiality: This communication and any attachments are intended for the above-named persons only and may be confidential and/or legally privileged. Any opinions expressed in this communication are not necessarily those of NICE. If this communication has come to you in error you must take no action based on it, nor must you copy or show it to anyone; please delete/destroy and inform the sender by e-mail immediately.

Monitoring: NICE may monitor incoming and outgoing e-mails.

Viruses: Although we have taken steps toward ensuring that this e-mail and attachments are free from any virus, we advise that in keeping with good computing practice the recipient should ensure they are actually virus free.

---

From: "Parthasarathi R" <[email-masked]>
Date: Fri, 17 May 2013 21:10:10 +0530

Nice to hear that MSRP is added. I'll happy to review MSRP recording.

> Sent: Friday, May 17, 2013 2:30 AM
> To: Brian Rosen
> Cc: [email-masked]
> Behalf
> done
> siprec
> work

---

From: Henry Lum <[email-masked]>
Date: Fri, 17 May 2013 21:00:50 +0000

I support MSRP work as well.

I also want to see if there is interest in recording VoiceXML dialogs. I have a few suggestions that I can write up for providing standard metadata and mechanisms in VoiceXML.

Regards,
Henry