Subject: [siprec] Privacy Considerations in Metadata draft.

From: "Hutton, Andrew" <[email-masked]>
Date: Thu, 9 Jan 2014 15:01:32 +0000

Hi All,

During the IESG review of the siprec-architecture draft Stephen Farrell raised the following issue

"I do have a privacy related question though.  3.3.1 here only points at I-D.ietf-siprec-metadata which specifies all of the various things the can be metadata but doesn't seem to say which ought or ought not be recorded.  And neither does this document. I assume there's an implicit requirement to only record metadata that's needed, but where is/should that be stated?"

I don't think we have even discussed this issue but we should add a statement in the metadata draft that the SRS must only record the metadata it needs to satisfy the application requirements and nothing more.

Any objections/comments?

Regards
Andy (SIPREC Co-Chair).

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Thu, 9 Jan 2014 16:16:51 +0000

Hi Andy,

 Mary Barnes raising a similar concern in the past  - http://www.ietf.org/mail-archive/web/siprec/current/msg03769.html
We would definitely need some text that recommends on what SRC/SRS is expected to do w.r.t sensitive information in metadata.

Do you or others in the WG has any inputs on what text we can add ?

Regards,
Ram

From:  <Hutton>, Andrew <[email-masked]<mailto:[email-masked]>>
Date:  Thursday, 9 January 2014 8:31 PM
To:  "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject:  [siprec] Privacy Considerations in Metadata draft.

Hi All,
During the IESG review of the siprec-architecture draft Stephen Farrell raised the following issue
“I do have a privacy related question though.  3.3.1 here only points at I-D.ietf-siprec-metadata which specifies all of the various things the can be metadata but doesn't seem to say which
ought or ought not be recorded.  And neither does this document. I assume there's an implicit requirement to only record metadata that's needed, but where is/should that be stated?”
I don’t think we have even discussed this issue but we should add a statement in the metadata draft that the SRS must only record the metadata it needs to satisfy the application requirements and nothing more.
Any objections/comments?
Regards
Andy (SIPREC Co-Chair).

---

From: "Dave Higton" <[email-masked]>
Date: Thu, 9 Jan 2014 16:20:45 +0000

What sort of things do other RFCs say about privacy?

I'm not sure that the SIPREC RFC should say what has been suggested - but I do think it should flag recording of metadata as a possible privacy concern.

Dave

From: siprec [mailto:[email-masked]] On Behalf Of Ram Mohan R (rmohanr)
Sent: 09 January 2014 16:17
To: Hutton, Andrew; [email-masked]
Subject: Re: [siprec] Privacy Considerations in Metadata draft.

Hi Andy,

Regards,
Ram

Hi All,
During the IESG review of the siprec-architecture draft Stephen Farrell raised the following issue
"I do have a privacy related question though.  3.3.1 here only points at I-D.ietf-siprec-metadata which specifies all of the various things the can be metadata but doesn't seem to say which
ought or ought not be recorded.  And neither does this document. I assume there's an implicit requirement to only record metadata that's needed, but where is/should that be stated?"
I don't think we have even discussed this issue but we should add a statement in the metadata draft that the SRS must only record the metadata it needs to satisfy the application requirements and nothing more.
Any objections/comments?
Regards
Andy (SIPREC Co-Chair).

NICE Systems UK Limited ("NICE") is registered in England under company number, 3403044. The registered office of NICE is at Tollbar Way, Hedge End, Southampton, Hampshire SO30 2ZP.

Confidentiality: This communication and any attachments are intended for the above-named persons only and may be confidential and/or legally privileged. Any opinions expressed in this communication are not necessarily those of NICE. If this communication has come to you in error you must take no action based on it, nor must you copy or show it to anyone; please delete/destroy and inform the sender by e-mail immediately.

Monitoring: NICE may monitor incoming and outgoing e-mails.

Viruses: Although we have taken steps toward ensuring that this e-mail and attachments are free from any virus, we advise that in keeping with good computing practice the recipient should ensure they are actually virus free.

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 09 Jan 2014 13:09:58 -0500

This seems a little strange. Superficially it seems harmless to add such 
a statement, but it also seems nearly useless.

If this is an important concern, then I would think the SRC and SRS 
would want to negotiate what is required, and then the SRC only send 
that much. (But that would add a lot of complexity to the protocol.)

It seems more likely that the SRC will decide what it is *willing* to 
divulge.

	Thanks,
	Paul

On 1/9/14 10:01 AM, Hutton, Andrew wrote:
> “I do have a privacy related question though.  3.3.1 here only points at
> I-D.ietf-siprec-metadata which specifies all of the various things the
> can be metadata but doesn't seem to say which ought or ought not be
> recorded.  And neither does this document. I assume there's an implicit
> requirement to only record metadata that's needed, but where is/should
> that be stated?”
> I don’t think we have even discussed this issue but we should add a
> statement in the metadata draft that the SRS must only record the
> metadata it needs to satisfy the application requirements and nothing more.
> Any objections/comments?
> Regards
> Andy (SIPREC Co-Chair).
>
>
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>

---

From: Brian Rosen <[email-masked]>
Date: Thu, 9 Jan 2014 13:18:30 -0500

Suggested text:

This document describes an extensive set of metadata that may be recorded by the SRS.  Most of the metadata could be considered private data.  SRCs may send metadata that is not appropriate for the SRS to record.  What of this metadata is actually recorded by the SRS must be carefully considered (a “retention policy”) to balance privacy concerns with usability.  Implementations MUST control what metadata is recorded, and MUST NOT save metadata sent by the SRC that does not conform to the retention policy of the SRS.

Brian

On Jan 9, 2014, at 11:20 AM, Dave Higton <[email-masked]> wrote:

> From:  <Hutton>, Andrew <[email-masked]>
> To:  "[email-masked]" <[email-masked]>

---

From: "Yanqiang (Michael)" <[email-masked]>
Date: Fri, 10 Jan 2014 01:55:33 +0000

+1 to Brian.
BTW there could be SRC to control the metadata as well. For example: Implementations (of SRC) MUST control what metadata will be sent to SRS, especially for those private data.
SRC could provide the *configuration* feature to choose what kind of metadata would be sent (basic control data or include other metadata).

Michael

From: siprec [mailto:[email-masked]] On Behalf Of Brian Rosen
Sent: Friday, January 10, 2014 2:19 AM
To: Dave Higton
Cc: [email-masked]
Subject: Re: [siprec] Privacy Considerations in Metadata draft.

Suggested text:

Brian

On Jan 9, 2014, at 11:20 AM, Dave Higton <[email-masked]<mailto:[email-masked]>> wrote:

Dave

From: siprec [mailto:[email-masked]] On Behalf Of Ram Mohan R (rmohanr)
Sent: 09 January 2014 16:17
To: Hutton, Andrew; [email-masked]<mailto:[email-masked]>
Subject: Re: [siprec] Privacy Considerations in Metadata draft.

Hi Andy,

Regards,
Ram

Hi All,

[email-masked]<mailto:[email-masked]>

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Fri, 10 Jan 2014 02:53:51 +0000

Hi Paul,

Inline

Ram

-----Original Message-----
From: Paul Kyzivat <[email-masked]>
Date: Thursday, 9 January 2014 11:39 PM
To: "[email-masked]" <[email-masked]>
Subject: Re: [siprec] Privacy Considerations in Metadata draft.

>a statement, but it also seems nearly useless.

I do see that several other RFCs which have XML in SIP have some kind of
recommendation. For example if you look at RFC4235 which as well exposes a
lot of UA capabilities in XML there is text in
http://tools.ietf.org/search/rfc4235#section-7 that talks about
considerations. Perhaps we need some thing similar for metadata and not
just a superficial text.

>It seems more likely that the SRC will decide what it is *willing* to

Yes I agree with you, SRC would most likely (based on its policy) will
decide on what to send.

Ram

>> ³I do have a privacy related question though.  3.3.1 here only points at
>> that be stated?²
>> I don¹t think we have even discussed this issue but we should add a

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Mon, 20 Jan 2014 11:16:35 +0000

The below text looks good to me. I also suggest we add a note that SRC MAY also have a policy based on which it may choose not to send parts of metadata.

Regards,
Ram

From: Brian Rosen <[email-masked]<mailto:[email-masked]>>
Date: Thursday, 9 January 2014 11:48 PM
To: Dave Higton <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [siprec] Privacy Considerations in Metadata draft.

Suggested text:

Brian

Dave

Hi Andy,

Regards,
Ram

Hi All,