Subject: Re: [siprec] SIPREC and ICE use case

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Wed, 12 Nov 2014 13:41:35 +0000

Hi Yaron,

SIPREC should work with ICE (in SDP offer/answer between SRC and SRS) and
ICE procedures. From what I see we don¹t have any thing specific to be
standardised for it. What are looking for ?
If its just about adding some examples perhaps it can be added to call
flow draft.

Ram
>
>
>From:  Yaron Pdut <[email-masked]>
>Date:  Wednesday, 12 November 2014 5:59 pm
>To:  "[email-masked]" <[email-masked]>
>Subject:  [siprec] SIPREC and ICE use case
>
>
>Guys,
> 
>There are case where there is a need for NAT traversal between SRS and
>SRC.
>Do you think using ICE with SIPREC in this case, is something that can be
>documented in current document set, or is it worth a separate informative
>draft?
> 
>YARON PDUT 
>Enterprise Architect\Multi Channel Recording
>
>
>
> 
>

---

From: Yaron Pdut <[email-masked]>
Date: Wed, 12 Nov 2014 15:48:36 +0200

I agree with you that there is nothing new it. 
Maybe as a call flow example for cloud-to-cloud integration or for WebRTC integration (using SIPREC over WebSockets I guess). 

The context that raise it, and maybe this is something worth thinking in WG, is recording of WebRTC client that would like to initiate a recording.
An example for it might be a trader working from home with desktop software that do support WebRTC (like "soft turret" using WebRTC).

-----Original Message-----
From: Ram Mohan R (rmohanr) [mailto:[email-masked]] 
Sent: יום ד, 12 נובמבר 2014 15:42
To: Yaron Pdut; [email-masked]
Subject: Re: [siprec] SIPREC and ICE use case

Hi Yaron,

SIPREC should work with ICE (in SDP offer/answer between SRC and SRS) and ICE procedures. From what I see we don¹t have any thing specific to be standardised for it. What are looking for ?
If its just about adding some examples perhaps it can be added to call flow draft.

Ram
>Do you think using ICE with SIPREC in this case, is something that can 
>be documented in current document set, or is it worth a separate 
>informative draft?
> 
>YARON PDUT

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Wed, 12 Nov 2014 13:56:41 +0000

inline

-----Original Message-----
From: Yaron Pdut <[email-masked]>
Date: Wednesday, 12 November 2014 7:18 pm
To: Cisco Employee <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [siprec] SIPREC and ICE use case

>Maybe as a call flow example for cloud-to-cloud integration or for WebRTC
>integration (using SIPREC over WebSockets I guess).
>
>The context that raise it, and maybe this is something worth thinking in
>WG, is recording of WebRTC client that would like to initiate a recording.
>An example for it might be a trader working from home with desktop
>software that do support WebRTC (like "soft turret" using WebRTC).

Sure. If you are interested in contributing with the call flows feel free
to do so and it can be added to SIPREC callfow document once the WG
reviews the flow.

Regards,
Ram