Subject: [siprec] WGLC for draft-ietf-siprec-callflows-06

From: "Hutton, Andrew" <[email-masked]>
Date: Tue, 17 May 2016 11:15:33 +0000

This message starts a working group last call (WGLC) for https://tools.ietf.org/html/draft-ietf-siprec-callflows-06. 

Please review the draft in detail and send comments to the SIPREC mailing list.
 
The WGLC will last 3 weeks and will therefore end on the 7th of June 2016.

The SIPREC metadata and protocols draft are very close to done so now is a good time to review the call flows again.
 
Regards
Andy and Brian (SIPREC Co-Chairs).

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Mon, 30 May 2016 12:58:53 +0000

(Including the mailing list)

Hi Dimitry,

Thanks for your feedback.  This is a very good review and I see you are
able to find errors which is not easy to spot.
I will go ahead and fix them and send the diffs soon.

Regards,
Ram

-----Original Message-----
From: Dmitry Andreyev <[email-masked]>
Date: Monday, 30 May 2016 at 4:37 PM
To: Cisco Employee <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Uri Frieder
<[email-masked]>, Yaron Pdut <[email-masked]>
Subject: RE: FW: [siprec] WGLC for draft-ietf-siprec-callflows-06

>Hi Ram,
>
>I have reviewed the draft and below are my comments
>
>
>Opening and closing XML tags do not match
>
>Page 12, 25 
>
>         <participantsessionassoc
>            participant_id="Atnm1ZRnOC6Pm5MApkrDzQ=="
>            session_id="hVpd7YQgRW2nD22h7q60JQ==">
>            <associate-time>2013-12-16T23:41:07Z</associate-time>
>         </participantsession>
>
>
>Page 14, 18, 28
>
>            <disasociate-time>2010-12-16T23:41:07Z</disassociate-time>
>
>Page 30
>
><sipSession>33c77aac7deb414cbc8c10f363fccb71
>            ;remote=a358d2b81a444a8c8fb05950cef331e7</sipSessionID>
>
>
>XML schema issues
>
>Page 10  ³send² should be before ³recv²
>
>            <participantstreamassoc
>             participant_id="srfBElmCRp2QB23b7Mpk0w==">
>             <recv>8zc6e0lYTlWIINA6GR+3ag==</recv>
>             <recv>EiXGlc+4TruqqoDaNE76ag==</recv>
>             <send>i1Pz3to5hGk8fuXl+PbwCw==</send>
>             <send>UAAMm5GRQKSCMVvLyl4rFw==</send>
>            </participantstreamassoc>
>
>
>Page 13  ³nameIDaor² must be ³nameID aor²
>
>         <participant
>            participant_id="Atnm1ZRnOC6Pm5MApkrDzQ==">
>            <nameIDaor="sip:[email-masked]">
>             <name xml:lang="it">Carol</name>
>           </nameID>
>         </participant>
>
>
>Page 14, 18, 28  wrong case in element value. Must be ³partial²
>
>             <datamode>Partial</datamode>
>
>
>Page 17, 19, 29  wrong order of elements ³sipSessionID² must be before
>³start-time²
>
>          <session session_id="bfLZ+NTFEeCNxQTuRyQBmw==">
>            <start-time>2010-12-16T23:41:07Z</start-time>
>            <sipSessionID>3363127f0d084c10876dddd4f8e5eeb9
>            ;remote=2272bb7e70fe41dba0025ae9a26d54cf</sipSessionID>
>          </session>
>
>Page 19 - wrong order of elements ³participantsessionassoc² must be
>first, then ³participantstreamassoc²
>
>          <participantstreamassoc
>             participant_id="srfBElmCRp2QB23b7Mpk0w==">
>             <send>i1Pz3to5hGk8fuXl+PbwCw==</send>
>             <recv>i1Pz3to5hGk8fuXl+PbwCw==</recv>
>          </participantstreamassoc>
>          <participantsessionassoc
>              participant_id="zSfPoSvdSDCmU3A3TRDxAw=="
>                   session_id="hVpd7YQgRW2nD22h7q60JQ==">
>             <associate-time>2010-12-16T23:41:07Z</associate-time>
>          </participantsessionassoc>
>
>
>Page 29  "zzlafnvvjlCHllaHF6mn8kkSS==" is not a valid Base64 string
>
>         <session session_id="zzlafnvvjlCHllaHF6mn8kkSS==">
>
>Page 29  wrong order, ³sipSessionID² must be before ³group-ref²
>
>             <group-ref>7+OTCyoxTmqmqyA/1weDAg==</group-ref>
>            <start-time>2010-12-16T23:41:07Z</start-time>
>             <sipSessionID>fa3b60f27e91441e84c55a9a0095f075
>             ;remote=a358d2b81a444a8c8fb05950cef331e7</sipSessionID>
>
>
>MIME headers issues
>
>Page 5, 19, 22, 23, 26  there must be a blank line between
>³Content-Disposition² MIME header and the XML text.
>
>Content-Type: application/rs-metadata
>Content-Disposition: recording-session
><?xml version="1.0" encoding="UTF-8"?>
>
>
>Hope this helps,
>
>Dmitry Andreyev
>System Architect 
>R&D Recording & Platform Apps Group
>NICE Systems Israel
> 
>(T) +972-9-775-3032
>[email-masked]
>www.nice.com
>
>
>
>-----Original Message-----
>From: siprec <[email-masked]> on behalf of "Hutton, Andrew"
><[email-masked]>
>Date: Tuesday, 17 May 2016 at 4:45 PM
>To: "[email-masked]" <[email-masked]>
>Subject: [siprec] WGLC for draft-ietf-siprec-callflows-06
>
>>This message starts a working group last call (WGLC) for
>>https://tools.ietf.org/html/draft-ietf-siprec-callflows-06.
>>
>>The SIPREC metadata and protocols draft are very close to done so now
>>is a good time to review the call flows again.
>>
>>Regards
>>_______________________________________________
>>siprec mailing list
>>[email-masked]
>>https://www.ietf.org/mailman/listinfo/siprec
>