Subject: [Slim] Wording about selection in draft-ietf-slim-negotiating-human-language-01

From: Gunnar Hellström <[email-masked]>
Date: Fri, 8 Apr 2016 10:34:15 +0200

There is a wording in draft-ietf-slim-negotiating-human-language-01.txt 
that needs slight adjustment,
and also can shed some light on the discussed wording around 'lang' in 
RFC 4566.
I made a comment on this in a mail about change proposals yesterday but 
bring it up here for discussion.

It is this section in 6.2

" There are two attributes, one ending in "-send" and the
    other in "-recv" to indicate the language used when sending and
    receiving media:

       a=humintlang-send:<language tag>
       a=humintlang-recv:<language tag>

    Each can appear multiple times in an offer for a media stream.

    In an offer, the 'humintlang-send' values constitute a list in
    preference order (first is most preferred) of the languages the
    offerer wishes to send using the media, and the 'humintlang-recv'
    values constitute a list in preference order of the languages the
    offerer wishes to receive using the media.
"

The wish to use simple language has caused some uncertainty that requires studying of the language in the whole section to find out the real meaning. It is likely that the same kind of desire to use simple wording caused the wording around the 'lang' attribute in RFC4566 to be possible to interpret in different ways.

1. On line 2 it says "to indicate the language used" when it in some cases can be a list, of which at least one in each direction will be used.

I suggest to change to "each indicating a language possible to use"

2. The expression later: "the languages the offerer wishes to send" reads as if the offeror has a preference to send in multiple languages, while we really mean an offered selection.

Change from:
"In an offer, the 'humintlang-send' values constitute a list in
    preference order (first is most preferred) of the languages the
    offerer wishes to send using the media, and the 'humintlang-recv'
    values constitute a list in preference order of the languages the
    offerer wishes to receive using the media."

To:
    "In an offer the 'humintlang-send' values constitute a list in preference order (first is most preferred) of the languages the party is capable to select from for sending using the media, and the 'humintlang-recv' values constitute a list in preference order of the languages in which the party is capable of receiving contents using the media."

Note that in the change proposal from yesterday, I also include the answering part in the description and move the preference description to a separate paragraph in order to describe the preference to have scope across all media lines. That is still the valid proposal, so see the above as a proposal just for the topic of inclusive list versus selection.

Gunnar

-- 
-----------------------------------------
Gunnar Hellström
Omnitor
[email-masked]
+46 708 204 288

---

From: Randall Gellens <[email-masked]>
Date: Fri, 8 Apr 2016 05:52:29 -0700

Hi Gunnar,

At 10:34 AM +0200 4/8/16, Gunnar Hellström wrote:

>  1. On line 2 it says "to indicate the language 
> used" when it in some cases can be a list, of 
> which at least one in each direction will be 
> used.
>

Thanks for pointing this out.  I think the best 
way to fix the possible ambiguity here is to 
simply delete the text "to indicate the language 
used when sending and receiving media", because 
further down it is explained in more detail.

>
>  2. The expression later: "the languages the 
> offerer wishes to send" reads as if the offeror 
> has a preference to send in multiple languages, 
> while we really mean an offered selection.
>
>  Change from:
>     "In an offer the 'humintlang-send' values 
> constitute a list in preference order (first is 
> most preferred) of the languages the party is 
> capable to select from for sending using the 
> media, and the 'humintlang-recv' values 
> constitute a list in preference order of the 
> languages in which the party is capable of 
> receiving contents using the media."

I think a more clear and direct way of phrasing it is:

    In an offer, 'humintlang-send' indicates the language the offerer
    wishes to send using the media, and 'humintlang-recv' indicates the
    language the offerer wishes to receive using the media.  In both
    cases the values constitute a list of languages in preference order
    (first is most preferred).

>
>  Note that in the change proposal from 
> yesterday, I also include the answering part in 
> the description and move the preference 
> description to a separate paragraph in order to 
> describe the preference to have scope across 
> all media lines. That is still the valid 
> proposal, so see the above as a proposal just 
> for the topic of inclusive list versus 
> selection.
>
>  Gunnar
>
>  --
>  _______________________________________________
>  SLIM mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/slim

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
MIPS:  Meaningless Indicator of Processor Speed.

---

From: Gunnar Hellström <[email-masked]>
Date: Sun, 10 Apr 2016 22:48:53 +0200

Randall,
See comments below

Den 2016-04-08 kl. 14:52, skrev Randall Gellens:
>>  1. On line 2 it says "to indicate the language used" when it in some 
>> cases can be a list, of which at least one in each direction will be 
>> used.
>>
> Thanks for pointing this out.  I think the best way to fix the 
> possible ambiguity here is to simply delete the text "to indicate the 
> language used when sending and receiving media", because further down 
> it is explained in more detail.
Possibly.
Please show the section with your proposed modification so that it can 
be assessed.
>
>>
>>  2. The expression later: "the languages the offerer wishes to send" 
>> reads as if the offeror has a preference to send in multiple 
>> languages, while we really mean an offered selection.
>>
>>  Change from:
>>     "In an offer the 'humintlang-send' values constitute a list in 
>> preference order (first is most preferred) of the languages the party 
>> is capable to select from for sending using the media, and the 
>> 'humintlang-recv' values constitute a list in preference order of the 
>> languages in which the party is capable of receiving contents using 
>> the media."
>
No, this is as unclear as the initial wording.
It says that the attribute indicates a language, when it can indicate a 
list of languages.
It is safer to describe it exactly as in my proposal above.
I also think that the se of the word "wish" complicates it. If you say 
that the list is a list of languages the user wishes to use, then you 
get the impression that more would be better. If you instead say that 
the user is capable of using, then it is neutral and selecting one is 
sufficient.

>
>
>>
>>  Note that in the change proposal from yesterday, I also include the 
>> answering part in the description and move the preference description 
>> to a separate paragraph in order to describe the preference to have 
>> scope across all media lines. That is still the valid proposal, so 
>> see the above as a proposal just for the topic of inclusive list 
>> versus selection.
Still true.

/Gunnar