Subject: [Slim] draft meeting notes IETF 95

From: Chris Newman <[email-masked]>
Date: Thu, 07 Apr 2016 17:27:08 -0300

Slim WG Meeting Notes

Note Taker: Chris Newman

Presentation: draft-ietf-slim-multilang-content-00:

Call for volunteers to help test multipart/multilingual on more clients
(will repeat on list)

*  realistically need to support both message/rfc822 and message/global

Target update for about mid-May

draft-ietf-slim-negotiating-human-language-01:

Randall: Changes to document were mostly clarifications. Declined to
make changes that made the proposal more complex. Would really like to
not add things. Some disagreement over how to interpret wording for
lang attribute.

draft-ietf-slim-use-cases-01:

Updated today with some cleanup including proper references. Needs
some quick review.

Randy has sent comments on the document.
Brian agreed to review document and comment.

ETSI Statement (Gunnar):

Q: If ETSI is publishing use cases, does the IETF need to publish a
use case document?

A: No reference to IETF use cases document by ETSI.

Gunnar sent mail about ETSI use cases that are not well covered.

comment overview:
* Seen a number of grouping mechanisms in various ways, they're
complicated and tend not to be implemented and don't seem to help as
much as we thought they would.
* The simpler we keep the document, the more likely it is to be
implemented. That makes it easier to extend it based on real needs.

The current lang attribute

comment overview:
* The current lang attribute is defined to cover content. There
was previous agreement in a face2face that we could not use the
existing attribute.
* Order of importance has meaning for static media
(e.g. newscast with multi-lingual content)
* Would really like us to try to separate requirements from
mechanisms. If we decide we have a requirement to do more complex
cases then we need a mechanism. If we decide we don't have such a
requirement, then we can have a simpler mechanism =

Grouping preferences

comment overview:
* Don't think we have requirement to do grouping. Would prefer to
start simple and go back later if we find we need the ability later.
* can add grouping mechanism later.
* don't think we need either order or grouping.
* Don't believe we solve enough for the necessary use cases. The
simple use cases can be done with the 'lang' attribute. The new
attribute should handle the complex use cases so it's different.
* Do we have a way of coming to consensus on which use cases
are required vs. optional. Given that, can we reach consensus on if
technology fits use cases.

Chair: please send uses cases to list to update use cases along this
line.

comment overview:
* need to see if we have rough consensus on simpler mechanism
earlier.
* extraneous media is not a problem.
* In addition to getting right media, also need right resources,
such as an interpreter.
* that is not a signalling problem.

---

From: "Drage, Keith (Nokia - GB)" <[email-masked]>
Date: Thu, 7 Apr 2016 20:53:31 +0000

I find it unacceptable that a document editor is allowed to make statements like: " Declined to make changes that made the proposal more complex. Would really like to not add things." without further clarification (and yes, this is what he said because I was listening remotely).

This is a working group document. The editor needs to reflect to will of the working group. If things are not agreed, then it needs to be resolved on the list, not by declaration of non-acceptance by the document editor.

Regards

Keith

-----Original Message-----
From: SLIM [mailto:[email-masked]] On Behalf Of EXT Chris Newman
Sent: 07 April 2016 21:27
To: [email-masked]
Subject: [Slim] draft meeting notes IETF 95

Slim WG Meeting Notes

Note Taker: Chris Newman

Call for volunteers to help test multipart/multilingual on more clients (will repeat on list)

Randall: Changes to document were mostly clarifications. Declined to make changes that made the proposal more complex. Would really like to not add things. Some disagreement over how to interpret wording for lang attribute.

Updated today with some cleanup including proper references. Needs some quick review.

ETSI Statement (Gunnar):

Q: If ETSI is publishing use cases, does the IETF need to publish a use case document?

comment overview:
* Seen a number of grouping mechanisms in various ways, they're complicated and tend not to be implemented and don't seem to help as much as we thought they would.
* The simpler we keep the document, the more likely it is to be implemented. That makes it easier to extend it based on real needs.

comment overview:
* The current lang attribute is defined to cover content. There was previous agreement in a face2face that we could not use the existing attribute.
* Order of importance has meaning for static media (e.g. newscast with multi-lingual content)
* Would really like us to try to separate requirements from mechanisms. If we decide we have a requirement to do more complex cases then we need a mechanism. If we decide we don't have such a requirement, then we can have a simpler mechanism =

Grouping preferences

comment overview:
* Don't think we have requirement to do grouping. Would prefer to start simple and go back later if we find we need the ability later.
* can add grouping mechanism later.
* don't think we need either order or grouping.
* Don't believe we solve enough for the necessary use cases. The simple use cases can be done with the 'lang' attribute. The new attribute should handle the complex use cases so it's different.
* Do we have a way of coming to consensus on which use cases are required vs. optional. Given that, can we reach consensus on if technology fits use cases.

Chair: please send uses cases to list to update use cases along this line.

comment overview:
* need to see if we have rough consensus on simpler mechanism earlier.
* extraneous media is not a problem.
* In addition to getting right media, also need right resources, such as an interpreter.
* that is not a signalling problem.

_______________________________________________
SLIM mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/slim

---

From: Brian Rosen <[email-masked]>
Date: Thu, 7 Apr 2016 18:03:26 -0300

I took his statement to be that he didn’t make the change because he didn’t think there was no consensus to do that.  I think we have rough consensus not do make that change.  However, neither of us can decide that.  I certainly would hope that if there is consensus, as determined by chairs, that he will make whatever changes are needed to conform to that consensus.  If he didn’t, then we would have to have another editor, but I’m confident that won’t be needed.

I think it is VERY common for an editor not to make a change he personally disagrees with until there is a consensus determination. I see no issue here.

Brian

> On Apr 7, 2016, at 5:53 PM, Drage, Keith (Nokia - GB) <[email-masked]> wrote:
>

---

From: "Drage, Keith (Nokia - GB)" <[email-masked]>
Date: Thu, 7 Apr 2016 21:13:27 +0000

All I would say is that is not what he said in the meeting.

It would not have taken much effort to say (from either the editor or the chairs), "but we will seek consensus on the mailing list concerning those issues".

Keith

-----Original Message-----
From: EXT Brian Rosen [mailto:[email-masked]] 
Sent: 07 April 2016 22:03
To: Drage, Keith (Nokia - GB)
Cc: EXT Chris Newman; [email-masked]
Subject: Re: [Slim] draft meeting notes IETF 95

Brian

---

From: Natasha Rooney <[email-masked]>
Date: Thu, 7 Apr 2016 21:19:52 +0000

As a chair I should perhaps then reiterate that we plan to do this on the mailing list, and I plan to get this done next week. This week is busy for a number of us let’s take a few days to digest, have a think, and address this on list next week.

Apologies if I didn’t make this clear; too many British colloquialisms probably!

As a participant I agree with Brian’s interpretation of events. I have no issue with no action on behalf of the editor as up till now we have only had objection from one person. To note: we take these concerns seriously, but having not come to a resolution it seems reasonable for no action to have occurred as of yet.

Thanks!

Natasha

Natasha Rooney | Technologist, Web and Internet, W3C & IETF | GSMA | [email-masked]<mailto:[email-masked]> | +44 (0) 7730 219 765 | @thisNatasha | Skype: [email-masked]<mailto:[email-masked]>

On Apr 7, 2016, at 6:13 PM, Drage, Keith (Nokia - GB) <[email-masked]<mailto:[email-masked]>> wrote:

Keith

-----Original Message-----
From: EXT Brian Rosen [mailto:[email-masked]]
Sent: 07 April 2016 22:03
To: Drage, Keith (Nokia - GB)
Cc: EXT Chris Newman; [email-masked]<mailto:[email-masked]>
Subject: Re: [Slim] draft meeting notes IETF 95

Brian

On Apr 7, 2016, at 5:53 PM, Drage, Keith (Nokia - GB) <[email-masked]<mailto:[email-masked]>> wrote:

Regards

Keith

-----Original Message-----
From: SLIM [mailto:[email-masked]] On Behalf Of EXT Chris Newman
Sent: 07 April 2016 21:27
To: [email-masked]<mailto:[email-masked]>
Subject: [Slim] draft meeting notes IETF 95

Slim WG Meeting Notes

Note Taker: Chris Newman

ETSI Statement (Gunnar):

comment overview:

comment overview:

Grouping preferences

comment overview:

comment overview:

_______________________________________________
SLIM mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/slim
_______________________________________________
SLIM mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/slim

_______________________________________________
SLIM mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/slim

This email and its attachments are intended for the above named only and may be confidential. If they have come to you in error you must take no action based on them, nor must you copy or show them to anyone; please reply to this email or call +44 207 356 0600 and highlight the error.