Subject: Query regarding BER/DER encoding of CMS data

From: Deepak <[email-masked]>
Date: Thu, 14 Aug 2003 09:28:56 -0700 (PDT)

Hi,

  When i go through the CMS RFC's its saying, all the
contenttype(SignedData,EnvelopedData) should be BER
encoded. But when i go thorugh the some of the ietf
examples, especially in EnvelopedData->RecipientInfo
is encoded by DER.(its starting with 31 82 ..). It
should be like sequence 30 80 .. ? 

Could you please explain why was it happend ?

Thanks,
Deepak

__________________________________
Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software
http://sitebuilder.yahoo.com

---

From: "Jim Schaad" <[email-masked]>
Date: Sun, 17 Aug 2003 08:21:54 -0600

DER is a legal encoding when BER is called for.  BER is not required to
be indefinite length encoding.

jim

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Deepak
> Sent: Thursday, August 14, 2003 9:29 AM
> To: [email-masked]
> Subject: Query regarding BER/DER encoding of CMS data
> 
> 
> 
> Hi,
> 
> Yahoo! SiteBuilder - Free, easy-to-use web site design 
> software http://sitebuilder.yahoo.com
>