Subject: New modules drafts posted

From: Paul Hoffman <[email-masked]>
Date: Fri, 9 Jan 2009 08:52:21 -0800

Greetings again. This message should appear after the posting announcements for draft-ietf-pkix-new-asn1-02 and draft-ietf-smime-new-asn1-02 appear. If not, please wait a bit. :-)

Jim and I have major changes to the modules, and we think that our work is now done, modulo bug fixes. To that end, we would *really* like folks on either of these two lists who have ASN.1 compilers that handle the 2002 syntax to review the modules carefully and let both lists know if there are any errors. In addition, we are still open to comments on our choice of style for the new objects in the modules.

If you want to get copies of the modules without tedious copy-and-pasting, get the latest version of a2c from the a2c project (<http://code.google.com/p/a2c/>), specifically either <http://a2c.googlecode.com/files/a2c-v8.zip> or <http://a2c.googlecode.com/files/a2c-v8.tgz>. The modules are in the test/ directory. The makefile in that directory has all of the dependencies needed, although we are happy to have you test your own dependencie chain yourself.

At this point, we think that comments to both lists are appropriate, given the shared design between the two drafts and the heavy cross-dependencies between the modules.

--Paul Hoffman, Director
--VPN Consortium

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 14 Jan 2009 08:55:54 -0800

Since I sent out this message below, we had one group of folks respond with a few small technical changes, but no other comments.

In the spirit of forward motion, we would like the chairs of PKIX and S/MIME to put the respective documents into WG Last Call so we can shake out any last comments and put these on standards track.