Subject: [smime] [Editorial Errata Reported] RFC5752 (2028)

From: RFC Errata System <[email-masked]>
Date: Fri, 29 Jan 2010 12:54:51 -0800 (PST)

The following errata report has been submitted for RFC5752,
"Multiple Signatures in Cryptographic Message Syntax (CMS)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5752&eid=2028

--------------------------------------
Type: Editorial
Reported by: Alfred Hoenes <[email-masked]>

Section: 2.1, pg. 6

Original Text
-------------
   The following is an example:

      SignedData
        DigestAlg=sha1,sha256
        SignerInfo1                SignerInfo2
          digestAlg=sha1             digestAlg=sha256
          signatureAlg=dsawithsha1   signatureAlg=ecdsawithsha256
          signedAttrs=               signedAttrs=
            signingTime1               signingTime1
            messageDigest1             messageDigest2
            multiSig1=                 multiSig2=
              bodyHash=sha256           bodyHash=sha1
              signAlg=ecdsawithsha256   signAlg=dsawithsha1
 |              signAttrsHash=          signAttrsHash=
 |              algID=sha1              algID=sha256
 |              hash=value1             hash=value2

Corrected Text
--------------
   The following is an example:

      SignedData
        DigestAlg=sha1,sha256
        SignerInfo1                SignerInfo2
          digestAlg=sha1             digestAlg=sha256
          signatureAlg=dsawithsha1   signatureAlg=ecdsawithsha256
          signedAttrs=               signedAttrs=
            signingTime1               signingTime1
            messageDigest1             messageDigest2
            multiSig1=                 multiSig2=
              bodyHash=sha256           bodyHash=sha1
              signAlg=ecdsawithsha256   signAlg=dsawithsha1
 |            signAttrsHash=            signAttrsHash=
 |              algID=sha1                algID=sha256
 |              hash=value1               hash=value2

Notes
-----
Rationale:
  Fixed indentation for consistency and clarity
  (visual indication of subordinate elements).

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5752 (draft-ietf-smime-multisig-05)
--------------------------------------
Title               : Multiple Signatures in Cryptographic Message Syntax (CMS)
Publication Date    : January 2010
Author(s)           : S. Turner, J. Schaad
Category            : PROPOSED STANDARD
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Sean Turner <[email-masked]>
Date: Fri, 29 Jan 2010 16:16:12 -0500

The proposed correction is appropriate, and does not result in a 
technical change to the RFC. I have no objection to this errata.

spt