Subject: [smime] [Technical Errata Reported] RFC5752 (2027)

From: RFC Errata System <[email-masked]>
Date: Fri, 29 Jan 2010 12:51:23 -0800 (PST)

The following errata report has been submitted for RFC5752,
"Multiple Signatures in Cryptographic Message Syntax (CMS)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5752&eid=2027

--------------------------------------
Type: Technical
Reported by: Alfred Hoenes <[email-masked]>

Section: 5, pg. 8

Original Text
-------------
   This section describes recommended processing of signatures when
|  there are more than one SignerInfo present in a message.  This may be
   due to either multiple SignerInfo objects being present in a single
|  SignedData object or multiple SignerData objects embedded in each
   other.

   [...]

   Order of operations:

   1) Evaluate each SignerInfo object independently.

   2) Combine the results of all SignerInfo objects at the same level
|     (i.e., attached to the same SignerData object).

|  3) Combine the results of the nested SignerData objects.  Note that
      this should ignore the presence of other CMS objects between the
      SignedData objects.

Corrected Text
--------------
   This section describes recommended processing of signatures when
|  there is more than one SignerInfo object present in a message.  This
   may be due to either multiple SignerInfo objects being present in a
|  single SignedData object or multiple SignedData objects embedded in
   each other.

   [...]

   Order of operations:

   1) Evaluate each SignerInfo object independently.

   2) Combine the results of all SignerInfo objects at the same level
|     (i.e., attached to the same SignedData object).

|  3) Combine the results of the nested SignedData objects.  Note that
      this should ignore the presence of other CMS objects between the
      SignedData objects.

Notes
-----
Rationale:
  There's no such ASN.1 type/object "SignerData".
  Based on the importance of referencing the correct type/object,
  the correction to "SignedData" is classified as 'Technical'.
  Also a clarification and fix is applied in the first sentence.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5752 (draft-ietf-smime-multisig-05)
--------------------------------------
Title               : Multiple Signatures in Cryptographic Message Syntax (CMS)
Publication Date    : January 2010
Author(s)           : S. Turner, J. Schaad
Category            : PROPOSED STANDARD
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Sean Turner <[email-masked]>
Date: Fri, 29 Jan 2010 16:15:17 -0500

The proposed correction is appropriate. I have no objection to this errata.

spt