Subject: [smime] [Technical Errata Reported] RFC3183 (3757)

From: RFC Errata System <[email-masked]>
Date: Fri, 18 Oct 2013 07:44:26 -0700 (PDT)

The following errata report has been submitted for RFC3183,
"Domain Security Services using S/MIME".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=3183&eid=3757

--------------------------------------
Type: Technical
Reported by: Russ Housley <[email-masked]>

Section: 3.1.2

Original Text
-------------
   An S/MIME signed attribute is used to indicate the type of signature.
   This should be used in conjunction with the naming conventions
   specified in the previous section.  When an S/MIME signed message
   containing the signature type attribute is received it triggers the
   software to verify that the correct naming convention has been used.

   The ASN.1 [4] notation of this attribute is: -

      SignatureType ::= SEQUENCE OF OBJECT IDENTIFIER

Corrected Text
--------------
   An S/MIME signed attribute is used to indicate the type of signature.
   This should be used in conjunction with the naming conventions
   specified in the previous section.  When an S/MIME signed message
   containing the signature type attribute is received it triggers the
   software to verify that the correct naming convention has been used.

   The following object identifier identifies the SignatureType
   attribute:

      id-aa-signatureType OBJECT IDENTIFIER ::= { iso(1) 
          member-body(2) us(840) rsadsi(113549) pkcs(1) pkcs9(9) 28 }

   The ASN.1 [4] notation of this attribute is:

      SignatureType ::= SEQUENCE OF OBJECT IDENTIFIER

Notes
-----
The specification provides the syntax for the SignatureType attribute,
but it fails to provide the object identifier for the attribute.  The object
identifier was assigned, but for some reason it is not provided in the
document.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3183 (draft-ietf-smime-domsec-09)
--------------------------------------
Title               : Domain Security Services using S/MIME
Publication Date    : October 2001
Author(s)           : T. Dean, W. Ottaway
Category            : EXPERIMENTAL
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: "Ottaway William" <[email-masked]>
Date: Tue, 22 Oct 2013 11:11:11 +0100

Hi all,

Tim and I have discussed the proposed errata and we are happy for the change to be made.

Bill

William Ottaway BSc(Hons) CEng MBCS CITP

Cyber Vigilance Practice
Security Division

BL208,
QinetiQ,
Malvern Technology Centre,
St Andrews Road,              Tel: +44 (0) 1684 894079
Malvern,                      MB: +44 (0) 7917 577176
Worcestershire,               Mil: 9214 801 4079
WR14 3PS

www.QinetiQ.com/Cyber   
People Who Know How 

Connect with us: Read our blog | Follow us on LinkedIn | Like us on FaceBook | Follow us on Twitter

All opinions are my own

-----Original Message-----
From: RFC Errata System [mailto:[email-masked]] 
Sent: 18 October 2013 15:44
To: Dean Tim; Ottaway William; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Technical Errata Reported] RFC3183 (3757)

The following errata report has been submitted for RFC3183, "Domain Security Services using S/MIME".

Section: 3.1.2

Original Text
-------------

Corrected Text
--------------

Notes
-----
The specification provides the syntax for the SignatureType attribute, but it fails to provide the object identifier for the attribute.  The object identifier was assigned, but for some reason it is not provided in the document.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please use "Reply All" to discuss whether it should be verified or rejected. When a decision is reached, the verifying party (IESG) can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3183 (draft-ietf-smime-domsec-09)
--------------------------------------
Title               : Domain Security Services using S/MIME
Publication Date    : October 2001
Author(s)           : T. Dean, W. Ottaway
Category            : EXPERIMENTAL
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG
This email and any attachments to it may be confidential and are
intended solely for the use of the individual to whom it is 
addressed. If you are not the intended recipient of this email,
you must neither take any action based upon its contents, nor 
copy or show it to anyone. Please contact the sender if you 
believe you have received this email in error. QinetiQ may 
monitor email traffic data and also the content of email for 
the purposes of security. QinetiQ Limited (Registered in England
& Wales: Company Number: 3796233) Registered office: Cody Technology 
Park, Ively Road, Farnborough, Hampshire, GU14 0LX  http://www.qinetiq.com.