Subject: [smime] Last Call: <draft-housley-smime-oids-00.txt> (Object Identifier Registry for the S/MIME Mail Security Working Group) to Informational RFC

From: The IESG <[email-masked]>
Date: Mon, 21 Oct 2013 06:03:40 -0700

The IESG has received a request from an individual submitter to consider
the following document:
- 'Object Identifier Registry for the S/MIME Mail Security Working Group'
  <draft-housley-smime-oids-00.txt> as Informational RFC

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action. Please send substantive comments to the
[email-masked] mailing lists by 2013-11-18. Exceptionally, comments may be
sent to [email-masked] instead. In either case, please retain the
beginning of the Subject line to allow automated sorting.

Abstract

   When the S/MIME Mail Security Working Group was chartered, an object
   identifier arc was donated by RSA Data Security for use by that
   working group.  This document describes the object identifiers that
   were assigned in that donated arc, it transfers control of that arc
   to IANA, and it establishes IANA allocation policies for any future
   assignments within that arc.

The file can be obtained via
http://datatracker.ietf.org/doc/draft-housley-smime-oids/

IESG discussion can be tracked via
http://datatracker.ietf.org/doc/draft-housley-smime-oids/ballot/

No IPR declarations have been submitted directly on this I-D.

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 21 Oct 2013 07:54:56 -0700

I know there is not much energy on this mailing list these days, but it is very important that all S/MIME implementers review this document carefully. Aligning OIDs with reality is tricky, so please do not assume that Russ of course got everything right on the first try. All reviews, even "I found no problems", are appreciated.

--Paul Hoffman

---

From: Sean Leonard <[email-masked]>
Date: Mon, 21 Oct 2013 17:21:36 -0700

I read the draft. However, the format is not really conducive to 
checking easily.

Is there some other format (e.g., a spreadsheet) where everything is listed?

Thanks, Sean

> I know there is not much energy on this mailing list these days, but it is very important that all S/MIME implementers review this document carefully. Aligning OIDs with reality is tricky, so pleas…
[SNIP]

---

From: Russ Housley <[email-masked]>
Date: Tue, 22 Oct 2013 08:15:39 -0400

Not really.  The only other format is here: http://www.imc.org/ietf-smime/sm-oid.asn

Russ

On Oct 21, 2013, at 8:21 PM, Sean Leonard wrote:

> I read the draft. However, the format is not really conducive to checking easily.
> 
> _______________________________________________
> smime mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/smime

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 22 Oct 2013 08:43:50 -0700

> Not really.  The only other format is here: http://www.imc.org/ietf-smime/sm-oid.asn

But I wouldn't trust that the data from sm-oid.asn was necessarily copied correctly. Everyone: please review the draft as carefully as possible. Getting the IANA registry wrong, even in a small way, when it is constructed can lead to interop problems.

--Paul Hoffman