Subject: RE: snmpconf FW: MIBs for events and notification logging

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Tue, 23 Oct 2001 21:47:22 +0200

The idea of my email was more to stimulate the WG
to try and address the issue of persistence of
configuration data and event data.

If the MIB that is out of the DISMAN WG is no good,
then that topic should be discussed in the DISMAN WG.

Or so I think.

Bert 

> -----Original Message-----
> From: David T. Perkins [mailto:[email-masked]]
> Sent: Tuesday, October 23, 2001 8:42 PM
> To: [email-masked]
> Subject: Re: snmpconf FW: MIBs for events and notification logging
> 
> 
> HI,
> 
> Using the log MIB found in RFC 3014 would be a good choice
> if it was a well designed MIB module. But I believe it has
> enough problems to render it unusable except for simple
> cases. I'll willing to demonstrate this by writing an
> implementation report if I can get access to a device
> that supports the log MIB. And I'm willing to work together
> with anyone who also has interest. Anyone that knows of
> an implementation, please send me the version of the system
> software and the device.  (If I don't have access
> to one of the devices, then I'll need some help in getting
> access.)
> 
> Regards,
> /david t. perkins
> 
> On Tue, 23 Oct 2001, Wijnen, Bert (Bert) wrote:
> 
> > FYI and possible actions
> > 
> > Bert 
> > 
> > -----Original Message-----
> > From: Wijnen, Bert (Bert) [mailto:[email-masked]]
> > Sent: Thursday, October 18, 2001 7:15 PM
> > To: IESG
> > Subject: MIBs for events and notification logging
> > 
> > 
> > All, while discussing the frnetmib documnet, we talked about
> > how to handle data (events) that should be persistent.
> > 
> > In general, managed devices do not keep such persistent
> > information. Instead, they send notifications, that is
> > traps or informed (if enabled by configuration), to one
> > or more management stations. The management stations/apps
> > would keep the data in a persistent database. Also, managers
> > will poll devices to obtain status/usage info and save that
> > in a persistent database.
> > 
> > Events/notifications may not be delivered to a manager
> > if there are network problems. In that case, usage of the
> > event mib (RFC2981) or the notification log mib (RFC3014)
> > can keep such data at a managed device for a while.
> > 
> > Does this explain enough?
> > 
> > I will post to SNMPCONF WG to stimulate that they include
> > something in the SNMP BCP that they are working on
> > 
> > Bert 
> > 
>

---

From: Jon Saperia <[email-masked]>
Date: Wed, 24 Oct 2001 08:56:26 -0400

Bert, one follow up. Persistence of configuration data is dealt with a
bit in the BCP. Persistence of alarm data is, a bit differenet in
my view. I just posted to the DISMAN list that I thought the alarm MIB
or even that in combination with an implementation of the LOG MIB is too
heavy weight for notifications sent from a device. Perhaps the problem
could be broken down into two parts. Work on a conformance statement
with some restructure might do the trick for the Alarm MIB. 

With regard to the configuration aspect, I recall a discussion at
an SNMPCONF WG meeting a couple of IETFs ago about configuration
persistence. I do no know where that went, if anywhere. Was there
something that should have happened that did not?

/jon
> > > something in the SNMP BCP that they are working on

Thanks,
/jon
--

Jon Saperia		     [email-masked]
			     Phone: 617-744-1079
			     Fax:   617-249-0874
			     http://www.jdscons.com/