Subject: snmpconf FW: MIBs for events and notification logging

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Tue, 23 Oct 2001 13:33:58 +0200

FYI and possible actions

Bert 

-----Original Message-----
From: Wijnen, Bert (Bert) [mailto:[email-masked]]
Sent: Thursday, October 18, 2001 7:15 PM
To: IESG
Subject: MIBs for events and notification logging

All, while discussing the frnetmib documnet, we talked about
how to handle data (events) that should be persistent.

In general, managed devices do not keep such persistent
information. Instead, they send notifications, that is
traps or informed (if enabled by configuration), to one
or more management stations. The management stations/apps
would keep the data in a persistent database. Also, managers
will poll devices to obtain status/usage info and save that
in a persistent database.

Events/notifications may not be delivered to a manager
if there are network problems. In that case, usage of the
event mib (RFC2981) or the notification log mib (RFC3014)
can keep such data at a managed device for a while.

Does this explain enough?

I will post to SNMPCONF WG to stimulate that they include
something in the SNMP BCP that they are working on

Bert

---

From: "Rick V. Martija" <[email-masked]>
Date: Tue, 23 Oct 2001 09:01:32 -0400

unsubscribe

---

From: "David T. Perkins" <[email-masked]>
Date: Tue, 23 Oct 2001 11:41:56 -0700 (PDT)

HI,

Using the log MIB found in RFC 3014 would be a good choice
if it was a well designed MIB module. But I believe it has
enough problems to render it unusable except for simple
cases. I'll willing to demonstrate this by writing an
implementation report if I can get access to a device
that supports the log MIB. And I'm willing to work together
with anyone who also has interest. Anyone that knows of
an implementation, please send me the version of the system
software and the device.  (If I don't have access
to one of the devices, then I'll need some help in getting
access.)

Regards,
/david t. perkins