Subject: sysuptime and snmpv3 integrity checking

From: "Harrington, David" <[email-masked]>
Date: Mon, 23 Jun 2003 07:32:21 -0400

Hi,

I'm just looking for a sanity check. Am I correct in my belief that:

The Time Window checking in RFC3414 is NOT affected by sysUptime rollover; the time window checking does not use the value of sysUptime in its calculations.

Thanks,
dbh

David Harrington
Director, Network Management Architecture
Office of the CTO
Enterasys Networks

---

From: Wes Hardaker <[email-masked]>
Date: Mon, 23 Jun 2003 06:39:35 -0700

>>>>> On Mon, 23 Jun 2003 07:32:21 -0400, "Harrington, David" <[email-masked]> said:

David> The Time Window checking in RFC3414 is NOT affected by
David> sysUptime rollover; the time window checking does not use the
David> value of sysUptime in its calculations.

Correct because snmpEngineTime is not defined using the sysUpTime
value.:

  2.2. Replay Protection
...
    - snmpEngineTime, which is the number of seconds since the
      snmpEngineBoots counter was last incremented.

-- 
Wes Hardaker
Sparta